Corrupt screen on Mint 19 Xfce with VMWare Fusion

Questions about virtualization software
Forum rules
Before you post please read how to get help
Post Reply
maximumwarp
Level 1
Level 1
Posts: 5
Joined: Wed Jul 04, 2018 7:08 am

Corrupt screen on Mint 19 Xfce with VMWare Fusion

Post by maximumwarp » Wed Jul 04, 2018 4:34 pm

Hello,
I installed Mint 19 "Tara" Cinnamon on my HP workstation and it runs like a charm! :D
I need to use Mint 19 Xfce too on a virtual machine created with VMware Fusion 10.1 on my MacBook Pro but I have a serious problem: the installation is successful but if I try to change screen resolution to a higher value than 800x600 the desktop becomes corrupted and the system becomes unusable... :cry:

Installing VMware Tools before changing resolution do not solve the problem, is there a possible solution or I have to wait a VMware Fusion or Mint update? :!:
vmint.png

maximumwarp
Level 1
Level 1
Posts: 5
Joined: Wed Jul 04, 2018 7:08 am

Re: Corrupt screen on Mint 19 Xfce with VMWare Fusion

Post by maximumwarp » Fri Jul 06, 2018 3:04 am

I (temporarily) solved the problem by disabling 3D graphics acceleration in VMWare Fusion's settings...
I anyone knows better solutions, please help me, thank you!

User avatar
catweazel
Level 17
Level 17
Posts: 7068
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Corrupt screen on Mint 19 Xfce with VMWare Fusion

Post by catweazel » Fri Jul 06, 2018 3:46 am

maximumwarp wrote:
Fri Jul 06, 2018 3:04 am
I (temporarily) solved the problem by disabling 3D graphics acceleration in VMWare Fusion's settings...
I anyone knows better solutions, please help me, thank you!
Since nobody has come forward to assist you, perhaps you might try the VMware forum.

https://communities.vmware.com/welcome
Caution: Dancing Wu Li Master and Official curmudgeon-in-chief

PhallusImpudicus
Level 1
Level 1
Posts: 1
Joined: Wed Aug 22, 2018 11:22 am

Re: Corrupt screen on Mint 19 Xfce with VMWare Fusion

Post by PhallusImpudicus » Wed Aug 22, 2018 11:53 am

Have the exact same issue with Mint 19 xfce on VMware Workstation. Unchecking "Accelerate 3D Graphics" seems to have worked as a work around. I also have a VM for Mint 18 Mate that works without issue even with "Accelerate 3D Graphics" check within VMware Workstation. Tried updating VMware tools through workstation and terminal with the same result. Only 800x600 works with the Mint 19 xfce VM with "Accelerate 3D Graphics" enabled.

Post Reply

Return to “Virtualization”