Corrupt screen on Mint 19 Xfce with VMWare Fusion

Questions about virtualization software
Forum rules
Before you post please read how to get help
Post Reply
maximumwarp
Level 1
Level 1
Posts: 16
Joined: Wed Jul 04, 2018 7:08 am

Corrupt screen on Mint 19 Xfce with VMWare Fusion

Post by maximumwarp » Wed Jul 04, 2018 4:34 pm

Hello,
I installed Mint 19 "Tara" Cinnamon on my HP workstation and it runs like a charm! :D
I need to use Mint 19 Xfce too on a virtual machine created with VMware Fusion 10.1 on my MacBook Pro but I have a serious problem: the installation is successful but if I try to change screen resolution to a higher value than 800x600 the desktop becomes corrupted and the system becomes unusable... :cry:

Installing VMware Tools before changing resolution do not solve the problem, is there a possible solution or I have to wait a VMware Fusion or Mint update? :!:
vmint.png

maximumwarp
Level 1
Level 1
Posts: 16
Joined: Wed Jul 04, 2018 7:08 am

Re: Corrupt screen on Mint 19 Xfce with VMWare Fusion

Post by maximumwarp » Fri Jul 06, 2018 3:04 am

I (temporarily) solved the problem by disabling 3D graphics acceleration in VMWare Fusion's settings...
I anyone knows better solutions, please help me, thank you!

User avatar
catweazel
Level 18
Level 18
Posts: 8218
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Corrupt screen on Mint 19 Xfce with VMWare Fusion

Post by catweazel » Fri Jul 06, 2018 3:46 am

maximumwarp wrote:
Fri Jul 06, 2018 3:04 am
I (temporarily) solved the problem by disabling 3D graphics acceleration in VMWare Fusion's settings...
I anyone knows better solutions, please help me, thank you!
Since nobody has come forward to assist you, perhaps you might try the VMware forum.

https://communities.vmware.com/welcome
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

PhallusImpudicus
Level 1
Level 1
Posts: 2
Joined: Wed Aug 22, 2018 11:22 am

Re: Corrupt screen on Mint 19 Xfce with VMWare Fusion

Post by PhallusImpudicus » Wed Aug 22, 2018 11:53 am

Have the exact same issue with Mint 19 xfce on VMware Workstation. Unchecking "Accelerate 3D Graphics" seems to have worked as a work around. I also have a VM for Mint 18 Mate that works without issue even with "Accelerate 3D Graphics" check within VMware Workstation. Tried updating VMware tools through workstation and terminal with the same result. Only 800x600 works with the Mint 19 xfce VM with "Accelerate 3D Graphics" enabled.

PhallusImpudicus
Level 1
Level 1
Posts: 2
Joined: Wed Aug 22, 2018 11:22 am

Re: Corrupt screen on Mint 19 Xfce with VMWare Fusion

Post by PhallusImpudicus » Thu Oct 25, 2018 4:11 pm

Well, seems I found some solution/work around for this issue. If I change my resolution once accelerate 3d graphics is turned on my screen is messed up and my mouse pointer isn't where it shows. But then if I open "Desktop Settings" and change the Window manage to anything it seems to fix itself. I can then turn it back to what it was originally set to and the issue does not come back.

Fusix
Level 1
Level 1
Posts: 30
Joined: Thu Mar 24, 2011 11:49 pm

Re: Corrupt screen on Mint 19 Xfce with VMWare Fusion

Post by Fusix » Sat Dec 15, 2018 12:30 pm

I have had the same issue as well on VMware Workstation and Mint 19 Xfce. 64-bit and on Windows 10 host.

This is how I solved it:

When making a VM where you are loading the live CD don't choose "Ubuntu 64-bit" when you are prompted, choose "Debian 9.x 64-bit".

Linux Mint is not an option. See this page for more details:
https://superuser.com/questions/676231/ ... d-i-select

It advises -
---------------
This box is used only to determine minimum hardware required to run given OS, best compatibility options and installation automation method.

Speaking of requirements and compatibility, Mint should work fine with Ubuntu presets. I'm not sure about setup automation, but you can give it a try. In case of setup failing take notes on what hardware Player had assigned for the Ubuntu preset, then create new VM bit this time choosing Other Linux 3.x kernel and configure identical hardware. Installation automation will be skipped for Other.
-------------------

and also -

--------------
Mint is a spin-off of Ubuntu which is a spin-off of Debian.
So first preference is Ubuntu 64bit, then Debian 64bit.
As a last resort try "Other Linux" with the highest 64bit kernel available and then work you way downwards to earlier kernel presets if needed.
---------------------


I tried "Ubuntu 64-bit" to start off with and I got this problem (the screen 'bug'). When I chose the "Debian 64-bit" option it went away. I was able to resize my desktop/screen without it going haywire and locking the computer and having to restart.

Of course, you still will not be able to save this as it is not a persistent install off the Live CD. So when you restart, you will have to resize again. But at least this 'bug' goes away.


If you actually want to have a persistent install where you can save stuff and it remembers all your settings, then you need to take a different approach.

This is a little mini-tutorial for those of you not familiar with setting Linux Mint up in a Virtual Machine:

When first installing the VM, you want to install the OS later from the options menu, not giving it the path to the .iso initially. You will be creating a blank hard disk on which you will later install Mint OS. Choose 20GB as a good starting point.

When prompted this time, I didn't choose Linux, I chose "Other", with "Other 64-bit" as the version. This is just for your blank hard drive, remember. But you could just as well choose the earlier option of "Debian 9.x 64-bit". It doesn't really matter. But if you do select "Ubuntu 64-bit" then this graphics 'bug' will persist and it won't work. We are just creating an initial canvas on which to paint the OS of our choice, essentially.

When your VM is created and you go to 'play' it, you will then need to load the .iso. There is no OS on this disk, yet. We will use the .iso to install it via a virtual Live CD.

To mount the .iso so it can be read and act like a live CD you have to set the path for it from the 'Removable Devices' menu option in VMware. Then you have to go back to the same menu to "Connect". Wait a second. Then you have to restart the VM from the button on the bottom of the screen. Now it will automatically load the live CD (.iso). When Mint is fully loaded on the desktop then select the "I finished installing" button at the bottom. That's it.

Don't forget if you lose your mouse pointer at any point in this process then hit 'Ctrl-Alt' to get it back in focus.

Now you can install the Live CD on to your virgin hard drive image with the "Install Linux Mint" CD icon on the desktop. This will install it on to the disk you just created. You can mess around with partitions and whatnot later when installing. I just chose the "Erase Disk and install linux mint" default option from the installer to see if it would work, and it did - it all installed perfectly like a dream.

Now you have a persistent install that you can update and save stuff to. It worked like a charm for me with internet connected automatically (piggy backing off the host OS I imagine). I updated with Update Manager and after a few minutes I was ready to go with a brand new up to date system.

And you can even change and save the resolution/size of your desktop/screen!

You could use this methodology to install as many versions of Mint as you wanted (HD space permitting) of course. VMware Workstation is free for personal use. I'm more used to Virtual Box, but it's had some problems lately on this particular system so I thought I'd give VMware a shot. It works well.

I'm going to install Rosa later on, and mess about with some partition options in the Mint installer. It all makes for a very quick and easy practice run before you commit to doing this to actual hardware and hard disks.

Kudos to the Mint development team. This seems to be a very nice and easy to use distro. I may even try it out with something other than Xfce also. Having said that, I really do like Xfce!



TL;DR:
Don't choose "Ubuntu 64-bit" when you are prompted in the VMware options, choose "Debian 9.x 64-bit" instead.

This solved the issue for me on VMware Workstation.

Post Reply

Return to “Virtualization”