Washed out desktop background image in Mint 19 Virtualbox VM

Questions about virtualization software
Forum rules
Before you post please read how to get help
Post Reply
rockadile
Level 1
Level 1
Posts: 34
Joined: Mon Jun 24, 2013 3:15 pm

Washed out desktop background image in Mint 19 Virtualbox VM

Post by rockadile » Fri Jul 20, 2018 6:46 pm

I have been running Mint 18.3 on Virtualbox 5.2.8 for a while with no issues. After upgrading to Mint 19, the background image is washed out. It doesn't matter which image is selected. Right clicking on the desktop, selecting "Change desktop background image" and choosing a new image and then switching back fixes it. Additionally, the selected image also appears on the login page fine. Once I log in is when it becomes washed out. I have upgraded to Virtualbox 5.2.16 as well as upgrading guest additions but the issue still persists.

ajgringo619
Level 5
Level 5
Posts: 544
Joined: Thu Mar 01, 2018 8:36 pm
Location: San Diego, California

Re: Washed out desktop background image in Mint 19 Virtualbox VM

Post by ajgringo619 » Fri Jul 20, 2018 7:30 pm

What video driver are you using?
[Mint 19 XFCE, AMD FX-8350 Eight-Core w/16 GB RAM, 4.15.0-42-generic, GeForce GTX 960 w/Nvidia 415.18]
Image

rockadile
Level 1
Level 1
Posts: 34
Joined: Mon Jun 24, 2013 3:15 pm

Re: Washed out desktop background image in Mint 19 Virtualbox VM

Post by rockadile » Sat Jul 21, 2018 9:30 pm

The virtualbox driver.

ajgringo619
Level 5
Level 5
Posts: 544
Joined: Thu Mar 01, 2018 8:36 pm
Location: San Diego, California

Re: Washed out desktop background image in Mint 19 Virtualbox VM

Post by ajgringo619 » Sat Jul 21, 2018 9:31 pm

rockadile wrote:
Sat Jul 21, 2018 9:30 pm
The virtualbox driver.
Sorry...I meant on the host OS.
[Mint 19 XFCE, AMD FX-8350 Eight-Core w/16 GB RAM, 4.15.0-42-generic, GeForce GTX 960 w/Nvidia 415.18]
Image

rockadile
Level 1
Level 1
Posts: 34
Joined: Mon Jun 24, 2013 3:15 pm

Re: Washed out desktop background image in Mint 19 Virtualbox VM

Post by rockadile » Sun Jul 22, 2018 10:52 am

I am on Windows 10 running both Intel's driver for the Intel HD GRaphics 530 and AMD's driver for the AMD FirePro W5130M.

User avatar
windyweather
Level 3
Level 3
Posts: 141
Joined: Wed Nov 09, 2011 8:34 pm
Location: Coos Bay, OR

Me too.

Post by windyweather » Wed Aug 01, 2018 8:12 pm

Count me too. I'm using Nvidia latest driver for GTX 1060 graphics in the Win 10 host.
When I first set the BG image, it's fine. Then if I reboot, it goes washed out and over exposed when system comes back up.
I assume this is what we are talking about.
[LM 18, LM 19 in VirtualBox / Windows 10 Host on AMD Ryzen 1800x, 32GB, 1TB of SSDs]

User avatar
Mage of Maple
Level 1
Level 1
Posts: 39
Joined: Tue Jul 10, 2018 10:41 am
Location: Maryland USA
Contact:

Re: Washed out desktop background image in Mint 19 Virtualbox VM

Post by Mage of Maple » Mon Aug 06, 2018 7:14 pm

I am experiencing this as well. Switching to a different background, waiting a second, and then switching back fixes it. Switch and switch back too quickly and it does not. This is a strange one ... I have not previously had this problem. (Not sure if it is caused by the update to Mint or an update to VB.)

rockadile
Level 1
Level 1
Posts: 34
Joined: Mon Jun 24, 2013 3:15 pm

Re: Washed out desktop background image in Mint 19 Virtualbox VM

Post by rockadile » Wed Aug 29, 2018 8:24 pm

Just to add more information, I just did a fresh install of Mint19 in VirtualBox and I am having the same issue so it does not appear to be related to the upgrade from 18 to 19 but Linux Mint 19 itself.

ajgringo619
Level 5
Level 5
Posts: 544
Joined: Thu Mar 01, 2018 8:36 pm
Location: San Diego, California

Re: Washed out desktop background image in Mint 19 Virtualbox VM

Post by ajgringo619 » Wed Aug 29, 2018 8:39 pm

This is really strange. I'm running Mint 19 XFCE as my main OS (in a VM; host is Windows 10 w/Nvidia GeForce 960), along with 7 other Linux OSes (Mint 19 Cinnamon/LMDE 3 Beta, CentOS 7, Fedora 28 XFCE/Gnome, Manjaro 17, Ubuntu 18.04), and I can't duplicate this error. Can anyone here install another Linux OS in a VM and see if the issue continues?
[Mint 19 XFCE, AMD FX-8350 Eight-Core w/16 GB RAM, 4.15.0-42-generic, GeForce GTX 960 w/Nvidia 415.18]
Image

rockadile
Level 1
Level 1
Posts: 34
Joined: Mon Jun 24, 2013 3:15 pm

Re: Washed out desktop background image in Mint 19 Virtualbox VM

Post by rockadile » Wed Sep 26, 2018 6:52 pm

ajgringo619 wrote:
Wed Aug 29, 2018 8:39 pm
This is really strange. I'm running Mint 19 XFCE as my main OS (in a VM; host is Windows 10 w/Nvidia GeForce 960), along with 7 other Linux OSes (Mint 19 Cinnamon/LMDE 3 Beta, CentOS 7, Fedora 28 XFCE/Gnome, Manjaro 17, Ubuntu 18.04), and I can't duplicate this error. Can anyone here install another Linux OS in a VM and see if the issue continues?
Does any other OS do the "fade in" on the background when logging in? This appears to be the crux of the issue since I am using a Qiana background (and have been since the Qiana release) and this was not an issue until Mint 19. In Mint 19, the "fade in" only happens from login. If you go in and select "Change Desktop Background" and choose it, there is no fade in effect and the issue doesn't manifest.

User avatar
windyweather
Level 3
Level 3
Posts: 141
Joined: Wed Nov 09, 2011 8:34 pm
Location: Coos Bay, OR

Fade In Bug?

Post by windyweather » Tue Oct 09, 2018 1:38 pm

Ok. So maybe the issue is that the Fade In fails to go completely in on the VirtualBox Graphics Driver.
There's another bug too. You can't take a screenshot in a virtual machine. You can take a screenshot from the host of the VM, but not inside the VM. You get black. So looks like the VirtualBox graphics driver needs some love and hugs.

d
[LM 18, LM 19 in VirtualBox / Windows 10 Host on AMD Ryzen 1800x, 32GB, 1TB of SSDs]

ajgringo619
Level 5
Level 5
Posts: 544
Joined: Thu Mar 01, 2018 8:36 pm
Location: San Diego, California

Re: Fade In Bug?

Post by ajgringo619 » Tue Oct 09, 2018 1:56 pm

windyweather wrote:
Tue Oct 09, 2018 1:38 pm
Ok. So maybe the issue is that the Fade In fails to go completely in on the VirtualBox Graphics Driver.
There's another bug too. You can't take a screenshot in a virtual machine. You can take a screenshot from the host of the VM, but not inside the VM. You get black. So looks like the VirtualBox graphics driver needs some love and hugs.

d
EDIT: From my LMDE3 VM (Cinnamon), I tried a screenshot. I got the background image, but it ignored the desktop icons and open windows.
I tried the same thing, this time logging on to the XFCE desktop. This time the screenshot function worked as advertised.
[Mint 19 XFCE, AMD FX-8350 Eight-Core w/16 GB RAM, 4.15.0-42-generic, GeForce GTX 960 w/Nvidia 415.18]
Image

rockadile
Level 1
Level 1
Posts: 34
Joined: Mon Jun 24, 2013 3:15 pm

Re: Fade In Bug?

Post by rockadile » Tue Oct 09, 2018 2:53 pm

windyweather wrote:
Tue Oct 09, 2018 1:38 pm
Ok. So maybe the issue is that the Fade In fails to go completely in on the VirtualBox Graphics Driver.
There's another bug too. You can't take a screenshot in a virtual machine. You can take a screenshot from the host of the VM, but not inside the VM. You get black. So looks like the VirtualBox graphics driver needs some love and hugs.

d
It’s a shame we’re not given the option to disable the fade in (at least that I am aware of).

User avatar
smurphos
Level 8
Level 8
Posts: 2240
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: Fade In Bug?

Post by smurphos » Wed Oct 10, 2018 2:54 am

rockadile wrote:
Tue Oct 09, 2018 2:53 pm
It’s a shame we’re not given the option to disable the fade in (at least that I am aware of).
Look at the settings in Effects from the Cinnamon menu - Session Startup Animation is the one to toggle.

rockadile
Level 1
Level 1
Posts: 34
Joined: Mon Jun 24, 2013 3:15 pm

Re: Fade In Bug?

Post by rockadile » Wed Oct 10, 2018 8:05 am

smurphos wrote:
Wed Oct 10, 2018 2:54 am
rockadile wrote:
Tue Oct 09, 2018 2:53 pm
It’s a shame we’re not given the option to disable the fade in (at least that I am aware of).
Look at the settings in Effects from the Cinnamon menu - Session Startup Animation is the one to toggle.
Thanks. Unfortunately, that made no difference.

JosephM
Level 6
Level 6
Posts: 1086
Joined: Sun May 26, 2013 6:25 pm

Re: Washed out desktop background image in Mint 19 Virtualbox VM

Post by JosephM » Wed Oct 10, 2018 10:59 pm

Open a terminal and try

Code: Select all

gsettings set org.cinnamon.muffin background-transition 'none'
That setting was added specifically for working around issues with the background in vbox. Hopefully that helps.
When I give opinions, they are my own. Not necessarily those of any other Linux Mint developer or the Linux Mint project as a whole.

rockadile
Level 1
Level 1
Posts: 34
Joined: Mon Jun 24, 2013 3:15 pm

Re: Washed out desktop background image in Mint 19 Virtualbox VM

Post by rockadile » Fri Oct 12, 2018 12:59 pm

JosephM wrote:
Wed Oct 10, 2018 10:59 pm
Open a terminal and try

Code: Select all

gsettings set org.cinnamon.muffin background-transition 'none'
That setting was added specifically for working around issues with the background in vbox. Hopefully that helps.
Looks like that works. Thanks!

User avatar
Mage of Maple
Level 1
Level 1
Posts: 39
Joined: Tue Jul 10, 2018 10:41 am
Location: Maryland USA
Contact:

Re: Washed out desktop background image in Mint 19 Virtualbox VM

Post by Mage of Maple » Sat Oct 27, 2018 12:44 pm

Awesome, that did it! Thanks!!!

Post Reply

Return to “Virtualization”