VirtualBox 32 bit only (Solved)

Questions about virtualization software
Forum rules
Before you post please read how to get help
Post Reply
stevep3129
Level 2
Level 2
Posts: 94
Joined: Mon Sep 21, 2015 6:10 pm
Location: Oregon

VirtualBox 32 bit only (Solved)

Post by stevep3129 » Wed Nov 14, 2018 12:50 am

What am I doing wrong?

In a previous post "viewtopic.php?f=231&t=281175" my problem was solved!
After disabling Secure Boot I ran:

"apt purge virtualbox* && apt install virtualbox-5.2"

Decided to give it a test run. With a 64 bit Mint 18.3 ISO install DVD, which I used for my original Mint install.
To test it I booted the DVD and it worked.

My problem is that VB will only run 32 bit installs no matter what OS is selected.
Screenshot from 2018-11-10 00-03-26.png
In the drop down boxes there are only 32 bit choices.

On that post it was suggested to download VB from
https://www.virtualbox.org/wiki/Linux_Downloads
I found the install Debian based instructions confusing.
Looked around in their documentation and community pages and online couln't find any clarity on how to install it.

Looking around in Mint VB forums found a possible solution:
viewtopic.php?f=231&t=279038

To make sure I removed all VB in Software Manager.

Ran the following code to insure all instances VB was gone:

apt purge virtualbox*

Ran:

wget -q -O - http://download.virtualbox.org/virtualb ... x_2016.asc | sudo apt-key add -
sudo sh -c 'echo "deb http://download.virtualbox.org/virtualbox/debian bionic non-free contrib" >> /etc/apt/sources.list.d/virtualbox.org.list'
sudo apt update && sudo apt install virtualbox-5.2 virtualbox-ext-pack

It installed
Version 5.2.22 r126460 (Qt5.9.5)

I thought it would get me the version that will run a 64 bit OS.
When I start 'Oracle VM VirtualBox' from Application Menu or 'virtualbox' in Terminal, I get the same result. 32 bit only. Clicking on check for updates in VB it says I already have the most recent version.
What should I do next?
Last edited by stevep3129 on Thu Nov 15, 2018 12:18 am, edited 1 time in total.

User avatar
catweazel
Level 17
Level 17
Posts: 7774
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: VirtualBox 32 bit only

Post by catweazel » Wed Nov 14, 2018 12:59 am

stevep3129 wrote:
Wed Nov 14, 2018 12:50 am
What am I doing wrong?
What should I do next?
You've installed a 32bit VBox. Uninstall it and download the correct version.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

stevep3129
Level 2
Level 2
Posts: 94
Joined: Mon Sep 21, 2015 6:10 pm
Location: Oregon

Re: VirtualBox 32 bit only

Post by stevep3129 » Wed Nov 14, 2018 1:04 am

OK, I am a novice LM user .
Can you or someone else show me how to execute a step by step set of commands to do that.
That way I'd learn what it each command does.
I'd appreciate it!

gm10
Level 13
Level 13
Posts: 4669
Joined: Thu Jun 21, 2018 5:11 pm

Re: VirtualBox 32 bit only

Post by gm10 » Wed Nov 14, 2018 2:26 am

I strongly doubt you've got a 32 bit version installed, there isn't even one for LM19, but run apt policy virtualbox-5.2 to check.

Instead check your BIOS settings and make sure you've got the Intel virtualization and Intel VT-d options all enabled.

stevep3129
Level 2
Level 2
Posts: 94
Joined: Mon Sep 21, 2015 6:10 pm
Location: Oregon

Re: VirtualBox 32 bit only

Post by stevep3129 » Wed Nov 14, 2018 2:46 am

Result of running

Code: Select all

 apt pvirtualbox-5.2:
  Installed: 5.2.22-126460~Ubuntu~bionic
  Candidate: 5.2.22-126460~Ubuntu~bionic
  Version table:
 *** 5.2.22-126460~Ubuntu~bionic 100
        100 /var/lib/dpkg/status
steolicy virtualbox-5.2
I really don't want to mess with BIOS, unless absolutely necessary.
Is there a way to check via terminal if they are.
Last edited by stevep3129 on Wed Nov 14, 2018 2:55 am, edited 1 time in total.

gm10
Level 13
Level 13
Posts: 4669
Joined: Thu Jun 21, 2018 5:11 pm

Re: VirtualBox 32 bit only

Post by gm10 » Wed Nov 14, 2018 2:50 am

It is necessary or I wouldn't have said so. If virtualization is disabled in the BIOS you cannot address 64-bit VMs.

That apt policy output is interesting as well. You've got the right version installed but for some reason you removed the virtualbox repository again after installing? Why? You should re-enable/re-add that in order to be able to receive updates.

User avatar
Pierre
Level 17
Level 17
Posts: 7703
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: VirtualBox 32 bit only

Post by Pierre » Wed Nov 14, 2018 4:05 am

interestingly, and up to quite recently, it does seem that I've been using both 32bit & 64bit ISOs
- in a 32bit VirtualBox AKA ubuntu_trusty_i386.deb
all I've been doing, is to check some options, in the Guest system properties list,
but even then, there are both 32 bit & 64 bit VBs that can be selected.
:?
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

gm10
Level 13
Level 13
Posts: 4669
Joined: Thu Jun 21, 2018 5:11 pm

Re: VirtualBox 32 bit only

Post by gm10 » Wed Nov 14, 2018 4:16 am

Pierre wrote:
Wed Nov 14, 2018 4:05 am
interestingly, and up to quite recently, it does seem that I've been using both 32bit & 64bit ISOs
- in a 32bit VirtualBox AKA ubuntu_trusty_i386.deb
all I've been doing, is to check some options, in the Guest system properties list,
but even then, there are both 32 bit & 64 bit VBs that can be selected.
:?
That's working as intended. As long as you've got 64-bit hardware with hardware virtualization support you can run 64-bit guests, the architecture of the virtualbox application doesn't matter.

User avatar
Pierre
Level 17
Level 17
Posts: 7703
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: VirtualBox 32 bit only

Post by Pierre » Wed Nov 14, 2018 4:44 am

and which, continues to confirm my theory, that all PCs
from Vista onwards - are 64Bit based CPUs 8)
( my PCs are all Ex Vista )
- - great for recycling .. .


so - what type of machine does stevep3129 have ?.
- it should be a 64bit machine, so it seems.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

stevep3129
Level 2
Level 2
Posts: 94
Joined: Mon Sep 21, 2015 6:10 pm
Location: Oregon

Re: VirtualBox 32 bit only

Post by stevep3129 » Wed Nov 14, 2018 10:43 pm

Looked around in BIOS and found what I think VT-d might be in CPU setup, Intel Virtualization Technology, it was disabled, enabled it.
My machine is home build a little over three years old.
Here is my system info:

Code: Select all

steve@steve ~ $ inxi -Fxz
System:    Host: steve Kernel: 4.15.0-39-generic x86_64 bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
Machine:   Device: desktop System: ASUS product: All Series serial: N/A
           Mobo: ASUSTeK model: Z97-A-USB31 v: Rev 1.xx serial: N/A
           UEFI: American Megatrends v: 2501 date: 06/24/2015
Battery    hidpp__0: charge: N/A condition: NA/NA Wh
           model: Logitech Wireless Mouse M325 status: Discharging
CPU:       Quad core Intel Core i5-4690K (-MCP-) 
           arch: Haswell rev.3 cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 27996
           clock speeds: max: 4300 MHz 1: 1077 MHz 2: 984 MHz 3: 978 MHz
           4: 1130 MHz
Graphics:  Card: NVIDIA GM206 [GeForce GTX 950] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: nvidia (unloaded: modesetting,fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: GeForce GTX 950/PCIe/SSE2
           version: 4.6.0 NVIDIA 390.77 Direct Render: Yes
Audio:     Card-1 NVIDIA Device 0fba driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Intel 9 Series Family HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-39-generic
Network:   Card: Intel Ethernet Connection (2) I218-V
           driver: e1000e v: 3.2.6-k port: f040 bus-ID: 00:19.0
           IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 1256.3GB (35.7% used)
           ID-1: /dev/sda model: MKNSSDRE256GB size: 256.1GB
           ID-2: /dev/sdb model: WDC_WD10EZEX size: 1000.2GB
Partition: ID-1: / size: 219G used: 58G (28%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 17.11GB used: 0.00GB (0%)
           fs: swap dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 0.0:28C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 205 Uptime: 1 min Memory: 1102.1/15977.3MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 
steve@steve ~ $ 
What should I do next?

gm10
Level 13
Level 13
Posts: 4669
Joined: Thu Jun 21, 2018 5:11 pm

Re: VirtualBox 32 bit only

Post by gm10 » Wed Nov 14, 2018 10:46 pm

Next you try if you can create 64-bit VMs now. Otherwise you probably missed another option in the BIOS (it's often 2 separate ones).

stevep3129
Level 2
Level 2
Posts: 94
Joined: Mon Sep 21, 2015 6:10 pm
Location: Oregon

Re: VirtualBox 32 bit only

Post by stevep3129 » Thu Nov 15, 2018 12:17 am

Enabling Intel Virtualization Technology solved the problem.
Thank you!

Post Reply

Return to “Virtualization”