Page 1 of 1

USB ports in LM 19.1 & VB 6.0.8

Posted: Thu May 16, 2019 5:15 am
by richard-g8jvm
I'd ask on the oracle forum , but its blocking anyone joining and the mailing list seems defunct.
Guest OS win7

Code: Select all

$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 0bda:5520 Realtek Semiconductor Corp. 
Bus 001 Device 005: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC
Bus 001 Device 003: ID 0cf3:e009 Atheros Communications, Inc. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

The USB devices are greyed out on the setting, and its not seeing device 005
I've added it to a filter, and the guest OS cant see it
I've added the guest additions, well I double clicked on it and it said it had updated

What magic incantations need to be uttered to get VB6 to see the USB ports, I've tried all know anglo saxon ones :)

Re: USB ports in LM91.1 & VB 6.0.8

Posted: Thu May 16, 2019 4:35 pm
by pbear
Hard to know where you're going sideways, but I can confirm USB access works fine in 6.0.8. Now, that's with a known working guest (Mint rather than Win7, but shouldn't matter), guest additions properly installed (and updated), extension pack properly installed (and updated), and prior experience accessing USB drives. In addition to the obvious, i.e., going back over the ground with a fine tooth comb, I'll mention that I've never found filters useful for USB drives. Rather, I set up everything else, then claim the drive manually from menu, i.e., Devices > USB > [Select from list].

Re: USB ports in LM91.1 & VB 6.0.8

Posted: Thu May 16, 2019 4:41 pm
by richard-g8jvm
Hiya

I've tried that, I've had to resort to an old clunker in storage and load win7 on it
the clunker is old enough to have a serial port on it, so that saves trying to use a USB FTDI adaptor

Re: USB ports in LM91.1 & VB 6.0.8

Posted: Thu May 16, 2019 4:58 pm
by AndyMH
Have you installed the VB extension pack?

Have you installed guest additions in win7?

Are you a member of vboxusers group in mint?

Have you installed usb3.0 drivers in win7?

Re: USB ports in LM91.1 & VB 6.0.8

Posted: Thu May 16, 2019 5:08 pm
by richard-g8jvm
hi
yes, yes, yes and no
the ftdi usb device isn't usb3, also not sure if usb3 was in use for win7 ?

Re: USB ports in LM91.1 & VB 6.0.8

Posted: Thu May 16, 2019 5:31 pm
by AndyMH
That's why I asked, win7 shipped without usb3.

You have everything in place so should work :(

On a laptop that doesn't have VB on it, so from memory think the default setting in VB is usb1.0, what have you got set there?

Does any usb device work with VB & win7?

Re: USB ports in LM91.1 & VB 6.0.8

Posted: Thu May 16, 2019 5:39 pm
by richard-g8jvm
There is a pickit3 device which was used with an earlier version of VB, I haven't tried it with VB6.
I'll have a play in the morning asnd see if it gets picked up in VB6, I suspect it was just added from a earlier version
cheers

Re: USB ports in LM91.1 & VB 6.0.8

Posted: Fri May 17, 2019 12:47 am
by farkas
If your machine has an Intel processor check out https://downloadcenter.intel.com/downlo ... duct=65855 .
Check to see if your machine meets the specs.
If it does start your win7 guest OS. Within your guest OS download and install the USB drivers.

Re: USB ports in LM91.1 & VB 6.0.8

Posted: Fri May 17, 2019 1:15 am
by AndyMH
I'd ask on the oracle forum , but its blocking anyone joining and the mailing list seems defunct.
I've just logged in there, have only posted/asked questions a couple of times. All seems to be working.
https://login.oracle.com/oaam_server/lo ... 1933161658

Re: USB ports in LM91.1 & VB 6.0.8

Posted: Fri May 17, 2019 4:20 am
by richard-g8jvm
If you register to join as soon as the email address conformation is sent, you get the large splash saying you are now registered,
but siiting behind that is a HTTP error message from the server saying its rejected.
And thats repeatable

Anyway by the time LM reaches v 91.1 it will be fixed, I hadn't noticed the typo