3D acceleration Virtualbox no longer working

Questions about virtualization software
Forum rules
Before you post please read how to get help
ACE256
Level 1
Level 1
Posts: 9
Joined: Tue Sep 15, 2020 9:25 am

3D acceleration Virtualbox no longer working

Post by ACE256 »

Since yesterday my Linux mint (cinnamon 20.2) virtual machines no longer works in VirtualBox - the screen goes white and nothing is visible.

1. My Windows10 and Kali Linux virtual machines works fine
2. When I disable 3d acceleration things work fine
3. it all worked fine until yesterday

Host is Linux mint cinnamon 20.2

Have searched but find nothing or anyone with similar problem

Any ideas? Thanks
Last edited by ACE256 on Wed Aug 04, 2021 3:16 pm, edited 2 times in total.
calisto42
Level 1
Level 1
Posts: 3
Joined: Wed Aug 04, 2021 7:36 am

Re: 3D acceleration Virtualbox no longer working

Post by calisto42 »

I got exactle the same problem after booting up today. Screen gets white, Menu icons flat white on black background. Opening up the Menu just gives hints of scrambled text (see attachment)

Host is a WIndows 10 Notebook with current patches on a Intel Core i5-1135G7 with Intel Iris XE Chipset Graphics.

What I tried but didn't work:
- Upgrade virtualbox to current version, including installing current version of guest extensions
- Upgrade Mint to 20.2 (was 20.0 or 20.1 before)
- Booting Grub with older Kernel (5.4.x.77 instead of .80)

What does work as workaround: Disabling 3d in virtual Box
Attachments
VirtualBox_Mint_04_08_2021_13_42_14.png
gawkroger
Level 1
Level 1
Posts: 1
Joined: Wed Aug 04, 2021 8:12 am

Re: 3D acceleration Virtualbox no longer working

Post by gawkroger »

Same problem here. Reverted back to an older Virtualbox image installed updates and blocked:
-mesa=21.0.3-0ubuntu0.2~20.04.1
-xorg-server=2:1.20.11-1ubuntu1~20.04.2

Then 3D acceleration is working again!
RIH
Level 6
Level 6
Posts: 1329
Joined: Sat Aug 22, 2015 3:47 am

Re: 3D acceleration Virtualbox no longer working

Post by RIH »

Linux Mint 20.2 Host & Linux mint 20.2 Guest.
Black screen if 3D acceleration turned off.
Worked as normal when 3D ticked..
User avatar
absque fenestris
Level 11
Level 11
Posts: 3583
Joined: Sat Nov 12, 2016 8:42 pm
Location: Confoederatio Helvetica

Re: 3D acceleration Virtualbox no longer working

Post by absque fenestris »

@ calisto42

In contrast to the opener, you offer almost all details about the host and guest, except for one thing: which Mint desktop are you using?

I'm currently using Mint 20.2 Cinnamon as a guest on a Windows 10 host and have no problems with the 3D acceleration.
Linux Mint 18.3 Sylvia (MATE) 32-bit - Acer D250 Netbook
Linux Mint 20.0 Ulyana (Cinnamon) - Huawei MateBook X Pro
User avatar
absque fenestris
Level 11
Level 11
Posts: 3583
Joined: Sat Nov 12, 2016 8:42 pm
Location: Confoederatio Helvetica

Re: 3D acceleration Virtualbox no longer working

Post by absque fenestris »

I think now we can compare our virtual boxes - I run this version on the current Windows 10:

VirtualBox 6.1.16 r140961 (Qt 5.6.2) with the associated extensions


:?: That was actually intended as an answer to opener @ ACE ...
Linux Mint 18.3 Sylvia (MATE) 32-bit - Acer D250 Netbook
Linux Mint 20.0 Ulyana (Cinnamon) - Huawei MateBook X Pro
calisto42
Level 1
Level 1
Posts: 3
Joined: Wed Aug 04, 2021 7:36 am

Re: 3D acceleration Virtualbox no longer working

Post by calisto42 »

you offer almost all details about the host and guest, except for one thing: which Mint desktop are you using?
I'm using Cinnamon. I'm not exactly sure if it was 20.0 or 20.1 at time when problem occured, but I later updated to 20.2 and problem was still showing.
Last edited by calisto42 on Wed Aug 04, 2021 10:07 am, edited 1 time in total.
calisto42
Level 1
Level 1
Posts: 3
Joined: Wed Aug 04, 2021 7:36 am

Re: 3D acceleration Virtualbox no longer working

Post by calisto42 »

gawkroger wrote:
Wed Aug 04, 2021 8:33 am
Same problem here. Reverted back to an older Virtualbox image installed updates and blocked:
-mesa=21.0.3-0ubuntu0.2~20.04.1
-xorg-server=2:1.20.11-1ubuntu1~20.04.2

Then 3D acceleration is working again!
Thats a good hint. the last update before it broke for me was, according to history:

Code: Select all

Start-Date: 2021-08-03  18:02:29
Commandline: /usr/sbin/synaptic --hide-main-window --non-interactive --parent-window-id 92274701 -o Synaptic::closeZvt=true --set-selections-file /tmp/tmp3djwm_d2
Requested-By: torstenp (1000)
Install: ffmpeg:amd64 (7:4.2.4-1ubuntu0.1, automatic), python3-pyxattr:amd64 (0.6.1-2, automatic), python3-netaddr:amd64 (0.7.19-3, automatic), libjcat1:amd64 (0.1.3-2~ubuntu20.04.1, automatic), rtmpdump:amd64 (2.4+20151223.gitfa8646d.1-2
build1, automatic), mpv:amd64 (0.32.0-1ubuntu1, automatic), libllvm12:amd64 (1:12.0.0-3ubuntu1~20.04.3, automatic), youtube-dl:amd64 (2021.04.26-1, automatic), ieee-data:amd64 (20180805.1, automatic), libavresample4:amd64 (7:4.2.4-1ubuntu
0.1, automatic)
Upgrade: libgoa-backend-1.0-1:amd64 (3.36.0-linuxmint1, 3.36.1-linuxmint1+uma), libqpdf26:amd64 (9.1.1-1build1, 9.1.1-1ubuntu0.1), gnome-settings-daemon-common:amd64 (3.36.1-0ubuntu1, 3.36.1-0ubuntu1.1), hypnotix:amd64 (1.6, 2.0), libdrm-
nouveau2:amd64 (2.4.102-1ubuntu1~20.04.1, 2.4.105-3~20.04.1), xserver-common:amd64 (2:1.20.9-2ubuntu1.2~20.04.2, 2:1.20.11-1ubuntu1~20.04.2), xserver-xorg-core:amd64 (2:1.20.9-2ubuntu1.2~20.04.2, 2:1.20.11-1ubuntu1~20.04.2), libgoa-1.0-0b
:amd64 (3.36.0-linuxmint1, 3.36.1-linuxmint1+uma), libegl-mesa0:amd64 (20.2.6-0ubuntu0.20.04.1, 21.0.3-0ubuntu0.2~20.04.1), libgoa-1.0-common:amd64 (3.36.0-linuxmint1, 3.36.1-linuxmint1+uma), mintinstall:amd64 (8.0.5, 8.0.8), mint-themes:
amd64 (1.8.7, 1.8.8), libglapi-mesa:amd64 (20.2.6-0ubuntu0.20.04.1, 21.0.3-0ubuntu0.2~20.04.1), yelp:amd64 (3.36.0-linuxmint1, 3.36.2-linuxmint1+uma), libyelp0:amd64 (3.36.0-linuxmint1, 3.36.2-linuxmint1+uma), ubuntu-advantage-tools:amd64
 (27.2.1~20.04.1, 27.2.2~20.04.1), lightdm-settings:amd64 (1.5.2, 1.5.5), mintsystem:amd64 (8.5.1, 8.5.2), mintlocale:amd64 (1.5.7, 1.5.8), xserver-xorg-legacy:amd64 (2:1.20.9-2ubuntu1.2~20.04.2, 2:1.20.11-1ubuntu1~20.04.2), libxatracker2
:amd64 (20.2.6-0ubuntu0.20.04.1, 21.0.3-0ubuntu0.2~20.04.1), gnome-settings-daemon:amd64 (3.36.1-0ubuntu1, 3.36.1-0ubuntu1.1), passwd:amd64 (1:4.8.1-1ubuntu5.20.04, 1:4.8.1-1ubuntu5.20.04.1), libgbm1:amd64 (20.2.6-0ubuntu0.20.04.1, 21.0.3
-0ubuntu0.2~20.04.1), xserver-xephyr:amd64 (2:1.20.9-2ubuntu1.2~20.04.2, 2:1.20.11-1ubuntu1~20.04.2), libdrm-amdgpu1:amd64 (2.4.102-1ubuntu1~20.04.1, 2.4.105-3~20.04.1), mintreport:amd64 (1.2.3, 1.2.5), libfwupdplugin1:amd64 (1.3.11-1~foc
al1, 1.5.11-0ubuntu1~20.04.2), mintdrivers:amd64 (1.5.5, 1.5.8), nvidia-prime-applet:amd64 (1.2.7, 1.2.9), xwayland:amd64 (2:1.20.9-2ubuntu1.2~20.04.2, 2:1.20.11-1ubuntu1~20.04.2), libsndfile1:amd64 (1.0.28-7, 1.0.28-7ubuntu0.1), mintback
up:amd64 (2.4.1, 2.4.2), libdrm2:amd64 (2.4.102-1ubuntu1~20.04.1, 2.4.105-3~20.04.1), libwebkit2gtk-4.0-37:amd64 (2.32.0-0ubuntu0.20.04.1, 2.32.3-0ubuntu0.20.04.1), gnome-online-accounts:amd64 (3.36.0-linuxmint1, 3.36.1-linuxmint1+uma), l
ogin:amd64 (1:4.8.1-1ubuntu5.20.04, 1:4.8.1-1ubuntu5.20.04.1), mintstick:amd64 (1.4.4, 1.4.6), libgl1-mesa-dri:amd64 (20.2.6-0ubuntu0.20.04.1, 21.0.3-0ubuntu0.2~20.04.1), libfwupd2:amd64 (1.3.11-1~focal1, 1.5.11-0ubuntu1~20.04.2), fwupd-s
igned:amd64 (1.27.1ubuntu2+1.3.11-1~focal1, 1.27.1ubuntu5+1.5.11-0ubuntu1~20.04.2), warpinator:amd64 (1.1.2+ulyssa, 1.2.4+uma), folder-color-switcher:amd64 (1.4.6, 1.4.8), fwupd:amd64 (1.3.11-1~focal1, 1.5.11-0ubuntu1~20.04.2), gir1.2-web
kit2-4.0:amd64 (2.32.0-0ubuntu0.20.04.1, 2.32.3-0ubuntu0.20.04.1), libgnutls30:amd64 (3.6.13-2ubuntu1.3, 3.6.13-2ubuntu1.6), libdrm-intel1:amd64 (2.4.102-1ubuntu1~20.04.1, 2.4.105-3~20.04.1), libdrm-radeon1:amd64 (2.4.102-1ubuntu1~20.04.1
, 2.4.105-3~20.04.1), mesa-vdpau-drivers:amd64 (20.2.6-0ubuntu0.20.04.1, 21.0.3-0ubuntu0.2~20.04.1), mesa-vulkan-drivers:amd64 (20.2.6-0ubuntu0.20.04.1, 21.0.3-0ubuntu0.2~20.04.1), libexiv2-27:amd64 (0.27.2-8ubuntu2.4, 0.27.2-8ubuntu2.5),
 libjavascriptcoregtk-4.0-18:amd64 (2.32.0-0ubuntu0.20.04.1, 2.32.3-0ubuntu0.20.04.1), gir1.2-javascriptcoregtk-4.0:amd64 (2.32.0-0ubuntu0.20.04.1, 2.32.3-0ubuntu0.20.04.1), mesa-va-drivers:amd64 (20.2.6-0ubuntu0.20.04.1, 21.0.3-0ubuntu0.2~20.04.1), libglx-mesa0:amd64 (20.2.6-0ubuntu0.20.04.1, 21.0.3-0ubuntu0.2~20.04.1), libdrm-common:amd64 (2.4.102-1ubuntu1~20.04.1, 2.4.105-3~20.04.1)
End-Date: 2021-08-03  18:02:57
ACE256
Level 1
Level 1
Posts: 9
Joined: Tue Sep 15, 2020 9:25 am

Re: 3D acceleration Virtualbox no longer working

Post by ACE256 »

absque fenestris wrote:
Wed Aug 04, 2021 9:45 am
I think now we can compare our virtual boxes - I run this version on the current Windows 10:

VirtualBox 6.1.16 r140961 (Qt 5.6.2) with the associated extensions


:?: That was actually intended as an answer to opener @ ACE ...

I run Version 6.1.26 r145957 (Qt5.12.8)
User avatar
absque fenestris
Level 11
Level 11
Posts: 3583
Joined: Sat Nov 12, 2016 8:42 pm
Location: Confoederatio Helvetica

Re: 3D acceleration Virtualbox no longer working

Post by absque fenestris »

.
I see in my pending updates that a Mesa update is due.

Image


To be on the safe side, I'll do a Timeshift snap - and a vbox snap in Windows. Let's see if that's the bad boy. Thanks @ gawcroger for the hint.
Linux Mint 18.3 Sylvia (MATE) 32-bit - Acer D250 Netbook
Linux Mint 20.0 Ulyana (Cinnamon) - Huawei MateBook X Pro
User avatar
absque fenestris
Level 11
Level 11
Posts: 3583
Joined: Sat Nov 12, 2016 8:42 pm
Location: Confoederatio Helvetica

Re: 3D acceleration Virtualbox no longer working

Post by absque fenestris »

A short interim remark:

This thread shows once again how important the details are. At "VirtualBox" we inevitably talk about apples, pears and strawberries and look for the rotten tomato somewhere ...
Linux Mint 18.3 Sylvia (MATE) 32-bit - Acer D250 Netbook
Linux Mint 20.0 Ulyana (Cinnamon) - Huawei MateBook X Pro
delanef
Level 1
Level 1
Posts: 5
Joined: Wed Aug 04, 2021 10:58 am

Re: 3D acceleration Virtualbox no longer working

Post by delanef »

HI All,

First time post...

I'm experiencing the same issue as the rest of you. Yesterday it worked, today it has gone "white screen". I'm posting my info and an observation in hopes it will help someone determine the cause.

Host: Window 10
Emulation: VirtualBox 6.1.26 r145957
Guest: Linux Mint 20.2(Uma)

Situation: Normal login prompt; but, after login graphics rendering are corrupted and the VM goes "white screen" with black menu and no graphics rendered. Luckily, I was able to restore a snapshot to recover.

Observation: On the login prompt, one can switch desktop environment from Cinnamon(Default) to Cinnamon(Software Rendering). After login, the desktop rendering appears as normal.

If you haven't performed an upgrade to Uma, don't! The upgrade will cause this issue as well. I suspect it's in connection to the listed mesa and xorg-server updates in the past couple days.

Regards,
delanef
GrahamLMC
Level 1
Level 1
Posts: 6
Joined: Sun Mar 03, 2019 2:22 pm

Re: 3D acceleration Virtualbox no longer working

Post by GrahamLMC »

I've had the same experience as previous posters with a white screen in LM20 Cinnamon.

To test if it was the Mesa update I've just created a new LM20.2 Cinnamon VM in Virtual Box 6.1.26, using the following steps:

1. Create new VM from LM20.2 Cinnamon ISO and install to disk.
2. After installation reboot, and then install 6.1.26 Guest Additions.
3. After reboot run Timeshift and make a system backup.
4. Install all updates (including kernel update) except Mesa VDPAU 21.0.3-0ubuntu0.2-20.04.1
5. After reboot run Timeshift and make another backup, then install Mesa VDPAU 21.0.3-0ubuntu0.2-20.04.1 and reboot.

The result as expected was a white screen, so I stopped the VM.

6. Turn 3D acceleration off and restart the VM. The desktop display was fine with the message about software rendering.
7. Revert the system back to the previous Timeshift backup.
8. After reboot, stop the VM to switch 3D acceleration back on.
9. Restart the VM and the desktop display was fine.

Which seems to show that Mesa VDPAU update is the problem.
User avatar
absque fenestris
Level 11
Level 11
Posts: 3583
Joined: Sat Nov 12, 2016 8:42 pm
Location: Confoederatio Helvetica

Re: 3D acceleration Virtualbox no longer working

Post by absque fenestris »

GrahamLMC wrote:
Wed Aug 04, 2021 2:49 pm
...
Which seems to show that Mesa VDPAU update is the problem.
Thank you for sharing your observations here. Saves a lot of time and trouble - I'll blacklist the Mesa update.
Linux Mint 18.3 Sylvia (MATE) 32-bit - Acer D250 Netbook
Linux Mint 20.0 Ulyana (Cinnamon) - Huawei MateBook X Pro
User avatar
agtiger
Level 1
Level 1
Posts: 15
Joined: Wed Aug 04, 2021 3:06 pm

Re: 3D acceleration Virtualbox no longer working

Post by agtiger »

Environment: VirtualBox 6.1.26 r 145957 (Qt5.6.2) running on Windows Host OS.
Matching version extension pack installed.
Matching Guest Additions running inside of linux virtualbox machines.
Virtual box display settings set to: VMSVGA (this is the appropriate setting per the VirtualBox User Guide for linux guest machines.)

Guest machines running:
Linux Mint 20.2
Cinnamon 5.0.5
Kernel: 5.4.0-80-generic
Graphics Card: VMware SVGA II Adapter (prog-if 00 [VGA controller])

Installed WORKING versions of files/drivers:

mesa-vdpau-drivers 20.2.6-0ubuntu0.20.04.1
libllvm11 1:11.0.0-2~ubuntu20.04.1

Problem occurs when:
After applying update: mesa VDPAU video acceleration drivers 21.0.3-0ubuntu0.2~20.04.1

Symptoms:
After applying update and either logging out/logging in of Cinnamon, or restarting machine and logging into Cinnamon:
- screen is all white
- icons on panel are all white
- menu displays in illegible white characters - navigating around the menu changes this to illegible colored large pixels for the menu text

Further info from /var/log/apt/history.log of what was changed when applying mesa VDPAU video acceleration drivers:

Start-Date: 2021-08-04 12:01:04
Commandline: /usr/sbin/synaptic --hide-main-window --non-interactive --parent-window-id 88080398 -o Synaptic::closeZvt=true --set-selections-file /tmp/tmporokdjxx
Requested-By: user (1000)
Install: libllvm12:amd64 (1:12.0.0-3ubuntu1~20.04.3, automatic)
Upgrade: libgles2-mesa:amd64 (20.2.6-0ubuntu0.20.04.1, 21.0.3-0ubuntu0.2~20.04.1), libegl-mesa0:amd64 (20.2.6-0ubuntu0.20.04.1, 21.0.3-0ubuntu0.2~20.04.1), libglapi-mesa:amd64 (20.2.6-0ubuntu0.20.04.1, 21.0.3-0ubuntu0.2~20.04.1), libxatracker2:amd64 (20.2.6-0ubuntu0.20.04.1, 21.0.3-0ubuntu0.2~20.04.1), libegl1-mesa:amd64 (20.2.6-0ubuntu0.20.04.1, 21.0.3-0ubuntu0.2~20.04.1), libgbm1:amd64 (20.2.6-0ubuntu0.20.04.1, 21.0.3-0ubuntu0.2~20.04.1), libwayland-egl1-mesa:amd64 (20.2.6-0ubuntu0.20.04.1, 21.0.3-0ubuntu0.2~20.04.1), libgl1-mesa-dri:amd64 (20.2.6-0ubuntu0.20.04.1, 21.0.3-0ubuntu0.2~20.04.1), libgl1-mesa-glx:amd64 (20.2.6-0ubuntu0.20.04.1, 21.0.3-0ubuntu0.2~20.04.1), mesa-vdpau-drivers:amd64 (20.2.6-0ubuntu0.20.04.1, 21.0.3-0ubuntu0.2~20.04.1), mesa-vulkan-drivers:amd64 (20.2.6-0ubuntu0.20.04.1, 21.0.3-0ubuntu0.2~20.04.1), mesa-va-drivers:amd64 (20.2.6-0ubuntu0.20.04.1, 21.0.3-0ubuntu0.2~20.04.1), libglx-mesa0:amd64 (20.2.6-0ubuntu0.20.04.1, 21.0.3-0ubuntu0.2~20.04.1)
End-Date: 2021-08-04 12:01:28
User avatar
rattkjelke
Level 2
Level 2
Posts: 64
Joined: Wed Jul 13, 2011 5:55 pm
Location: USA

Re: 3D acceleration Virtualbox no longer working

Post by rattkjelke »

I have 20.2 Cinnamon and 20.2 Mate VMs on a host machine that is running 20.2 Xfce.
I'm using the latest VirtualBox and guest additions 6.1.26 from their web site.
The white screen happens on Cinnamon but not Mate.
Sumarious
Level 1
Level 1
Posts: 1
Joined: Wed Aug 04, 2021 6:31 pm

Re: 3D acceleration Virtualbox no longer working

Post by Sumarious »

Just had this exact issue when running updates on mint.

Before you login, change your session to software rendering.

Once you're logged in, attach the guest utils cd, and run the installer to reinstall them.

For some reason on this latest kernel update, the guest utils don't get applied to the latest kernel..

sudo /sbin/rcvboxadd quicksetup all

Reboot, and you should be golden.
ajgringo619
Level 9
Level 9
Posts: 2598
Joined: Thu Mar 01, 2018 8:36 pm
Location: Southern Kali, USA

Re: 3D acceleration Virtualbox no longer working

Post by ajgringo619 »

Sumarious wrote:
Wed Aug 04, 2021 6:32 pm
For some reason on this latest kernel update, the guest utils don't get applied to the latest kernel..
Did you mean "mesa" update? There was no kernel update yesterday, at least not on the 5.4 LTS branch.
Image
RIH
Level 6
Level 6
Posts: 1329
Joined: Sat Aug 22, 2015 3:47 am

Re: 3D acceleration Virtualbox no longer working

Post by RIH »

Version 6.1.26 r145957 (Qt5.12.8) running on Cinnamon Mint 20.2
VBoxGuestAdditions-6.1.26
Host & Guest Kernel 5.4.0-80
Mesa updates done yesterday.
3 D Acceleration working.

I did notice that the guest system, yesterday, told me that a new version of Guest Additions was available & I ran that as well..
raymondjpg
Level 1
Level 1
Posts: 6
Joined: Fri Jan 04, 2013 9:43 pm

Re: 3D acceleration Virtualbox no longer working

Post by raymondjpg »

Sumarious wrote:
Wed Aug 04, 2021 6:32 pm
Just had this exact issue when running updates on mint.

Before you login, change your session to software rendering.

Once you're logged in, attach the guest utils cd, and run the installer to reinstall them.

For some reason on this latest kernel update, the guest utils don't get applied to the latest kernel..

sudo /sbin/rcvboxadd quicksetup all

Reboot, and you should be golden.
Workaround not working here. Linux Mint 20.1 Cinnamon guest running in Windows 10 host, Nvidia graphics.

Guess we just have to wait for Mesa VDPAU update.
Post Reply