grub issue: errors and no 3.16 kernel [solved]

Archived topics about LMDE 1 and LMDE 2
Locked
User avatar
xfrank
Level 5
Level 5
Posts: 608
Joined: Sat Nov 24, 2012 6:09 pm
Location: Mexico City
Contact:

grub issue: errors and no 3.16 kernel [solved]

Post by xfrank »

Following my post in: http://forums.linuxmint.com/viewtopic.p ... 0#p1018910 This section is more appropriate to continue.
After the upgrade process I still had kernel 3.11 as the olnly default in grub, and when I attempted to update-grub:

Code: Select all

root@xflmde:/home/xfrank# update-grub
GRUB >= 2.00 has been unpacked but not yet configured.
grub-mkconfig will not work until the upgrade is complete.
It should run later as part of configuring the new GRUB packages.
OK. Searching the forums I've found that this happened to others, for example: http://ubuntuforums.org/showthread.php?t=2259462 or http://crunchbang.org/forums/viewtopic.php?id=32251

I tried to swap the /etc/grub.d/00_header with /etc/grub.d/00_header.dpkg-dist and then reinstalling grub-common. This time the update-grub output changed to:

Code: Select all

root@xflmde:/home/xfrank# update-grub
Generating grub configuration file ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Found linux image: /boot/vmlinuz-3.16.0-4-amd64
Found initrd image: /boot/initrd.img-3.16.0-4-amd64
Found linux image: /boot/vmlinuz-3.11-2-amd64
Found initrd image: /boot/initrd.img-3.11-2-amd64
Encontrado Windows 7 (loader) en /dev/sde1
cat: /video.lst: No existe el fichero o el directorio
/usr/sbin/grub-probe: error: no se pudo obtener la ruta canónica de «».
No se ha especificado una ruta o un dispositivo.
Uso: grub-probe [OPCIÓN...] [OPCIÓN]... [RUTA|DISPOSITIVO]
Pruebe «grub-probe --help» o «grub-probe --usage» para más información.
.
This way, I rebooted: the grub still don't show kernel 3.16. And there are that error messages... So, what I suppose to do now? :?
Last edited by xfrank on Tue May 19, 2015 9:33 pm, edited 1 time in total.
Active Distros in my computers: LM19.3 (Mate,Xfce); MXLinux (Xfce); SparkyLinux (Xfce); Manjaro (Xfce)

User avatar
xfrank
Level 5
Level 5
Posts: 608
Joined: Sat Nov 24, 2012 6:09 pm
Location: Mexico City
Contact:

Re: grub issue: errors and no 3.16 kernel

Post by xfrank »

Update. I solved this issue this way: in /etc/grub.d/ I had to move the old 00_header (renamed as OLD) in a separate folder. This way the system could not "see" it anymore. The only file available is now the 00_header.dpkg-dist renamed as 00_header.
Then I did in the terminal a sudo update-grub. Bingo! Grub was reconfigured and recognized kernel 3.16 by default. :P
Active Distros in my computers: LM19.3 (Mate,Xfce); MXLinux (Xfce); SparkyLinux (Xfce); Manjaro (Xfce)

Locked

Return to “LMDE Archive”