Page 1 of 1

Chrome never works

Posted: Sun Feb 03, 2013 12:46 pm
by victorsk
Hi all,

I've had this LMDE for, oh, several years now and the only thing I haven't been able to make work so far is Chrome browser. I tried to install it from Package Manager and official Google site and while the app icon appears, when I click on it, nothing happens. I use Firefox as my browser but occasionally need Chrome to test my web apps I am developing, since it's better for developer to test in different browsers. BTW Opera installed just fine.

So the problem when I try to run chrome, from shell for example, is this:

Code: Select all

me@localhost:/usr/bin$ cd /opt/google/chrome/
me@localhost:/opt/google/chrome$ ./google-chrome 
[29001:29001:0202/] Failed to read master_preferences file at /opt/google/chrome/master_preferences. Falling back to default preferences.
[29001:29001:0202/] Creating shared memory in /dev/shm/ failed: No such file or directory
[29001:29001:0202/] Unable to access(W_OK|X_OK) /dev/shm: No such file or directory
[29001:29001:0202/] This is frequently caused by incorrect permissions on /dev/shm.  Try 'sudo chmod 1777 /dev/shm' to fix.
me@localhost:/opt/google/chrome$ sudo chmod 1777 /dev/shm
Edit: and when I try to execute last line I get this:

Code: Select all

chmod: cannot operate on dangling symlink `/dev/shm'
Same error when I try to run it from this location: 'me@localhost:/opt/google/chrome$ ./google-chrome'

I really have ran out of options on what to do. I considered compiling Chrome from source but Chrome source files I saw were like 2GB or 400MB, which didn't seem right, and I doubt that would work anyways.

Does anybody know what could the problem be and how I could solve it?


[SOLVED] Re: Chrome never works

Posted: Sun Feb 03, 2013 2:32 pm
by victorsk
Great news! I was finally able to resolve this issue after Googling for error: chmod: cannot operate on dangling symlink `/dev/shm'

The solution is here: ... _3DBkF2H0J

"mkdir /run/shm
chmod 1777 /run/shm "

However, this shows there was a potential bug in my LMDE installation since I had to go through this workaround? Just an FYI to LMDE developers :wink: