Page 1 of 1

SOLVED - Bluetooth Connection to Bose Soundlink II

Posted: Thu Aug 08, 2013 8:59 am
by Fajah
I've had no issues connecting my various Bluetooth enabled devices to my Bose Soundlink II speaker, including my Windows 8 (partition). Using LMDE (regardless of the DE), recognizing and pairing the Bose speaker was fine, however, subsequent connection attempts were brief and ultimately failed. I could not find any solutions through searches, so I examined what was installed via the Synaptic Package Manager.

All the necessary packages/files seemed to be installed so I decided to try some of the additional managers and/or tools. I first tried Blueman. It didn't work, and subsequently uninstalled it. I then installed Bluez-tools (0.1.38+git662e-3) and it solved the issue. The Bose was detected immediately and a solid connection maintained. It also showed up in the list of "Output Devices" so that I can select it.

Unfortunately, I'm not able to explain why this package fixed the issue, other than to surmise that some file was added that was previously missing. Maybe someone with more technical knowledge of Linux and this issue could weigh in. Bottom line is..... it works ..... so I consider myself lucky :)

Hope others might find this useful.

Re: SOLVED - Bluetooth Connection to Bose Soundlink II

Posted: Fri Aug 15, 2014 11:29 am
by rogerbx
Hello,

Thanks for the tip.

I was turning around to reconnect my Bose SoundLink Mini to my PC with Ubuntu 12.04.
This was working fine for weeks and after trying a live Ubuntu Studio distribution where I was not able to connect the bluetooth device using Blueman and I lost the connexion. Don't ask why I don't know.
Trying to connect after booting under windows 7 works fine.

bluez-tools solved the problem under ubuntu after the following commands.

bt-device -r <mac adress>
bt-adapter -d
bt-audio -c <mac adress>

Best regards and thank you

Roger