Page 1 of 1

unable to install a Brother printer in LMDE 64bit [solved!]

Posted: Sun Aug 25, 2013 6:53 pm
by xfrank
I have tried all, searched all the forums, but I can't install properly my Brother MFC-J270w, either usb or wifi.
This printer work on 32 bit, I was successful to set up it in another PC with Mint13. The problem is:

1 - Brother do have the .deb driver (cupswrapper and RPL) to install, but is only for 32bit. I installed it, the printer won't print (is recongnized but don't print). Brother dowload center: http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/download_prn.html#MFC-J270W

2 - Brother site says that (in order to activate the 32bit driver) I have to install also this library for 64bit compatibility: ia32-libs or lib32stdc++ The first is (I guess) for Ubuntu, the other for Debian. I tried to install both, but I have dependencies issues:

Code: Select all

 xflmde Descargas # apt-get install lib32stdc++
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Nota, seleccionando «lib32stdc++6-4.4-dbg» para la expresión regular «lib32stdc+»
Nota, seleccionando «lib32stdc++6-dbg» para la expresión regular «lib32stdc+»
Nota, seleccionando «lib32stdc++6-4.1-dbg» para la expresión regular «lib32stdc+»
Nota, seleccionando «lib32stdc++6-4.5-dbg» para la expresión regular «lib32stdc+»
Nota, seleccionando «lib32stdc++6-4.2-dbg» para la expresión regular «lib32stdc+»
Nota, seleccionando «lib32stdc++6-4.6-dbg» para la expresión regular «lib32stdc+»
Nota, seleccionando «lib32stdc++6-4.3-dbg» para la expresión regular «lib32stdc+»
Nota, seleccionando «lib32stdc++6» para la expresión regular «lib32stdc+»
Nota, seleccionando «lib32stdc++6-4.0-dbg» para la expresión regular «lib32stdc+»
Nota, seleccionando «lib32stdc++6-4.7-dbg» para la expresión regular «lib32stdc+»
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 lib32stdc++6 : Depende: lib32gcc1 (>= 1:4.1.1) pero no va a instalarse
                Depende: libc6-i386 (>= 2.3.2) pero no va a instalarse
 lib32stdc++6-4.4-dbg : Depende: lib32gcc1-dbg pero no va a instalarse
                        Depende: lib32gcc1 (>= 1:4.1.1) pero no va a instalarse
                        Depende: libc6-i386 (>= 2.3.2) pero no va a instalarse
 lib32stdc++6-4.6-dbg : Depende: lib32gcc1-dbg pero no va a instalarse
                        Depende: lib32gcc1 (>= 1:4.1.1) pero no va a instalarse
                        Depende: libc6-i386 (>= 2.3.2) pero no va a instalarse
                        Entra en conflicto: lib32stdc++6-4.4-dbg pero 4.4.7-2 va a ser instalado
 lib32stdc++6-4.7-dbg : Depende: lib32gcc1-dbg pero no va a instalarse
                        Depende: lib32gcc1 (>= 1:4.1.1) pero no va a instalarse
                        Depende: libc6-i386 (>= 2.3.2) pero no va a instalarse
                        Entra en conflicto: lib32stdc++6-4.4-dbg pero 4.4.7-2 va a ser instalado
                        Entra en conflicto: lib32stdc++6-4.6-dbg pero 4.6.3-11 va a ser instalado
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.
Same happens if I try with Synaptic, in this case the package manager want to uninstall a lot of packages to prevent conflicts (seems to me dangerous).

The online printing management recognizes the printer, but this don't work: http://localhost:631/printers/

Anyone can help me?

Re: unable to install a Brother printer in LMDE 64bit

Posted: Mon Aug 26, 2013 12:48 am
by Transitman
xfrank wrote:I have tried all, searched all the forums, but I can't install properly my Brother MFC-J270w, either usb or wifi.
This printer work on 32 bit, I was successful to set up it in another PC with Mint13. The problem is:

1 - Brother do have the .deb driver (cupswrapper and RPL) to install, but is only for 32bit. I installed it, the printer won't print (is recongnized but don't print). Brother dowload center: http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/download_prn.html#MFC-J270W

2 - Brother site says that (in order to activate the 32bit driver) I have to install also this library for 64bit compatibility: ia32-libs or lib32stdc++ The first is (I guess) for Ubuntu, the other for Debian. I tried to install both, but I have dependencies issues:

Anyone can help me?
Check this post concerning multi-arch: http://forums.linuxmint.com/viewtopic.php?f=190&t=122296

Follow along with copy and paste in a terminal, and you should be able to install and get recognized the Brother MFC-J270w.

Re: unable to install a Brother printer in LMDE 64bit

Posted: Mon Aug 26, 2013 9:12 am
by xfrank
thanks for your answer Transitman, I have read all the post on multiarch. I understand now that multiarch is te substitute for the deprecated ia32-libs. I checked
dpkg --print-foreign-architectures and the output is already i386:

Code: Select all

xfrank@xflmde ~ $ dpkg --print-foreign-architectures
i386
so i guess I have multiarch enabled. But my printer still won't work.

By the way I tried to install also wine, and I cannot:

Code: Select all

xfrank@xflmde ~ $ sudo apt-get install wine-bin
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 wine-bin:i386 : Depende: libc6:i386 (>= 2.4) pero no va a instalarse
                 Depende: libwine-bin:i386 (= 1.4.1-4) pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

Re: unable to install a Brother printer in LMDE 64bit

Posted: Mon Aug 26, 2013 2:03 pm
by xfrank
I have a new problem.
In an attempt to solve the above issue (following a thread I've found in a forum), I tried to upgrade cups activating romeo and sid repos. I did upgraded 4 libraries:

cups-bsd (from 1.5.3-2.4 to 1.6.3-1)
cups-client (from 1.5.3-2.4 to 1.6.3-1)
cups-common (from 1.5.3-2.4 to 1.6.3-1)
libcups2 (from 1.5.3-2.4 to 1.6.3-1)

After that, the system changed completely the printer client, it won't add any new printer, only offer a "server printer". Also the online printing service is off.

I tried to revert the upgrades (after removing sid and did a update): I can do this only for cups-common, the others are dependent to each other, pointing to libcups2: if I try to uninstall this, Synaptic says is necessary to remove a lot of programs, not related to printing. Too dangerous and messy! Go figure to uninstall libcups2, Synaptic want to remove + than 50 programs, including core system packages. This is insane.

Is possible to revert libcups2 to the former version? How I can fix this?

I can live without that printer, but I can't live without any printers at all, I have to fix this problem now.

Re: unable to install a Brother printer in LMDE 64bit

Posted: Mon Aug 26, 2013 9:16 pm
by xfrank
Again here. I know this was my fault, but I'm just a beginner, I try to learn from my experience.
I messed up my printing services and I need to restore the defaults. What I suppose I can do now? This is a serious problem for me because I need to print. :|

I will open a new thread in the beginner subforum, I hope someone can help me.

Re: unable to install a Brother printer in LMDE 64bit

Posted: Mon Aug 26, 2013 9:30 pm
by Transitman
xfrank wrote:I have a new problem.
In an attempt to solve the above issue (following a thread I've found in a forum), I tried to upgrade cups activating romeo and sid repos. I did upgraded 4 libraries:

cups-bsd (from 1.5.3-2.4 to 1.6.3-1)
cups-client (from 1.5.3-2.4 to 1.6.3-1)
cups-common (from 1.5.3-2.4 to 1.6.3-1)
libcups2 (from 1.5.3-2.4 to 1.6.3-1)
First, change your Debian repos to Testing/Jessie.
Do not use SID repos.

Second, in Synaptic, search for cups and list what you have installed.
It looks like you do not have all the required cups packages.

Re: unable to install a Brother printer in LMDE 64bit

Posted: Mon Aug 26, 2013 10:06 pm
by xfrank
I don't have sid marked in repos now, and I have UN-marked Romeo, and marked Debian stable (is ok?).
Now I realize that my fault was to enable Sid, because confusing it with testing.

After updating, I have installed:

cups
phyton-cups
cups-filters
pyton-cupshelpers
printer-driver-gutenprint
cups-pk-helper
libcupsfilters1
cups-bsd
ghostscript-cups
cups-common
libcups2
gtklp
libcupsimage2
system-config-printer
foomatic-filters
mfcj270wcupswrapper:i386
libcupscgi1
cups-client
cups-ppdc
printer-driver-hpijs
system-config-printer-udev
foomatic-db-gutenprint
libcupsdriver1
libcupsmime1
foomatic-db
ijgutenprint
foomatic-db-engine
libgutenprint2
printer-driver-escpr
------------------
I
some of these packages are green with a yellow star on (I don't know if this matter).
update: yellow stars are for packages that have a newer version available (probably because at this moment debian stable is active in the repos. I won't touch/upgrade anything for the moment).

Re: unable to install a Brother printer in LMDE 64bit

Posted: Mon Aug 26, 2013 10:10 pm
by xfrank
to be more precise with my active repositories:

software source:

Main packages ON
Upstream packages ON
Imported packages ON
Backported pakages ON

http://mirror.metrocast.net/linuxmint-debian/latest testing ON
http://mirror.metrocast.net/linuxmint-debian/latest/security testing ON
http://mirror.metrocast.net/linuxmint-debian/latest/multimedia testing ON

stable actual reliese of Debian ON


that's all

Re: unable to install a Brother printer in LMDE 64bit

Posted: Mon Aug 26, 2013 10:31 pm
by Transitman
xfrank wrote:to be more precise with my active repositories:

software source:

Main packages ON
Upstream packages ON
Imported packages ON
Backported pakages ON

http://mirror.metrocast.net/linuxmint-debian/latest testing ON
http://mirror.metrocast.net/linuxmint-debian/latest/security testing ON
http://mirror.metrocast.net/linuxmint-debian/latest/multimedia testing ON

stable actual reliese of Debian ON
that's all
Change your Debian selection from Stable to Testing/Jessie.
It looks like you're following with the Upgrade Package from LinuxMint.

From your list, you need to install a few more cups related packages.
cups-browsed
cups-daemon
cups-filters
cups-server-common
foomatic-db
libcupscgi1
libcupsimage2
libcupsppdc1
libfontembed1

Re: unable to install a Brother printer in LMDE 64bit

Posted: Mon Aug 26, 2013 10:53 pm
by xfrank
I guessed what repositories are the jessie /testing (sorry, I'm a beginner) and I added:

deb http://ftp.debian.org/debian testing main contrib non-free

then I updated the system in the terminal, and then opened again Synaptic. Now I see (again) several cups related packages with ugradable versions (yellow stars): have I to upgrade all them?

Also have I to install (from your list):

cups-browsed
cups-daemon
cups-server-common
libfontembed1

then these packages already are installed but are marked as upgradable:

cups-filters
foomatic-db
libcupscg1
libcupsimage2
libcupsppdc1

:?:

I will not touch anything at this point. The testing repos are active now and would update a lot of packages:

"++ Found 1174 recommended software updates"

I won't break my system! I will wait for your instructions.

Re: unable to install a Brother printer in LMDE 64bit

Posted: Mon Aug 26, 2013 11:41 pm
by Transitman
xfrank wrote:I guessed what repositories are the jessie /testing (sorry, I'm a beginner) and I added:

deb http://ftp.debian.org/debian testing main contrib non-free

then I updated the system in the terminal, and then opened again Synaptic. Now I see (again) several cups related packages with ugradable versions (yellow stars): have I to upgrade all them?

Also have I to install (from your list):

cups-browsed
cups-daemon
cups-server-common
libfontembed1

then these packages already are installed but are marked as upgradable:

cups-filters
foomatic-db
libcupscg1
libcupsimage2
libcupsppdc1

:?:

I will not touch anything at this point. The testing repos are active now and would update a lot of packages:

"++ Found 1174 recommended software updates"

I won't break my system! I will wait for your instructions.
If you are following LinuxMint with Update Packs, then disable TESTING.
If you are wanting to be more up to date with Debian Testing, then update the 1174 recommended Software Updates. Be warned, this might not be all, as there are dependencies that comes with this.
It could also want to uninstall some packages.

Install these packages:

cups-browsed
cups-daemon
cups-server-common
libfontembed1

then these packages already are installed but are marked as upgradable:
and then upgrade these packages only! Watch for dependencies to install with them (they are needed).
And watch for packages that may want to be uninstalled.

cups-filters
foomatic-db
libcupscg1
libcupsimage2
libcupsppdc1

After doing this, then stop following Debian Testing, unless you want to have a more up to date system.
I do not guarantee against breakages, but I've done this type of recommended software updates after have done a system reinstall with no ill effects.

Re: unable to install a Brother printer in LMDE 64bit

Posted: Tue Aug 27, 2013 8:42 am
by xfrank
Transitman, many thanks!!! I followed your instructions and now I have again the printer services! :D
Now I disable debian testing and stay only with standard mint testing repos.

As for the Brother printer, I can print with it from windows.

Thanks again!

Re: unable to install a Brother printer in LMDE 64bit

Posted: Tue Aug 27, 2013 3:27 pm
by Transitman
xfrank wrote:Transitman, many thanks!!! I followed your instructions and now I have again the printer services! :D
Now I disable debian testing and stay only with standard mint testing repos.

As for the Brother printer, I can print with it from windows.

Thanks again!
Glad it has worked out for you.

And you're welcome.

Re: unable to install a Brother printer in LMDE 64bit

Posted: Sat Aug 31, 2013 2:58 pm
by ritchi
Did you check, http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/evaluation.html first to see if your ver. of Linux is supported for your printer?? I'm running mint 13 (Ubuntu 12.04) and this printer is not supported. you would have to be running, Ubuntu11.04(32bit/64bit) to use there support. You could try http://openprinting.org/printers/manufacturer/Brother. I just finished testing my new brother dcp-7060d it did not run out of the box ether, so after two or three hours of reading I downloaded 5 .deb packets from brother installed them via GDeb package manager and although not all the functionality is there it works just fine, both printer and scanner. If you do get a driver installed don't forget you have to select the driver in the printer properties dialog box.

Re: unable to install a Brother printer in LMDE 64bit [solve

Posted: Sun Feb 16, 2014 6:33 pm
by xfrank
I reopen this thread because finally my printer works!!! after almost one year... :shock:
In short:
1 - I had long ago renounced to use this printer in linux because brother don't support a 64bit driver for this model (and there is not a free one in cups).
2 - After Update Pack 8, today printer services didn't work.
3 - I did a reset of printer services: sudo /etc/init.d/cups restart
4 - I searched again for printers connected to my pc: one laser, and the ink printer that never worked, connected via USB.
5 - I found in cups a driver that match my printer
6 - I tried to print a page and... it printed!!! :D

I'm so happy. I do like this printer. Now, I have one reason less to enter in windows! 8)

*edit: also the scanner works! In this case, Brother has in it's site the 64bit driver to download and this works with SimpleScan.