LMDE XFCE UP7 Report

Archived topics about LMDE 1 and LMDE 2
Locked
mikecz
Level 2
Level 2
Posts: 76
Joined: Sat Jun 11, 2011 5:14 pm

LMDE XFCE UP7 Report

Post by mikecz »

I know that LMDE XFCE is no longer supported, but I figured there are still a fair number of LMDE XFCE users still out there that I wanted to share my experience applying UP7 to my box (HP Pavillion HDX16).

Overall, the process was relatively painless, except for the 3.10-2-686-pae kernel update breaking my NVidia drivers (I manually installed them rather than navigating the quagmire of confusing packages in Synaptic). It took me a bit of wrangling trying to reinstall the old drivers, but I eventually downloaded the latest version of the drivers (319.49) from www.nvidia.com and that did the trick.

The 'system default' graphical environment changed from xfce to Cinnamon, which is to be expected I suppose given the abandonment of xfce by the LMDE developers.

A bunch of xfce4 packages did get updated (probably part of the repositories), which is nice. It means that those of us who swear by LMDE XFCE won't be left out in the cold by the discontinuation.

The only other oddity I found was that the icons on the xfce panel were all bunched up to the left side of the screen, and the size of the panel had increased. A bit of tinkering with the panel settings, and the fix I found in the xubuntu forums via a google search (http://ubuntuforums.org/showthread.php?t=1286739) took care of that.

Anyway: I figured it would be of interest to someone so I'm posting it here.

MikeC

TheOneLaw
Level 1
Level 1
Posts: 6
Joined: Sat Mar 24, 2012 1:47 am

Re: LMDE XFCE UP7 Report

Post by TheOneLaw »

mikecz wrote:I know that LMDE XFCE is no longer supported, but I figured there are still a fair number of LMDE XFCE users still out there
...
<>
...
and the fix I found in the xubuntu forums via a google search (http://ubuntuforums.org/showthread.php?t=1286739) took care of that.

Anyway: I figured it would be of interest to someone so I'm posting it here.

MikeC
That fix you pointed to is actually quite useful for curing many XFCE desktop illnesses,
I seem to use it (or just delete at random :lol: there) about once a year anyway.

For XFCE it always pays to have a desktop root terminal launcher handy (except that this time fonts were dead there).

When my system resurfaced i had no panels and text entry was impossible in anything I could get to open
(terminal, konqueror <shhh - yes i know but spacefm was not available and I was waiting UP7 before bailing thunar/nautilus)
so I just went CLI root (CTRL-ALT-F3) and deleted my ~/.config/xfce4/panel directory and rebooted.

Other than that it all looks mostly the same so far, more intensive hands on to come,
I will have my hands full (Vbox broken, as expected with such a nice kernel upgrade, other stuff to discover)

There are only (1,2,3,4,5,6,...7) seven of us who use the XFCE incarnation of LMDE anyway,
so its not like there will be widespread knowledge about how to stay sane aside from your posting - so thanks for the leadin.

posted from my Toshiba t580 running XFCE 64bit LMDE since kernel 2.6.39

dclement
Level 4
Level 4
Posts: 267
Joined: Thu Apr 19, 2012 9:59 am

Re: LMDE XFCE UP7 Report

Post by dclement »

Hi, glad to know we're not alone. I too did the update yesterday, so I have a few comments.
mikecz wrote:... kernel update breaking my NVidia drivers (I manually installed them rather than navigating the quagmire of confusing packages in Synaptic). It took me a bit of wrangling trying to reinstall the old drivers, but I eventually downloaded the latest version of the drivers (319.49) from http://www.nvidia.com and that did the trick.
My case too, and for Nvidia drivers I use the [url=http://smxi.org/]smxi/sgfxi scripts[/url]. Another member had written excellent explanations [url=http://forums.linuxmint.com/viewtopic.php?f=198&t=112835]here[/url] (post #7) as to how it must be done properly without losing access to your X server. BTW, my Nvidia driver version shows 325.15.
The only other oddity I found was that the icons on the xfce panel were all bunched up to the left side of the screen, and the size of the panel had increased.
Yes, you needed an "expanding transparent separator". I noticed the same. Why did it disappear? In my case, I suspect that I was using a version of the Whisker Menu which was no longer supported under XFCE 4.10. Hence it got removed, and the panel got confused.
The 'system default' graphical environment changed from xfce to Cinnamon,
I think I even got a glimpse of the dreadful gnome 3 desktop, but fortunately it didn't last long.

Apart from this, XFCE 4.10 breaks the display of network drive icons. A [url=http://forum.xfce.org/viewtopic.php?id=7899]known problem[/url] which nobody seems able to solve.

There are other issues, but they aren't XFCE-specific so I'll open a separate thread for that.

Best regards, Daniel

Ken_g6
Level 1
Level 1
Posts: 20
Joined: Fri May 11, 2012 12:43 pm

Re: LMDE XFCE UP7 Report

Post by Ken_g6 »

Well, it's not going as well for me so far. I figured out the nVidia drivers, but got completely surprised by the lack of XFCE support!

Since I didn't see XFCE, I Googled for how to get it back, and did what it said [url=http://forums.linuxmint.com/viewtopic.php?f=199&t=84376]here[/url]. Then all my taskbars disappeared. I got the XFCE taskbar back with "xfce4-panel &".

Then I rebooted. Which wasn't easy because Menu -> Logout gives me an error:
Received error while trying to log out

Could not get owner of name 'org.xfce.SessionManager': no such name
I had to do a manual sudo shutdown -r now

After rebooting, I see the taskbars for Gnome and for XFCE! I'd set up a startup command to start the XFCE taskbar as above if it wasn't already started. So it did that, but apparently the window manager got switched back to "Mutter". I can manually switch back with xfwm4 --replace, but on reboot it goes back to Gnome. How can I fix this?

Edit: Also, I can't figure out how to switch my desktop icons from Nautilus to Thunar. I killall nautilus, start thunar, but the Thunar desktop icons don't appear.

User avatar
Beardedragon
Level 4
Level 4
Posts: 356
Joined: Sat Jan 29, 2011 3:37 am

Re: LMDE XFCE UP7 Report

Post by Beardedragon »

In my recent #7 upgrade I began from scratch. Using the Cinnamon version I did a simple upgrade, then added Xfce Desktop and goodies etc. Then using the instructions to get the Update Pack from the Linux Mint instructions I ran it under the Xfce Desktop. May sound confusing but I just decided to use LMDE after being away for a year. I did not notice any of the problems with Panels or the transparent separator. Also I have ATI instead of Nvidia so no problems with the drivers. I have updated my signature, I'm now running Debian 7.1 Xfce, SalineOS 2.0 Dev 2 Xfce and LMDE Xfce. Basically "Debian Xfce" with different dressings including Testing and Stable.
Robert Collard, Madison, WI
Linux Mint 19.2 Tina Kernel: 4.15.0-55
Desktop System: HP EliteDesk 705 G1 SFF
CPU: Quad Core model: AMD A10-6800K APU
NVIDIA GK208 [GeForce GT 720] nvidia v: 340.107
Acer Technologies 24" 1920 x 1080

TheOneLaw
Level 1
Level 1
Posts: 6
Joined: Sat Mar 24, 2012 1:47 am

Re: LMDE XFCE UP7 Report

Post by TheOneLaw »

Ken_g6 wrote: ... but apparently the window manager got switched back to "Mutter".
I can manually switch back with xfwm4 --replace, but on reboot it goes back to Gnome. How can I fix this?
checking mine,

Code: Select all

root@pc2:/home/techqc# ps -Af | grep mutter
root      5854  5848  0 03:02 pts/1    00:00:00 grep mutter
root@pc2:/home/techqc# ps -Af | grep nautilus
root      5856  5848  0 03:02 pts/1    00:00:00 grep nautilus
root@pc2:/home/techqc# ps -Af | grep mdm     
root      5946  5848  0 03:17 pts/1    00:00:00 grep mdm
root@pc2:/home/techqc# ps -Af | grep xfwm
techqc    4070  4063  0 01:06 ?        00:00:02 xfwm4 --display :0.0 --sm-client-id 28e71cea8-0a2f-4ab5-8408-2a3f7531d8d8
root      5948  5848  0 03:17 pts/1    00:00:00 grep xfwm
root@pc2:/home/techqc# ps -Af | grep gdm 
root      5950  5848  0 03:17 pts/1    00:00:00 grep gdm
root@pc2:/home/techqc# 
I think I remember a great deal of grief back last year and I decided to try and hurl Nautilus+gnome stuff out the window.
Puking my brain out with all their top-down control-freakisms, I rebelled.

IIRC, I got there by aggressively installing every stick of xfce I could find in the repositories then getting into
settings>session-and-startup and making sure what was displayed in the gui was what actually happened.
I cannot remember if I did a CLI session to get rid of mutter

A big part was to make sure to use session chooser so if something breaks I can always just make a new session.
Edit: Also, I can't figure out how to switch my desktop icons from Nautilus to Thunar. I killall nautilus, start thunar, but the Thunar desktop icons don't appear.
Settings >preferred_applications filemanager =Thunar?

To be sure, I have a broken (by anyone's standards) system that works just great for me.
And with the new kernel 3.10 and xfce being on par with Sabayon's current state of affairs,
LMDE is still just about the best thing our there if you are willing to CLI just a bit.

Just loaded the new debian-system-adjustments 2013.09.29, - if no problems will edit this to say so
EDIT update - no immediately visible issues with the debian-system-adjustments 2013.09.29 here

dclement
Level 4
Level 4
Posts: 267
Joined: Thu Apr 19, 2012 9:59 am

Re: LMDE XFCE UP7 Report

Post by dclement »

Ken_g6 wrote:Edit: Also, I can't figure out how to switch my desktop icons from Nautilus to Thunar. I killall nautilus, start thunar, but the Thunar desktop icons don't appear.
This ought to be easy: you can simply go to preferences > desktop (or right-click on the desktop) > icons tab, and from there select which icons you want on the desktop.

Ken_g6
Level 1
Level 1
Posts: 20
Joined: Fri May 11, 2012 12:43 pm

Re: LMDE XFCE UP7 Report

Post by Ken_g6 »

I finally figured out how to switch back to XFCE:

1. Leave Gnome running. Don't manually kill its processes and replace them with XFCE ones. :twisted:
2. Log out of Gnome. (Click your username in the upper-right area of the screen and log out.)
3. Use one of the options below the login prompt to switch the window manager to XFCE. When prompted, make the change permanent.
4. Log back in.

Everything looks much better now. :D

dclement
Level 4
Level 4
Posts: 267
Joined: Thu Apr 19, 2012 9:59 am

Re: LMDE XFCE UP7 Report

Post by dclement »

Ken_g6 wrote:I finally figured out how to switch back to XFCE:
[...]
3. Use one of the options below the login prompt to switch the window manager to XFCE. When prompted, make the change permanent.
Ah, I see. I was assuming you had already done this!
Everything looks much better now. :D
I guess it does! Glad you solved it.

Locked

Return to “LMDE Archive”