no DVD/CD player after UP-7 [SOLVED]

Archived topics about LMDE 1 and LMDE 2
Locked
rudar
Level 2
Level 2
Posts: 60
Joined: Thu Sep 27, 2012 7:34 am

no DVD/CD player after UP-7 [SOLVED]

Post by rudar »

I am afraid I must report another issue: my DVD/CD player appears dead after UP-7.

I cannot play any CD or DVD. It's HP DVD ADH 16 ABSH, according to specifications, while the system is desktop HP Microtower LH 120 EA. There were no problems whatsoever with previous kernel versions (3.2-0.3, 3.2-0.4). What can be done? :(
Last edited by rudar on Fri Oct 04, 2013 6:03 am, edited 1 time in total.
LMDE Mate
M J
Level 1
Level 1
Posts: 22
Joined: Sun Jan 10, 2010 9:58 pm
Location: Chicago, IL USA

Re: no DVD/CD player after UP-7

Post by M J »

I have the same issue after I upgraded to UP-7. Initially no disc will even show up as being in the drive, but if I mess around with it enough it will eventually work. It's almost like it takes a while to realize it has a dvd/cd in the drive. Then after I use it and eject the disc, it wont work or even eject again. The button on the tray will do nothing, and if I right click on the drive in Caja it gives an error: "Inappropriate ioctl for device". It will work after I reboot, but then will not read any disc in the drive again until after I mess with it for a while. It is an HP UJDA775 drive in an old HP Compaq 6910p laptop.
rudar
Level 2
Level 2
Posts: 60
Joined: Thu Sep 27, 2012 7:34 am

Re: no DVD/CD player after UP-7

Post by rudar »

It seems we share a similar problem like in this topic: http://forums.linuxmint.com/viewtopic.php?f=198&t=146165

It's impossible to remove USB sticks safely. They may only be 'ejected'.
LMDE Mate
M J
Level 1
Level 1
Posts: 22
Joined: Sun Jan 10, 2010 9:58 pm
Location: Chicago, IL USA

Re: no DVD/CD player after UP-7

Post by M J »

I was only able to eject my usb stick also. I didn't think much of that at the time, but now that I think about it, my other desktop computer I run the mint main edition on (Olivia 64bit) does give a "safely remove" option. However, I do remember there were times I was only able to eject there also. I don't remember if it was with a usb flash drive, or hdd though. Due to this dvd drive issue and some other issues, I decided to ditch lmde and try a diff distro for now. I just checked, and only have an eject option now too with a usb stick. This is with the beta of Ubuntu 13.10. This might be a newb question, but what is the difference between eject and safely remove?

edit: I just went to my desktop computer running the Mint Main edition... with a usb stick I only get the eject option. With a usb hdd I only get a "safely remove" option.
rudar
Level 2
Level 2
Posts: 60
Joined: Thu Sep 27, 2012 7:34 am

Re: no DVD/CD player after UP-7

Post by rudar »

When I tried to insert a DVD, it was impossible to open the player manually. Then I opened Caja and clicked 'eject'. There came the message:

Error ejecting /dev/sr0: Command-line `eject "/dev/sr0"' exited with non-zero exit status 1: eject: unable to eject, last error: Inappropriate ioctl for device

Luckily enough, DVD player did open and I inserted a DVD. Nothing happened. Then I started Brasero and suddenly, after 10-15 secs, I was able to use my DVD. So, it's a kind of progress...
LMDE Mate
MrD
Level 4
Level 4
Posts: 227
Joined: Wed Dec 09, 2009 8:34 am
Location: UK
Contact:

Re: no DVD/CD player after UP-7

Post by MrD »

I haven't actually played a dvd on my laptop in a long time, but since the upgrade my tray has been frequently and randomly opening itself....
Dell Inspiron 1520 - T6570 2.1ghz C2D, 4 gigs ram, integrated Intel 965 GPU, Intel replacement wifi card.
rudar
Level 2
Level 2
Posts: 60
Joined: Thu Sep 27, 2012 7:34 am

Re: no DVD/CD player after UP-7

Post by rudar »

Well, it seems that I have found a simple solution to my problem: open the tray, insert DVD or CD, then start Brasero and here it is, the icon describing my disc and the disc itself is ready to use. It appears that Brasero does not play any role, the program itself can be closed (if I don't want to copy discs etc). The disc itself can be used in all possible ways like before: to read, to copy, to erase, whatever.

I only wish I knew why is this happening, but it's just important that it works. I have checked this on two separate PCs (both desktops, with LMDE as the only OS installed).
LMDE Mate
M J
Level 1
Level 1
Posts: 22
Joined: Sun Jan 10, 2010 9:58 pm
Location: Chicago, IL USA

Re: no DVD/CD player after UP-7

Post by M J »

Sounds very similar to the issues I had with the DVD drive, along withe the same error message. You said you can read and all that, but will it play a movie. That is the other issue I had once I was able to read it. I could see the files in Caja, but it would not play the movie.
User avatar
palimmo
Level 4
Level 4
Posts: 333
Joined: Sun Feb 03, 2013 9:55 am

Re: no DVD/CD player after UP-7

Post by palimmo »

could it be?
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=716911
LM Cinnamon 64bit
rudar
Level 2
Level 2
Posts: 60
Joined: Thu Sep 27, 2012 7:34 am

Re: no DVD/CD player after UP-7

Post by rudar »

M J wrote:Sounds very similar to the issues I had with the DVD drive, along withe the same error message. You said you can read and all that, but will it play a movie. That is the other issue I had once I was able to read it. I could see the files in Caja, but it would not play the movie.
Yes, it plays movies. I can also listen to music. Everything is fine. It's just a bit puzzling: I don't know why I must start Brasero when I insert a disc. Only a few seconds later this disc is recognized, I can normally use a DVD or a CD, and I turn off Brasero.
LMDE Mate
rudar
Level 2
Level 2
Posts: 60
Joined: Thu Sep 27, 2012 7:34 am

Re: no DVD/CD player after UP-7 [SOLVED]

Post by rudar »

palimmo wrote:could it be?
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=716911
It's possible, at least these symptoms look the same. But this bug comes with XFCE, while I use Mate. So, it may have something to do with Caja, after all. Nevertheless, it seems I found a solution, so I'm satisfied with the way it is. That's it!
LMDE Mate
akabanekuroido
Level 1
Level 1
Posts: 14
Joined: Thu Feb 07, 2013 8:38 pm

Re: no DVD/CD player after UP-7 [SOLVED]

Post by akabanekuroido »

From what I read at the bug report site the current Gvfs 1.16.3.-1 for Debian-testing has some bugs, since it doesn't mount certain DVD's or CD's.
According to one person you can downgrade to version 1.12.3-4, to make things work again, but then programs like Brasero, Aptoncd will also be removed.
Better to wait for a never version of gvfs (version 1.17.3?). Of course for now the most easy way is to start diskutility or Brasero to mount the DVD or CD.
Monsta
Level 10
Level 10
Posts: 3058
Joined: Fri Aug 19, 2011 3:46 am

Re: no DVD/CD player after UP-7 [SOLVED]

Post by Monsta »

akabanekuroido wrote:According to one person you can downgrade to version 1.12.3-4, to make things work again, but then programs like Brasero, Aptoncd will also be removed.
Where did you read that?
akabanekuroido
Level 1
Level 1
Posts: 14
Joined: Thu Feb 07, 2013 8:38 pm

Re: no DVD/CD player after UP-7 [SOLVED]

Post by akabanekuroido »

Hello Monsta,
You can read it here: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=716911
Monsta
Level 10
Level 10
Posts: 3058
Joined: Fri Aug 19, 2011 3:46 am

Re: no DVD/CD player after UP-7 [SOLVED]

Post by Monsta »

No, I was talking about this:
programs like Brasero, Aptoncd will also be removed
akabanekuroido
Level 1
Level 1
Posts: 14
Joined: Thu Feb 07, 2013 8:38 pm

Re: no DVD/CD player after UP-7 [SOLVED]

Post by akabanekuroido »

Monsta:
Well that easy to tell. Try to remove the actual version of gvfs 1.16 with synaptic, then synaptic will tell you which programs have to be removed (brasero AptonCD, nautilus, mate-applets)
There are people who did this and wrote everything went well, but I myself don't know. Maybe it might break-up the system.
Better to be patient and wait for a newer version.
Monsta
Level 10
Level 10
Posts: 3058
Joined: Fri Aug 19, 2011 3:46 am

Re: no DVD/CD player after UP-7 [SOLVED]

Post by Monsta »

akabanekuroido wrote:Try to remove the actual version of gvfs 1.16 with synaptic, then synaptic will tell you which programs have to be removed (brasero AptonCD, nautilus, mate-applets)
Don't do it with Synaptic, [url=http://forums.linuxmint.com/viewtopic.php?f=198&t=146187#p770495]do it from the console[/url].
akabanekuroido
Level 1
Level 1
Posts: 14
Joined: Thu Feb 07, 2013 8:38 pm

Re: no DVD/CD player after UP-7 [SOLVED]

Post by akabanekuroido »

Monsta: thanks! I read your instructions and will test it on one of my computers.
Your terminal list of gvfs looks the same as mine, so thing will go well I think.
Monsta
Level 10
Level 10
Posts: 3058
Joined: Fri Aug 19, 2011 3:46 am

Re: no DVD/CD player after UP-7 [SOLVED]

Post by Monsta »

akabanekuroido wrote:Your terminal list of gvfs looks the same as mine, so thing will go well I think.
The instructions should work even if the list is different - you just need to adjust the parameters for apt-get and apt-mark.
Dai777
Level 1
Level 1
Posts: 18
Joined: Sat Apr 13, 2013 1:55 pm

Re: no DVD/CD player after UP-7 [SOLVED]

Post by Dai777 »

Can't get my burner to work since upgrade. Tried this soulution but no joy http://forums.linuxmint.com/viewtopic.php?f=198&t=146187#p770495 any help would be appreciated. just want to burn mint to install that to many problems with debian.
Locked

Return to “LMDE Archive”