Minor Cinnamon bug & screensaver question

Archived topics about LMDE 1 and LMDE 2
Locked
mikecz
Level 2
Level 2
Posts: 76
Joined: Sat Jun 11, 2011 5:14 pm

Minor Cinnamon bug & screensaver question

Post by mikecz »

This may be another simple question, but I've noticed that with my new LMDE Cinnamon box (Dell Vostro 200 with the onboard video, which is an Intel card of some stripe) when it comes back from having the screen blanked, popup balloons (like when you hover your mouse over a link in Firefox) and dialog boxes are completely black. Logging off and logging back on will clear that (as would, I imagine, ctrl-alt-backspace, though I haven't tried that yet), but I wanted to know if this is a known bug and if so what the fix (if any) for it is.

On a related note: is there a full screensaver for LMDE Cinnamon? Or do I only have the choice for screen blanking/locking. I can't find any control panel items for a screensaver.

MikeC, is liking LMDE Cinnamon despite my minor problems.

mizts
Level 1
Level 1
Posts: 4
Joined: Mon Oct 07, 2013 12:53 pm

Re: Minor Cinnamon bug & screensaver question

Post by mizts »

Having the same problem after the recent huge LMDE update, but I don't think its related to screensaver.

Firefox or any window can suddenly start drawing completely black while using the system. It's like some sort of resource leak. Restarting X resolves it.

Doesn't seem to be related to fonts or screensaver.

mizts
Level 1
Level 1
Posts: 4
Joined: Mon Oct 07, 2013 12:53 pm

Re: Minor Cinnamon bug & screensaver question

Post by mizts »

It appears to be a bug in the Intel video driver, as noted in this thread
https://bugs.mageia.org/show_bug.cgi?id=9044

If no xorg.conf exists in /etc/X11 create it using Xorg -configure command

Once /etc/X11/xorg.conf exists, edit it and uncomment the AccelMethod line within the Intel device section so it reads

Option "AccelMethod" "sna"

Then restart and hopefully black window issue is resolved for now, pending a bug fix on the Intel driver.

mikecz
Level 2
Level 2
Posts: 76
Joined: Sat Jun 11, 2011 5:14 pm

Re: Minor Cinnamon bug & screensaver question

Post by mikecz »

mizts wrote:It appears to be a bug in the Intel video driver, as noted in this thread
https://bugs.mageia.org/show_bug.cgi?id=9044

If no xorg.conf exists in /etc/X11 create it using Xorg -configure command

Once /etc/X11/xorg.conf exists, edit it and uncomment the AccelMethod line within the Intel device section so it reads

Option "AccelMethod" "sna"

Then restart and hopefully black window issue is resolved for now, pending a bug fix on the Intel driver.
There is no /etc/X11/xorg.conf file, and when I run Xorg -configure (from within a sudo sh, and after stopping mdm with the /etc/rc2.d/S20MDM stop command and making sure there are no x-related things running with a ps -eaf), I get an error that it can't write the file.

I've tried to poke around but am far from an expert (or fan).

MikeC

mizts
Level 1
Level 1
Posts: 4
Joined: Mon Oct 07, 2013 12:53 pm

Re: Minor Cinnamon bug & screensaver question

Post by mizts »

Do alt-shift-f1 to switch to the text terminal

login as root there..

then enter telinit 1

when it has completed switching to runlevel 1, you can use the Xorg -configure
It will create xorg.conf.new in the current directory.

Edit this for the sna setting, and copy it to /etc/X11/xorg.conf

Restart the GUI with telinit 2


Hope that helps.

mikecz
Level 2
Level 2
Posts: 76
Joined: Sat Jun 11, 2011 5:14 pm

Re: Minor Cinnamon bug & screensaver question

Post by mikecz »

mizts wrote:Do alt-shift-f1 to switch to the text terminal

login as root there..

then enter telinit 1

when it has completed switching to runlevel 1, you can use the Xorg -configure
It will create xorg.conf.new in the current directory.

Edit this for the sna setting, and copy it to /etc/X11/xorg.conf

Restart the GUI with telinit 2


Hope that helps.
Same result; Xorg -configure complains that the number of displays detected is different and will not write the xorg.conf.new file.

I'm actually thinking about going to another distro at this point: as much as I have liked LMDE in the past, the fact that as it stands now a fresh install of the distro is guaranteed to break if you just do an automatic update as it suggests right after installation rankles me. Even for a distro that is intended for more advanced users, it is not an unreasonable expectation that a distro can update itself without breaking.

Anyway: either I'll go to another distro or live with this annoyance at this point, though I may dig into it a bit later.

MikeC

mizts
Level 1
Level 1
Posts: 4
Joined: Mon Oct 07, 2013 12:53 pm

Re: Minor Cinnamon bug & screensaver question

Post by mizts »

The warning about number of displays mismatch doesn't seem to be a problem for me.. I went with the config it generated anyway and it works fine. Maybe that warning might just be due to there being virtual displays defined.

mikecz
Level 2
Level 2
Posts: 76
Joined: Sat Jun 11, 2011 5:14 pm

Re: Minor Cinnamon bug & screensaver question

Post by mikecz »

mizts wrote:The warning about number of displays mismatch doesn't seem to be a problem for me.. I went with the config it generated anyway and it works fine. Maybe that warning might just be due to there being virtual displays defined.
I didn't define any, and the onboard video of the Vostro 200 only has 1 VGA port, so I don't see why the default driver setup would have defined any.

As I said: I tolerate X, and may well move to SolusOS or SolydXK given that I prefer XFCE as my desktop manager.

MikeC

jmaltube
Level 1
Level 1
Posts: 6
Joined: Sat Apr 06, 2013 3:41 pm

Re: Minor Cinnamon bug & screensaver question

Post by jmaltube »

sna worked great to solve the black windows but it's giving me random crashes and logging me out!. Anyone else experiencing the same?

JohnML
Level 1
Level 1
Posts: 26
Joined: Sat Mar 20, 2010 1:13 pm
Location: frankfurt, germany

Re: Minor Cinnamon bug & screensaver question

Post by JohnML »

Xorg -configure didn't work for me!

I have a Intel GPU, and i have these annoying black windows.

But you can do it this way:

create as root the file /etc/X11/xorg.conf

in terminal type ( if you don't have a /etc/X11/xorg.conf ) :
sudo touch /etc/X11/xorg.conf

open editor in admin mode:
gksu gedit /etc/X11/xorg.conf

... and write/copy these lines:

Section "Device"
Identifier "Card0″
Driver "intel"
Option "AccelMethod" "sna"
EndSection

reboot

if that doesn't help do in terminal:
rm /etc/X11/xorg.conf
to delete it again


seems to work ok for me, but i have to test this some days first.

update: 10.07.14
..still working ok!
That was the solution for these annoying black pop-up windows!!

Locked

Return to “LMDE Archive”