changed dvd won't play

Archived topics about LMDE 1 and LMDE 2
Locked
User avatar
yonnie
Level 3
Level 3
Posts: 103
Joined: Mon Jan 03, 2011 12:18 am

changed dvd won't play

Post by yonnie »

Using latest LMDE 2013, similar results different installs and machines. If I put a movie into the drive and reboot, the DVD logo with movie name appears on the desktop and the movie will play. If I change the DVD the logo will not appear on the desktop and it will tell me I do not permission to play the dvd. Banshee, Movie Player and VLC, same results. I've tried installing multimedia-player and multimedia-video metapackages no improvements with problem.

Is this a bug? Is there a fix?
We are children of children and do as we are shown.
-James Curran

nomko

Re: changed dvd won't play

Post by nomko »

Before we start shooting with blanks, first paste the output of the following terminal command here:

Code: Select all

inxi -F

User avatar
yonnie
Level 3
Level 3
Posts: 103
Joined: Mon Jan 03, 2011 12:18 am

Re: changed dvd won't play

Post by yonnie »

mary@prancer ~ $ inxi -F
System: Host prancer Kernel 3.10-2-amd64 x86_64 (64 bit) Distro LinuxMint 1 debian
CPU: Dual core AMD E-300 APU with Radeon HD Graphics (-MCP-) cache 1024 KB flags (lm nx sse sse2 sse3 sse4a ssse3 svm) bmips 5190.22
Clock Speeds: (1) 780.00 MHz (2) 780.00 MHz
Graphics: Card Advanced Micro Devices [AMD/ATI] Wrestler [Radeon HD 6310] X.Org 1.12.4 Res: 1366x768@60.0hz
GLX Renderer AMD Radeon HD 6310 Graphics GLX Version 4.2.12217 Compatibility Profile Context 12.104 Direct Rendering Yes
Audio: Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller driver snd_hda_intel BusID: 00:14.2
Card-2 Advanced Micro Devices [AMD/ATI] Wrestler HDMI Audio driver snd_hda_intel BusID: 00:01.1
Sound: Advanced Linux Sound Architecture Version k3.10-2-amd64
Network: Card-1 Qualcomm Atheros AR9485 Wireless Network Adapter driver ath9k BusID: 07:00.0
Card-2 Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller driver r8169 v: 2.3LK-NAPI at port 2000 BusID: 03:00.0
Disks: HDD Total Size: 320.1GB (2.0% used) 1: /dev/sda WDC_WD3200BEVT 320.1GB
Partition: ID:/ size: 23G used: 6.0G (28%) fs: ext4 ID:/home size: 263G used: 118M (1%) fs: ext4
ID:swap-1 size: 8.39GB used: 0.00GB (0%) fs: swap
Sensors: System Temperatures: cpu: 39.4C mobo: N/A gpu: 39.00C
Fan Speeds (in rpm): cpu: N/A
Info: Processes 154 Uptime 3 min Memory 506.6/3564.4MB Runlevel 2 Client Shell inxi 1.4.23
mary@prancer ~ $


Oh, this brings up more questions.
If I do this command while running from a LiveCD (USB) the DVD player automatically starts MPlayer when a dvd movie is inserted (and plays). Also, the CPU clock is double-speed than shown here.
We are children of children and do as we are shown.
-James Curran

User avatar
yonnie
Level 3
Level 3
Posts: 103
Joined: Mon Jan 03, 2011 12:18 am

Re: changed dvd won't play

Post by yonnie »

Let me clarify my last question as I flubbed it. BTW- inxi doesn't work from the livecd (on usb). I did find that dvd's work properly when running the PC via a livecd(usb), why is that? And I don't see how this can be a regionset issue since all that changed was the boot-source. After installing a lot of codecs and libdvdcss2 the VLC player quit working upon disc insertion and the vlc player suddenly couldn't find the dvd drive and needed assistance in the settings. SMPlayer and Banshee also works. VLC, SM and Banshee have to be started first and the disc to be played has to be selected from there as device SR0 (for sata), not via the filemanager. MPlayer won't play ball. Package manager calls SMPlayer, mplayer2.

This problem appears to be some sort of a filemanager breakage issue, my guess it's done on purpose. Attempting to use the FM generates ioctl errors. I'm finding via google this issue goes back years with Debian, a bug would have been fixed. Wasting every ones time searching for an answer is criminal behavior. At least ubuntu has the restricted-extras.

I will gladly repent should someone point out a fix to this problem that does not include using a different distro.
We are children of children and do as we are shown.
-James Curran

jjaythomas
Level 5
Level 5
Posts: 602
Joined: Sun Mar 07, 2010 12:52 pm

Re: changed dvd won't play

Post by jjaythomas »

Try to install 'udisks-glue', its in the repos
then test (it's a daemon) by using alt-F2 and run comand 'udisks-glue' (without quote) and try CDs/DVDs ect.
if the daemon works you then put same comand in the autostart list. :wink:
if doesn't work for what your asking you can reboot (so daemon not running) and uninstall the package.

J.Jay
P.S. had similiar problem (work for my needs in mate64(but not in a Xfce enviroven't (my preference) using exaile or goobox (music/CD players) but does in thunar :roll:

Locked

Return to “LMDE Archive”