Update manager wants to uninstall MATE [SOLVED]

Archived topics about LMDE 1 and LMDE 2
Locked
unkilbeeg
Level 1
Level 1
Posts: 42
Joined: Tue Apr 27, 2010 5:02 pm

Update manager wants to uninstall MATE [SOLVED]

Post by unkilbeeg »

I've never used anything but the MATE version of LMDE on this machine, but when I try to use the upgrade manager it wants to uninstall all of MATE and replace it with Cinnamon. I double checked and it looks like apt-get dist-upgrade is trying to do the same thing. According to the upgrade manager it's pointing at UP8, although it's been a *very* long time since i did an upgrade. I have no idea what upgrade pack I have actually installed.

Is there something I've done to make it think that I'm a Cinnamon user?

How can I do an upgrade and keep MATE? I suppose I could let the upgrade proceed and then spend days fixing the breakage and reinstalling MATE, but if I had time to do that I'd have stuck with Gentoo. :)
Last edited by unkilbeeg on Thu Aug 28, 2014 8:29 am, edited 1 time in total.
User avatar
killer de bug
Level 14
Level 14
Posts: 5398
Joined: Tue Jul 08, 2008 1:49 pm
Location: Leuven, Belgium

Re: Update manager wants to uninstall MATE

Post by killer de bug »

It could be easier if you could post the results of

Code: Select all

apt dist-upgrade
We would have a better understanding of the situation. Which software did you install recently?
If it ain't broke, fix it until it is.
unkilbeeg
Level 1
Level 1
Posts: 42
Joined: Tue Apr 27, 2010 5:02 pm

Re: Update manager wants to uninstall MATE

Post by unkilbeeg »

I actually haven't installed any software for months. One of the reasons I haven't updated in so long is that I saw that MATE was about to be uninstalled, and I didn't have time to deal with it. It may be close to a year since I've made any changes to the system.

I don't know about using plain old apt. I don't see a "simulate" option, and I'm not willing to launch an update that will really change the system until I know why this is happening. Here is what an apt-get dist-update gives me:

Code: Select all

friday steve # apt-get -s dist-upgrade

Reading package lists...
Building dependency tree...
Reading state information...
The following packages will be REMOVED:
  firefox-l10n-en-us gnome-desktop-data libaudit0 libcheese-gtk21 libcheese3
  libcogl-pango0 libcogl9 libmarco libmatedesktop libmatekbd libmatekeyring
  libmatepanelapplet libmateweather libmatewnck libmutter0 libperl5.14
  libreoffice-filter-mobiledev libvlccore5 libxvmcnvidia1 mate-core
  mate-desktop-environment texlive-common texlive-doc-base
  xserver-xorg-video-apm xserver-xorg-video-ark xserver-xorg-video-chips
  xserver-xorg-video-i128 xserver-xorg-video-i740 xserver-xorg-video-rendition
  xserver-xorg-video-s3 xserver-xorg-video-s3virge xserver-xorg-video-sis
  xserver-xorg-video-tseng xserver-xorg-video-voodoo
The following NEW packages will be installed:
  attr cinnamon-desktop-data cpp-4.8 cracklib-runtime g++-4.8 gcc-4.8
  gir1.2-cinnamondesktop-3.0 gir1.2-clutter-gst-2.0 gir1.2-gee-0.8
  gir1.2-gst-plugins-base-1.0 gir1.2-gstreamer-1.0 gnome-user-share
  grilo-plugins-0.2 gstreamer1.0-clutter gstreamer1.0-plugins-bad
  gstreamer1.0-pulseaudio libaio1 libappindicator1 libarchive-extract-perl
  libasan0 libasn1-8-heimdal libatomic1 libaudit-common libaudit1 libavcodec55
  libavdevice55 libavformat55 libbasicusageenvironment0
  libboost-date-time1.54.0 libboost-iostreams1.54.0 libboost-system1.54.0
  libcheese-gtk23 libcheese7 libchromaprint0 libcinnamon-desktop0
  libcloog-isl4 libclucene-contribs1 libclucene-core1 libclutter-gst-2.0-0
  libcogl-pango12 libcogl12 libcolord-gtk1 libcrack2 libdbusmenu-glib4
  libdbusmenu-gtk4 libdee-1.0-4 libdmapsharing-3.0-2 libebml4 libelf1:i386
  libfftw3-long3 libfluidsynth1 libfreerdp1 libgcc-4.8-dev libgee-0.8-2
  libgles2-mesa libgnome-desktop-3-7 libgnutls28 libgrilo-0.2-1 libgroupsock1
  libgssapi3-heimdal libgstreamer-plugins-bad1.0-0 libgupnp-av-1.0-2
  libgupnp-dlna-2.0-3 libhcrypto4-heimdal libhdb9-heimdal libheimbase1-heimdal
  libheimntlm0-heimdal libhogweed2 libhx509-5-heimdal libibus-1.0-5
  libimobiledevice4 libindicator7 libisl10 libkdc2-heimdal libkrb5-26-heimdal
  liblavfile-2.1-0 liblavjpeg-2.1-0 liblavplay-2.1-0 libldb1 liblivemedia16
  libllvm3.3 libllvm3.3:i386 liblog-message-simple-perl libmarco-private0
  libmate-desktop-2-17 libmate-keyring1 libmate-panel-applet4-1
  libmatekbd-common libmatekbd4 libmateweather1 libmatewnck0 libmatroska6
  libmjpegutils-2.1-0 libmodule-pluggable-perl libmono-corlib4.5-cil
  libmono-system-runtime-serialization-formatters-soap4.0-cil
  libmono-system-runtime2.0-cil libmpeg2encpp-2.1-0 libmplex2-2.1-0
  libmutter0b libmwaw-0.1-1 libnvidia-ml1 libodfgen-0.0-0 liborbit-2-0
  liborcus-0.6-0 libpam-systemd libperl4-corelibs-perl libperl5.18
  libpod-latex-perl libproxy1 libpwquality-common libpwquality1
  libroken18-heimdal librygel-core-2.0-1 librygel-renderer-2.0-1
  librygel-server-2.0-1 libsasl2-modules-db libsasl2-modules-db:i386 libsbc1
  libspice-server1 libsrtp0 libstdc++-4.8-dev libsystemd-journal0
  libtaglib2.1-cil libtasn1-6:i386 libtasn1-bin libtelepathy-logger3
  libterm-ui-perl libtext-soundex-perl libtiff5:i386 libtsan0 libudev1
  libudev1:i386 libusageenvironment1 libusbmuxd2 libvidstab0.9 libvlccore7
  libwind0-heimdal libx264-133 libx264-140 libxatracker1 libzeitgeist-1.0-1
  libzeitgeist-2.0-0 linux-headers-3.11-2-amd64 linux-headers-3.11-2-common
  linux-image-3.11-2-amd64 linux-kbuild-3.11 python-dnspython python-ldb
  python-samba python-talloc python-tdb python-zeitgeist
  python3-aptdaemon.gtk3widgets python3-software-properties rygel
  samba-dsdb-modules samba-libs systemd tdb-tools
  xserver-xorg-video-modesetting xserver-xorg-video-qxl zeitgeist
  zeitgeist-core zeitgeist-datahub
The following packages will be upgraded:
  accountsservice acpid alien alsa-utils amd64-microcode apt apt-utils
  aptitude aptitude-common aptitude-doc-en apturl at at-spi2-core atril
  atril-common autopoint avr-libc avrdude banshee base-passwd bash-completion
  binfmt-support binutils binutils-avr bluez btrfs-tools busybox
  ca-certificates caja caja-common caja-gksu caja-open-terminal caribou
  cheese-common chromium chromium-inspector console-setup console-setup-linux
  consolekit cpp cpp-4.6 cpp-4.7 cryptsetup cryptsetup-bin cups cups-bsd
  cups-client cups-common cups-daemon cups-ppdc cups-server-common curl dbus
  dbus-x11 dconf-gsettings-backend dconf-service debconf debconf-i18n
  debhelper debian-system-adjustments debugedit desktop-file-utils dh-python
  dialog dictionaries-common diffstat diffutils dmsetup dmz-cursor-theme
  dnsmasq-base dpkg dpkg-dev dselect engrampa engrampa-common eom eom-common
  ethtool evince evince-common evolution-data-server-common exim4 exim4-base
  exim4-config exim4-daemon-light fancontrol ffmpeg ffmpegthumbnailer
  file-roller firefox flac flashplugin-nonfree folks-common fontconfig
  fontconfig-config fonts-cantarell fonts-droid fonts-liberation
  fonts-opensymbol fonts-samyak-gujr fonts-samyak-taml fonts-telu-extra
  foomatic-db g++ g++-4.6 g++-4.7 gcc gcc-4.6 gcc-4.6-base gcc-4.7
  gcc-4.7-base gcc-4.7-base:i386 gcc-4.8-base gcc-4.8-base:i386 gcc-avr gdb
  gdbserver geoip-database gettext gettext-base giblib1
  gir1.2-accountsservice-1.0 gir1.2-atk-1.0 gir1.2-atspi-2.0
  gir1.2-caribou-1.0 gir1.2-clutter-1.0 gir1.2-clutter-gst-1.0 gir1.2-cogl-1.0
  gir1.2-coglpango-1.0 gir1.2-evince-3.0 gir1.2-folks-0.6
  gir1.2-gdesktopenums-3.0 gir1.2-gdkpixbuf-2.0 gir1.2-gtk-2.0 gir1.2-gtk-3.0
  gir1.2-gtkclutter-1.0 gir1.2-javascriptcoregtk-3.0 gir1.2-json-1.0
  gir1.2-mate-panel gir1.2-muffin-3.0 gir1.2-mutter-3.0 gir1.2-notify-0.7
  gir1.2-packagekitglib-1.0 gir1.2-panelapplet-4.0 gir1.2-pango-1.0
  gir1.2-polkit-1.0 gir1.2-soup-2.4 gir1.2-telepathyglib-0.12
  gir1.2-telepathylogger-0.2 gir1.2-totem-1.0 gir1.2-upowerglib-1.0
  gir1.2-vte-2.90 gir1.2-webkit-3.0 git git-man glib-networking
  glib-networking-services glx-alternative-mesa glx-alternative-nvidia
  glx-diversions gnome-accessibility-themes gnome-control-center
  gnome-control-center-data gnome-desktop3-data gnome-icon-theme
  gnome-icon-theme-symbolic gnome-screensaver gnome-screenshot
  gnome-session-bin gnome-session-common gnome-settings-daemon gnome-sushi
  gnome-terminal gnome-terminal-data gnome-themes-standard
  gnome-themes-standard-data gnupg gnuplot gnuplot-nox gnustep-base-common
  gnustep-base-runtime google-musicmanager-beta gparted gpgv grep grub-common
  grub-pc grub-pc-bin grub2-common gsettings-desktop-schemas
  gstreamer0.10-gconf gstreamer0.10-plugins-good gstreamer0.10-plugins-ugly
  gstreamer0.10-pulseaudio gstreamer1.0-libav gstreamer1.0-plugins-base
  gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly gstreamer1.0-x
  gtk2-engines gtk2-engines-pixbuf gucharmap gvfs gvfs-backends gvfs-bin
  gvfs-daemons gvfs-libs gzip handbrake-cli handbrake-gtk hardening-includes
  hdparm hostname hplip hplip-data icedtea-6-jre-cacao icedtea-6-jre-jamvm
  iftop ifupdown imagemagick imagemagick-common info init-system-helpers
  initramfs-tools install-info installation-report intel-microcode inxi
  iproute iproute2 iptables iso-codes keyboard-configuration klibc-utils
  krb5-locales lib32gcc1 lib32stdc++6 libaccountsservice0
  libalgorithm-diff-xs-perl libapr1 libapt-inst1.5 libapt-pkg-perl
  libapt-pkg4.12 libasound2 libasound2:i386 libasound2-data libasound2-plugins
  libasprintf-dev libasprintf0c2 libass4 libatasmart4 libatk-adaptor
  libatk-adaptor-data libatk-bridge2.0-0 libatk-wrapper-java
  libatk-wrapper-java-jni libatk1.0-0 libatk1.0-data libatril libatspi2.0-0
  libaudio2 libaudio2:i386 libautodie-perl libavcodec54 libavdevice54
  libavfilter3 libavformat54 libavutil51 libavutil52 libblas3 libblas3gf
  libbluetooth3 libbluray1 libbonobo2-0 libbonobo2-common
  libboost-date-time1.49.0 libboost-date-time1.53.0 libboost-iostreams1.49.0
  libboost-system1.53.0 libburn4 libc-bin libc-dev-bin libc6 libc6:i386
  libc6-dbg libc6-dev libc6-i386 libc6-i686:i386 libcairo-gobject2
  libcairo-perl libcairo2 libcaja-extension libcaribou-common libcaribou0
  libcddb2 libcdio-cdda1 libcdio-paranoia1 libcdio13 libck-connector0
  libclone-perl libclutter-1.0-0 libclutter-gst-1.0-0 libclutter-gtk-1.0-0
  libclutter-imcontext-0.1-0 libclutter-imcontext-0.1-bin
  libcluttergesture-0.0.2-0 libcmis-0.3-3 libcogl-common libcryptsetup4
  libcups2 libcups2:i386 libcupscgi1 libcupsimage2 libcupsmime1 libcupsppdc1
  libcurl3 libcurl3:i386 libcurl3-gnutls libcurl3-nss libcwidget3 libdatrie1
  libdbus-1-3 libdbus-1-3:i386 libdc1394-22 libdca0 libdconf1
  libdevice-serialport-perl libdevmapper-event1.02.1 libdevmapper1.02.1
  libdiscid0 libdjvulibre-text libdjvulibre21 libdpkg-perl libdrm-dev
  libdrm-intel1 libdrm-intel1:i386 libdrm-nouveau2 libdrm-nouveau2:i386
  libdrm-radeon1 libdrm-radeon1:i386 libdrm2 libdrm2:i386 libdvbpsi9
  libdvdnav4 libdvdread4 libedit2 libedit2:i386 libegl1-mesa
  libegl1-mesa-drivers libelf1 libemail-valid-perl libenca0 libept1.4.12
  liberror-perl libevdocument3-4 libevview3-3 libexception-class-perl
  libexttextcat-2.0-0 libexttextcat-data libfdk-aac0 libffmpegthumbnailer4
  libfftw3-3 libfftw3-double3 libfftw3-single3 libfile-fcntllock-perl libflac8
  libflac8:i386 libfolks-telepathy25 libfolks25 libfontconfig1
  libfontconfig1:i386 libfreetype6 libfreetype6:i386 libftdi1 libgadu3
  libgail-3-0 libgail-common libgail18 libgbm1 libgcc-4.7-dev libgcc1
  libgcc1:i386 libgcrypt11 libgcrypt11:i386 libgd3 libgd3:i386 libgdata-common
  libgdata13 libgdata2.1-cil libgdiplus libgdk-pixbuf2.0-0 libgegl-0.2-0
  libgeoclue0 libgeoip1 libgettextpo-dev libgettextpo0 libgfortran3
  libgl1-mesa-dev libgl1-mesa-dri libgl1-mesa-dri:i386
  libgl1-mesa-dri-experimental libgl1-mesa-glx libgl1-mesa-glx:i386
  libgl1-nvidia-glx libglapi-mesa libglapi-mesa:i386 libglib-perl libglu1-mesa
  libglu1-mesa:i386 libgmime-2.6-0 libgmime2.6-cil libgmp10 libgmpxx4ldbl
  libgnome2-canvas-perl libgnome2-perl libgnome2-vfs-perl libgnomevfs2-0
  libgnomevfs2-common libgnomevfs2-extra libgnustep-base1.22
  libgnutls-openssl27 libgnutls26 libgnutls26:i386 libgoa-1.0-0
  libgoa-1.0-common libgomp1 libgpg-error0 libgpg-error0:i386 libgpgme11
  libgphoto2-2 libgphoto2-2:i386 libgphoto2-l10n libgphoto2-port0
  libgphoto2-port0:i386 libgpod-common libgpod4 libgssapi-krb5-2
  libgssapi-krb5-2:i386 libgssdp-1.0-3 libgstreamer-plugins-base1.0-0
  libgstreamer1.0-0 libgtk-3-0 libgtk-3-bin libgtk-3-common libgtk2-perl
  libgtk2.0-0 libgtk2.0-bin libgtk2.0-common libgtkhtml-4.0-0
  libgtkhtml-4.0-common libgtkhtml-editor-3.14-0 libgtkhtml-editor-3.14-common
  libgtkhtml-editor-4.0-0 libgtkhtml3.14-19 libgtksourceview2.0-0
  libgtksourceview2.0-common libgtop2-7 libgtop2-common libgucharmap-2-90-7
  libgudev-1.0-0 libgupnp-1.0-4 libgweather-common libgxps2 libhpmud0
  libhsqldb-java libhtml-format-perl libhtml-parser-perl libhtml-template-perl
  libhtml-tree-perl libhunspell-1.3-0 libicu48 libidl0 libieee1284-3
  libieee1284-3:i386 libimlib2 libio-pty-perl libio-socket-inet6-perl
  libio-socket-ip-perl libio-socket-ssl-perl libipc-system-simple-perl
  libiso9660-8 libisofs6 libitm1 libjavascriptcoregtk-1.0-0
  libjavascriptcoregtk-3.0-0 libjpeg62 libjpeg62:i386 libjpeg8 libjpeg8:i386
  libjson-c2 libjson-c2:i386 libjson-glib-1.0-0 libjson-glib-1.0-common
  libjson0 libjson0:i386 libk5crypto3 libk5crypto3:i386 libkeyutils1
  libkeyutils1:i386 libklibc libkpathsea6 libkrb5-3 libkrb5-3:i386
  libkrb5support0 libkrb5support0:i386 liblangtag-common liblangtag1
  liblapack3 liblapack3gf liblcms1 liblcms1:i386 liblcms2-2 libldap-2.4-2
  libldap-2.4-2:i386 liblensfun-data liblensfun0 liblist-moreutils-perl
  libllvm3.2 libllvm3.2:i386 liblocale-gettext-perl liblognorm0 liblouis-data
  liblua5.2-0 liblvm2app2.2 liblzo2-2 liblzo2-2:i386 libmagick++5
  libmagickcore5 libmagickcore5-extra libmagickwand5 libmatebluetooth
  libmatemenu libmatepolkit libmatesensorsappletplugin libmateweather-common
  libmatewnck-common libmhash2 libmission-control-plugins0 libmodplug1
  libmono-addins-gui0.2-cil libmono-addins0.2-cil libmono-cairo2.0-cil
  libmono-cairo4.0-cil libmono-compilerservices-symbolwriter4.0-cil
  libmono-corlib2.0-cil libmono-corlib4.0-cil libmono-data-tds2.0-cil
  libmono-data-tds4.0-cil libmono-i18n-west2.0-cil libmono-i18n-west4.0-cil
  libmono-i18n4.0-cil libmono-messaging2.0-cil libmono-posix2.0-cil
  libmono-posix4.0-cil libmono-security2.0-cil libmono-security4.0-cil
  libmono-sharpzip2.84-cil libmono-sharpzip4.84-cil libmono-simd2.0-cil
  libmono-sqlite2.0-cil libmono-sqlite4.0-cil
  libmono-system-configuration4.0-cil libmono-system-core4.0-cil
  libmono-system-data-linq2.0-cil libmono-system-data2.0-cil
  libmono-system-data4.0-cil libmono-system-drawing4.0-cil
  libmono-system-enterpriseservices4.0-cil libmono-system-messaging2.0-cil
  libmono-system-runtime-serialization4.0-cil libmono-system-security4.0-cil
  libmono-system-transactions4.0-cil
  libmono-system-web-applicationservices4.0-cil
  libmono-system-web-services4.0-cil libmono-system-web2.0-cil
  libmono-system-web4.0-cil libmono-system-xml-linq4.0-cil
  libmono-system-xml4.0-cil libmono-system2.0-cil libmono-system4.0-cil
  libmono-wcf3.0-cil libmono-web4.0-cil libmono2.0-cil libmpfr4 libmpg123-0
  libmpg123-0:i386 libmtdev1 libmtp-common libmtp-runtime libmtp9 libmuffin0
  libmusicbrainz-discid-perl libmx-1.0-2 libmx-bin libnautilus-extension1a
  libnemo-extension1 libneon27-gnutls libnet-dbus-perl libnet-dns-perl
  libnet-domain-tld-perl libnet-ssleay-perl libnewt0.52 libnm-gtk-common
  libnm-gtk0 libnotify-bin libnotify4 libnspr4 libnspr4:i386 libnspr4-0d
  libnspr4-0d:i386 libnss3 libnss3:i386 libnss3-1d libnss3-1d:i386 libobjc4
  libodbc1 libodbc1:i386 libopenraw1 libopenvg1-mesa liborbit2 liborc-0.4-0
  libp11-kit0 libp11-kit0:i386 libpackagekit-glib2-16 libpam-ck-connector
  libpanel-applet-4-0 libpango-1.0-0 libpango-perl libpango1.0-0
  libpangocairo-1.0-0 libpangoft2-1.0-0 libpangoxft-1.0-0 libparted0debian1
  libpcsclite1 libperlio-gzip-perl libpixman-1-0 libplist1 libpng12-0
  libpng12-0:i386 libpolkit-agent-1-0 libpolkit-backend-1-0
  libpolkit-gobject-1-0 libpoppler-glib8 libpoppler19 libpopt0 libpopt0:i386
  libportaudio2 libpostproc52 libptexenc1 libpthread-stubs0-dev
  libpulse-mainloop-glib0 libpulse0 libpulse0:i386 libpulsedsp libpurple0
  libpython-stdlib libpython2.7 libpython2.7-minimal libpython2.7-stdlib
  libpython3-stdlib libpython3.3 libpython3.3-minimal libpython3.3-stdlib
  libqpdf13 libqt4-dbus libqt4-network libqt4-webkit libqt4-xml libqtcore4
  libqtdbus4 libqtgui4 libqtwebkit4 libquadmath0 libquicktime2 libquvi-scripts
  libquvi7 libraptor2-0 librdf0 librecode0 libreoffice libreoffice-base
  libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core
  libreoffice-draw libreoffice-emailmerge libreoffice-gnome libreoffice-gtk
  libreoffice-impress libreoffice-java-common libreoffice-math
  libreoffice-report-builder-bin libreoffice-style-galaxy
  libreoffice-style-tango libreoffice-writer librpm3 librpmbuild3 librpmio3
  librpmsign1 librsvg2-2 librsvg2-common libruby1.8 libruby1.9.1 libsane
  libsane:i386 libsane-common libsane-hpaio libsasl2-2 libsasl2-2:i386
  libsasl2-modules libsasl2-modules:i386 libsdl-image1.2 libsdl1.2debian
  libsdl1.2debian:i386 libselinux1 libselinux1:i386 libsemanage-common
  libsemanage1 libsensors4 libsepol1 libsmbclient libsmi2ldbl libsnmp30
  libsocket-perl libsocket6-perl libsoundtouch0 libsoup-gnome2.4-1
  libsoup2.4-1 libspeechd2 libspeex1 libspeexdsp1 libsqlite0 libsqlite3-0
  libsqlite3-0:i386 libssl1.0.0 libssl1.0.0:i386 libstdc++5:i386 libstdc++6
  libstdc++6:i386 libstdc++6-4.6-dev libstdc++6-4.7-dev libsub-identify-perl
  libsub-name-perl libswresample0 libswscale2 libsystemd-daemon0
  libsystemd-login0 libtag1-vanilla libtag1c2a libtagc0 libtalloc2 libtar0
  libtasn1-3-bin libtasn1-6 libtelepathy-glib0 libtext-aspell-perl
  libtext-charwidth-perl libtext-iconv-perl libthai-data libthai0 libtiff4
  libtiff4:i386 libtiff5 libtotem0 libtracker-sparql-0.16-0 libtry-tiny-perl
  libudisks2-0 libuniconf4.6 libunshield0 libupower-glib1 libusb-0.1-4
  libusb-0.1-4:i386 libusb-1.0-0 libusb-1.0-0:i386 libuuid-perl libva-x11-1
  libva1 libvisio-0.0-0 libvlc5 libvo-aacenc0 libvo-amrwbenc0 libvte-2.90-9
  libvte-2.90-common libwacom-common libwacom2 libwavpack1 libwayland-client0
  libwayland-server0 libwbclient0 libwebkitgtk-1.0-0 libwebkitgtk-1.0-common
  libwebkitgtk-3.0-0 libwebkitgtk-3.0-common libwireshark-data libwireshark3
  libwiretap3 libwnck-3-0 libwnck-3-common libwpd-0.9-9 libwpg-0.2-2
  libwsutil3 libwvstreams4.6-base libwvstreams4.6-extras libx11-6
  libx11-6:i386 libx11-data libx11-dev libx11-xcb-dev libx11-xcb1
  libx11-xcb1:i386 libxcb-composite0 libxcb-dri2-0 libxcb-dri2-0:i386
  libxcb-dri2-0-dev libxcb-glx0 libxcb-glx0:i386 libxcb-glx0-dev libxcb-randr0
  libxcb-render0 libxcb-render0:i386 libxcb-shape0 libxcb-shm0 libxcb-xfixes0
  libxcb-xv0 libxcb1 libxcb1:i386 libxcb1-dev libxerces2-java
  libxml-libxml-perl libxml-parser-perl libxnvctrl0 libxres1 libxtables10
  libyaml-libyaml-perl libyelp0 libzbar0 libzephyr4 libzip2 lintian
  linux-headers-amd64 linux-image-amd64 linux-libc-dev lm-sensors locales
  logrotate luatex make manpages manpages-dev marco marco-common mate-applets
  mate-applets-common mate-backgrounds mate-bluetooth mate-calc
  mate-control-center mate-desktop mate-desktop-common mate-dialogs
  mate-icon-theme mate-keyring mate-media mate-media-common
  mate-media-gstreamer mate-menus mate-netspeed mate-notification-daemon
  mate-panel mate-panel-common mate-polkit mate-power-manager
  mate-power-manager-common mate-screensaver mate-screensaver-common
  mate-sensors-applet mate-session-manager mate-settings-daemon
  mate-settings-daemon-common mate-settings-daemon-gstreamer
  mate-system-monitor mate-system-tools mate-terminal mate-terminal-common
  mate-text-editor mate-themes mate-user-share mate-utils mate-utils-common
  mdm mesa-common-dev mesa-utils mint-common mint-flashplugin-11
  mint-mdm-themes mint-themes mint-themes-gtk3 mint-translations mint-x-icons
  mintbackup mintdesktop mintinstall mintmenu mintnanny mintsystem mintupload
  mintwelcome mintwifi mjpegtools mobile-broadband-provider-info modemmanager
  mono-2.0-gac mono-4.0-gac mono-gac mono-runtime mozo mplayer muffin-common
  multiarch-support murrine-themes mutter-common nautilus nautilus-data
  nautilus-dropbox nemo-data network-manager-gnome network-manager-pptp
  network-manager-pptp-gnome nmap normalize-audio nvidia-alternative
  nvidia-driver nvidia-glx nvidia-installer-cleanup nvidia-kernel-common
  nvidia-kernel-dkms nvidia-settings nvidia-support nvidia-vdpau-driver
  nvidia-xconfig obexd-client odbcinst odbcinst1debian2 odbcinst1debian2:i386
  openjdk-6-jre openjdk-6-jre-headless openjdk-6-jre-lib openssh-client
  openssh-server openssl oss-compat p11-kit packagekit
  packagekit-backend-aptcc packagekit-tools patch patchutils perl perl-base
  perl-doc perl-modules perl-tk pidgin pluma pluma-common pm-utils policykit-1
  poppler-utils ppp printer-driver-escpr printer-driver-foo2zjs
  printer-driver-hpcups printer-driver-hpijs printer-driver-m2300w
  printer-driver-min12xxw printer-driver-pnm2ppa printer-driver-postscript-hp
  printer-driver-ptouch printer-driver-pxljr procmail pulseaudio
  pulseaudio-esound-compat pulseaudio-module-gconf pulseaudio-module-x11
  pulseaudio-module-zeroconf pulseaudio-utils python python-apt
  python-apt-common python-crypto python-cups python-cupshelpers
  python-egenix-mxdatetime python-egenix-mxtools python-feedparser
  python-httplib2 python-mako python-markupsafe python-mate-menu
  python-minimal python-nevow python-numpy python-openssl python-pkg-resources
  python-pyatspi python-pyatspi2 python-renderpm python-reportlab
  python-reportlab-accel python-simplejson python-six
  python-software-properties python-twisted-bin python-twisted-core
  python-twisted-web python-uno python2.7 python2.7-minimal python3
  python3-apt python3-minimal python3-packagekit python3-pkg-resources
  python3.3 python3.3-minimal qdbus qpdf qtcore4-l10n rpm rpm-common rpm2cpio
  rsync rsyslog rtkit ruby-gettext ruby-locale ruby-text ruby1.8 ruby1.9.1
  samba samba-common samba-common-bin sane-utils scite simple-scan
  software-properties-common software-properties-gtk streamer sudo synaptic
  system-config-printer system-config-printer-udev tar telepathy-gabble
  telepathy-mission-control-5 tex-common texlive texlive-base texlive-binaries
  texlive-extra-utils texlive-font-utils texlive-fonts-recommended
  texlive-fonts-recommended-doc texlive-generic-recommended texlive-latex-base
  texlive-latex-base-doc texlive-latex-recommended
  texlive-latex-recommended-doc texlive-luatex texlive-metapost
  texlive-metapost-doc texlive-pstricks texlive-pstricks-doc thunderbird
  tomboy totem totem-common totem-plugins transcode transcode-doc tshark
  ttf-ubuntu-font-family udev udisks udisks2 ufraw-batch unar unixodbc
  uno-libs3 unshield unzip upower ure usb-modeswitch usb-modeswitch-data
  usbmuxd user-setup vim vim-common vim-runtime vim-tiny vino
  virtualbox-guest-dkms virtualbox-guest-utils virtualbox-guest-x11 vlc
  vlc-data vlc-nox vlc-plugin-notify vlc-plugin-pulse w3m wajig wget whiptail
  wireshark wireshark-common x11-common x11-xserver-utils xawtv-plugins xchat
  xchat-common xnest xorg-sgml-doctools xserver-common xserver-xorg
  xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-evdev
  xserver-xorg-input-mouse xserver-xorg-input-synaptics
  xserver-xorg-input-vmmouse xserver-xorg-input-wacom xserver-xorg-video-all
  xserver-xorg-video-ati xserver-xorg-video-cirrus xserver-xorg-video-fbdev
  xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga
  xserver-xorg-video-neomagic xserver-xorg-video-nouveau
  xserver-xorg-video-nvidia xserver-xorg-video-openchrome
  xserver-xorg-video-r128 xserver-xorg-video-radeon xserver-xorg-video-savage
  xserver-xorg-video-siliconmotion xserver-xorg-video-sisusb
  xserver-xorg-video-tdfx xserver-xorg-video-trident xserver-xorg-video-vesa
  xserver-xorg-video-vmware xterm xtrans-dev yelp yelp-xsl
1157 upgraded, 165 newly installed, 34 to remove and 0 not upgraded.
Monsta
Level 10
Level 10
Posts: 3058
Joined: Fri Aug 19, 2011 3:46 am

Re: Update manager wants to uninstall MATE

Post by Monsta »

Obsolete MATE libs are removed, MATE itself is upgraded, some Cinnamon-related packages are installed (you can investigate further later and possibly remove them), Cinnamon itself is not installed.

Looks like a normal upgrade from UP6 (or maybe 7) to UP8.

Careful reading of apt dist-upgrade output is all you need. :)
User avatar
killer de bug
Level 14
Level 14
Posts: 5398
Joined: Tue Jul 08, 2008 1:49 pm
Location: Leuven, Belgium

Re: Update manager wants to uninstall MATE

Post by killer de bug »

I agree with Monsta. This is an upgrade to UP8.
unkilbeeg wrote: According to the upgrade manager it's pointing at UP8, although it's been a *very* long time since i did an upgrade. I have no idea what upgrade pack I have actually installed.
This confused me. Clearly It says that UP8 is available, not that you have it :)
If it ain't broke, fix it until it is.
unkilbeeg
Level 1
Level 1
Posts: 42
Joined: Tue Apr 27, 2010 5:02 pm

Re: Update manager wants to uninstall MATE

Post by unkilbeeg »

Monsta wrote: Careful reading of apt dist-upgrade output is all you need. :)
Well, a careful, or maybe an informed reading. This makes sense and sets my mind at ease. Now that I know what to look for I can see what you're saying.
killer de bug wrote: This confused me. Clearly It says that UP8 is available, not that you have it :)
Yeah. I had no idea what I have installed, only that the upgrade was pointing at UP8.

Thanks! I'll start the upgrade now.
Monsta
Level 10
Level 10
Posts: 3058
Joined: Fri Aug 19, 2011 3:46 am

Re: Update manager wants to uninstall MATE [SOLVED]

Post by Monsta »

It's better to read UP notes first (either here or in mintUpdate).
unkilbeeg
Level 1
Level 1
Posts: 42
Joined: Tue Apr 27, 2010 5:02 pm

Re: Update manager wants to uninstall MATE [SOLVED]

Post by unkilbeeg »

You're right, and I should have. To be fair, however, nothing in the notes indicates this issue. They *do* indicate some changes in Cinnamon, but why would that affect me? I've never installed or used any part of Cinnamon.

That was part of what fooled me. Mate components were being removed and Cinnamon components were being added. Sure, if I looked further down the list (a lot further down) other Mate components were being updated. I didn't look that far down. And I still don't know why any Cinnamon stuff would be added.

Anyway, the upgrade seems to have gone fine, and I'm making the changes the upgrade notes suggest for APT sources.

Except it looks like I had to install mintsources by hand, and it's not working...
User avatar
killer de bug
Level 14
Level 14
Posts: 5398
Joined: Tue Jul 08, 2008 1:49 pm
Location: Leuven, Belgium

Re: Update manager wants to uninstall MATE [SOLVED]

Post by killer de bug »

did you install mint-mirrors also?
look here http://forums.linuxmint.com/viewtopic.p ... 57#p822185

And Monsta was telling you to read the UP notes before upgrading. Because in order to avoid troubles you may have to perform a few steps before upgrading. But it was too late for you :lol:
If it ain't broke, fix it until it is.
py-thon
Level 4
Level 4
Posts: 315
Joined: Fri Sep 27, 2013 2:24 pm
Location: Paraguay

Re: Update manager wants to uninstall MATE [SOLVED]

Post by py-thon »

unkilbeeg wrote:Is there something I've done to make it think that I'm a Cinnamon user?
If you installed LMDE in 2012 this would have been a hybrid system with both Mate and Cinnamon (you could decide between MATE- and Cinnamon-sessions). In this case the new versions of your old cinnamon packages on your system might cause additional cinnamon-packages to be installed.
Tower: Sparky 64 bit Mate+mintmenu - Netbook: Sparky 32 bit Mate+mintmenu
unkilbeeg
Level 1
Level 1
Posts: 42
Joined: Tue Apr 27, 2010 5:02 pm

Re: Update manager wants to uninstall MATE [SOLVED]

Post by unkilbeeg »

killer de bug wrote:did you install mint-mirrors also?
look here http://forums.linuxmint.com/viewtopic.p ... 57#p822185

And Monsta was telling you to read the UP notes before upgrading. Because in order to avoid troubles you may have to perform a few steps before upgrading. But it was too late for you :lol:
Yep, I found the mint-mirrors thread, and that solved that problem.

I did go over the UP notes after the fact, and they did help me fix some things. But they didn't address most of what I was having trouble with, including the requirement for mint-mirrors, so even if I had read them in advance, I'd have still been here, asking the same questions I did.
py-thon wrote:If you installed LMDE in 2012 this would have been a hybrid system with both Mate and Cinnamon (you could decide between MATE- and Cinnamon-sessions). In this case the new versions of your old cinnamon packages on your system might cause additional cinnamon-packages to be installed.
The initial install was probably 2010. If some subsequent update added the cinnamon packages in, they might have already been here. Otherwise probably not.
Locked

Return to “LMDE Archive”