when lmde 2 (betsy) will be available?

Archived topics about LMDE 2
var
Level 3
Level 3
Posts: 115
Joined: Mon Jul 14, 2014 1:29 am

Re: when lmde 2 (betsy) will be available?

Post by var » Tue Nov 25, 2014 1:32 pm

Yep it's looking like Spring 2015 for us LMDE users. Once again we get shafted by the development team who would rather spend time improving Qiana while leaving us out in the cold.

I love LMDE but I dislike feeling like a second-class citizen with Mint. If LMDE 2 is not out by February 2015, then SolydK is going to be getting a new user.

Jessie has been in freeze for nearly 2 weeks now.

Distro-Don
Level 3
Level 3
Posts: 149
Joined: Thu May 23, 2013 8:43 pm

Re: when lmde 2 (betsy) will be available?

Post by Distro-Don » Tue Nov 25, 2014 3:14 pm

py-thon wrote:
reference2myself wrote:I already upgraded to LMDE 2 and it didn't break anything.
Good for you but no proof that it will be like that for everyone.
Same can be said for Mint 17.1

LMDE mate works great for me. No Problems at all. I'll switch to LMDE (2) "When it is Ready".

py-thon
Level 4
Level 4
Posts: 317
Joined: Fri Sep 27, 2013 2:24 pm
Location: Paraguay

Re: when lmde 2 (betsy) will be available?

Post by py-thon » Wed Nov 26, 2014 10:15 am

Distro-Don wrote:Same can be said for Mint 17.1
Sure, but installing 17.1 you would note problems right at the install. That's hardly time lost.
Installing LMDE 201403 might work fine but give trouble with the big upgrade in spring 2015 on a fully installed system. That's more time lost to fix or install anew.
Tower: Sparky 64 bit Mate+mintmenu - Netbook: Sparky 32 bit Mate+mintmenu

Distro-Don
Level 3
Level 3
Posts: 149
Joined: Thu May 23, 2013 8:43 pm

Re: when lmde 2 (betsy) will be available?

Post by Distro-Don » Wed Nov 26, 2014 3:17 pm

py-thon wrote:
Distro-Don wrote:Same can be said for Mint 17.1
Sure, but installing 17.1 you would note problems right at the install. That's hardly time lost.
Installing LMDE 201403 might work fine but give trouble with the big upgrade in spring 2015 on a fully installed system. That's more time lost to fix or install anew.
I haven't had any problems with any upgrades yet. I don't think I'll have any in the future. We'll see, "When it is Ready". Why are you so negative?

var
Level 3
Level 3
Posts: 115
Joined: Mon Jul 14, 2014 1:29 am

Re: when lmde 2 (betsy) will be available?

Post by var » Wed Nov 26, 2014 3:22 pm

Distro-Don wrote:"When it is Ready"
You'll be waiting a long time then. If it takes them longer than a few weeks to apply Mint customisations and tweaks to a Debian system then they probably don't care much.

I could have completed 'Linux from Scratch' by Spring 2015. It's ridiculous.

User avatar
Bolle1961
Level 5
Level 5
Posts: 718
Joined: Tue Jun 29, 2010 12:59 pm
Contact:

Re: when lmde 2 (betsy) will be available?

Post by Bolle1961 » Wed Nov 26, 2014 3:34 pm

Install Debian Jessie, then you have MATE 1.8.1 or Cinnamon 2.2 :wink:
https://www.debian.org/devel/debian-installer/

If you want you can later always add the Mint LMDE repo for some Mint tools
“Only when the last tree has been cut down, the last fish been caught, and the last stream poisoned, will we realize we cannot eat money.” ― Cree Indian Prophecy
Image

Distro-Don
Level 3
Level 3
Posts: 149
Joined: Thu May 23, 2013 8:43 pm

Re: when lmde 2 (betsy) will be available?

Post by Distro-Don » Wed Nov 26, 2014 7:46 pm

Ignore
Last edited by Distro-Don on Wed Nov 26, 2014 8:01 pm, edited 4 times in total.

Distro-Don
Level 3
Level 3
Posts: 149
Joined: Thu May 23, 2013 8:43 pm

Re: when lmde 2 (betsy) will be available?

Post by Distro-Don » Wed Nov 26, 2014 7:48 pm

Distro-Don wrote:
var wrote:
Distro-Don wrote:"When it is Ready"
=You'll be waiting a long time then. If it takes them longer than a few weeks to apply Mint customisations and tweaks to a Debian system then they probably don't care much.

I could have completed 'Linux from Scratch' by Spring 2015. It's ridiculous.
It will not be too long for me as LMDE mate is working so well for me now that I can wait until "LMDE (2) mate is ready". There isn't anything that I need that LMDE mate doesn't do or have now. I don't need, or want, any eye-candy updates.
Last edited by Distro-Don on Wed Nov 26, 2014 10:37 pm, edited 2 times in total.

Distro-Don
Level 3
Level 3
Posts: 149
Joined: Thu May 23, 2013 8:43 pm

Re: when lmde 2 (betsy) will be available?

Post by Distro-Don » Wed Nov 26, 2014 7:56 pm

Ignore

Distro-Don
Level 3
Level 3
Posts: 149
Joined: Thu May 23, 2013 8:43 pm

Re: when lmde 2 (betsy) will be available?

Post by Distro-Don » Wed Nov 26, 2014 7:59 pm

Ignore

User avatar
clem
Level 12
Level 12
Posts: 4137
Joined: Wed Nov 15, 2006 8:34 am
Contact:

Re: when lmde 2 (betsy) will be available?

Post by clem » Thu Nov 27, 2014 8:45 am

kurotsugi wrote:
Debian Jessie isn’t frozen yet and a lot of packages are still making their way into it. The recent upower and GTK updates show that the base isn’t quite ready just yet.
jessie is now in frozen state and these excuses is no longer applied. if you want to get LMDE 2, then ask them. gather some people, start a campaign, or even start a petition to force mint team release LMDE 2. historical record shows that mint team will take action when certain riot started in LMDE forum.
- UP 6 haven't got updated. lot people complained, people take over LMDE KDE and XFCE version. you got UP 7
- UP 7 haven't got updated. lot people complained. people threaten to take over LMDE as community project. you got UP 8
- UP 8 haven't got updated. to make it worse, mint team planned to abandon it until jessie got released. lot people complained. lot of them moved to another distro. mint team promised to give UP 9 as a transition between testing to stable.

the UP 9 renamed into LMDE 2 and originally planned to be released on this november. later, they changed to original plan (abandon LMDE until jessie got released) when the riot stopped. time to start a new one perhaps?
This is unbelievable...

Let me make something very clear:

- Each release aims at being as good as possible and to reach the same level of expectations as before, or higher. LMDE is no exception, it needs to do better and that's only possible with a stable base.
- We allocate focus and resources based on what most of our users want/need.

Considering there's far less LMDE users than Mint users AND we want LMDE to be as good as Mint itself, it's a normal consequence that it takes more time for LMDE to get ready than Mint. Somebody said he felt like a 2nd-class citizen, I'm sorry about this, but that's the case for anyone in any project who's not using what the majority of people are using. I love working on LMDE, but if it represents x% of our user base it gets x% of our focus.

When people move away from LMDE, we do not put more resources into it, we put less resources into it. Our goal is not to maximize the number of users we have and to prevent other distributions from being successful, our goal is for each release to be better than the one before.

Finally, Betsy will last 2 years at the very least. That means you'll need to wait 2+ years between LMDE 2 and LMDE 3. If you already feel like 10+ months is unacceptable then you're not using the right distribution. We don't care how long it takes for something to come out, we're not all that interested in running bleeding edge software or implementing rolling aspects either, what really matters to us is stability. How long it takes for us to achieve that is almost irrelevant.

We're not in a hurry, NO you will NOT get some half cooked ISO before we fully fix GTK 3.14 issues or take our time and properly decide whether to ship systemd or not. You're not waiting longer because we don't care about LMDE, you're waiting longer because we care about LMDE, we just care less about delaying it than making it work. There's an ISO out there already for Betsy, and it's not for you to play with. We've plenty of changes in the installer, we've an entirely new base to adapt to, we've init/session/power integration to iron out, gtk to tame... we'll take our time with all that.

@kurotsugi: I find the idea of lobbying us really disgusting. I don't see what made you think we were sensitive to that.. we never give ETA, we never make empty promises, we're always really careful not to recommend updates, not to tell people about what we're planning until we know for sure it's going to land. We switched Mint to LTS and LMDE to Stable precisely because we wanted to stop running forward, we wanted to take more time, to do things better and to provide desktop OSes which last longer and were more stable, all that knowing very well we'd lose some users interesting in bleeding edge at the profit of Arch, Debian or even Ubuntu. Why is it that you think things happen when you threaten to leave? There's plenty of Debian derivatives to choose from already, there's plenty of alternatives to LMDE for people already. What we want to build takes time and we're doing it for a minority of our users, so yes: It will be awesome, but yes, it will take time to come out. If by then it's Spring 2015, some genius made his own LFS and everybody thinks it's great, so be it. I want a Betsy release I'm proud of, at the very least it'll achieve the goals we set for Rebecca, I really don't care how long that takes.
Image

py-thon
Level 4
Level 4
Posts: 317
Joined: Fri Sep 27, 2013 2:24 pm
Location: Paraguay

Re: when lmde 2 (betsy) will be available?

Post by py-thon » Thu Nov 27, 2014 10:23 am

Distro-Don wrote:I haven't had any problems with any upgrades yet. I don't think I'll have any in the future. We'll see, "When it is Ready". Why are you so negative?
I didn't have grave problems either, but lots of people had judging from comments on linuxmintusers.de. I'm not being negative, it is just my opinion that if you want some kind of Mint the sensible choice right now is to install 17.1 (when it is released) rather than LMDE 201403.
clem wrote:Somebody said he felt like a 2nd-class citizen, I'm sorry about this, but that's the case for anyone in any project who's not using what the majority of people are using.
The majority of people use Windows, do they really feel 1st-class? :wink:
clem wrote:If you already feel like 10+ months is unacceptable then you're not using the right distribution.
That's exactly why lots of LMDE-users are annoyed. We chose LMDE because it was supposed to be a semi-rolling distribution. Months after the decision to stop it from rolling and switch to Stable http://www.linuxmint.com/download_lmde.php still says "Linux Mint Debian Edition (LMDE) is a semi-rolling distribution based on Debian Testing." Posts in this forum and linuxmintusers.de show that there are still people installing LMDE anew because they believe what is written on the download page.
Tower: Sparky 64 bit Mate+mintmenu - Netbook: Sparky 32 bit Mate+mintmenu

User avatar
clem
Level 12
Level 12
Posts: 4137
Joined: Wed Nov 15, 2006 8:34 am
Contact:

Re: when lmde 2 (betsy) will be available?

Post by clem » Thu Nov 27, 2014 10:44 am

py-thon wrote:That's exactly why lots of LMDE-users are annoyed. We chose LMDE because it was supposed to be a semi-rolling distribution. Months after the decision to stop it from rolling and switch to Stable http://www.linuxmint.com/download_lmde.php still says "Linux Mint Debian Edition (LMDE) is a semi-rolling distribution based on Debian Testing." Posts in this forum and linuxmintusers.de show that there are still people installing LMDE anew because they believe what is written on the download page.
I understand. This decision to switch to Stable was communicated on the blogs but it never impacted the description of the existing LMDE (1). You're making a good point. I removed all erroneous or misleading information on the page you mentioned. If there are other places which need updating please do let us know.

I'm personally very excited about Betsy. One thing I'm not interested in is in attracting people looking for what it won't be. LMDE is not here to bring us more users. I've no issue with recommending other distributions to people when they're into something we're not into ourselves. Our communication might be lacking at times, I can see it's not consistent and I'm aware not everyone read the blog. My apologies to newcomers who installed 20140303 for its rolling aspects without being aware of LMDE's new direction.
Image

User avatar
Crewp
Level 9
Level 9
Posts: 2517
Joined: Sat Dec 01, 2012 8:36 pm
Location: Connecticut,USA

Re: when lmde 2 (betsy) will be available?

Post by Crewp » Thu Nov 27, 2014 12:50 pm

You can't please every one, no matter what distro you use. there will always be some thing that is not to one's liking. But, I love LMDE and fully support the move to Debian stable. Heck, you can run Debian now with Cinnamon, or Mate but what makes Mint really are all the Mint tools etc. and with more time for the team to work on those LMDE has no where to go but UP. ( pardon the Pun ) . :D
Image

User avatar
ilAli
Level 2
Level 2
Posts: 86
Joined: Thu Mar 31, 2011 3:00 am
Location: Iran
Contact:

Re: when lmde 2 (betsy) will be available?

Post by ilAli » Fri Nov 28, 2014 6:55 am

var wrote: I love LMDE but I dislike feeling like a second-class citizen with Mint.
i do too, :(

var
Level 3
Level 3
Posts: 115
Joined: Mon Jul 14, 2014 1:29 am

Re: when lmde 2 (betsy) will be available?

Post by var » Fri Nov 28, 2014 9:45 am

py-thon wrote: The majority of people use Windows, do they really feel 1st-class? :wink:
Sarcasm or missing the point?

On a serious note, LMDE is becoming outdated. The last updates were when? I know it is not as popular but it should not be an unequal thing. Qiana users can wait for their beloved 17.1 can't they? Or they can go to Ubuntu or learn to use LMDE.

Sorry to be negative but when I use a semi-rolling release I expect to be fed snapshots at least 3 - 4 times a week. Not to be greedy but because I need updated packages as I deal with documents across OS X, windows and nix, things like the latest libreoffice makes a difference. I don't want to leave but soon I won't have a choice.

py-thon
Level 4
Level 4
Posts: 317
Joined: Fri Sep 27, 2013 2:24 pm
Location: Paraguay

Re: when lmde 2 (betsy) will be available?

Post by py-thon » Fri Nov 28, 2014 10:32 am

var wrote:
py-thon wrote: The majority of people use Windows, do they really feel 1st-class? :wink:
Sarcasm or missing the point?
What do you think the smiley is for?
var wrote:On a serious note, LMDE is becoming outdated. The last updates were when? I know it is not as popular but it should not be an unequal thing. Qiana users can wait for their beloved 17.1 can't they? Or they can go to Ubuntu or learn to use LMDE.

Sorry to be negative but when I use a semi-rolling release I expect to be fed snapshots at least 3 - 4 times a week. Not to be greedy but because I need updated packages as I deal with documents across OS X, windows and nix, things like the latest libreoffice makes a difference. I don't want to leave but soon I won't have a choice.
I think you missed the point. The decision has been made by the LMDE maintainers months ago. That's why I don't use LMDE anymore, it's dead in my opinion.
But demanding to be fed a snapshot 3-4 times a week is ridiculous. That would be a snapshot every other day. Who is supposed to test all those snapshots? You can get this frequency tracking Debian Testing (well, right now you can't :)
I wouldn't want to upgrade every other day and I seriously doubt that installing each and every new version of libreoffice increases productivity.

As Debian Testing offers no Live-DVDs (and probably no multimedia support ootb) I used Sparky to get there and added mintmenu. My system looks exactly like before, is quicker than before and I can upgrade whatever I want and whenever I feel like it.
Tower: Sparky 64 bit Mate+mintmenu - Netbook: Sparky 32 bit Mate+mintmenu

User avatar
Crewp
Level 9
Level 9
Posts: 2517
Joined: Sat Dec 01, 2012 8:36 pm
Location: Connecticut,USA

Re: when lmde 2 (betsy) will be available?

Post by Crewp » Fri Nov 28, 2014 10:36 am

var wrote:
py-thon wrote: The majority of people use Windows, do they really feel 1st-class? :wink:
Sarcasm or missing the point?

On a serious note, LMDE is becoming outdated. The last updates were when? I know it is not as popular but it should not be an unequal thing. Qiana users can wait for their beloved 17.1 can't they? Or they can go to Ubuntu or learn to use LMDE.

Sorry to be negative but when I use a semi-rolling release I expect to be fed snapshots at least 3 - 4 times a week. Not to be greedy but because I need updated packages as I deal with documents across OS X, windows and nix, things like the latest libreoffice makes a difference. I don't want to leave but soon I won't have a choice.

Well if you read what Clem wrote above, then maybe LMDE is not for you. Because, LMDE moves slow, and has no time table. This has never been a distro about about the latest software. But about stabiltiy. Isn't that what Debian is all about?
Image

User avatar
reference2myself
Level 2
Level 2
Posts: 91
Joined: Sat Sep 18, 2010 10:44 am

Re: when lmde 2 (betsy) will be available?

Post by reference2myself » Tue Dec 02, 2014 12:06 am

var wrote:
py-thon wrote: The majority of people use Windows, do they really feel 1st-class? :wink:
Sarcasm or missing the point?

On a serious note, LMDE is becoming outdated. The last updates were when? I know it is not as popular but it should not be an unequal thing. Qiana users can wait for their beloved 17.1 can't they? Or they can go to Ubuntu or learn to use LMDE.

Sorry to be negative but when I use a semi-rolling release I expect to be fed snapshots at least 3 - 4 times a week. Not to be greedy but because I need updated packages as I deal with documents across OS X, windows and nix, things like the latest libreoffice makes a difference. I don't want to leave but soon I won't have a choice.
I've always updated to the debian testing or unstable repos. Nothing is stopping anybody from still doing that. You might lose a mint-meta* package or two is all.

daspicer
Level 1
Level 1
Posts: 17
Joined: Sat Mar 22, 2014 11:30 pm

Re: when lmde 2 (betsy) will be available?

Post by daspicer » Tue Dec 02, 2014 12:41 pm

I love LMDE, but I've jumped over to openSUSE Tumbleweed and I'm really enjoying it.

Locked

Return to “LMDE 2 "Betsy" Archive”