LMDE 2 Betsy with Cinnamon 2.4

Archived topics about LMDE 1 and LMDE 2
Monsta
Level 10
Level 10
Posts: 3058
Joined: Fri Aug 19, 2011 3:46 am

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by Monsta »

If you'll ever try the upgrade again, can you please post what apt-get says on dist-upgrade? e.g. which packages will be upgraded, which new packages will be installed, and which packages will be held back.
User avatar
reference2myself
Level 2
Level 2
Posts: 91
Joined: Sat Sep 18, 2010 10:44 am

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by reference2myself »

Crewp wrote:Sorry Fred, I don't know any guide's for synaptic. Like everything else I learn from trial and error.

Monsta, Betsy is beautiful. the team should be real proud of the work done in her. I've had stable release's of distro's not as good as this, and she is still in beta.
agreed, being on top of debian jessie is gonna make this a real stable distro, i find debian testing even more stable than ubuntu
Last edited by reference2myself on Thu Feb 12, 2015 2:00 pm, edited 1 time in total.
User avatar
reference2myself
Level 2
Level 2
Posts: 91
Joined: Sat Sep 18, 2010 10:44 am

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by reference2myself »

For people having trouble with the upgrade...

Pay attention to what's going to be removed, if there's an upgrade that's gonna remove a bunch of crap you use or take out your whole desktop environment or something then you gotta be selective about what you upgrade and not do it all at once. If something is being removed, see if it's being replaced by something similar. Sometimes holding back just one package is all it takes. Sometimes you gotta do a few packages at a time to get it to go smooth. It can get messy if you're unfamiliar with the packages or inexperienced with apt-get and synaptic, but playing around is the only way to figure it all out. Don't try on your main install unless you're prepared to start from scratch. Good luck.
User avatar
killer de bug
Level 14
Level 14
Posts: 5398
Joined: Tue Jul 08, 2008 1:49 pm
Location: Leuven, Belgium

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by killer de bug »

I have tested the upgrade path in a VB.
This was not easy. I had to dist-upgrade 3 times and to apt install -f in the middle :lol:

But finally it works and the new Cinnamon is wonderful! Can't wait to have it on my computer!
If it ain't broke, fix it until it is.
User avatar
killer de bug
Level 14
Level 14
Posts: 5398
Joined: Tue Jul 08, 2008 1:49 pm
Location: Leuven, Belgium

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by killer de bug »

Everything works fine, except the terminal. I can't open it. :shock:
If it ain't broke, fix it until it is.
User avatar
Crewp
Level 9
Level 9
Posts: 2511
Joined: Sat Dec 01, 2012 8:36 pm
Location: Connecticut,USA

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by Crewp »

Killer de Bug I am running it on a laptop I use to play around with and I can't find any bugs, except software manager loads real slow, and typing in it's search bar produces very slow results, if at all. My terminal works fine, I'm trying to find things wrong for when it opens up for testing, but can't. At least so far. :mrgreen:
PS: I can't wait to put this on my main box, but won't till it's official , Cinnamon 2.4 is much more responsive, than 2.0
Image
Monsta
Level 10
Level 10
Posts: 3058
Joined: Fri Aug 19, 2011 3:46 am

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by Monsta »

killer de bug wrote:Everything works fine, except the terminal. I can't open it. :shock:
Which version is it? Clem added 3.6.2 to Betsy repos, and there's also 3.14.1 in Jessie repos.

You can still check that in the system console (Ctrl-Alt-F1) or in any other terminal emulator (e.g. roxterm). :)
User avatar
killer de bug
Level 14
Level 14
Posts: 5398
Joined: Tue Jul 08, 2008 1:49 pm
Location: Leuven, Belgium

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by killer de bug »

The system seems responsive and starts fast. That's true. But since it's in a VB, I don't want to comment on this now. I will wait to have it on my computer to discuss this :)
I'm also suspecting that the init system is different between this VB and that will be used for LMDE2. So no comments here :)

On the gtk theme, I really don't like at all the green border on the selected button. It makes everything look so cheap. I will have to edit this theme. I know that I have already said this in the past and I know why JosephM did this but still :?

It is clear that a lot of things are not finished yet to allow the migration to LMDE2. For example, now when I start IRC, I'm directly connected to Debian channel and not to LMDE anymore :)

I have gnome-terminal 3.14.1 installed and I am now forcing to go back to 3.6.2. Let's see :)
If it ain't broke, fix it until it is.
User avatar
killer de bug
Level 14
Level 14
Posts: 5398
Joined: Tue Jul 08, 2008 1:49 pm
Location: Leuven, Belgium

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by killer de bug »

Ok with 3.6.x it works!
Nice terminal slightly transparent. Really nice! At least we can look through it :lol:
Too bad there is no menu bar on the other hand. I guess it's a bug with my VB :lol:
If it ain't broke, fix it until it is.
Monsta
Level 10
Level 10
Posts: 3058
Joined: Fri Aug 19, 2011 3:46 am

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by Monsta »

killer de bug wrote:I'm also suspecting that the init system is different between this VB and that will be used for LMDE2.
You can easily check that out. If you have sysvinit-core + systemd-shim installed, your init system is the traditional sysvinit. If you have systemd-sysv instead of them, your init system is systemd.
killer de bug wrote:For example, now when I start IRC, I'm directly connected to Debian channel and not to LMDE anymore :)
Yes, because it's a new IRC client (hexchat - like in Mint 17.x) and it's not customized for the Mint channels in Betsy yet. It's in the roadmap so it'll be done eventually.
Or do you still use xchat and accidentally upgraded it to the version from Jessie? That would bring the same effect. :)
killer de bug wrote:Nice terminal slightly transparent. Really nice! At least we can look through it
That's why it's there in the repos. The transparency feature has been removed after 3.8 IIRC, so Clem still keeps gnome-terminal at 3.6. I think there were other reasons as well but I can't remember now.
killer de bug wrote:Too bad there is no menu bar on the other hand. I guess it's a bug with my VB
No, it's Clem's decision to turn it off by default. You can see that in Mint 17.x as well. You can bring it back again via the right-click menu.
User avatar
reference2myself
Level 2
Level 2
Posts: 91
Joined: Sat Sep 18, 2010 10:44 am

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by reference2myself »

hmm, i've been using the 3.14 terminal cuz i've had it since before 3.6 was added to the betsy repo. Does it have the transparancy options added back into it?
User avatar
reference2myself
Level 2
Level 2
Posts: 91
Joined: Sat Sep 18, 2010 10:44 am

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by reference2myself »

nvm, i just downgraded it to 3.6 from betsy. I see it's configured by default to have some transparency, I can't get into the profile preferences though, clicking Edit/Profile Preferences does nothing for me, does it work for you guys? I also have to reenable the menu bar each time i launch it, that's annoying :/
User avatar
killer de bug
Level 14
Level 14
Posts: 5398
Joined: Tue Jul 08, 2008 1:49 pm
Location: Leuven, Belgium

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by killer de bug »

Monsta wrote: You can easily check that out. If you have sysvinit-core + systemd-shim installed, your init system is the traditional sysvinit. If you have systemd-sysv instead of them, your init system is systemd.
sytemd-shim and systemd-sysv are isntalled. Not sysvinit-core.
Monsta wrote: Yes, because it's a new IRC client (hexchat - like in Mint 17.x) and it's not customized for the Mint channels in Betsy yet. It's in the roadmap so it'll be done eventually.
Or do you still use xchat and accidentally upgraded it to the version from Jessie? That would bring the same effect. :)
It's hexchat. Xchat was obviously removed by the upgrade. Unless I did it manually in the past but I don't remember doing so. This said, it's an old VB so I don't remember everything :)


Monsta wrote: No, it's Clem's decision to turn it off by default. You can see that in Mint 17.x as well. You can bring it back again via the right-click menu.
Ok interesting. I know that I don't use this menu bar normally. But not seeing it is shocking. Question of habit :)
If it ain't broke, fix it until it is.
User avatar
killer de bug
Level 14
Level 14
Posts: 5398
Joined: Tue Jul 08, 2008 1:49 pm
Location: Leuven, Belgium

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by killer de bug »

reference2myself wrote: I also have to reenable the menu bar each time i launch it, that's annoying :/
This is an option, so there is probably a file somewhere where you can change this. This is Linux, so I'm sure you can fix this easily :lol:
If it ain't broke, fix it until it is.
Monsta
Level 10
Level 10
Posts: 3058
Joined: Fri Aug 19, 2011 3:46 am

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by Monsta »

killer de bug wrote:sytemd-shim and systemd-sysv are isntalled. Not sysvinit-core.
Hmm... :shock:
Well, systemd-shim should probably do nothing when systemd-sysv is in charge. So, you seem to have systemd as the init system.
Monsta
Level 10
Level 10
Posts: 3058
Joined: Fri Aug 19, 2011 3:46 am

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by Monsta »

reference2myself wrote:I can't get into the profile preferences though, clicking Edit/Profile Preferences does nothing for me, does it work for you guys? I also have to reenable the menu bar each time i launch it, that's annoying :/
Clem just fixed the first problem today and released gnome-terminal 3.6.2.1. Not sure about the second problem, but maybe it got fixed as well.
User avatar
reference2myself
Level 2
Level 2
Posts: 91
Joined: Sat Sep 18, 2010 10:44 am

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by reference2myself »

Monsta wrote:
reference2myself wrote:I can't get into the profile preferences though, clicking Edit/Profile Preferences does nothing for me, does it work for you guys? I also have to reenable the menu bar each time i launch it, that's annoying :/
Clem just fixed the first problem today and released gnome-terminal 3.6.2.1. Not sure about the second problem, but maybe it got fixed as well.
Just got the update, I can get into the profile preferences now, also now that I can get in there I can check the box to show the menubar by default in new terminals. So both problems are fixed. Thanks Clem!!
User avatar
reference2myself
Level 2
Level 2
Posts: 91
Joined: Sat Sep 18, 2010 10:44 am

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by reference2myself »

It would be cool if a more current version of the stable nvidia proprietary driver was included. The one in debian is dated. I'm using 346.35 on my system which is the latest long lived branch version. I still hope compiz gets added to the betsy repo too. I might switch from cinnamon to mate if it gets added.
User avatar
reference2myself
Level 2
Level 2
Posts: 91
Joined: Sat Sep 18, 2010 10:44 am

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by reference2myself »

User avatar
Crewp
Level 9
Level 9
Posts: 2511
Joined: Sat Dec 01, 2012 8:36 pm
Location: Connecticut,USA

Re: LMDE 2 Betsy with Cinnamon 2.4

Post by Crewp »

Very nice ref :)
Image
Locked

Return to “LMDE Archive”