Page 1 of 2

LMDE2 - Betsy - with XFCE (My Setup) [DU to XFCE 4.12]

Posted: Wed Mar 18, 2015 3:11 pm
by GeneC
UPDATE May 3, 2015
As LMDE2 is based on Debian Stable and will not see XFCE 4.12 for a LONG time (2 years.?.) I have decided to upgrade from XFCE 4.10 to Xfce 4.12 using the Mepis MX-14 repo.


Not recommended for production machines.
Make a backup first.... :wink:

See this post for details.
http://forums.linuxmint.com/viewtopic.p ... 0#p1013650


======================
OP

Not being a Mate fan, and preferrring XFCE over Cinnamon. I just installed the LMDE2 RC (Cinnamon) and added the XFCE desktop on top of it. Very easy for anyone wishing to try. Just install the XFCE4 package from Synaptic (Its a meta package that gives you all the basics).

I also added:
  • thunar
    xfce4-appfinder
    catfish
    xfburn
    whisker menu
    some of the "xfce4-goodies"
    conky manager
    numix icons
No issues with anything, as of yet... :wink:

(The panel is on autohide at bottom, a setup I prefer)...

Image

Re: LMDE2 - Betsy - with XFCE (My Setup)

Posted: Wed Mar 18, 2015 4:14 pm
by excollier
Nice, must try that. I like xfce.

Re: LMDE2 - Betsy - with XFCE (My Setup)

Posted: Wed Mar 18, 2015 4:19 pm
by GeneC
Added Nvidia with SMXI

http://smxi.org/

Code: Select all

gene@lmde2 ~ $ inxi -G
Graphics:  Card: NVIDIA GF104 [GeForce GTX 460]
           Display Server: X.Org 1.16.4 driver: nvidia Resolution: 1680x1050@59.95hz
           GLX Renderer: GeForce GTX 460/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 346.47
Added things I routinely use.
Installed the following packages:
abiword
alien (8.92)
baobab (3.14.1-1)
bleachbit (1.4-1)
catfish (1.2.2-1)
chkconfig (11.4.54.60.1debian1)
conky-all (1.9.0-6)
dconf-editor (0.22.0-1)
disk-manager (1.1.1-2)
fsarchiver (0.6.19-2)
google-chrome
gparted
gtkorphan (0.4.4-1.1)
hardinfo
localepurge (0.7.3.4)
menulibre (2.0.6-1)
pavu control
pinta (1.3-3)
qt4-fsarchiver
rpm (4.11.3-1.1)
transmission (2.84-0.2)
upgrade-system (1.7.2.2)
Removed things I dont:
Firefox,
Thunderbird,
LibreOffice,
Gimp,
Brasero
Lets see how long before I upgrade the whole thing to Debian Testing.... :roll: ... :P

Re: LMDE2 - Betsy - with XFCE (My Setup)

Posted: Wed Mar 18, 2015 4:22 pm
by GeneC
excollier wrote:Nice, must try that. I like xfce.
Yep, Its hard to beat. Never an issue, and with a little 'tweaking" (Icons, themes, wallpaper) as good looking as any desktop.

Re: LMDE2 - Betsy - with XFCE (My Setup)

Posted: Mon Mar 23, 2015 4:23 pm
by fayad
Thanks GeneC. Hoping this thread will lead to Xfce 4.12 on Betsy. I am really interested. Folks at Mepis have already backported 4.12 for wheezy.

Re: LMDE2 - Betsy - with XFCE (My Setup)

Posted: Wed Mar 25, 2015 9:35 am
by jjaythomas
Hi Gene :D (Forgot my login here, so long/old age) :P

Also going to try Xfce on 'Betsy' but going to try the 'Debian-xfce' meta package (still even in 'betsy repos) over the mate64 version.

P.S. their is a/the xfce4 meta package for 4.12 in experimental (never freezes their), had luck installing on testing (sparky)64 bit (but not on the 32 bit versions :? ) but does break a lot of stuff.

If pointing to testing 4.12 will probably hit sid right away, and testing month or so down line. (after freeze)

J.Jay

Re: LMDE2 - Betsy - with XFCE (My Setup)

Posted: Wed Mar 25, 2015 10:55 am
by ddurdle
Nice thread. I wouldn't mind seeing more of this XFCE.

I'm holding out for an upgrade path from LMDE1. I've been using Compiz on top of MATE for the past 2-3 years, and been loving it, but I seem to have to move windows managers or stay where I am.

Re: LMDE2 - Betsy - with XFCE (My Setup)

Posted: Wed Mar 25, 2015 12:00 pm
by jjaythomas
Was also using 'Mate' to get around needed/want features of Xfce4.10
but like the Xfce panel and plugins better. :)
Can put the xfce4-panel in mate, but need at least (1) mate panel (or becomes very unstable!) :wink:

P.S. even had mate (only) with the xfce4-panel from experimental (love the intelligent auto-hide feature). :o

J.Jay

Re: LMDE2 - Betsy - with XFCE (My Setup)

Posted: Wed Mar 25, 2015 12:19 pm
by jjaythomas
Just chatter :lol:

Was looking over the current thread for moving to testing.
2 points

1.experimental can be used from testing (during freeze even less breakage might happen :wink: )

2. not all packages/packagers use experimental, some go directly into 'sid' with no 'experimental' stage/progression.

J.Jay

Re: LMDE2 - Betsy - with XFCE (My Setup)

Posted: Wed Mar 25, 2015 12:58 pm
by jjaythomas
More chatter (slow day) :lol:

Can move to testing if want Cinnamon (no unless use debian version) mate probably, xfce even more probable. :wink:

delete preferences in apt
uninstall mintsources & upgrademanager (accident happen... easier :twisted: ) Ialso install sparky repo (in FAQ at site) and use aptus (great tool with built in tools/tabs) :wink:

change source list
upgrade (I use Aptus from sparkylinux)

J.Jay

Re: LMDE2 - Betsy - with XFCE (My Setup)

Posted: Wed Mar 25, 2015 5:29 pm
by jjaythomas
Have fully pointing to testing
installed 'experimental debian repo' (will on testing, but may have more dependency problems than on sid)
tried forcing version (from experimental) for the xfce4-panel 1st to see if work
It worked! :D
then crossed fingers (& toes) and tried the xfce4 'meta package' from a terminal.
It also worked :D

Now to see what broke :evil:
most plugins (whisker menu & weather update can force (again from experimental) mail watcher not their yet need alternative! *EDIT*(mail notify in tray(?) I use gmail anyways (a couple alternatives)

J.Jay

Re: LMDE2 - Betsy - with XFCE (My Setup)

Posted: Wed Mar 25, 2015 7:46 pm
by jjaythomas
Not to make this into another distro thread...
But
solydx (a distro) may be a better fit. It did birth in 'MintWorld' going seperate ways when 'LMDE(1) dropped suport for kde then xfce. :shock:

Can do about same thing and add the 'LMDE2' repo. And probally have more Xfce bits (you forgot) baked in. :wink: (what my 'experimental forays don't break) :twisted:

J.Jay

Re: LMDE2 - Betsy - with XFCE (My Setup)

Posted: Fri Mar 27, 2015 11:55 pm
by jjaythomas
More

Kdebian.org (don't let name fool you)

has many of the 'missing pieces' for Xfce4.12 (not the xfce4 'meta package or the goodies meta!) has mail-watcher & places plugins.

J.Jay
Still looking around their repo :wink:

Re: LMDE2 - Betsy - with XFCE (My Setup)

Posted: Sat Mar 28, 2015 1:12 am
by fayad
jjaythomas wrote:Kdebian.org (don't let name fool you)
has many of the 'missing pieces' for Xfce4.12 (not the xfce4 'meta package or the goodies meta!) has mail-watcher & places plugins.
Still looking around their repo :wink:
Good luck with that. And when you are done can you share the steps you followed to get 4.12 running ?

Re: LMDE2 - Betsy - with XFCE (My Setup)

Posted: Tue Apr 07, 2015 7:57 pm
by jjaythomas
Good luck with that. And when you are done can you share the steps you followed to get 4.12 running ?
Done 4 or 5 times now. (compulsive distrohopper :twisted: LMDE, LMDE2 mateRC ,solydxk, sparkylinux both 3.6 and from openbox 4.0 RC. All on the 64 bit version.

Used experimental debian has the meta package 'xfce4' thats for the 4.12 version. Use google to find the wiki to know how to use! May want the xfce4-goodies package also (from experimental).
after have the basic Xfce4.12 I deactivate the experimental (comment out in source list or source listd).
then put the kdebian repo in source list or sorcelistd. Again google, their listed at kdebian.org. (repo and gpgkey downloadable there). and upgrade.

rather have kdebian (sid repo active) then the experimental repo (will change when jessie goes stable)

no problems yet
J.Jay

UPGRADE TO XFCE 4.12

Posted: Sun May 03, 2015 11:28 am
by GeneC
To update to OP (May 3)
Running XFCE with no issues since installation (expected behavior)... :P

=====================

Experiment (Upgrade to XFCE 4.12 from Mepis MX-14 repo)

Not recommended for production machines (should be very stable, BUT....).
If you do use-- use at your own risk, and MAKE A BACKUP first...


1. TEMPORARILY, Add this repo to your soruces list

Code: Select all

deb http://main.mepis-deb.org/mx/repo/ mx15 main
2. Update and Upgrade (I like to use Synaptic).
It will come back with =
W: GPG error: http://main.mepis-deb.org mx15 InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 81E77EAF14E225A0
EDIT: May 4 - (Thanks to Gene Benson for the info!)
To install Mepis public key =

Download link ("save link as")
http://teharris.net/mx14repo.asc

Run (from folder file was downloaded to- I use 'home')..

Code: Select all

su -c "apt-key add mx14repo.asc"
Checking main.mepis-deb.org_mx_repo_dists_mx15_InRelease
Good GPG signature found.
Update from XFCE 4.10 to 4.12

Code: Select all

Commit Log for Sun May  3 11:00:41 2015

Upgraded the following packages:
exo-utils (0.10.2-4) to 0.10.4-1mx150+1
gtk2-engines-xfce (3.0.1-2) to 3.2.0-0mx150+1
gtk3-engines-xfce (3.0.1-2) to 3.2.0-0mx150+1
libexo-1-0 (0.10.2-4) to 0.10.4-1mx150+1
libexo-common (0.10.2-4) to 0.10.4-1mx150+1
libexo-helpers (0.10.2-4) to 0.10.4-1mx150+1
libgarcon-1-0 (0.2.1-2) to 0.4.0-1mx150+1
libgarcon-common (0.2.1-2) to 0.4.0-1mx150+1
libthunarx-2-0 (1.6.3-2) to 1.6.7-1mx150+1
libtumbler-1-0 (0.1.30-1+b1) to 0.1.31-1mx150+1
libxfce4ui-1-0 (4.10.0-6) to 4.12.1-1mx150+1
libxfce4ui-utils (4.10.0-6) to 4.12.1-1mx150+1
libxfce4util-common (4.10.1-2) to 4.12.1-1mx150+1
libxfconf-0-2 (4.10.0-3) to 4.12.0-0mx150+1
orage (4.10.0-1+b2) to 4.12.1-1mx150+1
thunar (1.6.3-2) to 1.6.7-1mx150+1
thunar-archive-plugin (0.3.1-3) to 1:0.3.1-2mx150+1
thunar-data (1.6.3-2) to 1.6.7-1mx150+1
tumbler (0.1.30-1+b1) to 0.1.31-1mx150+1
tumbler-common (0.1.30-1) to 0.1.31-1mx150+1
xfburn (0.5.2-1) to 0.5.2-1mx150+1
xfce-keyboard-shortcuts (4.10.0-6) to 4.12.1-1mx150+1
xfce4 (4.10.1) to 4.12.1mx150+1
xfce4-appfinder (4.10.1-1) to 4.12.0-0mx150+1
xfce4-datetime-plugin (0.6.2-2) to 1:0.6.2-1mx150+1
xfce4-mixer (4.10.0-3) to 1:4.11.0-1mx150+1
xfce4-panel (4.10.1-1) to 4.12.0-1mx150+1
xfce4-power-manager (1.4.1-1) to 1.4.4-2mx150+1
xfce4-power-manager-data (1.4.1-1) to 1.4.4-2mx150+1
xfce4-session (4.10.1-10) to 4.12.1-1mx150+1
xfce4-settings (4.10.1-2) to 4.12.0-1mx150+1
xfce4-weather-plugin (0.8.3-2) to 1:0.8.5-0mx150+1
xfce4-whiskermenu-plugin (1.4.0-1) to 1.5.0-1mx150+2
xfconf (4.10.0-3) to 4.12.0-0mx150+1
xfdesktop4 (4.10.2-3) to 4.12.1-1mx150+1
xfdesktop4-data (4.10.2-3) to 4.12.1-1mx150+1
xfwm4 (4.10.1-3) to 4.12.2-1mx150+1

Installed the following packages:
libxfce4ui-common (4.12.1-1mx150+1)
libxfce4util7 (4.12.1-1mx150+1)
3. Comment out or completely remove Mepis repo.

4. Log OUT/IN.

Your now on XFCE 4.12

===================

References
http://forums.debian.net/viewtopic.php? ... 922a59ad02

What's new in XFCE 4.12
http://www.webupd8.org/2015/03/a-look-a ... video.html

Re: LMDE2 - Betsy - with XFCE (My Setup) [DU to XFCE 4.12]

Posted: Sun May 03, 2015 3:14 pm
by killer de bug
A screenshot? :P

You still like to live dangerously, don't you? :lol:

Re: LMDE2 - Betsy - with XFCE (My Setup) [DU to XFCE 4.12]

Posted: Sun May 03, 2015 3:32 pm
by GeneC
Here ya go, Killer.. :P

Image

LMDE2 with Debian Stable..? What could be dangerous.... :lol:
Seriously, I've been running 4.12 on Sparky with no issues for months, so don't expect them here.

Now my SPARKY (Debian SID) with 4.0 kernel and latest Nvidia. That IS just a bit dangerous.... :wink:

Re: LMDE2 - Betsy - with XFCE (My Setup) [DU to XFCE 4.12]

Posted: Sun May 03, 2015 4:07 pm
by killer de bug
I must admit that when I see what you are capable of doing with XFCE, I tend to think that I should reinstall it. :lol:
Nice desktop :wink:

Re: LMDE2 - Betsy - with XFCE (My Setup) [DU to XFCE 4.12]

Posted: Sun May 03, 2015 4:54 pm
by exploder
GeneC always comes up with something cool! 8)