LMDE 2 MATE 32-bit Live Disk Doesn't Load Completely

Archived topics about LMDE 1 and LMDE 2
Locked
rbeltz48
Level 4
Level 4
Posts: 273
Joined: Mon Jan 16, 2012 3:08 pm
Location: Florida, USA

LMDE 2 MATE 32-bit Live Disk Doesn't Load Completely

Post by rbeltz48 »

Anyone with this problem? It loads so far and then I got a blank screen. Checked disk integrity and it was OK.
User avatar
darethehair
Level 4
Level 4
Posts: 239
Joined: Sun Mar 08, 2009 2:22 pm
Location: Morden Manitoba Canada
Contact:

Re: LMDE 2 MATE 32-bit Live Disk Doesn't Load Completely

Post by darethehair »

rbeltz48 wrote:Anyone with this problem? It loads so far and then I got a blank screen. Checked disk integrity and it was OK.
Perhaps unrelated, but I just tried LMDE 2 32-bit Cinnamon on two Intel Atom-based netbooks, and one worked (ASUS MK90H) and one did not (HP 1035NR). The one that did not work had the same symptoms as you described. I find this very odd i.e. one working and one not. You might want to try another computer.
There is nothing more dangerous than a bored cat.
rbeltz48
Level 4
Level 4
Posts: 273
Joined: Mon Jan 16, 2012 3:08 pm
Location: Florida, USA

Re: LMDE 2 MATE 32-bit Live Disk Doesn't Load Completely

Post by rbeltz48 »

I have been using Mint on my 3 Lenovo T61 Thinkpads since 2012 without a hitch. Thinkpads are very compatible with virtually any version of Linux. The laptop I tried to run LMDE 2 32-bit on previously had LMDE 1 201403 on it and it ran flawlessly. I don't see how it can be the laptop.
lizbeth
Level 4
Level 4
Posts: 329
Joined: Thu Mar 31, 2011 5:44 pm

Re: LMDE 2 MATE 32-bit Live Disk Doesn't Load Completely

Post by lizbeth »

if you are certain the disk is burned correctly by a md5 or sha sum check then the like problem is with the graphics driver. look on the site on how to add the command no mode set to the boot.
User avatar
cli-86
Level 1
Level 1
Posts: 45
Joined: Thu Mar 12, 2015 4:57 am

Re: LMDE 2 MATE 32-bit Live Disk Doesn't Load Completely

Post by cli-86 »

rbeltz48 wrote:Anyone with this problem? It loads so far and then I got a blank screen. Checked disk integrity and it was OK.
this happened to me i had it to run uefi and i got to grub menu then blank screen, i went into boot priority and changed it to usb stick i was using but without (uefi) beside it and resolved my problem
C.L.I (COMMAND - LINE - INTELLIGENCE)
User avatar
darethehair
Level 4
Level 4
Posts: 239
Joined: Sun Mar 08, 2009 2:22 pm
Location: Morden Manitoba Canada
Contact:

Re: LMDE 2 MATE 32-bit Live Disk Doesn't Load Completely

Post by darethehair »

lizbeth wrote:if you are certain the disk is burned correctly by a md5 or sha sum check then the like problem is with the graphics driver. look on the site on how to add the command no mode set to the boot.
Yes, in the specific case where one of my netbooks boots into a black screen, adding 'nomodeset' to my grub2 boot command does allow it to boot -- but I end up with a software-based screen rendering (slow) because of this. Now I remember what I originally may have done to overcome that hurdle when I originally installed Linux LMDE on that same netbook in the past...
There is nothing more dangerous than a bored cat.
lizbeth
Level 4
Level 4
Posts: 329
Joined: Thu Mar 31, 2011 5:44 pm

Re: LMDE 2 MATE 32-bit Live Disk Doesn't Load Completely

Post by lizbeth »

[quote="darethehair"][quote="lizbeth"]if you are certain the disk is burned correctly by a md5 or sha sum check then the like problem is with the graphics driver. look on the site on how to add the command no mode set to the boot.[/quote]

Yes, in the specific case where one of my netbooks boots into a black screen, adding 'nomodeset' to my grub2 boot command does allow it to boot -- but I end up with a software-based screen rendering (slow) because of this. Now I remember what I originally may have done to overcome that hurdle when I originally installed Linux LMDE on that same netbook in the past...[/quote]


would you post that here for the benefit of other users?

You should be able to install your specific drivers for your graphics card to overcome this problem on the first boot after install.
User avatar
darethehair
Level 4
Level 4
Posts: 239
Joined: Sun Mar 08, 2009 2:22 pm
Location: Morden Manitoba Canada
Contact:

Re: LMDE 2 MATE 32-bit Live Disk Doesn't Load Completely

Post by darethehair »

lizbeth wrote:would you post that here for the benefit of other users?

You should be able to install your specific drivers for your graphics card to overcome this problem on the first boot after install.
In order to test out the new LMDE 2 distro, my GRUB2 boot config file menuentry looks like this:

Code: Select all

menuentry "Mint Debian Edition 32bit" {
    # only 'by-label' seems to work now so 'darelinux' (or whatever) needs to be stated explicitly
    set isofile="/boot/isos/lmde-2-201503-cinnamon-32bit.iso"

    loopback loop $isofile
    linux (loop)/live/vmlinuz fromiso=/dev/disk/by-label/DARELINUX/$isofile boot=live config noeject --
    initrd (loop)/live/initrd.lz
}
Just as stated on the web (e.g. http://askubuntu.com/questions/38780/ho ... led-ubuntu), one of the things to try when Linux boots result in a black screen is to add the 'nomodeset' parameter option to the end of the 'boot' command:

Code: Select all

boot=live config noeject nomodeset --
Another thing I tried, with the same results, is a variation of this specifically for what is reasonable for my graphics card:

Code: Select all

boot=live config noeject i915.modeset=0 --
Yes, I suppose that I could try to install a better/different graphics driver after this, but in the case of the netbook that is giving me trouble, I need to first take an extra step and install required wireless drivers (which do not work out-of-the-box in this case).

My actual plans for this netbook are these: wait for the LMDE 2 'upgrade' scripts to be released, and try to move to LMDE 2 that way first. Hopefully that will preserve my working system with a minimum of fuss. If that doesn't work, then I will pursue a 'fresh' install'.
There is nothing more dangerous than a bored cat.
rbeltz48
Level 4
Level 4
Posts: 273
Joined: Mon Jan 16, 2012 3:08 pm
Location: Florida, USA

Re: LMDE 2 MATE 32-bit Live Disk Doesn't Load Completely

Post by rbeltz48 »

Update: I was able to normally run live and install the LMDE 2 MATE 64-bit version on my Lenovo Thinkpad T61. However, the 32-bit version has problems and would not even run live OK or install correctly. In the live mode, it will only run in compatibility mode. If you try to run it live normally it will hang up on a black screen. I was able to install it but then it only runs in recovery mode. There are serious problems with this 32-bit version which need to be addressed. I have never had problems this serious with Linux Mint since I started using it with LM 12 3-1/2 years ago. All versions have run out of the box until now. I hope this problem gets back to Clem and his team.
Locked

Return to “LMDE Archive”