Why is LMDE 2 not compatible with PPAs ?

Archived topics about LMDE 1 and LMDE 2
Locked
User avatar
RamBurner
Level 3
Level 3
Posts: 174
Joined: Wed Nov 23, 2011 7:31 pm

Why is LMDE 2 not compatible with PPAs ?

Post by RamBurner »

Why is LMDE 2 not compatible with PPAs ?
exploder
Level 15
Level 15
Posts: 5564
Joined: Tue Feb 13, 2007 10:50 am
Location: HartfordCity, Indiana USA

Re: Why is LMDE 2 not compatible with PPAs ?

Post by exploder »

Ubuntu and systems using it as a base can use ppa repos. Debian does not have ppa repos but they have been proposed recently. :) Ubuntu packages are not necessarily compatible with Debian and LMDE 2.
GregE
Level 4
Level 4
Posts: 472
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: Why is LMDE 2 not compatible with PPAs ?

Post by GregE »

To expand on that. PPAs are for Ubuntu and derivatives. Contrary to what a lot of people think Ubuntu is not based on Debian any more. They share the deb package format and the apt install system. Early versions of Ubuntu were just snapshots of Debian Unstable that were then cleaned up, but now Ubuntu is it's own beast. That means that they are not even close to 100% compatible. You can easily descend into "dependency hell" where various libs are the wrong versions for you setup. The quickest way to trash a Debian based system is to install an Ubuntu deb package. Some simple deb packages from Ubuntu might work, if you are lucky, and some are specifically tagged as usable for both eg Google Chrome.

Backports is the safest way to get updated programs.

Or learn to delve into Debian Sid. There are two bleeding edge Debian based distros Siduction and Aptosid which are based on Debian Unstable. Installing packages from these distros will also not necessarily work on the Debian Stable that LMDE2 is based.
Last edited by GregE on Wed Apr 29, 2015 7:28 pm, edited 1 time in total.
User avatar
RamBurner
Level 3
Level 3
Posts: 174
Joined: Wed Nov 23, 2011 7:31 pm

Re: Why is LMDE 2 not compatible with PPAs ?

Post by RamBurner »

Thank you, you have completely answered my question. I appreciate that you took the time to explain it to me.
User avatar
MadmanRB
Level 2
Level 2
Posts: 52
Joined: Tue May 21, 2013 6:28 pm

Re: Why is LMDE 2 not compatible with PPAs ?

Post by MadmanRB »

Well you can use ubuntu ppa's they are just not recommended.
If a ppa is needed best way for me to stay safe is use repos for Trusty/Precise and never use a interim release repos.
I use the removed repos and with a few hiccups its safe enough
nuttzo34
Level 1
Level 1
Posts: 26
Joined: Fri May 16, 2014 9:16 am

Re: Why is LMDE 2 not compatible with PPAs ?

Post by nuttzo34 »

Why not just use mint 17.1 then if ppa repos are important to you?

If you want newer software you can also manually backport packages from sid yourself.

https://wiki.debian.org/SimpleBackportCreation

Personally i've never done it because it's easier to just use mint 17.1 with ppa's rather than risk breaking something although you can still do damage with ppa's if you aren't careful.
exploder
Level 15
Level 15
Posts: 5564
Joined: Tue Feb 13, 2007 10:50 am
Location: HartfordCity, Indiana USA

Re: Why is LMDE 2 not compatible with PPAs ?

Post by exploder »

The new Debian leader has proposed ppa repos so we might see them in the future. :D
Monsta
Level 10
Level 10
Posts: 3058
Joined: Fri Aug 19, 2011 3:46 am

Re: Why is LMDE 2 not compatible with PPAs ?

Post by Monsta »

Hmm, indeed. You can read about it here and here.
Locked

Return to “LMDE Archive”