[SOLVED] LMDE Betsy and Wine

Archived topics about LMDE 1 and LMDE 2
Locked
mike77
Level 1
Level 1
Posts: 27
Joined: Sun Dec 07, 2014 1:18 pm

[SOLVED] LMDE Betsy and Wine

Post by mike77 »

Just in case someone else encounters the puzzling problem of not getting wine to work on a fresh Betsy install (not showing in the menu, in my case not installing any applications), here is a solution I found. It was originally for Debian Wheezy but works for me on Betsy, at any rate in a Virtualbox guest.

Please note: this is for a FRESH Betsy install. If you are running LMDE1 and have got wine working, the situation may be different after the dist upgrade, wine may be working well (I haven't upgraded my host machine yet so I don't know).

Here is what needs to be done:

1. Completely remove wine (including as a last step the .wine folder from the home directory). Anyway, that's what I did, not sure if it's necessary.

2. install wine again:
sudo apt-get install wine

3. sudo dpkg --add-architecture i386

4. sudo apt-get update

5. sudo apt-get install wine-bin:i386

It will install a ton of dependencies, but at the end, you have a working wine install. It will show up in the menu and allow you to install and run applications.
Last edited by zerozero on Wed May 20, 2015 10:27 am, edited 1 time in total.
Reason: Moved here, not an Upgrade Issue.

Locked

Return to “LMDE Archive”