Mounting DVD Drive [Solved]

Archived topics about LMDE 1 and LMDE 2
Locked
abtygwyn
Level 4
Level 4
Posts: 204
Joined: Mon Apr 25, 2011 4:33 am

Mounting DVD Drive [Solved]

Post by abtygwyn »

I have tended to play movies directly off the hard drive for years now, but recently my son wanted a film which we had on DVD. Loading it into my laptop it would not mount the drive correctly. I can use VLC player to search for an play files off the drive but it won't load directly.

I also am unable to install software from the drive. I have configured the hard drive to double boot with windows, but I can never get a DVD to load that either. I loaded LMDE 2 directly off a USB stick which I find is the fastest and easiest method I've come across.

This is not critical but if anybody can suggest ways of getting the drive to be recognised it would be helpful.

Thanks

This problem has been solved. I've no idea WHY this worked, but it appears to have worked for me.
I kept looking at at people's problems and came across one where the person couldn't use Brasero to burn a CD. They solved this problem by installing a package which had not been included in their distrubtion. It would appear that this has also been omitted from LMDE 2. Brasero is installed automatically but not brasero-cdrkit

I installed brasero-cdrkit using Synaptic Package Manager.

I now find that the CD/DVD drive is immediately recognised when I insert a disk and I get an icon appears on the Desktop.

As I said, I have no idea why this works or why Brasero didn't work without this. I can only report what I've found. Hopefully this will help some :)_
Last edited by abtygwyn on Sun Aug 23, 2015 4:43 am, edited 2 times in total.

User avatar
txba516
Level 3
Level 3
Posts: 197
Joined: Fri Aug 10, 2007 11:57 am
Location: Atlanta, GA

Re: Mounting DVD Drive

Post by txba516 »

It sounds likely to be a hardware issue with the drive or cabling. Can you eject the drive tray from within Windows or Linux? If so, then the drive is working at a basic level. The drive tray will open via the front button even if the data cable is not connected so that's not a valid test.
You could also use the Disks utility in the Preferences menu to see if the drive shows up at all.

Cheers!
LM17.2 x64 Cinnamon
Help the forums get answers faster! Mark your fixed problem thread as [SOLVED]

GeneBenson
Level 4
Level 4
Posts: 346
Joined: Fri Sep 17, 2010 9:55 pm

Re: Mounting DVD Drive

Post by GeneBenson »

Hi abtygwyn,

In addition to txba516's suggestions you could also check the settings in your File Manager with regard to mounting CD's/DVD's.

Also, in a terminal, enter these commands:

cat /sys/module/block/parameters/events_dfl_poll_msecs
cat /sys/block/sr0/events_poll_msecs

If you get 0 or -1 from both of those commands, kernel polling may be disabled.

abtygwyn
Level 4
Level 4
Posts: 204
Joined: Mon Apr 25, 2011 4:33 am

Re: Mounting DVD Drive

Post by abtygwyn »

GeneBenson wrote:Hi abtygwyn,

In addition to txba516's suggestions you could also check the settings in your File Manager with regard to mounting CD's/DVD's.

Also, in a terminal, enter these commands:

cat /sys/module/block/parameters/events_dfl_poll_msecs
cat /sys/block/sr0/events_poll_msecs

If you get 0 or -1 from both of those commands, kernel polling may be disabled.

I get 0 from the first one, but 2000 from the second. I am also none the wiser! I hope you are :)

GeneBenson
Level 4
Level 4
Posts: 346
Joined: Fri Sep 17, 2010 9:55 pm

Re: Mounting DVD Drive

Post by GeneBenson »

Hi abtygwyn,
I get 0 from the first one, but 2000 from the second. I am also none the wiser! I hope you are
Yes. That is okay. Did you check the settings in your File Manager with regard to mounting CD's/DVD's?
Is libdvdcss2 installed?

abtygwyn
Level 4
Level 4
Posts: 204
Joined: Mon Apr 25, 2011 4:33 am

Re: Mounting DVD Drive

Post by abtygwyn »

GeneBenson wrote:Hi abtygwyn,
I get 0 from the first one, but 2000 from the second. I am also none the wiser! I hope you are
Yes. That is okay. Did you check the settings in your File Manager with regard to mounting CD's/DVD's?
Is libdvdcss2 installed?
Thanks. Have never looked at File Manager much. There are not settings relating to mounting CDs/DVDs though.
There is a configure link under Enable Volume Management which brings up an error message "failed to execute child process "thunar-volman" (no such File or Directory). I suspect this may be something to do with my problems?

libdvdcss2 is installed. I can use the DVD drive. We managed to play a DVD in the end. But I couldn't browse the DVD and it won't mount on the system.

Thanks

PA Checked in package manager and thunar-volman was there but not installed so I installed. Now able to configure volume management. Thought this would sort it, have ticked all the DVD boxes, but still doesn't mount or detect DVD on insertion. Will continue looking for solutions, so any suggestion appreciated.

GeneBenson
Level 4
Level 4
Posts: 346
Joined: Fri Sep 17, 2010 9:55 pm

Re: Mounting DVD Drive

Post by GeneBenson »

Hi abtygwyn,

I have one final suggestion. In a terminal enter the following command:

Code: Select all

 sudo bash -c 'echo 2000 > /sys/module/block/parameters/events_dfl_poll_msecs'
Then see if a DVD will mount properly. This is a temporary solution that lasts until you shutdown/reboot.
If this works then for a permanent you need to edit, as root, this file: /etc/rc.local
Add the following before the 'exit' line in that file:

Code: Select all

echo 2000 > /sys/module/block/parameters/events_dfl_poll_msecs
Save the file and reboot.

abtygwyn
Level 4
Level 4
Posts: 204
Joined: Mon Apr 25, 2011 4:33 am

Re: Mounting DVD Drive

Post by abtygwyn »

GeneBenson wrote:Hi abtygwyn,

I have one final suggestion. In a terminal enter the following command:

Code: Select all

 sudo bash -c 'echo 2000 > /sys/module/block/parameters/events_dfl_poll_msecs'
Then see if a DVD will mount properly. This is a temporary solution that lasts until you shutdown/reboot.
If this works then for a permanent you need to edit, as root, this file: /etc/rc.local
Add the following before the 'exit' line in that file:

Code: Select all

echo 2000 > /sys/module/block/parameters/events_dfl_poll_msecs
Save the file and reboot.
Thanks for your help. This hasn't cured it, but I've added the script to the file in any event just in case !

Locked

Return to “LMDE Archive”