Update removes Cinnamon, codecs, Thunderbird [SOLVED]

Archived topics about LMDE 1 and LMDE 2
Locked
vlad1777d
Level 1
Level 1
Posts: 33
Joined: Fri Mar 13, 2015 6:20 pm

Update removes Cinnamon, codecs, Thunderbird [SOLVED]

Post by vlad1777d »

mintUpdate 4.9.3.

The update of hunspell-en-us needs to remove next packages: mint-meta-debian-cinnamon, thunderbird;
https://pp.vk.me/c623917/v623917447/4e8 ... Zi7AmA.jpg
the update of totem needs to remove packages: mint-meta-debian-codecs, totem-mozilla.
https://pp.vk.me/c623917/v623917447/4e8 ... 8tLKZ0.jpg

Without codecs, Cinnamon, Thunderbird system will be incomplete.

How to solve this?
Thanks.
Last edited by vlad1777d on Thu Oct 22, 2015 7:04 pm, edited 1 time in total.
Kassad
Level 1
Level 1
Posts: 7
Joined: Wed Feb 01, 2012 2:29 pm

Re: Update removes Cinnamon, codecs, Thunderbird

Post by Kassad »

There is a notion of possible conflict in this thread:

http://forums.linuxmint.com/viewtopic.p ... 15#p697381

I, too, ran into this problem more than one time.
I think, you can safely omit hunspell from the update, possibly, you will not need it.
Perhaps, some more knowledgable people can tell more about this.
User avatar
killer de bug
Level 14
Level 14
Posts: 5399
Joined: Tue Jul 08, 2008 1:49 pm
Location: Leuven, Belgium

Re: Update removes Cinnamon, codecs, Thunderbird

Post by killer de bug »

You are trying to upgrade Totem to a version different than the one given with LMDE2. On LMDE Totem is supposed to be at version 3.10.

Code: Select all

KDB@KDB-laptop ~ $ apt policy totem
totem:
  Installé : 3.10.1-1+betsy
  Candidat : 3.10.1-1+betsy
 Table de version :
     3.14.0-2 0
        500 http://ftp.debian.org/debian/ jessie/main amd64 Packages
 *** 3.10.1-1+betsy 0
        700 http://packages.linuxmint.com/ betsy/upstream amd64 Packages
        100 /var/lib/dpkg/status
This may explain your problem.
If it ain't broke, fix it until it is.
vlad1777d
Level 1
Level 1
Posts: 33
Joined: Fri Mar 13, 2015 6:20 pm

Re: Update removes Cinnamon, codecs, Thunderbird

Post by vlad1777d »

Oh,
Пакет totem:
i 3.10.1-1+betsy betsy 700
p 3.14.0-2 stable 990
p 3.18.1-1+b1 unstable 139

I don't know why the stable repositories have 990 priority. I thought It was standard.

Thank you.
vlad1777d
Level 1
Level 1
Posts: 33
Joined: Fri Mar 13, 2015 6:20 pm

Re: Update removes Cinnamon, codecs, Thunderbird

Post by vlad1777d »

I noticed the problem.
In my apt.conf there was: APT::Default-Release "stable", this is my fault.

Now I corrected this.
apt-cache policy: https://vk.com/wall16425447_1140
My preferences.d: https://vk.com/wall16425447_1141
apt.conf: https://vk.com/wall16425447_1142
I hope now is all OK.

Thank you for help =) But maybe you know how to see the list of all installed packages from other sources, that are in the betsy source too, if yes, tell please.
Locked

Return to “LMDE Archive”