Page 1 of 1

grub-install: error: will not proceed with blocklists

Posted: Fri Jan 01, 2016 7:00 pm
by Fred Barclay
As an exercise in futility :) I'm trying to install Grub to a partition of my HDD. I'm practicing with this on Mint before I use it in Manjaro (which is fussing at me due to my setup--hopefully giving it a partition to install Grub will calm its feelings.)

Anyhow, I have a GPT-partitioned HDD--however, I have BIOS, not UEFI. The partition I'm trying to install Grub to is sda7, a 1 GB partition that is (currently) FAT-32.
My system specs:

Code: Select all

fred@aussie! ~ $ inxi -Fxz
System:    Host: aussie! Kernel: 4.2.0-0.bpo.1-amd64 x86_64 (64 bit gcc: 4.9.2) 
           Desktop: Cinnamon 2.8.6 (Gtk 3.14.5+4) Distro: LinuxMint 2 betsy 
Machine:   System: Gateway product: T-1625 v: 90.02
           Mobo: GATEWAY model: N/A v: Rev1.90.02 Bios: Gateway v: 90.02 date: 08/02/2007
CPU:       Dual core AMD Turion 64 X2 Mobile TL-60 (-MCP-) cache: 1024 KB
           flags: (lm nx sse sse2 sse3 svm) bmips: 6400 
           Clock Speeds: 1: 1600 MHz 2: 1600 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS690M [Radeon Xpress 1200/1250/1270] bus-ID: 01:05.0
           Display Server: X.Org 1.16.4 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1280x800@60.00hz
           GLX Renderer: Gallium 0.4 on ATI RS690 GLX Version: 2.1 Mesa 10.3.2 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] RS690 HDMI Audio [Radeon Xpress 1200 Series] 
           driver: snd_hda_intel bus-ID: 01:05.2 
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA) driver: snd_hda_intel bus-ID: 00:14.2 
           Sound: Advanced Linux Sound Architecture v: k4.2.0-0.bpo.1-amd64
Network:   Card-1: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: a000 bus-ID: 08:00.0
           IF: eth0 state: down mac: <filter>
           Card-2: Realtek RTL8187B Wireless 802.11g 54Mbps Network Adapter usb-ID: 001-003
           IF: N/A state: N/A mac: N/A
Drives:    HDD Total Size: 314.4GB (31.7% used) ID-1: /dev/sda model: Hitachi_HTS54252 size: 250.1GB
           ID-2: USB /dev/sdb model: USB_2.0_FD size: 64.4GB
Partition: ID-1: / size: 108G used: 36G (35%) fs: ext4 dev: /dev/sda1 
           ID-2: swap-1 size: 5.24GB used: 0.00GB (0%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 47.0C mobo: N/A 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 176 Uptime: 3:50 Memory: 643.6/2569.4MB Init: SysVinit runlevel: 2 Gcc sys: 4.9.2 
           Client: Shell (bash 4.3.301) inxi: 2.1.28 
This is what happens in Mint (and also Manjaro) when I try to install Grub:

Code: Select all

 fred@aussie! ~ $ sudo grub-install --target=i386-pc /dev/sda7
Installing for i386-pc platform.
grub-install: warning: File system `fat' doesn't support embedding.
grub-install: warning: Embedding is not possible.  GRUB can only be installed in this setup by using blocklists.  However, blocklists are UNRELIABLE and their use is discouraged..
grub-install: error: will not proceed with blocklists.
I've tried multiple file systems--FAT 32, NTFS, and EXT4 (which the grub installer insists is ext2). For each, Grub reports that "embedding is impossible, so blocklists must be used--oh wait, I don't want to use blocklists after all. Sorry!" :)

Any ideas on how to work around this?

Re: grub-install: error: will not proceed with blocklists

Posted: Sat Jan 02, 2016 10:15 am
by Fred Barclay
Checked the Arch wiki on Grub--should have done it earlier. :) Apparently Grub will not install to a partition unless you force it to:

Code: Select all

sudo grub-install --target=i386-pc --force /dev/sda7
I'm not marking this as SOLVED just yet in case someone else can give a different perspective, but if no one else replies in the next few days I'll call the thread solved.