Page 1 of 1

Video Tearing Intel HD Graphics 5500 - 2016

Posted: Tue Jan 26, 2016 3:37 pm
by Chek
Hi All,

re: Video Tearing Intel HD Graphics 5500 - 2016

This is my first experience with LMDE 2, no complaints so far.

I have read many posts most are either outdated don't apply to my OS. To help assist others as well, I have put the year in the subject line so it will come up in a search...

I have a fresh install of LMDE 2 Mate.

My problem :
- after all my reading and research I cant get rid of the video tearing when watching video. One of the post had a driver forced, i tried that and it didn't work so I am looking for more current and up to date solutions.

My questions :
- first the easy question, is there an easy way to fix this? [and i'm not minty enough to find it]
- does anyone have an easy solution
- how can change to a different driver/package
- will the stable 4.4 kernel resolve this issue, if so can someone with LMDE2 let me how they epgraded

thank you,

Code: Select all

htpc@htpc-m ~ $ lspci
00:00.0 Host bridge: Intel Corporation Broadwell-U Host Bridge -OPI (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)
00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)
00:14.0 USB controller: Intel Corporation Wildcat Point-LP USB xHCI Controller (rev 03)
00:16.0 Communication controller: Intel Corporation Wildcat Point-LP MEI Controller #1 (rev 03)
00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #1 (rev e3)
00:1c.2 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #3 (rev e3)
00:1c.3 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #4 (rev e3)
00:1d.0 USB controller: Intel Corporation Wildcat Point-LP USB EHCI Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation Wildcat Point-LP LPC Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation Wildcat Point-LP SATA Controller [AHCI Mode] (rev 03)
00:1f.3 SMBus: Intel Corporation Wildcat Point-LP SMBus Controller (rev 03)
02:00.0 Network controller: Intel Corporation Wireless 3160 (rev 83)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)

Code: Select all

htpc@htpc-m ~ $ inxi -Fxz
System:    Host: htpc-m Kernel: 3.16.0-4-amd64 x86_64 (64 bit gcc: 4.8.4) Desktop: MATE 1.12.0 (Gtk 3.14.5+4) 
           Distro: LinuxMint 2 betsy 
Machine:   Mobo: GIGABYTE model: MQLP5AP-00 v: 1.x Bios: American Megatrends v: F2 date: 12/05/2014
CPU:       Dual core Intel Core i5-5200U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 8779 
           Clock Speeds: 1: 2200 MHz 2: 2200 MHz 3: 1423 MHz 4: 2166 MHz
Graphics:  Card: Intel Broadwell-U Integrated Graphics bus-ID: 00:02.0
           Display Server: X.Org 1.16.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1440x900@59.89hz
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.5, 256 bits)
           GLX Version: 3.0 Mesa 10.3.2 Direct Rendering: Yes
Audio:     Card-1 Intel Wildcat Point-LP High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0 
           Card-2 Intel Broadwell-U Audio Controller driver: snd_hda_intel bus-ID: 00:03.0 
           Sound: Advanced Linux Sound Architecture v: k3.16.0-4-amd64
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 03:00.0
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Intel Wireless 3160 driver: iwlwifi v: in-tree: bus-ID: 02:00.0
           IF: wlan0 state: down mac: <filter>
Drives:    HDD Total Size: 3250.6GB (3.9% used) ID-1: /dev/sda model: Samsung_SSD_850 size: 250.1GB
           ID-2: USB /dev/sdb model: My_Passport_0827 size: 3000.6GB
Partition: ID-1: / size: 50G used: 5.4G (12%) fs: ext4 dev: /dev/sda1 
           ID-2: /home size: 173G used: 962M (1%) fs: ext4 dev: /dev/sda3 
           ID-3: swap-1 size: 8.59GB used: 0.00GB (0%) fs: swap dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 184 Uptime: 1:47 Memory: 965.9/7453.5MB Init: SysVinit runlevel: 2 Gcc sys: 4.9.2 
           Client: Shell (bash 4.3.301) inxi: 2.1.28 

Re: Video Tearing Intel HD Graphics 5500 - 2016

Posted: Tue Jan 26, 2016 5:26 pm
by GeneBenson
Hi Chek,

Have you tried disabling compositing under Settings -> Window Manager Tweaks?

Re: Video Tearing Intel HD Graphics 5500 - 2016

Posted: Tue Jan 26, 2016 10:11 pm
by kevinthefixer
GeneBenson wrote:Hi Chek,

Have you tried disabling compositing under Settings -> Window Manager Tweaks?
If that doesn't work, and you can't find any other simple software tweak, you might consider a decent graphics card. You don't need to spend hundreds on one to get a large improvement over your onboard Intel graphics.

Re: Video Tearing Intel HD Graphics 5500 - 2016

Posted: Wed Jan 27, 2016 12:34 am
by Chek
GeneBenson wrote:Hi Chek,

Have you tried disabling compositing under Settings -> Window Manager Tweaks?
Hi there, thanks i will try that.

Re: Video Tearing Intel HD Graphics 5500 - 2016

Posted: Wed Jan 27, 2016 3:15 pm
by Chek
Hi there,

Changing the desk setting didn't work. also if metacity was chosen it caused other issues.

I have 2 installs of mint, one on my gigabyte brix and one on my thinkentre m58p, both have tearing.

I can force the tearing by scrolling quickly on a non maximized browser window. This problem occurs on both computers. Also tearing on both systems during video playback

I have installed LMDE2 because it looks easy enough for my brother to use and not screw up, also I can assist him with his computer challenges.

Everything on and about LMDE 2 is great, except the video tearing.

Formerly i used PCLOS and Gentoo without these issues.

I enjoy a puzzle, so please help me with the mint slang...
- why does drivers show unloaded in both of the outputs for inxi -Fxz?

Code: Select all

htpc@htpc-w1 ~ $  inxi -Fxz
System:    Host: htpc-w1 Kernel: 3.16.0-4-amd64 x86_64 (64 bit gcc: 4.8.4) Desktop: MATE 1.12.0 (Gtk 3.14.5+4) 
           Distro: LinuxMint 2 betsy 
Machine:   System: LENOVO product: 7220RU6 v: ThinkCentre M58p
           Mobo: LENOVO model: LENOVO Bios: LENOVO v: 5CKT46AUS date: 03/20/2009
CPU:       Dual core Intel Core2 Duo E8400 (-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) bmips: 11969 
           Clock Speeds: 1: 2000 MHz 2: 2000 MHz
Graphics:  Card: NVIDIA GT218 [GeForce 210] bus-ID: 01:00.0
           Display Server: X.Org 1.16.4 drivers: nouveau (unloaded: fbdev,vesa) Resolution: 1360x768@60.02hz
           GLX Renderer: Gallium 0.4 on NVA8 GLX Version: 3.0 Mesa 10.3.2 Direct Rendering: Yes
Audio:     Card-1 Creative Labs CA0106 Soundblaster driver: snd_ca0106 port: 3000 bus-ID: 11:00.0 
           Card-2 Intel 82801JD/DO (ICH10 Family) HD Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0 
           Card-3 NVIDIA High Definition Audio Controller driver: snd_hda_intel bus-ID: 01:00.1 
           Sound: Advanced Linux Sound Architecture v: k3.16.0-4-amd64
Network:   Card: Intel 82567LM-3 Gigabit Network Connection driver: e1000e v: 2.3.2-k port: 1820 bus-ID: 00:19.0
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 4160.8GB (84.1% used) ID-1: /dev/sda model: ST3160815AS size: 160.0GB
           ID-2: /dev/sdb model: ST2000DL003 size: 2000.4GB ID-3: USB /dev/sdg model: BUP_Slim_BK size: 2000.4GB
Partition: ID-1: / size: 50G used: 5.5G (12%) fs: ext4 dev: /dev/sda1 
           ID-2: /home size: 94G used: 22G (24%) fs: ext4 dev: /dev/sda3 
           ID-3: swap-1 size: 4.29GB used: 0.01GB (0%) fs: swap dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 48.0C mobo: N/A gpu: 68.0 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 168 Uptime: 13:53 Memory: 859.5/3804.3MB Init: SysVinit runlevel: 2 Gcc sys: 4.9.2 
           Client: Shell (bash 4.3.301) inxi: 2.1.28

Code: Select all

htpc@htpc-w1 ~ $ lspci
00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 4 Series Chipset PCI Express Root Port (rev 03)
00:03.0 Communication controller: Intel Corporation 4 Series Chipset HECI Controller (rev 03)
00:03.2 IDE interface: Intel Corporation 4 Series Chipset PT IDER Controller (rev 03)
00:03.3 Serial controller: Intel Corporation 4 Series Chipset Serial KT Controller (rev 03)
00:19.0 Ethernet controller: Intel Corporation 82567LM-3 Gigabit Network Connection (rev 02)
00:1a.0 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #5 (rev 02)
00:1a.2 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #6 (rev 02)
00:1a.7 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801JD/DO (ICH10 Family) HD Audio Controller (rev 02)
00:1d.0 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB controller: Intel Corporation 82801JD/DO (ICH10 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev a2)
00:1f.0 ISA bridge: Intel Corporation 82801JDO (ICH10DO) LPC Interface Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801JD/DO (ICH10 Family) SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801JD/DO (ICH10 Family) SMBus Controller (rev 02)
01:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 210] (rev a2)
01:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)
11:00.0 Multimedia audio controller: Creative Labs CA0106 Soundblaster

Re: Video Tearing Intel HD Graphics 5500 - 2016

Posted: Wed Jan 27, 2016 6:28 pm
by Chek
Well I am still playing around with the OS....

No luck with the Intel 5500 But, for the m58p, with the nvidea driver loaded and the tearing is barely noticeable.

Does anyone no where to find an intel driver to install? or if it exists/resides in the system how to force it to load? (i tried in synaptic but it would allow me to do it}

Code: Select all

htpc@htpc-w1 ~ $ inxi -Fxz
System:    Host: htpc-w1 Kernel: 3.16.0-4-amd64 x86_64 (64 bit gcc: 4.8.4) Desktop: MATE 1.12.0 (Gtk 3.14.5+4) 
           Distro: LinuxMint 2 betsy 
Machine:   System: LENOVO product: 7220RU6 v: ThinkCentre M58p
           Mobo: LENOVO model: LENOVO Bios: LENOVO v: 5CKT46AUS date: 03/20/2009
CPU:       Dual core Intel Core2 Duo E8400 (-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) bmips: 11970 
           Clock Speeds: 1: 2000 MHz 2: 2000 MHz
Graphics:  Card: NVIDIA GT218 [GeForce 210] bus-ID: 01:00.0
           Display Server: X.Org 1.16.4 driver: nvidia Resolution: 1360x768@60.02hz
           GLX Renderer: GeForce 210/PCIe/SSE2 GLX Version: 3.3.0 NVIDIA 340.96 Direct Rendering: Yes

Re: Video Tearing Intel HD Graphics 5500 - 2016

Posted: Wed Jan 27, 2016 11:04 pm
by kevinthefixer
The unloaded drivers are the generic ones that work with just about any hardware. They are very limited though, used usually just to get a "real" one set up. IIRC Vesa is limited to 640x480.

You might try Intel's website for a driver. Do a lot of reading before you try installing it though.

You also might consider switching to the Linux Mint main edition. It looks much like LMDE2, but is based on Ubuntu rather than Debian, and includes a "driver manager" for situations like this.

Re: Video Tearing Intel HD Graphics 5500 - 2016

Posted: Thu Jan 28, 2016 3:00 pm
by Chek
Thanks for the info i appreciate it.