postgresql-9.4 installation warning - ID_LIKE

Archived topics about LMDE 1 and LMDE 2
Locked
Emerson Prado
Level 2
Level 2
Posts: 50
Joined: Thu Nov 04, 2010 1:42 pm

postgresql-9.4 installation warning - ID_LIKE

Post by Emerson Prado »

Hi all,
I installed postgresql-9.4 in my LMDE installation, and got warnings about an environment variable not set, possibly related to a previous warning about unknown distribution:

Code: Select all

Configurando postgresql-common (165) ...
supported-versions: WARNING! Unknown distribution: linuxmint
/usr/share/postgresql-common/supported-versions: 64: /usr/share/postgresql-common/supported-versions: ID_LIKE: parameter not set
/usr/share/postgresql-common/supported-versions: 67: /usr/share/postgresql-common/supported-versions: ID_LIKE: parameter not set
Please submit this as a bug report to your distribution.
"Configurando" is Portuguese for "Configuring", what seems obvious, tho...
Apparently, the ID_LIKE variable depends on the distro, but Mint is not known to PostgreSQL. I'd think it should be dealt within PostreSQL code, but the warnings instruct to contact the distribution instead, so here I am.
Is this something that a bug should be reported?

My environment: LMDE 2 Betsy - Kernel 3.16.0-4-amd64

Thanks,
Emerson

Emerson Prado
Level 2
Level 2
Posts: 50
Joined: Thu Nov 04, 2010 1:42 pm

Re: postgresql-9.4 installation warning - ID_LIKE

Post by Emerson Prado »

Update: there is already a bug report:
https://bugs.launchpad.net/linuxmint/+bug/991734
Not much attention, tho. Should we report elsewhere?
Thanks,
Emerson

bigbenaugust
Level 3
Level 3
Posts: 106
Joined: Wed Dec 07, 2011 2:46 pm
Location: the 919

Re: postgresql-9.4 installation warning - ID_LIKE

Post by bigbenaugust »

Check the /etc/os-release file?

https://www.freedesktop.org/software/sy ... lease.html

Maybe it needs a line like:

Code: Select all

ID_LIKE=Debian
?
--Ben

Locked

Return to “LMDE Archive”