User session crashing frequently (MATE + fglrx)

Archived topics about LMDE 1 and LMDE 2
Locked
pioruns
Level 1
Level 1
Posts: 21
Joined: Tue Mar 17, 2015 4:25 pm

User session crashing frequently (MATE + fglrx)

Post by pioruns »

Hello,

I am using LMDE 2 Betsy with MATE, installed from fresh less than a month ago. No repositories have been added or changed, however, I allowed for all updates from level1 to level5 to be included. I also installed fglrx driver for AMD APU. Everything is working fine, except for random crashes when using desktop environment. Last one just happened when I had focus on Firefox browser, I clicked something and I was instantly logged off, screen flickered for 5 seconds and I was asked to log in again.

I am attaching last lines from all various logs. I will appreciate any help locating source of this problem so I can fill report of a bug.

System info:

Code: Select all

$ inxi -Fxz
System:    Host: probookmint Kernel: 3.16.0-4-amd64 x86_64 (64 bit gcc: 4.8.4) 
           Desktop: MATE 1.12.0 (Gtk 3.14.5+4) Distro: LinuxMint 2 betsy 
Machine:   System: Hewlett-Packard product: HP ProBook 4545s v: A1019D1103
           Mobo: Hewlett-Packard model: 17EA v: KBC Version 54.20
           Bios: Hewlett-Packard v: 68CPD Ver. F.61 date: 07/22/2015
CPU:       Quad core AMD A8-4500M APU with Radeon HD Graphics (-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 15172 
           Clock Speeds: 1: 1400 MHz 2: 1400 MHz 3: 1900 MHz 4: 1400 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Trinity [Radeon HD 7640G] bus-ID: 00:01.0
           Display Server: X.Org 1.16.4 driver: fglrx Resolution: 1366x768@59.99hz
           GLX Renderer: AMD Radeon HD 7640G GLX Version: 4.5.13399 - CPC 15.201.1151 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller driver: snd_hda_intel bus-ID: 00:14.2 
           Card-2 Advanced Micro Devices [AMD/ATI] Trinity HDMI Audio Controller 
           driver: snd_hda_intel bus-ID: 00:01.1 
           Sound: Advanced Linux Sound Architecture v: k3.16.0-4-amd64
Network:   Card-1: Ralink RT3290 Wireless 802.11n 1T/1R PCIe driver: rt2800pci v: 2.3.0 bus-ID: 03:00.0
           IF: wlan0 state: up mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 4000 bus-ID: 01:00.0
           IF: eth0 state: down mac: <filter>
Drives:    HDD Total Size: 240.1GB (9.3% used) ID-1: /dev/sda model: SanDisk_SDSSDA24 size: 240.1GB
Partition: ID-1: / size: 35G used: 14G (40%) fs: ext4 dev: /dev/sda4 
           ID-2: swap-1 size: 8.59GB used: 0.00GB (0%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 48.4C mobo: 0.0C gpu: 45.00C 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 166 Uptime: 2:28 Memory: 915.9/7387.0MB Init: SysVinit runlevel: 2 Gcc sys: 4.9.2 
           Client: Shell (bash 4.3.301) inxi: 2.1.28
Attachments
logs.7z
compressed user logs
(17.94 KiB) Downloaded 11 times
System: LMDE AMD64
Hardware: HP ProBook 4545s
AMD A8-4500M APU, 8GB RAM
SanDisk SSD PLUS 240GB

User avatar
austin.texas
Level 20
Level 20
Posts: 12047
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: User session crashing frequently (MATE + fglrx)

Post by austin.texas »

Check to see if you have the same problems when logged in as a different user.
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

pioruns
Level 1
Level 1
Posts: 21
Joined: Tue Mar 17, 2015 4:25 pm

Re: User session crashing frequently (MATE + fglrx)

Post by pioruns »

Thanks, I will try that. Firstly I will wait until problem occur again on current profile, I will collect more logs; once this is done, I will create new profile. Do you have any more suggestions? Some of these logs indicate this could be problem with X server (Xorg), what you think?

EDIT: My notebook just freezed, without logging out, just frozen screen and frozen mouse cursor. I could not do anything. CTRL+ALT+Backspace didn't work, neither did Sys Rq combination. Nothing in the logs :roll:
System: LMDE AMD64
Hardware: HP ProBook 4545s
AMD A8-4500M APU, 8GB RAM
SanDisk SSD PLUS 240GB

Locked

Return to “LMDE Archive”