[SOLVED] Chromium 52 fails to start (material_design_controller error)

Archived topics about LMDE 1 and LMDE 2
Level 1
Level 1
Posts: 2
Joined: Tue Aug 02, 2016 9:56 am

[SOLVED] Chromium 52 fails to start (material_design_controller error)

Post by TomWed »


yesterday Chromium 52 appeared in Debian stabIe, and I upgraded Chromium on my LMDE2 laptop from version 51 to 52. After that it did not start, and when started from a terminal I got a list of messages beginning with "FATAL:material_design_controller.cc(69)] Check failed:", followed by about ten lines with numbers, and an exit message. I can't reproduce this at the moment because I downgraded Chromium to version 51, what worked and now works again fine. But when necessary I can upgrade Chromium again and post the complete messages. On the web I found very few stuff about "material design", it seems to be a special thing in Chromium code. Is there a solution or workaround, or ist this a real bug in Chromium?

The system is a full up-to-date LMDE2 64-bit (German localized) with Cinnamon 3.06, fresh installed 2 weeks ago from the original ISO, but on old hardware (7-years-old Acer laptop, CPU Celeron 575 with Intel graphics). The stubborn Chromium version is 52.0.2743.82-1~deb8u1.

EDIT1: I have Openbox on this computer. Under Openbox, Chromium52 can be launched without problems. Opera39 (same browser engine als Chromium) has the same behaviour, with similar error messages when launched under Cinnamon. Problem with Cinnamon?

EDIT2: List of messages when Chromium52 is launched:

Code: Select all

tom@eule ~ $ chromium
[10552:10552:0802/221230:FATAL:material_design_controller.cc(69)] Check failed: is_mode_initialized_. 
#0 0x7f7168ffb1de <unknown>
#1 0x7f716900ec8b <unknown>
#2 0x7f71694e52c8 <unknown>
#3 0x7f716c05bd11 <unknown>
#4 0x7f7167847245 g_closure_invoke
#5 0x7f7167859272 <unknown>
#6 0x7f7167861778 g_signal_emit_valist
#7 0x7f71678619df g_signal_emit
#8 0x7f716784b99d <unknown>
#9 0x7f716784ddb1 g_object_notify
#10 0x7f7162408571 <unknown>
#11 0x7f716240b11e gtk_settings_set_string_property
#12 0x7f7159ca8887 Oxygen::QtSettings::loadKdeIcons()
#13 0x7f7159caa690 Oxygen::QtSettings::initialize()
#14 0x7f7159cc82e1 Oxygen::Style::initialize()
#15 0x7f7159cf70a8 Oxygen::StyleWrapper::instanceInit()
#16 0x7f7167869079 g_type_create_instance
#17 0x7f716784c837 <unknown>
#18 0x7f716784e22d g_object_newv
#19 0x7f716784e9c4 g_object_new
#20 0x7f7159cae1ba Oxygen::RCStyle::createStyle()
#21 0x7f71623e79d5 <unknown>
#22 0x7f71623eb857 gtk_rc_get_style
#23 0x7f71624bde50 <unknown>
#24 0x7f71624be052 gtk_widget_realize
#25 0x7f716c05f5cc <unknown>
#26 0x7f716c05be27 <unknown>
#27 0x7f716c05bdcb <unknown>
#28 0x7f7168dd428a <unknown>
#29 0x7f716b9a0a6f <unknown>
#30 0x7f716b75f1e5 <unknown>
#31 0x7f716b75ed6a <unknown>
#32 0x7f7168fc875b <unknown>
#33 0x7f7168fc6fd0 <unknown>
#34 0x7f7168b6aeaa ChromeMain
#35 0x7f71610a9b45 __libc_start_main
#36 0x7f7168b6ad59 <unknown>

EDIT3: The problem appears also on more recent hardware (3-year-old desktop pc).

Thanks & greetings, Tom
Last edited by TomWed on Wed Aug 10, 2016 7:56 am, edited 1 time in total.
Level 4
Level 4
Posts: 207
Joined: Sat May 24, 2008 5:03 pm

Re: Chromium 52 fails to start (material_design_controller error)

Post by darco »

I just installed it and it is running just fine...

Level 1
Level 1
Posts: 2
Joined: Tue Aug 02, 2016 9:56 am

Chromium-update 52.0.2743.116-1~deb8u1 solved the problem. (no text)

Post by TomWed »


Return to “LMDE Archive”