Page 1 of 1

Thunderbird not sending emails [SOLVED]

Posted: Sat Aug 04, 2018 7:39 am
by Sydney
Thunderbird not sending emails

This might or might not have anything to do with my last repository update that included updating Thunderbird from v. 1.52.8.x to v.

I am unable to send emails. Nothing happens when I try hitting the "send" button, go to "File" -> "send now" or use Ctrl+Return. I get no error message.
Also, the status bar doesn't show any message. It just says "PP privacy status unknown", which it never displayed before.
I do receive emails as usual, but likewise, the status bar does not display anything when getting messages. It just shows "unread:x total:y" in the left corner, but not the usual "no messages to download" or other progress information.
I also noted that when I try to close Thunderbird to restart it, I get an error message saying that Thunderbird is already running and that I should close it or restart the system.

Safe mode solves nothing.
The problem persists no matter which email provider (with different ports) I try.

Settings are unchanged (outgoing server, ports, etc). In fact I grabbed a computer that has an identical OS + Thunderbird set-up (minus some Thunderbird add-ons) and that has not been updated for a month (so runs a Thunderbird v. 1.52.8 ) and I was able to send mails without any problems (with identical settings, obviously).

Linux Mint Debian 64-bit.

As to the timing of this:
Last email I sent without probs was on July 31st.
Updated OS incl. Thunderbird on July 31st also, according to logs BEFORE that last email (but unsure how reliable timestamps are due to various timezones). I might also have updated but not rebooted until the next day or two.
Noticed problem on 3 August. Unable to solve.
Mozilla sent me here as I use repository updates.

Update history attached.

I have no idea how to identify the problem given that Thunderbird just pretends that I don't exist / tell it to send a message and does not communicate (no error message).
Any help would be HUGELY appreciated.
(I think it's pretty obvious that I'm not an expert user, thanks heaps for your patience).

Re: Thunderbird not sending emails

Posted: Sat Aug 04, 2018 8:08 am
by karlchen
Hello, Sydney.

Which "Linux Mint Debian 64-bit" are you using? - LMDE 2 "Betsy" or LMDE 3 "Cindy" (beta)?

About the Thunderbird problem which appeared after you had upgraded from Thunderbird 52.8 to 52.9.1:
  • You have tried the "magic reboot"? Means you have rebooted inbetween, just because sometimes a reboot does solve mysterious problems.
  • Have you tried launching Thunderbird from a terminal window by typing thunderbird and pressing the enter key?
    The idea is that the terminal window might display relevant error messages which point at the potential root cause.
Best regards,

Re: Thunderbird not sending emails

Posted: Sat Aug 04, 2018 8:16 am
by catweazel
Sydney wrote:
Sat Aug 04, 2018 7:39 am
Thunderbird not sending emails
You might try making a backup copy of the Thunderbird directory: /home/$USER/.thunderbird/ to be safe, then renaming the profile folder underneath that, perhaps add an underscore between the dot and default. Setup your account again and see if that works. If it does then there's an issue with your profile, which you can get back by deleting the new profile and renaming the old profile back to what it was.

Alternatively you can try adding a new account and setting up the same mail connection under that new account.

This is to help determine if the problem is in Thunderbird or something else.

Re: Thunderbird not sending emails

Posted: Sat Aug 04, 2018 8:13 pm
by Sydney
O.k. guys, thanks so much for your posts and sorry about the delay in getting back to you, but this is a crazy problem.


sorry about my nonchalance: LMDE 2 "Betsy" 64-bit.

Yes, I have rebooted mult. times without any change in outcome (including safe mode).

Thunderbird from terminal: had to close Thunderbird first. Same problem as described above: when trying to re-launch I got the error message that Thunderbird is already running.
Used "killall thunderbird" in terminal to close it for good. Then started it with the command "thunderbird". Before it launched though, this appeared in the terminal:

[calBackendLoader] Using Thunderbird's builtin libical backend

(nothing else). Thunderbird then started (with a short delay).

I then closed thunderbird again and tried to launch it as su. This worked normally (the [calBackend...] message did not appear).
Using Thunderbird as su, I was obviously not able to access my profile, but set up an account.
Interestingly, the su Thunderbird worked as it should:
Not only was I able to send emails, its status bar also looked and behaved normally (saying e.g. "connected to xxx" when retrieving messages) on the left hand side and showing the progress when sending an email. Additionally, Thunderbird did close when I closed it (no need to use a kill prompt in terminal).

So, maybe not an OS problem but a corrupt profile ?

I went ahead and ducked for similar probs and lo and behold, this guy: ... 749-print/
had a similar problem (albeit on a larger scale and with more output in his terminal).
In his case, it had been an add-on that had caused the issue.
This is the same info that I had found when I had tried to solve the problem yesterday, which is why I had restarted Thunderbird with add-ons disabled yesterday. Twice. Without any luck.
So, contrary to Einstein's logic, I did that exact same thing again, and this time it actually did solve my problem. ???!!!
I tried enabling some add-ons again, it broke, I disabled all of them again, and it remained broken.
Enabled one add-on, restarted, broken. Disabled it, restarted: broken. Repeated the exact same thing. Worked. Next add-on. Same problem. Disabled all add-ons: broken. Frustrating. You get the idea. In addition, as Thunderbird does not close properly, all add-ons that require a restart take about 20 attempts to enable / disable. Including a bunch of computer restarts.
After fiddling with it for hours and trying to find the add-on(s) that are causing the problem I remain clueless. I was not able to reproduce a working Thunderbird again, even with all add-ons disabled. Maybe not an add-on problem after all ? Back at square one.

when I change my profile name as suggested I cannot start Thunderbird ("Your Thunderbird profile cannot be loaded. It may be missing or inaccessible."). So I am not sure that I understood the instructions. However, what I tried earlier on (setting up an account as su with its own profile) I think pretty much demonstrated that something happened with the Thunderbird profile rather than the OS. Also, it is not just the connection (sending mail) but also the status bar issues (when the status bar in the compose window shows properly, then I am able to dispatch an email, see above) and the fact that I cannot close the program unless I kill it.

In theory, I could delete my regular Thunderbird profile and start from scratch, but unfortunately, that is not an option for me as I need to keep my old emails in Thunderbird.

Would anybody know anything about that message that popped up when I started Thunderbird from terminal ?
Any idea where to go from here ? Can I fix my profile ?
Thank you +++

Re: Thunderbird not sending emails

Posted: Sun Aug 05, 2018 6:47 am
by karlchen
Hello, Sydney.

As your experiment of running Thunderbird under the user root account shows, the software Thunderbird itself is not broken. It works.
Hence your conclusion that the problem is inside your normal user's Thunderbird profile seems to hit the nail on the head for sure.

This assumption was what catweazel's advice had been based on all the time.
Seems, however, that you may have misunderstood catweazel's advice partially.
He does not suggest to do away with your current Thunderbird profile. Instead he suggests to rename it.
  • Make sure that Thunderbird is not running any longer.
  • Use the command "ps" to make sure it is not. ps axu | grep -v "grep" | grep "thunderbird" must come back empty.
    Else kill the still loaded thunderbird process.
  • Now rename your Thunderbird profile. mv $HOME/.thunderbird $HOME/.thunderbird.bak
This will permit you to revert this step later on by executing mv $HOME/.thunderbird.bak $HOME/.thunderbird

Now launch Thunderbird. It will appear to Thunderbird as if it ran for the first time. So it will create $HOME/.thunderbird and any sub-folders which it needs. It will also ask you to configure your e-mail account. Do so. Configure one valid e-mail account for receiving and sending e-mails.
In case Thunderbird works correctly using the freshly created profile, then you know, what you should already know. Actually you had told so yourself. The root cause is inside your (current) old profile. And it is very likely one or more of the add-ons, which you use.

Assuming that Thunderbird, using the new profile, works correctly, there are two ways of restoring your current profile without restoring the current issue:
  • Either you keep the freshly created profile and start importing accounts and e-mail inboxes and address books from the renamed Thunderbird profile in $HOME/.thunderbird.bak
  • Or you drop the freshly created profile and rename the old profile back. Then, you launch Thunderbird without loading any add-ons, by executing thunderbird --safe-mode.
    Inside Thunderbird, you disable all add-ons. You may even decide to uninstall them.
    In case Thunderbird works normally again, your issue has been solved.

Re: Thunderbird not sending emails

Posted: Sun Aug 05, 2018 9:34 am
by Sydney
Problem solved. It was an add-on issue after all, but coming to that conclusion was an odyssey for a number of reasons.
Should others have this problem in the future I suggest to take into consideration the following:

1. The function "restart with add-ons disabled" under the "Help" button of Thunderbird did not work properly. The add-ons were marked as "disabled" in the add-ons overview, but parts of them still appeared in the user interface of Thunderbird (in places where they had previously not been) and broke it.
Solution: start Thunderbird in safe mode via terminal (type "thunderbird -safe-mode" or "thunderbird --safe-mode").

2. Disabling add-ons in the add-on list of Thunderbird misleadingly marked them as "disabled" but did not infact disable them properly. Parts still showed up in unusual places in the user interface of Thunderbird and broke it.
Solution: start Thunderbird in safe mode via terminal. Then, in safe mode, go to the list of add-ons and enable, then immediately disable them one by one (just click the buttons), then restart Thunderbird in normal mode. The add-ons will now be truly disabled.

3. Thunderbird did not close properly. Using the "restart" function in the add-on list thus did not work. Killing Thunderbird ("killall" in terminal) killed it, but did not lead to a restart with the add-on enabled or disabled (whichever was chosen).
Solution: start Thunderbird in safe-mode via terminal and enable / disable in safe mode.
RESTART COMPUTER AFTER EACH CHANGE (after disabling or enabling one single add-on) in order to make sure that any problems are not caused once more by Thunderbird not closing properly and / or leaving parts of any add-ons active.

Karl, thanks so much for your help.
I think reading the above explains what happened.
I had figured initially (before even posting here) that this was an add-on problem. The issue was that neither the "restart with add-ons disabled" function nor disabling / enabling single add-ons in the add-on list did what they were pretending to do.: Add-ons would be misleadingly displayed as "disabled" when in fact they were not wholly disabled, and continued to break Thunderbird's functionality. I noticed that parts of them (esp. PGP) still showed up in the Thunderbird UI, but in places where they had not previously been.
Additionally, as mentioned yesterday, Thunderbird would not shut down properly and I was relying on the "kill" command, which - again - did not work properly (? dependencies). The only reliable measure was a computer restart after each tweak.
No wonder I was struggling yesterday and failing to reproduce even the simplest of steps when Thunderbird was displaying wrong information. Crazy.

With regards to the actual add-ons:
Lightning was the one that caused the
[calBackendLoader] Using Thunderbird's builtin libical backend
Since I never used it (it came with Thunderbird originally) it was a no-brainer to get rid of it.
But the add-on that caused my problem of not being able to send emails was in fact Enigmail (PGP) !! This of course is a problem, and I can't believe that I would be the only person having this issue.
Something to do with EFAIL was changed in v.52.9., which might have caused my issues. I'll look into that later.

Thank you also for explaining catweazel's post. It seems that I had in fact understood the instructions, but the problem was that Thunderbird failed to create a new profile after I re-named the old one. It displayed the error message and would not launch at all.
Also, my somewhat less computery workaround to this suggestion would have been to temporarily replace my profile with a native one (that I saved when I first installed Betsy), but it was just easier to try my su-approach.

Again, thanks so much for your help and kind regards,