Audio player problems

Archived topics about LMDE 1 and LMDE 2
Locked
caris_mere
Level 2
Level 2
Posts: 88
Joined: Tue May 20, 2008 8:49 am
Location: Texan in Switzerland

Audio player problems

Post by caris_mere »

I have installed both exaile and decibel-audio-player, and they start up just fine. I add the music, ok. I try to play, they both close immediately.

Here is the output for exaile:

--------------------

(exaile.py:3030): GStreamer-CRITICAL **:
Trying to dispose object "sink", but it still has a parent "bin0".
You need to let the parent manage the object instead of unreffing the object directly.


(exaile.py:3030): GStreamer-CRITICAL **:
Trying to dispose object "gconfaudiosink0", but it still has a parent "bin0".
You need to let the parent manage the object instead of unreffing the object directly.


(exaile.py:3030): GStreamer-CRITICAL **:
Trying to dispose object "rgvolume0", but it still has a parent "bin0".
You need to let the parent manage the object instead of unreffing the object directly.

Traceback (most recent call last):
File "/usr/lib/exaile/xl/gui/main.py", line 1241, in as_play_track
int(track.duration), track.track)
File "/usr/lib/exaile/lib/scrobbler.py", line 149, in now_playing
raise AuthError("Please 'login()' first. (No session available)")
lib.scrobbler.AuthError: Please 'login()' first. (No session available)
Segmentation fault

---------------------

Thanks for the help,
Scott

kei84
Level 3
Level 3
Posts: 182
Joined: Tue Apr 14, 2009 8:54 pm
Location: Brazil
Contact:

Re: Audio player problems

Post by kei84 »

I had the same problem with Exaile.
Exaile has been my default audio player for a while but I wasn't able to make it work on LXDE.
I tried compiling Exaile 3.1.1 and 3.2, but none of them worked. I was able to import the audio files but when I tried to play them, it crashed.

For now, I'm using Banshee.

caris_mere
Level 2
Level 2
Posts: 88
Joined: Tue May 20, 2008 8:49 am
Location: Texan in Switzerland

Re: Audio player problems

Post by caris_mere »

I guess it is a Gstreamer problem, but I don't know how to fix it.

User avatar
Oscar799
Level 19
Level 19
Posts: 9924
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: Audio player problems

Post by Oscar799 »

Thread moved here at OP's request.
oscar799
Forum Admin
Image

User avatar
kwevej
Level 5
Level 5
Posts: 581
Joined: Mon Mar 22, 2010 3:35 pm
Location: Delft / Prague [@ LMDE]

Re: Audio player problems

Post by kwevej »

the same problem here

Code: Select all

(decibel-audio-player.py:7986): GStreamer-CRITICAL **: 
Trying to dispose object "sink", but it still has a parent "audiobin".
You need to let the parent manage the object instead of unreffing the object directly.

craigevil
Level 5
Level 5
Posts: 553
Joined: Wed Sep 15, 2010 6:10 am
Location: down the rabbit hole
Contact:

Re: Audio player problems

Post by craigevil »

Give Aqualung a try.
Aqualung Music Player : http://aqualung.factorial.hu/
Debian Sid KDE4.8.4 Kernel 3.4 Thinkpad R40 CPU Pentium M 1.3MHz RAM 2GB ATI Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi

User avatar
kwevej
Level 5
Level 5
Posts: 581
Joined: Mon Mar 22, 2010 3:35 pm
Location: Delft / Prague [@ LMDE]

Re: Audio player problems

Post by kwevej »

craigevil wrote:Give Aqualung a try.
Aqualung Music Player : http://aqualung.factorial.hu/
Looks like a school project player...

User avatar
kwevej
Level 5
Level 5
Posts: 581
Joined: Mon Mar 22, 2010 3:35 pm
Location: Delft / Prague [@ LMDE]

Re: Audio player problems

Post by kwevej »

bump

timh
Level 3
Level 3
Posts: 133
Joined: Thu Oct 25, 2007 2:36 pm
Location: Spain

Re: Audio player problems

Post by timh »

What's about this Gstreamer error? No help?
I don't want to live with aqualung - I want to go with Pogo a new player from Jendrik
https://launchpad.net/pogo
I like LMDE but this error is awful.
Image

User avatar
kwevej
Level 5
Level 5
Posts: 581
Joined: Mon Mar 22, 2010 3:35 pm
Location: Delft / Prague [@ LMDE]

Re: Audio player problems

Post by kwevej »

uninstall python-gi
http://forums.linuxmint.com/viewtopic.p ... it=+exaile


btw thx for mentioning the Pogo. It looks great. If it'd support last.fm i'd switch to that.

timh
Level 3
Level 3
Posts: 133
Joined: Thu Oct 25, 2007 2:36 pm
Location: Spain

Re: Audio player problems

Post by timh »

kwevej wrote:uninstall python-gi
Thank you very much - now Pogo plays ♫♪ :lol:
Image

Locked

Return to “LMDE Archive”