Page 1 of 1

Firefox 4 Beta

Posted: Mon Sep 20, 2010 5:04 pm
by newfie
Just wondering if there's any way to install upgrade to Firefox 4 Beta from 3.6. Any PPA or the like for this? I know I can just download it from the mozilla site, but I kinda want to do it the "debian" way :)

Re: Firefox 4 Beta

Posted: Mon Sep 20, 2010 5:10 pm
by gotjazz
hrm seeing as the debian way doesn't include an originally branded firefox anyway....
I think you'd have to grab it from mozilla. I think iceweasel in unstable is still at 3.6 too so well....

Also the mint repo is the only debian one i've seen so far that has any firefox at all

Re: Firefox 4 Beta

Posted: Mon Sep 20, 2010 5:19 pm
by tdockery97
I have Iceweasel 4 Beta 5 installed (same as latest Firefox beta). Just add the following to software sources:

http://mozilla.debian.net/packages/ ./

Re: Firefox 4 Beta

Posted: Mon Sep 20, 2010 5:23 pm
by secipolla
If you follow the instructions at http://forums.linuxmint.com/viewtopic.p ... 06#p315606 (after "If you're using LMDE,..."), you have the version from Mozilla and properly integrated in Debian.
I'm using Debian Sid, the only thing that must be changed regarding the above instructions is if you have more than one user in the system. If that's the case, add yourself to group "users"

Code: Select all

sudo adduser <username> users
then instead of

Code: Select all

chown <username>:<username> -R /opt/firefox
use

Code: Select all

chown root:users -R /opt/firefox
and

Code: Select all

chmod -R g+w /opt/firefox/
to give write permissions to the users group and so be able to update Firefox from its built-in updater.
(that's how it is in Debian, should work the same in LMDE).

Image

Uploaded with ImageShack.us

P.S. saw tdockery97's response, but this is an alternative.

Re: Firefox 4 Beta

Posted: Mon Sep 20, 2010 6:34 pm
by craigevil
Come to the dark side, we have cookies. Give Iceweasel a try.

# Iceweasel 4.0 beta packages for Debian http://glandium.org/blog/?p=1032
# deb http://mozilla.debian.net/packages/ ./

# apt-cache policy iceweasel
iceweasel:
Installed: 3.6.10-1
Candidate: 4.0~b5-0
Version table:
4.0~b5-0 0 ( Same as the current Firefox 4 beta )
500 http://mozilla.debian.net/packages/ ./ Packages
*** 3.6.10-1 0 ( Same as the current Firefox release)
101 http://ftp.debian.org/debian/ experimental/main i386 Packages
100 /var/lib/dpkg/status
3.5.13-1 0
500 http://mirrors.kernel.org/debian/ sid/main i386 Packages

All of the above packages are maintianed by the same Debian dev.

If want the version in experimental, you can add to your /etc/apt/preferences
Package: *
Pin: release a=experimental
Pin-Priority: 101

You would still need to do apt-get -t experimental install packagename

Re: Firefox 4 Beta

Posted: Mon Sep 20, 2010 9:49 pm
by newfie
Been using Iceweasel since I read these posts... beta 5 looking good.

Can't wait for the global menu to support non-GTK apps though... firefox + openoffice are so out of place :(

Re: Firefox 4 Beta

Posted: Tue Sep 21, 2010 4:40 pm
by Mike54
Iceweasel 4.0 Beta 5 works a treat. I've been running it for 3-4 days and it's solid as a rock.

Have I mentioned how much I am enjoying LMDE?

Re: Firefox 4 Beta

Posted: Wed Sep 22, 2010 1:27 pm
by burtb08
Works fine for me as well.

Re: Firefox 4 Beta

Posted: Fri Dec 24, 2010 2:38 am
by newfie
Gotta give this a bump.

Ever since Beta 8 has come out, I get this:

Code: Select all

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
  iceweasel: Depends: xulrunner-2.0 (>= 2.0~b8) but it is not going to be installed
I can't be the only one.

Re: Firefox 4 Beta

Posted: Fri Dec 24, 2010 4:37 am
by pollanza
newfie wrote:Gotta give this a bump.

Ever since Beta 8 has come out, I get this:

Code: Select all

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
  iceweasel: Depends: xulrunner-2.0 (>= 2.0~b8) but it is not going to be installed
I can't be the only one.
Nope. I've the same problem. I've also tried to add the debian experimental repo and use sid repo's, but nothing worked so far. Some package is missing and it can't install. The only thing I've found about this problem is here: http://aptosid.com/index.php?name=PNphp ... opic&t=560, but the libcairo2 is not present in the experimental repo. I really want to update to the last beta because I'm using Iceweasel 4b in all my computers and it works really well!

Iceweasel 4 Beta 8

Posted: Sun Dec 26, 2010 5:39 am
by pollanza
A quick recap of the errors that synaptic gives when I try to update Iceweasel to the last beta from the mozilla debian repo:

xulrunner 2.0 b7-2 wont' update to b8-1 because synaptic won't install:
- libmozjs4d 2.0 b8-1: in theory this is marked as upgradeable in synaptic but when I try to update it manually, synaptic want to remove iceweasel and xulrunner and install epiphany (with some gir and libseed0). ???
- libnss3-1d 3.12.9 beta2: this can't be found anywhere;
- libsqlite3-0 v3.7.4: this can't be found anywhere.

Re: Firefox 4 Beta

Posted: Tue Dec 28, 2010 11:33 pm
by newfie
This kinda sucks since I needed to do a reinstall :(

Any possible way to install Beta 7?

Re: Firefox 4 Beta

Posted: Fri Dec 31, 2010 4:16 pm
by Mike54
Anyone got any updates on this?

I've installed LMDE 64 bit and inserted - deb http://mozilla.debian.net/packages/ ./ - into my sources list. When I refresh the Update Manager, I get this error -

W: GPG error: http://mozilla.debian.net ./ Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 85A3D26506C4AE2A

I'm running Iceweasel 4.0 Beta7 on my 32 bit install of LMDE and would like to be able to use it on this box as well.

Re: Firefox 4 Beta

Posted: Fri Dec 31, 2010 5:15 pm
by ShexNivis
Mike54 wrote:Anyone got any updates on this?

I've installed LMDE 64 bit and inserted - deb http://mozilla.debian.net/packages/ ./ - into my sources list. When I refresh the Update Manager, I get this error -

W: GPG error: http://mozilla.debian.net ./ Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 85A3D26506C4AE2A

I'm running Iceweasel 4.0 Beta7 on my 32 bit install of LMDE and would like to be able to use it on this box as well.
You need to add the key.
read how to do it on http://mozilla.debian.net/packages/

Re: Firefox 4 Beta

Posted: Sat Jan 01, 2011 1:29 am
by joutlan
secipolla wrote:If you follow the instructions at http://forums.linuxmint.com/viewtopic.p ... 06#p315606 (after "If you're using LMDE,..."), snip....

Code: Select all

chmod -R g+w /opt/firefox/
to give write permissions to the users group and so be able to update Firefox from its built-in updater.
(that's how it is in Debian, should work the same in LMDE).

snip.....
What do you mean by firefox's "built in" updater? I remember one years ago, but don't see one in 3.6.xxx.....not sure what you mean here. tks

Re: Firefox 4 Beta

Posted: Sat Jan 01, 2011 7:24 am
by Mike54
ShexNivis wrote:You need to add the key.
Thanks for the direction! Sometimes this old dog just needs a reminder or three to get pushed off into the right directyion every now and again.

Re: Iceweasel 4 Beta 8

Posted: Sat Jan 01, 2011 7:47 am
by Mike54
pollanza wrote:A quick recap of the errors that synaptic gives when I try to update Iceweasel to the last beta from the mozilla debian repo:

xulrunner 2.0 b7-2 wont' update to b8-1 because synaptic won't install:
- libmozjs4d 2.0 b8-1: in theory this is marked as upgradeable in synaptic but when I try to update it manually, synaptic want to remove iceweasel and xulrunner and install epiphany (with some gir and libseed0). ???
- libnss3-1d 3.12.9 beta2: this can't be found anywhere;
- libsqlite3-0 v3.7.4: this can't be found anywhere.
I noticed libmozjs4d 2.0 b8-1 was in an update, late yesterday. So there's part of the puzzle.

I found libnss3-1d 3.12.9 beta2 by adding the Experimental repo, as per craigevil's list. But it will not allow me to get it, saying there are broken packages to be fixed.

I scanned through the list and did not see that libsqlite3-0 v3.7.4 was there. Experimental had some 600+ packages it wanted to grab, so I may have missed it.

On my 32 bit install, xulrunner-2.0~b7-2 is installed and the icon shows it is upgradeable, but it will obviously not upgrade, because of all the same issues. Trying to upgrade libmozjs4d.2.0~b7-1 to beta8 pitches the same warning about Iceweasel being removed and replaced with Epiphany.

I guess we wait.