FIREWALL IS OFF??

Archived topics about LMDE 1 and LMDE 2
Locked
specmod0
Level 3
Level 3
Posts: 144
Joined: Sun Sep 19, 2010 1:48 pm

FIREWALL IS OFF??

Post by specmod0 »

Just installed the system....I clicked the firewall? it was off??

am I always logged in as ROOT? it didn't ask me for a password?

Oh great... the next windows........

Edit, Mint windows........

User avatar
bobcollard
Level 5
Level 5
Posts: 708
Joined: Thu Oct 22, 2009 4:44 pm
Location: Springfield, IL

Re: FIREWALL IS OFF??

Post by bobcollard »

Most firewalls are off by default. The reason for this is they interfere with initial connections of wifi, depending on your hardware. Knowing this, turn it on.
Robert Collard, Springfield, IL
Dell Inspiron 1545 Laptop, Intel Duo T3400 CPUs @2.16 Ghz. 4GB RAM
Linux Mint Debian Edition, Xfce 4.6.2 Desktop, 2.6.37-0.dmz.6-liquorix-amd64

randomizer
Level 5
Level 5
Posts: 864
Joined: Mon May 03, 2010 7:15 am

Re: FIREWALL IS OFF??

Post by randomizer »

specmod0 wrote:am I always logged in as ROOT?
If you so choose, yes, otherwise no.

gotjazz
Level 4
Level 4
Posts: 383
Joined: Fri May 28, 2010 11:38 am
Location: Vienna, Austria

Re: FIREWALL IS OFF??

Post by gotjazz »

by default you're not - it didn't ask for a root pw because it was setting up sudo to work with your user account's pw
Image

NCCarlos
Level 1
Level 1
Posts: 15
Joined: Fri Dec 11, 2009 11:31 pm

Re: FIREWALL IS OFF??

Post by NCCarlos »

I've just switched from debian testing, and things are a little different.

If you want to be root, you can

Code: Select all

 su -
same as non-sudo distributions. Just give your user pw and you're root.

But to answer your question: no, the point of sudo seems to me to prevent or discourage users from logging in as root.

Edit: I've just looked at your recent posts and if you want debian, you should run debian.
| Linux Mint 10 | Gnome |

User avatar
Fred
Level 10
Level 10
Posts: 3337
Joined: Fri Jan 04, 2008 11:59 am
Location: NC USA

Re: FIREWALL IS OFF??

Post by Fred »

specmod0 wrote:
Just installed the system....I clicked the firewall? it was off??
As a matter of information, the firewall in Linux can never be "turned off." It is part of the ports infrastructure of the kernel. It must be there and functioning for the kernel to run. What you can turn on and off is the GUI front end to iptables. It is used solely for setting up the firewall and sometimes providing some fancier logging functions.
am I always logged in as ROOT? it didn't ask me for a password?
you are never logged in to an X session as root, unless you have reconfigured the log-in yourself, which is strongly discouraged.
Oh great... the next windows........

Edit, Mint windows........
Those that live in glass houses, (don't know what they are talking about), should refrain from throwing rocks, (shouldn't criticize, as it puts their lack of knowledge on display).

Have a nice day. :-)

Fred
Insanity: Doing the same thing over and over and each time expecting a different result.

Democracy is 2 wolves and a lamb voting on the menu. Liberty is an armed lamb protesting the electoral outcome. A Republic negates the need for an armed protest.

User avatar
Mike54
Level 1
Level 1
Posts: 35
Joined: Fri Jun 25, 2010 6:12 am
Location: Lafayette, Indiana U.S.A.
Contact:

Re: FIREWALL IS OFF??

Post by Mike54 »

NCCarlos wrote:I've just switched from debian testing, and things are a little different.
Edit: I've just looked at your recent posts and if you want debian, you should run debian.
I get the impression he isn't running Debian because he wants to visit here and complain about LMDE being LMDE and not Debian.

NCCarlos
Level 1
Level 1
Posts: 15
Joined: Fri Dec 11, 2009 11:31 pm

Re: FIREWALL IS OFF??

Post by NCCarlos »

Mike54 wrote:I get the impression he isn't running Debian because he wants to visit here and complain about LMDE being LMDE and not Debian.
You're probably right.

It's funny to me, because I have been using debian and lurking around debian user forums for several years and they often get former Ubuntu users complaining that debian should emulate Ubuntu.

Those posters are (at best) kicked to the curb, and rightly so. It's no different than Windows users complaining about Linux. I don't want to discourage anyone but sometimes they just want to be unhappy.
| Linux Mint 10 | Gnome |

indaymadel
Level 2
Level 2
Posts: 84
Joined: Thu Sep 30, 2010 8:57 pm
Contact:

Re: FIREWALL IS OFF??

Post by indaymadel »

specmod0 wrote:Just installed the system....I clicked the firewall? it was off??

am I always logged in as ROOT? it didn't ask me for a password?

Oh great... the next windows........

Edit, Mint windows........
Firewall is off be default as LMDE (like Ubuntu, i guess) have no open ports by default.

Logged in as root? Didn't ask you for a password?
- Running Linux Mint on Live CD/DVD don't ask for a password. If it's installed, it only asked for a sudo password every 15 minutes(if i'm not mistaken). I've read that somewhere in this forum. Unless you change that rule.
Get started building backlinks using my free backlinks collection.

User avatar
thermodynamics4
Level 1
Level 1
Posts: 38
Joined: Thu Sep 09, 2010 3:50 pm
Location: Mexico

Re: FIREWALL IS OFF??

Post by thermodynamics4 »

Fred wrote:specmod0 wrote:
Just installed the system....I clicked the firewall? it was off??
As a matter of information, the firewall in Linux can never be "turned off." It is part of the ports infrastructure of the kernel. It must be there and functioning for the kernel to run. What you can turn on and off is the GUI front end to iptables. It is used solely for setting up the firewall and sometimes providing some fancier logging functions.


Fred
Well said, this kind of people do not help to the movement, is better to say: I don't know anything and I would like to LEARN something about linux, can you please point me in the right direction? Yes I will try to.... be sweet.... Like Bill said in Kill Bill.
Thinkpad Lenovo T400 Core 2 Duo CPU P8400 2.26Mhz. 2G HD 250G. GM 4500 HD.Intel Pro Wireless Link 5100 AGN, Alfa 1000mw. LMDE, BackTrack and XP.

Thinkpad lenovo X61 T7500 2.2Mhz. 3Gb, HD 320G. Wireless 8191SE, Intel 3945, bluetooth. Debian 6.0, LMDE.

vincent
Level 8
Level 8
Posts: 2217
Joined: Tue Feb 09, 2010 4:10 am

Re: FIREWALL IS OFF??

Post by vincent »

NCCarlos wrote:I've just switched from debian testing, and things are a little different.

If you want to be root, you can

Code: Select all

 su -
same as non-sudo distributions. Just give your user pw and you're root.

But to answer your question: no, the point of sudo seems to me to prevent or discourage users from logging in as root.

Edit: I've just looked at your recent posts and if you want debian, you should run debian.
As an aside...You can run sudo on Debian, you just have to add yourself to the sudo group first, e.g.

Code: Select all

su -
usermod -a -G sudo your_username_here
LMDE comes with the ability to sudo by default.

As for the OP, if you want to enable your firewall, it's as easy as

Code: Select all

sudo ufw enable
Debian Testing x64/LM9 Main x64/Windows 7 x64 - LG R580 laptop w/ Intel Core 2 Duo T6500 2.1 GHz, 4 GB DDR2 RAM, Nvidia Geforce G 105M, Ralink rt2860 802.11n, 300 GB WD HD 5400 rpm

Locked

Return to “LMDE Archive”