Language support

Archived topics about LMDE 1 and LMDE 2
Locked
lotech
Level 2
Level 2
Posts: 86
Joined: Thu Jan 24, 2008 10:19 pm

Language support

Post by lotech »

How do I change language support on LMDE, I can't find it in Control Panel, how do I install other language ?
Do you Yahoo ? No I hiccup only ;p
secipolla
Level 4
Level 4
Posts: 355
Joined: Sun Sep 05, 2010 5:19 pm

Re: Language support

Post by secipolla »

The way I know is to open the terminal and

Code: Select all

sudo dpkg-reconfigure locales
This will enable you to choose all supported languages and the default one.
Then you can either login with one of them by choosing it in GDM's screen or run just an application in one of those supported languages.

For Firefox, Thunderbird, LibreOffice (OpenOffice), KDE and maybe others you need to install their respective language packs that you easily find in Synaptic.
lotech
Level 2
Level 2
Posts: 86
Joined: Thu Jan 24, 2008 10:19 pm

Re: Language support

Post by lotech »

Yeah got it thanks, looks familiar I've done that before but forgot.
Do you Yahoo ? No I hiccup only ;p
bluebundy
Level 1
Level 1
Posts: 14
Joined: Thu Nov 12, 2009 2:47 pm

Re: Language support

Post by bluebundy »

Hi,
I have to come back to the same issue.
All measures undertaken so far don't work, my language settings are messed up and it is really frustrating that LMDE/Debian doesn't support any easier way of language setting.

Status: When I open the terminal I get:

Code: Select all

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = "de_DE.utf8",
	LC_ALL = (unset),
	LANG = "de_DE@euro"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale -a shows

Code: Select all

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory
C
POSIX
de_DE.utf8
sudo gedit /etc/environment shows:

Code: Select all

LANGUAGE=de_DE.utf8
LANG=de_DE.utf8
I already did

Code: Select all

sudo dpkg-reconfigure locales
sudo locale-gen
and

Code: Select all

set-language-env
I should be all de_DE.utf8 but it is apparently not. This way I cannot use LMDE. Is there any help for my problem out there? Thanks in advance!
User avatar
linmint777
Level 5
Level 5
Posts: 647
Joined: Thu Nov 26, 2009 11:00 am

Re: Language support

Post by linmint777 »

ultimately you try to reinstall selecting the default language you want, just so I could install debian mint in Spanish.
remember to enable access to internet during installation.
Linux Mint #1 Distro.
http://mintyubuntu.blogspot.com
bluebundy
Level 1
Level 1
Posts: 14
Joined: Thu Nov 12, 2009 2:47 pm

Re: Language support

Post by bluebundy »

Hi,
you mean I should reinstall the whole system? Just for setting the language right? Won't do that. Would rather continue to use Isadora since LMDE is only my testing system. Think the idea of a rolling distribution is good, but the lousy language management is a killer. All files I touched in my home folder with LMDE with German characters were messed up. Why are basic things sometimes so complicated? Is there any GUI or program/package I could use? Don't mean the language packages for thunderbird et al. Thats easy, but setting the language in locales, then writing references in all sorts of different places (and where I obviously forgot some) is messed up.
Brgds Christoph
secipolla
Level 4
Level 4
Posts: 355
Joined: Sun Sep 05, 2010 5:19 pm

Re: Language support

Post by secipolla »

I'm using Debian Sid. I'm no expert on this. What can I say?

- /etc/environment here is empty.
- Unless capitalization makes no difference then there's no de_DE.utf8. /usr/share/i18n/SUPPORTED only lists
de_DE.UTF-8 UTF-8
de_DE ISO-8859-1
de_DE@euro ISO-8859-15
(bold is mine)
As an example, /etc/default/locale here says
# File generated by update-locale
LANG="pt_BR.UTF-8"
LANGUAGE="pt_BR:pt:en"
- I don't have language-env here (it's optional and don't even supports Portuguese).

What have I found that may be useful?

- From /usr/share/doc/locales/README, maybe you could run

Code: Select all

localedef -i de_DE -f UTF-8 de_DE
(read yourself the file mentioned, I have no clue if it's ok to do it)
- From man update-locale (this won't solve your misconfigured locales, only set the default system locale)

Code: Select all

update-locale LANG=de_DE.UTF-8 LANGUAGE
The command above removes definitions for LANGUAGE. To set it to de:en maybe you should run

Code: Select all

update-locale LANG=de_DE.UTF-8 LANGUAGE=de:en
bluebundy
Level 1
Level 1
Posts: 14
Joined: Thu Nov 12, 2009 2:47 pm

Re: Language support

Post by bluebundy »

That's it! Thanks a lot!
I actually changed the settings in

Code: Select all

sudo gedit /etc/environment
to

Code: Select all

LANG=de_DE
LANGUAGE=de_DE.UTF-8
LC_ALL=de_DE.UTF-8
Seems to work now, thanks again!
Is there really no package or GUI that would do this kind of work and also download the language packages for Firefox etc.?
secipolla
Level 4
Level 4
Posts: 355
Joined: Sun Sep 05, 2010 5:19 pm

Re: Language support

Post by secipolla »

In Debian this configuration is made automatically according with your options during installation and can be changed with 'dpkg-reconfigure locales'.
LMDE should have taken care of this too, if it didn't, probably something went wrong during installation or the DVD might have had some flaw.
Maybe language-env only confounded things a bit more. It isn't necessary and isn't a default package in debian, AFAIK.

Regarding Firefox, Thunderbird and OpenOffice, you will have to install the localization packages for them (I think they end with l10n-de). This was one of the things missing in this first release of LMDE and from what I read in the bug reports at launchpad.net ( https://launchpad.net/linuxmint ), automatic installation of those packages may be adressed for the next release.
Locked

Return to “LMDE Archive”