HOW TO: Solve your LMDE audio issues

Archived topics about LMDE 1 and LMDE 2
User avatar
blowtorch
Level 3
Level 3
Posts: 100
Joined: Sun Sep 05, 2010 10:03 pm

Re: HOW TO: Solve your LMDE audio issues

Post by blowtorch »

CDS wrote:I installed LMDE in 2 computers. One is acer aspire netbook. It works the sound using tutorial by blowtorch in this forum. Another is Acer Aspire 4710 notebook. It works the sound with the built-in speaker but it doesn't work with headphone. I tried Linuxmint 10; ubuntu 10.10. All are the same result. Speaker works but headphone doesn't. I tried solution for Ubuntu 9.10 but it doesn't work on Ubuntu version 10.10. Is this problem related to hardware related issue?
Desperately needed help!
ok i have had this problem with my headphone jack as well i used this thread to fix it
http://www.linuxforums.org/forum/coffee ... c9205.html
your fix will be similar but you need to select the one right for your sound chip... i'll try to help a little more later i have to go but this should get you started.
CDS
Level 1
Level 1
Posts: 35
Joined: Tue Mar 09, 2010 11:22 am

Re: HOW TO: Solve your LMDE audio issues

Post by CDS »

Thank you blowtorch for the reply. I will try when I get back home. Right now I am at work. And I will let you know the result.
CDS
Level 1
Level 1
Posts: 35
Joined: Tue Mar 09, 2010 11:22 am

Re: HOW TO: Solve your LMDE audio issues

Post by CDS »

blowtorch wrote:
CDS wrote:I installed LMDE in 2 computers. One is acer aspire netbook. It works the sound using tutorial by blowtorch in this forum. Another is Acer Aspire 4710 notebook. It works the sound with the built-in speaker but it doesn't work with headphone. I tried Linuxmint 10; ubuntu 10.10. All are the same result. Speaker works but headphone doesn't. I tried solution for Ubuntu 9.10 but it doesn't work on Ubuntu version 10.10. Is this problem related to hardware related issue?
Desperately needed help!
ok i have had this problem with my headphone jack as well i used this thread to fix it
http://www.linuxforums.org/forum/coffee ... c9205.html
your fix will be similar but you need to select the one right for your sound chip... i'll try to help a little more later i have to go but this should get you started.
I am not sure what and where to add specific line in the code. My computer and some specific I found out using command from the link:
Machine- Acer aspire notebook 4710
OS: Linuxmint (LMDE)
Codec: Realtek ALC268 ( after command from terminal- head -n 1 /proc/asound/card0/codec*)
Kernel: 2.6.32-5-686
GregKno
Level 1
Level 1
Posts: 1
Joined: Tue Nov 30, 2010 10:39 am

Re: HOW TO: Solve your LMDE audio issues

Post by GregKno »

Thanks. Thats great, now have sound my usb soundcard, but still not from any wine programs like spotify, groovewulrus
User avatar
blowtorch
Level 3
Level 3
Posts: 100
Joined: Sun Sep 05, 2010 10:03 pm

Re: HOW TO: Solve your LMDE audio issues

Post by blowtorch »

CDS wrote: I am not sure what and where to add specific line in the code. My computer and some specific I found out using command from the link:
Machine- Acer aspire notebook 4710
OS: Linuxmint (LMDE)
Codec: Realtek ALC268 ( after command from terminal- head -n 1 /proc/asound/card0/codec*)
Kernel: 2.6.32-5-686
so if you go here you'll find the options for ALC268 http://www.mjmwired.net/kernel/Document ... els.txt#67

then add the line with one of the options from the page above to /etc/modprobe.d/modprobe.conf and reboot until one works probabily "acer" or "acer-dmic" or "acer-aspire"

example of line to add to /etc/modprobe.d/modprobe.conf

Code: Select all

options snd-hda-intel model=acer
User avatar
blowtorch
Level 3
Level 3
Posts: 100
Joined: Sun Sep 05, 2010 10:03 pm

Re: HOW TO: Solve your LMDE audio issues

Post by blowtorch »

GregKno wrote:Thanks. Thats great, now have sound my usb soundcard, but still not from any wine programs like spotify, groovewulrus
you'll need to configure wine to use pulseaudio if i am not mistaken
CDS
Level 1
Level 1
Posts: 35
Joined: Tue Mar 09, 2010 11:22 am

Re: HOW TO: Solve your LMDE audio issues

Post by CDS »

No luck yet. I tried adding "acer" or "acer-dmic" or "acer-aspire" to /etc/modprobe.d/modprobe.conf and reboot. In all the 3 case, there is no choice for headphone in the connector under Sound preference>output>connector.
Back to the wine, how can I modify it to use pulseaudio?
User avatar
kwevej
Level 5
Level 5
Posts: 581
Joined: Mon Mar 22, 2010 3:35 pm
Location: Delft / Prague [@ LMDE]

Re: HOW TO: Solve your LMDE audio issues

Post by kwevej »

CDS wrote:No luck yet. I tried adding "acer" or "acer-dmic" or "acer-aspire" to /etc/modprobe.d/modprobe.conf and reboot. In all the 3 case, there is no choice for headphone in the connector under Sound preference>output>connector.
Back to the wine, how can I modify it to use pulseaudio?
I'd say it's HW issue, but you can try a different OS to see if it's so.
CDS
Level 1
Level 1
Posts: 35
Joined: Tue Mar 09, 2010 11:22 am

Re: HOW TO: Solve your LMDE audio issues

Post by CDS »

It works with Ubuntu 10.04 and Linuxmint 9 and 8. Windows xp also works with the same machine. From Ubuntu 10.10, linuxmint 10 it doesn't work. May be machine specific problem. With Acer aspire netbook, it works with instruction from this forum without any problem. Thanks for the feedback.
User avatar
blowtorch
Level 3
Level 3
Posts: 100
Joined: Sun Sep 05, 2010 10:03 pm

Re: HOW TO: Solve your LMDE audio issues

Post by blowtorch »

CDS wrote:No luck yet. I tried adding "acer" or "acer-dmic" or "acer-aspire" to /etc/modprobe.d/modprobe.conf and reboot. In all the 3 case, there is no choice for headphone in the connector under Sound preference>output>connector.
Back to the wine, how can I modify it to use pulseaudio?

keep trying all the model options related with your sound chip set even if they're not acer. its kind of a tedious thing i struggled with it for a while until i came across the right configuration.
after that you can try again with "probe_mask" and "position_fix" options i needed to add them to my setup to get it to work. example below.

Code: Select all

options snd-hda-intel model=acer probe_mask=1 position_fix=1
User avatar
blowtorch
Level 3
Level 3
Posts: 100
Joined: Sun Sep 05, 2010 10:03 pm

Re: HOW TO: Solve your LMDE audio issues

Post by blowtorch »

CDS wrote:With Acer aspire netbook, it works with instruction from this forum without any problem. Thanks for the feedback.
i'm confused it works? what operating system is giving you problems Ubuntu 10.10/Mint 10 or LMDE?
CDS
Level 1
Level 1
Posts: 35
Joined: Tue Mar 09, 2010 11:22 am

Re: HOW TO: Solve your LMDE audio issues

Post by CDS »

Non working maching is Aspire 4710. It is Notebook.Regarding to headphone sound, I am having problem with this machine on-
1. Ubuntu 10.10
2. Linuxmint 10
3. LMDE

This same machine worked with previous versions of Ubuntu and linuxmint, such as Ubuntu 10.04 and Linuxmint 9.

(Sorry my message was not very clear in the previous post. Another computer that works well with Ubuntu 10.10 and LMDE is netbook computer (Acer Aspire One), a small one. It just works with your instruction)
CDS
Level 1
Level 1
Posts: 35
Joined: Tue Mar 09, 2010 11:22 am

Re: HOW TO: Solve your LMDE audio issues

Post by CDS »

@blowtorch,
Thank you. It works now.
User avatar
kwevej
Level 5
Level 5
Posts: 581
Joined: Mon Mar 22, 2010 3:35 pm
Location: Delft / Prague [@ LMDE]

Re: HOW TO: Solve your LMDE audio issues

Post by kwevej »

CDS: How about opening a new topic about that? It's messy in here.
CDS
Level 1
Level 1
Posts: 35
Joined: Tue Mar 09, 2010 11:22 am

Re: HOW TO: Solve your LMDE audio issues

Post by CDS »

kwevej wrote:CDS: How about opening a new topic about that? It's messy in here.
Acer aspire 4710 Sound Headphone solution confirmation:

Dear kwevej,
My working configuration is as directed by blowtorch at the beginning of this thread. This is how I did exactly:
(Following guide provided by blowtorch):
1. Open terminal and copy and paste the following command-
sudo gedit /etc/asound.conf

Next, the whole code below is copied and pasted to a new popped up window, Save and close the window.Reboot the computer.

pcm.pulse {
type pulse
}
ctl.pulse {
type pulse
}
pcm.!default {
type pulse
}
ctl.!default {
type pulse
}


2. Now I use Romeo. To get to Romeo: Menu>All applications>Administration>Software Sources>Unstable package (Romeo) [checked it]>close....
After this there was software updates.

*(Additional information: Now, I installed Ubuntu 10.10 in another partition. It had updated software a lot and it works without any tweak. Many thanks to community members for their advice to make it work perfectly)
User avatar
kwevej
Level 5
Level 5
Posts: 581
Joined: Mon Mar 22, 2010 3:35 pm
Location: Delft / Prague [@ LMDE]

Re: HOW TO: Solve your LMDE audio issues

Post by kwevej »

Glad it did. Appreciate your description. Now I can imagine how you did it in the full detail and with perfect accuracy ;D
User avatar
Murdock
Level 3
Level 3
Posts: 144
Joined: Fri Apr 02, 2010 11:23 pm
Location: Costa Rica

Re: Solve your LMDE audio issues <<< sticky me

Post by Murdock »

blowtorch wrote:
c7p wrote:Thank you for the post :) , it solved the second problem occured after long time regarding my audio-card :D :D .
I am glad it helped you are one of the many people who have resolved your issue with this simple yet effective solution. The just reaffirms the need for this information to be stickied.
No. INCORPORATED, into the distro..
Pura Vida.
Arenal Botanical Garden
Lake Arenal, Costa Rica
User avatar
blowtorch
Level 3
Level 3
Posts: 100
Joined: Sun Sep 05, 2010 10:03 pm

Re: Solve your LMDE audio issues <<< sticky me

Post by blowtorch »

Murdock wrote:
blowtorch wrote:
c7p wrote:Thank you for the post :) , it solved the second problem occured after long time regarding my audio-card :D :D .
I am glad it helped you are one of the many people who have resolved your issue with this simple yet effective solution. The just reaffirms the need for this information to be stickied.
No. INCORPORATED, into the distro..

What are you trying to say here?
gotjazz
Level 4
Level 4
Posts: 381
Joined: Fri May 28, 2010 11:38 am
Location: Vienna, Austria

Re: Solve your LMDE audio issues <<< sticky me

Post by gotjazz »

blowtorch wrote:

What are you trying to say here?
presumably that it should be fixed? WHich btw it is. I don't know if it is applicable to old installations as I've fixed it on mine ages ago but as of the 201012 iso - at lease according to the release notes - this issue should not arise anymore in new installs.
Now if only I could get the new live-cd to boot :D
Image
jasperlotus
Level 1
Level 1
Posts: 12
Joined: Thu Sep 10, 2009 12:01 am

Re: HOW TO: Solve your LMDE audio issues

Post by jasperlotus »

Hi all,

I've just installed LMDE x64 201012 on my ASUS A42F laptop and there's no sound. Everything seems to be correctly configured but there's no sound at all.

I've put options options snd-hda-intel model=laptop-amic at the end of alsa-base.conf, still no sound :((

Any help and suggestion is greatly appreciated.
Locked

Return to “LMDE Archive”