Mintdesktop 3.22... (Solved)

Archived topics about LMDE 1 and LMDE 2
Locked
tenfoot
Level 6
Level 6
Posts: 1072
Joined: Sun Jun 03, 2007 4:12 am
Location: Waipapa, Bay of Islands, New Zealand

Mintdesktop 3.22... (Solved)

Post by tenfoot »

Using LMDE2919 on a Thinkpad T60.

Did an update today and got the following error message:

Code: Select all

/var/cache/apt/archives/mintdesktop_3.2.2_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Clicked on Details and the following was returned:

Code: Select all

E:/var/cache/apt/archives/mintdesktop_3.2.2_all.deb: there is no script in the new version of the package - giving up
(Reading database ... 185941 files and directories currently installed.)
Preparing to replace mintdesktop 3.2.1 (using .../mintdesktop_3.2.2_all.deb) ...
/var/lib/dpkg/info/mintdesktop.prerm: 32: cannot create /etc/gdm/PostLogin/mintDesktop.tmp: Directory nonexistent
dpkg: warning: subprocess old pre-removal script returned error exit status 2
dpkg - trying script from the new package instead ...
dpkg: error processing /var/cache/apt/archives/mintdesktop_3.2.2_all.deb (--unpack):
 there is no script in the new version of the package - giving up
configured to not write apport reports
                                      Errors were encountered while processing:
Any assistance in how I can update Mintdesktop would be much appreciated.
Last edited by tenfoot on Sat Jan 15, 2011 1:24 am, edited 1 time in total.
zerozero
Level 16
Level 16
Posts: 6477
Joined: Tue Jul 07, 2009 2:29 pm

Re: Mintdesktop 3.22...

Post by zerozero »

from the blog:

http://blog.linuxmint.com/?p=1595
Because of a problem in mintdesktop 3.2.1, you’ll need to run the following commands to ensure a smooth upgrade:

apt update

sudo rm /var/lib/dpkg/info/mintdesktop.prerm

apt install mintdesktop

This hiccup with mintdesktop is fixed in the version you’re upgrading to and a reminiscence of the previous version. Please accept our apologies for this little problem.
Image

[ bliss of ignorance ]
tenfoot
Level 6
Level 6
Posts: 1072
Joined: Sun Jun 03, 2007 4:12 am
Location: Waipapa, Bay of Islands, New Zealand

Re: Mintdesktop 3.22...

Post by tenfoot »

Thank you zerozero. All is now well with my world :)
zerozero
Level 16
Level 16
Posts: 6477
Joined: Tue Jul 07, 2009 2:29 pm

Re: Mintdesktop 3.22... (Solved)

Post by zerozero »

you're welcome :)
Image

[ bliss of ignorance ]
RavanH
Level 2
Level 2
Posts: 53
Joined: Sun Jan 17, 2010 6:24 am

Re: Mintdesktop 3.22...

Post by RavanH »

zerozero wrote:from the blog:

http://blog.linuxmint.com/?p=1595
Because of a problem in mintdesktop 3.2.1, you’ll need to run the following commands to ensure a smooth upgrade:

apt update

sudo rm /var/lib/dpkg/info/mintdesktop.prerm

apt install mintdesktop

This hiccup with mintdesktop is fixed in the version you’re upgrading to and a reminiscence of the previous version. Please accept our apologies for this little problem.
zero, THANK you :)
zerozero
Level 16
Level 16
Posts: 6477
Joined: Tue Jul 07, 2009 2:29 pm

Re: Mintdesktop 3.22... (Solved)

Post by zerozero »

glad it helped you 8)
Image

[ bliss of ignorance ]
kansasnoob
Level 4
Level 4
Posts: 296
Joined: Sun Jul 20, 2008 1:45 pm

Re: Mintdesktop 3.22... (Solved)

Post by kansasnoob »

Far out! I was just trying to decide if I should reinstall LMDE because I started with '201009'. With this resolved I see no need to reinstall using '201012'.

Great forum search tool :D
Pythzor
Level 3
Level 3
Posts: 161
Joined: Fri Jul 09, 2010 7:05 pm

Re: Mintdesktop 3.22... (Solved)

Post by Pythzor »

Thank you, zerozero (I googled first and found this thread).
Intel Core2 Duo, 3.0 GHz, 6 GB ram, 160 GB hdd; Ultimate Edition Oz Unity Star Sapphire (discontinued Ubuntu 14.04 remix that I've been able to upgrade to a 16.04 base); Linux Mint 18.2/Mate.
Locked

Return to “LMDE Archive”