Page 1 of 1

LMDE – with SID (unstable) repos – [solved]

Posted: Thu Mar 03, 2011 2:45 pm
by GeneC
I am relatively new to Linux, (about 6 months). I have been running LMDE-64 bit since it came out and am very happy with it.

I want to experiment and learn.
I just added a 2nd install of LMDE 64 bit to a new partiton. Its a standard installation with all levels of upgrades.

I am going to make a clone to a spare partition for backup. (Its only 10-15 minutes for the fresh install, but a LONG time with all the updates. Several hundred, so I dont want to have to do a fresh install).

My aim is to run this install with not the standard “testing” repos that LMDE is using, but to change to “sid” (unstable) repos. I expect some breaking, but thats ok. I seem to learn best by “fixing” things.

I just changed my sources list and “marked all upgrades” in synaptic, just to see what was going to happen.

There were 310 updates listed, (359MB worth).

I did notice a kernel upgrade (2.6-37-2)

I DID NOT upgrade anything from SID yet. Just checked what was going to happen.

Reason for this post, is that I am looking for any guidance, tips, whatever from expereinced users. :?

Is there anything in the updates that I should avoid?
Anything KNOW to be a problem?
Should I do all the upgrades at once, or maybe hold back on the kernel, and do that later?
I am really interested to hear from others who have done this.


Re: LMDE – with SID (unstable) repos – looking for advice.

Posted: Thu Mar 03, 2011 3:56 pm
by blowtorch
I use sid and love it ... i would however advise you to not use an update manager instead upgrade using apt about once a week

Code: Select all

apt-get update

Code: Select all

apt-get -s upgrade
(-s) simulation so you can see whats going top happen first

if it says that its holding back packages that mean you need to

Code: Select all

apt-get dist-upgrade
you can also -s to simulate the dis-upgrade

things to watch out for ...

when it says it's going to remove packages like "gnome" or "gnome-desktop-environment" or any "xorg" stuff it usually mean a dependency is broken in one of the new upgrades and wants to remove these packages as a result. Obviously if you elect to say 'yes' and remove these packages you're going to bork your system. Solution: wait 24 hours and try again and i bet all the issues will be resolved.

310 updates sound about right btw

Re: LMDE – with SID (unstable) repos – looking for advice.

Posted: Thu Mar 03, 2011 4:05 pm
by GeneC
Thanks Blowtorch

That is the kind of info I was looking for. :)
things to watch out for ...

when it says it's going to remove packages like "gnome" or "gnome-desktop-environment" or any "xorg" stuff it usually mean a dependency is broken in one of the new upgrades and wants to remove these packages as a result. Obviously if you elect to say 'yes' and remove these packages you're going to bork your system. Solution: wait 24 hours and try again and i bet all the issues will be resolved.
Also good info on the
you can also -s to simulate the dis-upgrade
I didnt know about the "-s" switch. That is the main reason that I used synaptic. I just wanted to SEE what was going to be upgraded before I did it.

Looks like I will give it a go.... LOL.
"...Got nothing to fear, but fear itself..."

Will post how I made out...

Re: LMDE – with SID (unstable) repos – looking for advice.

Posted: Thu Mar 03, 2011 4:12 pm
by blowtorch
GeneC wrote:Thanks Blowtorch

Will post how I made out...

Just go for it man, Sid is not as unstable as you may think. It's cutting edge with all the latest packages and has been working quite well for me for some time now. With the new .37 kernel there is no need for these liquorix ones at the moment :)

Re: LMDE – with SID (unstable) repos – looking for advice.

Posted: Thu Mar 03, 2011 4:35 pm
by GeneC
I havent upgraded quite yet.

I just ran the

Code: Select all

sudo apt-get update, then apt-get -s upgrade
I got a few download errors, but I guess that is par for the course. :lol:

Here is the output. I know its a long list, but see any problems?

I see some xorg stuff , but it doesnt say about "removing" anything. Not quite sure how to read it.

P.S. I Do have the Nvidia 195 drivers installed at present. Would that impose any problems? :?:

Code: Select all

gene@zordon ~ $ sudo apt-get update
[sudo] password for gene: 
Ign debian InRelease                         
Hit debian Release.gpg                       
Hit debian Release                           
Ign unstable/updates InRelease                      
Hit debian/upstream amd64 Packages           
Ign unstable/updates Release.gpg                    
Ign unstable InRelease              
Hit debian/import amd64 Packages   
Hit debian/main amd64 Packages     
Ign debian/import TranslationIndex 
Ign debian/main TranslationIndex   
Ign debian/upstream TranslationIndex
Ign unstable/updates Release              
Hit unstable InRelease                         
Hit unstable Release.gpg                      
Hit unstable/main amd64 Packages/DiffIndex     
Ign unstable/updates/contrib TranslationIndex
Ign unstable/updates/main TranslationIndex
Ign unstable/updates/non-free TranslationIndex
Hit unstable Release                
Hit unstable/contrib amd64 Packages/DiffIndex  
Hit unstable/non-free amd64 Packages/DiffIndex 
Ign unstable/contrib TranslationIndex          
Hit unstable/main amd64 Packages/DiffIndex
Hit unstable/main TranslationIndex             
Ign unstable/non-free TranslationIndex                   
Hit unstable/non-free amd64 Packages          
Hit unstable/main TranslationIndex  
Ign unstable/non-free TranslationIndex        
Err unstable/updates/main amd64 Packages            
  404  Not Found [IP: 80]
Err unstable/updates/contrib amd64 Packages
  404  Not Found [IP: 80]
Err unstable/updates/non-free amd64 Packages
  404  Not Found [IP: 80]
Ign unstable/updates/contrib Translation-en_US
Ign unstable/updates/contrib Translation-en
Ign unstable/updates/main Translation-en_US
Ign debian/import Translation-en_US
Ign unstable/updates/main Translation-en  
Ign unstable/updates/non-free Translation-en_US
Ign unstable/updates/non-free Translation-en
Ign debian/import Translation-en   
Ign debian/main Translation-en_US  
Ign debian/main Translation-en
Ign debian/upstream Translation-en_US
Ign debian/upstream Translation-en
Ign unstable/non-free Translation-en_US
Ign unstable/non-free Translation-en
Ign unstable/contrib Translation-en_US
Ign unstable/contrib Translation-en
Ign unstable/non-free Translation-en_US
Ign unstable/non-free Translation-en
W: Failed to fetch  404  Not Found [IP: 80]

W: Failed to fetch  404  Not Found [IP: 80]

W: Failed to fetch  404  Not Found [IP: 80]

E: Some index files failed to download. They have been ignored, or old ones used instead.


gene@zordon ~ $ apt-get -s upgrade
NOTE: This is only a simulation!
      apt-get needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  cpp-4.4 deskbar-applet evolution evolution-common evolution-data-server
  evolution-data-server-common evolution-plugins evolution-webcal g++-4.4
  gcc-4.4 gcc-4.4-base ghostscript ghostscript-x gnome-control-center
  gnome-panel gparted gstreamer0.10-nice gstreamer0.10-plugins-bad gwibber
  libavcodec52 libavformat52 libebackend1.2-0 libegroupwise1.2-13 libevolution
  libgcc1 libgfortran3 libgl1-mesa-dev libgl1-mesa-glx
  libgnome-window-settings1 libgomp1 libgstfarsight0.10-0 libgtkhtml3.14-19
  libnotify0.4-cil librdf0 libslv2-9 libspectre1 libstdc++6 libstdc++6-4.4-dev
  linux-headers-2.6-amd64 linux-image-2.6-amd64 mesa-common-dev mplayer
  python-evolution python-launchpadlib python-uno telepathy-gabble udisks
  uno-libs3 ure xserver-xorg xserver-xorg-core xserver-xorg-input-evdev
  xserver-xorg-input-synaptics xserver-xorg-input-wacom xserver-xorg-video-apm
  xserver-xorg-video-ark xserver-xorg-video-ati xserver-xorg-video-chips
  xserver-xorg-video-cirrus xserver-xorg-video-fbdev xserver-xorg-video-i128
  xserver-xorg-video-i740 xserver-xorg-video-intel xserver-xorg-video-mach64
  xserver-xorg-video-mga xserver-xorg-video-neomagic
  xserver-xorg-video-nouveau xserver-xorg-video-openchrome
  xserver-xorg-video-r128 xserver-xorg-video-radeon
  xserver-xorg-video-rendition xserver-xorg-video-s3
  xserver-xorg-video-s3virge xserver-xorg-video-savage
  xserver-xorg-video-siliconmotion xserver-xorg-video-sis
  xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident
  xserver-xorg-video-tseng xserver-xorg-video-vesa xserver-xorg-video-vmware
The following packages will be upgraded:
  acpid bind9-host binfmt-support binutils busybox bzr capplets-data
  chromium-browser-inspector console-setup consolekit dictionaries-common
  dmsetup dnsutils exim4-config fakeroot firmware-linux-free ghostscript-cups
  gir1.0-gstreamer-0.10 gnome-panel-data grub-common grub-pc gs-common
  gsfonts-x11 gstreamer0.10-tools iso-codes javascript-common kbd
  keyboard-configuration libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap
  libavutil50 libbind9-60 libc-bin libc-dev-bin libc6 libc6-dev libccid
  libck-connector0 libdb4.8 libdevmapper1.02.1 libdjvulibre-text
  libdjvulibre21 libdns69 libdrm-intel1 libdrm-radeon1 libdrm2 libelf1
  libfreetype6 libgadu3 libgc1c2 libgl1-mesa-dri libglu1-mesa
  libgnome-keyring0 libgnutls26 libgphoto2-2 libgphoto2-port0 libgpod-common
  libgpod4 libgstreamer0.10-0 libidn11 libisc62 libisccc60 libisccfg62
  libjs-jquery liblapack3gf liblouis-data liblwres60 liblzo2-2 libmms0
  libmpfr4 libmtp8 libnautilus-extension1 libnm-glib-vpn1 libnm-glib2
  libnm-util1 libpam-ck-connector libpanel-applet2-0 libpango1.0-0
  libpango1.0-common libpcsclite1 libpolkit-agent-1-0 libpolkit-backend-1-0
  libpolkit-gobject-1-0 libpolkit-gtk-1-0 libportaudio2 libpostproc51
  libraptor1 libschroedinger-1.0-0 libsqlite3-0 libswscale0 libtdb1
  libtracker-client-0.8-0 libusbmuxd1 libvlc5 libvlccore4 libwebkit-1.0-2
  libwebkit-1.0-common libwildmidi1 libx11-6 libx11-data libx11-dev
  libx11-xcb1 libxvidcore4 linux-base linux-libc-dev locales
  mobile-broadband-provider-info modemmanager nautilus nautilus-data
  network-manager network-manager-gnome openssh-client os-prober pcscd
  policykit-1 policykit-1-gnome python-bzrlib python-gnomeapplet
  python-gnomedesktop python-gnomekeyring python-lazr.restfulclient
  python-lazr.uri python-mako python-rsvg python-twisted-bin
  python-twisted-core python-twisted-web python-wadllib python-wnck rsyslog
  simple-scan ttf-opensymbol ufraw-batch ufw usbmuxd vlc-data w3m x11-common
  xserver-common xserver-xorg-input-all xserver-xorg-video-all
143 upgraded, 0 newly installed, 0 to remove and 95 not upgraded.
Inst keyboard-configuration [1.68] (1.70 Debian:unstable [all])
Inst console-setup [1.68] (1.70 Debian:unstable [all])
Inst libc6-dev [2.11.2-11] (2.11.2-13 Debian:unstable [amd64]) []
Inst libc-dev-bin [2.11.2-11] (2.11.2-13 Debian:unstable [amd64]) []
Inst linux-libc-dev [2.6.32-30] (2.6.37-2 Debian:unstable [amd64]) []
Inst libc-bin [2.11.2-11] (2.11.2-13 Debian:unstable [amd64]) [libc6:amd64 ]
Conf libc-bin (2.11.2-13 Debian:unstable [amd64]) [libc6:amd64 ]
Inst libc6 [2.11.2-11] (2.11.2-13 Debian:unstable [amd64])
Conf libc6 (2.11.2-13 Debian:unstable [amd64])
Inst libdb4.8 [4.8.30-4] (4.8.30-5 Debian:unstable [amd64])
Conf libdb4.8 (4.8.30-5 Debian:unstable [amd64])
Inst rsyslog [5.7.3-1] (5.7.6-1 Debian:unstable [amd64])
Inst bind9-host [1:9.7.2.dfsg.P3-1.1] (1:9.7.3.dfsg-1 Debian:unstable [amd64]) []
Inst dnsutils [1:9.7.2.dfsg.P3-1.1] (1:9.7.3.dfsg-1 Debian:unstable [amd64]) []
Inst libisc62 [1:9.7.2.dfsg.P3-1.1] (1:9.7.3.dfsg-1 Debian:unstable [amd64]) []
Inst libdns69 [1:9.7.2.dfsg.P3-1.1] (1:9.7.3.dfsg-1 Debian:unstable [amd64]) []
Inst libisccc60 [1:9.7.2.dfsg.P3-1.1] (1:9.7.3.dfsg-1 Debian:unstable [amd64]) []
Inst libisccfg62 [1:9.7.2.dfsg.P3-1.1] (1:9.7.3.dfsg-1 Debian:unstable [amd64]) []
Inst liblwres60 [1:9.7.2.dfsg.P3-1.1] (1:9.7.3.dfsg-1 Debian:unstable [amd64]) []
Inst libbind9-60 [1:9.7.2.dfsg.P3-1.1] (1:9.7.3.dfsg-1 Debian:unstable [amd64])
Inst exim4-config [4.72-6] (4.74-2 Debian:unstable [all])
Inst libgc1c2 [1:6.8-1.2] (1:7.1-7 Debian:unstable [amd64])
Inst libgnutls26 [2.10.4-2] (2.10.5-1 Debian:unstable [amd64])
Inst libidn11 [1.18-1] (1.20-1 Debian:unstable [amd64])
Inst libsqlite3-0 [3.7.4-2] (3.7.5-1 Debian:unstable [amd64])
Inst locales [2.11.2-11] (2.11.2-13 Debian:unstable [all])
Inst openssh-client [1:5.5p1-6] (1:5.8p1-2 Debian:unstable [amd64])
Inst w3m [0.5.3-1] (0.5.3-2 Debian:unstable [amd64])
Inst acpid [1:2.0.8-1] (1:2.0.8-2 Debian:unstable [amd64])
Inst binfmt-support [2.0.2] (2.0.3 Debian:unstable [amd64])
Inst binutils [2.20.1-16] ( Debian:unstable [amd64])
Inst busybox [1:1.17.1-8] (1:1.17.1-10 Debian:unstable [amd64])
Inst python-bzrlib [2.3.0-2] (2.3.0-6 Debian:unstable [amd64])
Inst bzr [2.3.0-2] (2.3.0-6 Debian:unstable [all])
Inst capplets-data [1:2.30.1-2] (1:2.30.1-3 Debian:unstable [all])
Inst chromium-browser-inspector [6.0.472.63~r59945-5] (9.0.597.98~r74359-1 Debian:unstable [all])
Inst libck-connector0 [0.4.3-2] (0.4.4-1 Debian:unstable [amd64])
Inst libpolkit-agent-1-0 [0.96-4] (0.99-3 Debian:unstable [amd64]) []
Inst policykit-1 [0.96-4] (0.99-3 Debian:unstable [amd64]) []
Inst libpolkit-backend-1-0 [0.96-4] (0.99-3 Debian:unstable [amd64]) []
Inst libfreetype6 [2.4.2-2.1] (2.4.4-1 Debian:unstable [amd64]) []
Inst libpango1.0-common [1.28.3-1+squeeze1] (1.28.3-2~sid1 Debian:unstable [all]) []
Inst libx11-data [2:1.4.1-4] (2:1.4.1-5 Debian:unstable [all]) []
Inst libx11-dev [2:1.4.1-4] (2:1.4.1-5 Debian:unstable [amd64]) []
Inst libx11-6 [2:1.4.1-4] (2:1.4.1-5 Debian:unstable [amd64]) []
Inst libpango1.0-0 [1.28.3-1+squeeze1] (1.28.3-2~sid1 Debian:unstable [amd64]) []
Inst policykit-1-gnome [0.96-3] (0.99-2 Debian:unstable [amd64]) []
Inst libpolkit-gtk-1-0 [0.96-3] (0.99-2 Debian:unstable [amd64]) []
Inst libpolkit-gobject-1-0 [0.96-4] (0.99-3 Debian:unstable [amd64])
Inst consolekit [0.4.3-2] (0.4.4-1 Debian:unstable [amd64])
Inst dictionaries-common [1.9.3] (1.10.1 Debian:unstable [all])
Inst libdevmapper1.02.1 [2:1.02.48-5] (2:1.02.63-1 Debian:unstable [amd64]) []
Inst dmsetup [2:1.02.48-5] (2:1.02.63-1 Debian:unstable [amd64])
Inst fakeroot [1.14.5-1] (1.14.5-2 Debian:unstable [amd64])
Inst firmware-linux-free [2.6.32-30] (2.6.37-2 Debian:unstable [all])
Inst ghostscript-cups [8.71~dfsg2-10] (9.01~dfsg-2 Debian:unstable [amd64])
Inst gir1.0-gstreamer-0.10 [0.10.30-1] (0.10.32-4 Debian:unstable [amd64])
Inst gnome-panel-data [2.30.2-3] (2.30.2-4 Debian:unstable [all])
Inst grub-pc [1.98+20100804-14] (1.99~rc1-3 Debian:unstable [amd64]) []
Inst grub-common [1.98+20100804-14] (1.99~rc1-3 Debian:unstable [amd64])
Inst gsfonts-x11 [0.21] (0.22 Debian:unstable [all])
Inst libgstreamer0.10-0 [0.10.30-1] (0.10.32-4 Debian:unstable [amd64])
Inst gstreamer0.10-tools [0.10.30-1] (0.10.32-4 Debian:unstable [amd64])
Inst iso-codes [3.24.1-1] (3.24.2-1 Debian:unstable [all])
Inst javascript-common [7] (8 Debian:unstable [all])
Inst kbd [1.15.2-2] (1.15.2-3 Debian:unstable [amd64])
Inst libaprutil1-ldap [1.3.9+dfsg-5] (1.3.10+dfsg-1 Debian:unstable [amd64]) []
Inst libaprutil1-dbd-sqlite3 [1.3.9+dfsg-5] (1.3.10+dfsg-1 Debian:unstable [amd64]) []
Inst libaprutil1 [1.3.9+dfsg-5] (1.3.10+dfsg-1 Debian:unstable [amd64])
Inst libavutil50 [5:0.6.1+svn20101128-0.2] (5:0.6.1+svn20110227-0.0 Unofficial Multimedia Packages:None/unstable [amd64])
Inst libdjvulibre-text [3.5.23-5] (3.5.23-6 Debian:unstable [amd64])
Inst libdjvulibre21 [3.5.23-5] (3.5.23-6 Debian:unstable [amd64])
Inst libdrm2 [2.4.23-0.0] (2.4.23-3 Debian:unstable [amd64])
Inst libdrm-intel1 [2.4.23-0.0] (2.4.23-3 Debian:unstable [amd64])
Inst libdrm-radeon1 [2.4.23-0.0] (2.4.23-3 Debian:unstable [amd64])
Inst libelf1 [0.148-1] (0.152-1 Debian:unstable [amd64])
Inst libgadu3 [1:1.9.0-2] (1:1.10.0+r1057-1 Debian:unstable [amd64])
Inst libgl1-mesa-dri [7.7.1-4] (7.10-4 Debian:unstable [amd64])
Inst libglu1-mesa [7.7.1-4] (7.10-4 Debian:unstable [amd64])
Inst libgnome-keyring0 [2.30.1-1] (2.32.0-1 Debian:unstable [amd64])
Inst libgphoto2-port0 [2.4.6-3] ( Debian:unstable [amd64])
Inst libgphoto2-2 [2.4.6-3] ( Debian:unstable [amd64])
Inst libgpod4 [0.7.93-0.3] (0.7.95-2 Debian:unstable [amd64])
Inst libgpod-common [0.7.93-0.3] (0.7.95-2 Debian:unstable [amd64])
Inst libjs-jquery [1.5-2] (1.5.1-1 Debian:unstable [all])
Inst liblapack3gf [3.2.1-8] (3.3.0-3 Debian:unstable [amd64])
Inst liblzo2-2 [2.03-2] (2.04-1 Debian:unstable [amd64])
Inst libmms0 [0.6.2-1] (0.6.2-2 Debian:unstable [amd64])
Inst libmpfr4 [3.0.0-2] (3.0.0-7 Debian:unstable [amd64])
Inst libmtp8 [1.0.5-2] (1.0.6-1 Debian:unstable [amd64])
Inst libnautilus-extension1 [2.30.1-2] (2.30.1-3 Debian:unstable [amd64])
Inst libnm-util1 [0.8.1-6] (0.8.2-5 Debian:unstable [amd64])
Inst libnm-glib-vpn1 [0.8.1-6] (0.8.2-5 Debian:unstable [amd64])
Inst libnm-glib2 [0.8.1-6] (0.8.2-5 Debian:unstable [amd64])
Inst libpam-ck-connector [0.4.3-2] (0.4.4-1 Debian:unstable [amd64])
Inst libpanel-applet2-0 [2.30.2-3] (2.30.2-4 Debian:unstable [amd64])
Inst libccid [1.4.1-2] (1.4.2-2 Debian:unstable [amd64])
Inst pcscd [1.6.6-2] (1.6.7-1 Debian:unstable [amd64])
Inst libpcsclite1 [1.6.6-2] (1.6.7-1 Debian:unstable [amd64])
Inst libportaudio2 [19+svn20071022-3.2] (19+svn20101113-3 Debian:unstable [amd64])
Inst libpostproc51 [5:0.6.1+svn20101128-0.2] (5:0.6.1+svn20110227-0.0 Unofficial Multimedia Packages:None/unstable [amd64])
Inst libraptor1 [1.4.21-2] (1.4.21-5 Debian:unstable [amd64])
Inst libschroedinger-1.0-0 [1.0.9-2] (1.0.10-2 Debian:unstable [amd64])
Inst libswscale0 [5:0.6.1+svn20101128-0.2] (5:0.6.1+svn20110227-0.0 Unofficial Multimedia Packages:None/unstable [amd64])
Inst libtdb1 [1.2.1-2+b1] (1.2.9-1 Debian:unstable [amd64])
Inst libtracker-client-0.8-0 [0.8.17-1] (0.8.17-2 Debian:unstable [amd64])
Inst libusbmuxd1 [1.0.4-1] (1.0.6-2 Debian:unstable [amd64])
Inst libvlccore4 [1.1.3-1squeeze2] (1.1.7-2 Debian:unstable [amd64]) []
Inst vlc-data [1.1.3-1squeeze2] (1.1.7-2 Debian:unstable [all])
Inst libvlc5 [1.1.3-1squeeze2] (1.1.7-2 Debian:unstable [amd64])
Inst libwebkit-1.0-common [1.2.6-2] (1.2.7-1 Debian:unstable [all])
Inst libwebkit-1.0-2 [1.2.6-2] (1.2.7-1 Debian:unstable [amd64])
Inst libwildmidi1 [] ( Debian:unstable [amd64])
Inst libx11-xcb1 [2:1.4.1-4] (2:1.4.1-5 Debian:unstable [amd64])
Inst libxvidcore4 [2:1.2.2-0.1] (2:1.3.0-0.0 Unofficial Multimedia Packages:None/unstable [amd64])
Inst linux-base [2.6.32-30] (2.6.37-2 Debian:unstable [all])
Inst mobile-broadband-provider-info [20101106-1] (20110218-1 Debian:unstable [all])
Inst modemmanager [0.4+git.20100624t180933.6e79d15-2] (0.4+git.20110124t203624.00b6cce-2 Debian:unstable [amd64])
Inst nautilus-data [2.30.1-2] (2.30.1-3 Debian:unstable [all])
Inst nautilus [2.30.1-2] (2.30.1-3 Debian:unstable [amd64])
Inst network-manager [0.8.1-6] (0.8.2-5 Debian:unstable [amd64])
Inst network-manager-gnome [0.8.1-2] (0.8.2-3 Debian:unstable [amd64])
Inst python-gnomeapplet [2.30.0-4] (2.30.0-4+b1 Debian:unstable [amd64])
Inst python-gnomedesktop [2.30.0-4] (2.30.0-4+b1 Debian:unstable [amd64])
Inst python-gnomekeyring [2.30.0-4] (2.30.0-4+b1 Debian:unstable [amd64])
Inst python-lazr.uri [1.0.2-2] (1.0.2-4 Debian:unstable [all])
Inst python-wadllib [1.1.4-2] (1.2.0+ds-1 Debian:unstable [all])
Inst python-lazr.restfulclient [0.9.21-1] (0.11.2-1 Debian:unstable [all])
Inst python-mako [0.3.6-1] (0.4.0-1 Debian:unstable [all])
Inst python-rsvg [2.30.0-4] (2.30.0-4+b1 Debian:unstable [amd64])
Inst python-twisted-bin [10.1.0-3] (10.2.0-1 Debian:unstable [amd64])
Inst python-twisted-core [10.1.0-3] (10.2.0-1 Debian:unstable [all])
Inst python-twisted-web [10.1.0-1] (10.2.0-1 Debian:unstable [all])
Inst python-wnck [2.30.0-4] (2.30.0-4+b1 Debian:unstable [amd64])
Inst simple-scan [2.31.1-1] ( Debian:unstable [amd64])
Inst ttf-opensymbol [1:3.2.1-11+squeeze2] (2:2.4.3+LibO3.3.1-1 Debian:unstable [all])
Inst ufraw-batch [0.16-3+b1] (0.18-1 Debian:unstable [amd64])
Inst ufw [0.30.0-2] (0.30.0-3 Debian:unstable [all])
Inst usbmuxd [1.0.4-1] (1.0.6-2 Debian:unstable [amd64])
Inst x11-common [1:7.5+8] (1:7.6+4 Debian:unstable [all])
Inst xserver-common [2:1.7.7-11] (2:1.9.4-3 Debian:unstable [all])
Inst xserver-xorg-input-all [1:7.5+8] (1:7.6+4 Debian:unstable [amd64])
Inst xserver-xorg-video-all [1:7.5+8] (1:7.6+4 Debian:unstable [amd64])
Inst gs-common [8.71~dfsg2-10] (9.01~dfsg-2 Debian:unstable [all])
Inst liblouis-data [2.0.0-1] (2.2.0-1 Debian:unstable [all])
Inst os-prober [1.42] (1.44 Debian:unstable [amd64])
Conf keyboard-configuration (1.70 Debian:unstable [all])
Conf console-setup (1.70 Debian:unstable [all])
Conf libc-dev-bin (2.11.2-13 Debian:unstable [amd64])
Conf linux-libc-dev (2.6.37-2 Debian:unstable [amd64])
Conf libc6-dev (2.11.2-13 Debian:unstable [amd64])
Conf rsyslog (5.7.6-1 Debian:unstable [amd64])
Conf libisc62 (1:9.7.3.dfsg-1 Debian:unstable [amd64])
Conf libdns69 (1:9.7.3.dfsg-1 Debian:unstable [amd64])
Conf libisccc60 (1:9.7.3.dfsg-1 Debian:unstable [amd64])
Conf libisccfg62 (1:9.7.3.dfsg-1 Debian:unstable [amd64])
Conf libbind9-60 (1:9.7.3.dfsg-1 Debian:unstable [amd64])
Conf liblwres60 (1:9.7.3.dfsg-1 Debian:unstable [amd64])
Conf bind9-host (1:9.7.3.dfsg-1 Debian:unstable [amd64])
Conf dnsutils (1:9.7.3.dfsg-1 Debian:unstable [amd64])
Conf exim4-config (4.74-2 Debian:unstable [all])
Conf libgc1c2 (1:7.1-7 Debian:unstable [amd64])
Conf libgnutls26 (2.10.5-1 Debian:unstable [amd64])
Conf libidn11 (1.20-1 Debian:unstable [amd64])
Conf libsqlite3-0 (3.7.5-1 Debian:unstable [amd64])
Conf locales (2.11.2-13 Debian:unstable [all])
Conf openssh-client (1:5.8p1-2 Debian:unstable [amd64])
Conf w3m (0.5.3-2 Debian:unstable [amd64])
Conf acpid (1:2.0.8-2 Debian:unstable [amd64])
Conf binfmt-support (2.0.3 Debian:unstable [amd64])
Conf binutils ( Debian:unstable [amd64])
Conf busybox (1:1.17.1-10 Debian:unstable [amd64])
Conf python-bzrlib (2.3.0-6 Debian:unstable [amd64])
Conf bzr (2.3.0-6 Debian:unstable [all])
Conf capplets-data (1:2.30.1-3 Debian:unstable [all])
Conf chromium-browser-inspector (9.0.597.98~r74359-1 Debian:unstable [all])
Conf libck-connector0 (0.4.4-1 Debian:unstable [amd64])
Conf libpolkit-gobject-1-0 (0.99-3 Debian:unstable [amd64])
Conf libpolkit-agent-1-0 (0.99-3 Debian:unstable [amd64])
Conf libpolkit-backend-1-0 (0.99-3 Debian:unstable [amd64])
Conf libx11-data (2:1.4.1-5 Debian:unstable [all])
Conf libx11-6 (2:1.4.1-5 Debian:unstable [amd64])
Conf consolekit (0.4.4-1 Debian:unstable [amd64])
Conf policykit-1 (0.99-3 Debian:unstable [amd64])
Conf libfreetype6 (2.4.4-1 Debian:unstable [amd64])
Conf libpango1.0-common (1.28.3-2~sid1 Debian:unstable [all])
Conf libx11-dev (2:1.4.1-5 Debian:unstable [amd64])
Conf libpango1.0-0 (1.28.3-2~sid1 Debian:unstable [amd64])
Conf policykit-1-gnome (0.99-2 Debian:unstable [amd64])
Conf libpolkit-gtk-1-0 (0.99-2 Debian:unstable [amd64])
Conf dictionaries-common (1.10.1 Debian:unstable [all])
Conf dmsetup (2:1.02.63-1 Debian:unstable [amd64])
Conf libdevmapper1.02.1 (2:1.02.63-1 Debian:unstable [amd64])
Conf fakeroot (1.14.5-2 Debian:unstable [amd64])
Conf firmware-linux-free (2.6.37-2 Debian:unstable [all])
Conf ghostscript-cups (9.01~dfsg-2 Debian:unstable [amd64])
Conf gir1.0-gstreamer-0.10 (0.10.32-4 Debian:unstable [amd64])
Conf gnome-panel-data (2.30.2-4 Debian:unstable [all])
Conf grub-common (1.99~rc1-3 Debian:unstable [amd64])
Conf grub-pc (1.99~rc1-3 Debian:unstable [amd64])
Conf gsfonts-x11 (0.22 Debian:unstable [all])
Conf libgstreamer0.10-0 (0.10.32-4 Debian:unstable [amd64])
Conf gstreamer0.10-tools (0.10.32-4 Debian:unstable [amd64])
Conf iso-codes (3.24.2-1 Debian:unstable [all])
Conf javascript-common (8 Debian:unstable [all])
Conf kbd (1.15.2-3 Debian:unstable [amd64])
Conf libaprutil1 (1.3.10+dfsg-1 Debian:unstable [amd64])
Conf libaprutil1-ldap (1.3.10+dfsg-1 Debian:unstable [amd64])
Conf libaprutil1-dbd-sqlite3 (1.3.10+dfsg-1 Debian:unstable [amd64])
Conf libavutil50 (5:0.6.1+svn20110227-0.0 Unofficial Multimedia Packages:None/unstable [amd64])
Conf libdjvulibre-text (3.5.23-6 Debian:unstable [amd64])
Conf libdjvulibre21 (3.5.23-6 Debian:unstable [amd64])
Conf libdrm2 (2.4.23-3 Debian:unstable [amd64])
Conf libdrm-intel1 (2.4.23-3 Debian:unstable [amd64])
Conf libdrm-radeon1 (2.4.23-3 Debian:unstable [amd64])
Conf libelf1 (0.152-1 Debian:unstable [amd64])
Conf libgadu3 (1:1.10.0+r1057-1 Debian:unstable [amd64])
Conf libgl1-mesa-dri (7.10-4 Debian:unstable [amd64])
Conf libglu1-mesa (7.10-4 Debian:unstable [amd64])
Conf libgnome-keyring0 (2.32.0-1 Debian:unstable [amd64])
Conf libgphoto2-port0 ( Debian:unstable [amd64])
Conf libgphoto2-2 ( Debian:unstable [amd64])
Conf libgpod4 (0.7.95-2 Debian:unstable [amd64])
Conf libgpod-common (0.7.95-2 Debian:unstable [amd64])
Conf libjs-jquery (1.5.1-1 Debian:unstable [all])
Conf liblapack3gf (3.3.0-3 Debian:unstable [amd64])
Conf liblzo2-2 (2.04-1 Debian:unstable [amd64])
Conf libmms0 (0.6.2-2 Debian:unstable [amd64])
Conf libmpfr4 (3.0.0-7 Debian:unstable [amd64])
Conf libmtp8 (1.0.6-1 Debian:unstable [amd64])
Conf libnautilus-extension1 (2.30.1-3 Debian:unstable [amd64])
Conf libnm-util1 (0.8.2-5 Debian:unstable [amd64])
Conf libnm-glib-vpn1 (0.8.2-5 Debian:unstable [amd64])
Conf libnm-glib2 (0.8.2-5 Debian:unstable [amd64])
Conf libpam-ck-connector (0.4.4-1 Debian:unstable [amd64])
Conf libpanel-applet2-0 (2.30.2-4 Debian:unstable [amd64])
Conf libccid (1.4.2-2 Debian:unstable [amd64])
Conf pcscd (1.6.7-1 Debian:unstable [amd64])
Conf libpcsclite1 (1.6.7-1 Debian:unstable [amd64])
Conf libportaudio2 (19+svn20101113-3 Debian:unstable [amd64])
Conf libpostproc51 (5:0.6.1+svn20110227-0.0 Unofficial Multimedia Packages:None/unstable [amd64])
Conf libraptor1 (1.4.21-5 Debian:unstable [amd64])
Conf libschroedinger-1.0-0 (1.0.10-2 Debian:unstable [amd64])
Conf libswscale0 (5:0.6.1+svn20110227-0.0 Unofficial Multimedia Packages:None/unstable [amd64])
Conf libtdb1 (1.2.9-1 Debian:unstable [amd64])
Conf libtracker-client-0.8-0 (0.8.17-2 Debian:unstable [amd64])
Conf libusbmuxd1 (1.0.6-2 Debian:unstable [amd64])
Conf vlc-data (1.1.7-2 Debian:unstable [all])
Conf libvlccore4 (1.1.7-2 Debian:unstable [amd64])
Conf libvlc5 (1.1.7-2 Debian:unstable [amd64])
Conf libwebkit-1.0-common (1.2.7-1 Debian:unstable [all])
Conf libwebkit-1.0-2 (1.2.7-1 Debian:unstable [amd64])
Conf libwildmidi1 ( Debian:unstable [amd64])
Conf libx11-xcb1 (2:1.4.1-5 Debian:unstable [amd64])
Conf libxvidcore4 (2:1.3.0-0.0 Unofficial Multimedia Packages:None/unstable [amd64])
Conf linux-base (2.6.37-2 Debian:unstable [all])
Conf mobile-broadband-provider-info (20110218-1 Debian:unstable [all])
Conf modemmanager (0.4+git.20110124t203624.00b6cce-2 Debian:unstable [amd64])
Conf nautilus-data (2.30.1-3 Debian:unstable [all])
Conf nautilus (2.30.1-3 Debian:unstable [amd64])
Conf network-manager (0.8.2-5 Debian:unstable [amd64])
Conf network-manager-gnome (0.8.2-3 Debian:unstable [amd64])
Conf python-gnomeapplet (2.30.0-4+b1 Debian:unstable [amd64])
Conf python-gnomedesktop (2.30.0-4+b1 Debian:unstable [amd64])
Conf python-gnomekeyring (2.30.0-4+b1 Debian:unstable [amd64])
Conf python-lazr.uri (1.0.2-4 Debian:unstable [all])
Conf python-wadllib (1.2.0+ds-1 Debian:unstable [all])
Conf python-lazr.restfulclient (0.11.2-1 Debian:unstable [all])
Conf python-mako (0.4.0-1 Debian:unstable [all])
Conf python-rsvg (2.30.0-4+b1 Debian:unstable [amd64])
Conf python-twisted-bin (10.2.0-1 Debian:unstable [amd64])
Conf python-twisted-core (10.2.0-1 Debian:unstable [all])
Conf python-twisted-web (10.2.0-1 Debian:unstable [all])
Conf python-wnck (2.30.0-4+b1 Debian:unstable [amd64])
Conf simple-scan ( Debian:unstable [amd64])
Conf ttf-opensymbol (2:2.4.3+LibO3.3.1-1 Debian:unstable [all])
Conf ufraw-batch (0.18-1 Debian:unstable [amd64])
Conf ufw (0.30.0-3 Debian:unstable [all])
Conf usbmuxd (1.0.6-2 Debian:unstable [amd64])
Conf x11-common (1:7.6+4 Debian:unstable [all])
Conf xserver-common (2:1.9.4-3 Debian:unstable [all])
Conf xserver-xorg-input-all (1:7.6+4 Debian:unstable [amd64])
Conf xserver-xorg-video-all (1:7.6+4 Debian:unstable [amd64])
Conf gs-common (9.01~dfsg-2 Debian:unstable [all])
Conf liblouis-data (2.2.0-1 Debian:unstable [all])
Conf os-prober (1.44 Debian:unstable [amd64])
gene@zordon ~ $ 
Thanks! :mrgreen:

Re: LMDE – with SID (unstable) repos – looking for advice.

Posted: Thu Mar 03, 2011 5:00 pm
by blowtorch
what are the contents of your sources.list? I think its not totally correct because there are no security repos for sid ...

For Sid my sources.list looks something like this (not on my computer right now)

Code: Select all

deb unstable main contrib non-free
deb-src unstable main contrib non-free
deb sid main non-free

try updating that then try with apt again

also looks like you didn't run the apt-get -s dist-upgrade as root
i prefer to su rather than sudo(ing) all the time

Re: LMDE – with SID (unstable) repos – looking for advice.

Posted: Thu Mar 03, 2011 5:06 pm
by GeneC
More info.

I am having trouble decipehring the above output from terminal

I went back into synaptic, to see if it would clarify. (to me) :oops:

from Synaptic I get

Code: Select all

To be removed

Looks like it wants to remove my Nvidia driver.
I guess I should not have even loaded it so early.

It will not download any new Nvidia stuff. So I am thinking I will reboot to the "black screen of death" :)

I gotta research more before I dive in...

Perhaps I should downgrade back to the default LMDE-64 driver that gets loaded for Nvidia. BUT, not sure what it is. "Nouveau"? " NV"?


Blowtorch. I just saw your last post. I will check things out and get back to you... :wink:

Re: LMDE – with SID (unstable) repos – looking for advice.

Posted: Thu Mar 03, 2011 5:17 pm
by GeneC
My current sources list

Code: Select all

deb debian import main
deb unstable main contrib non-free
deb unstable/updates main contrib non-free
deb unstable main non-free
Its the LMDE standard " testing" with "testing" replaced by "unstable". I thought that was the correct way to go.

Re: LMDE – with SID (unstable) repos – looking for advice.

Posted: Thu Mar 03, 2011 5:19 pm
by blowtorch
yes you are right it looks to be removing your nvidia drive and honestly i'm not sure how to handle that other than switching (like you said) back to the free driver before upgrading ...

oh btw its going to remove open office and replace it with libre office

Re: LMDE – with SID (unstable) repos – looking for advice.

Posted: Thu Mar 03, 2011 5:24 pm
by GeneC
Yep! :)

Very good learning experience.

I am going to mull things over, and get back at this again tomorrow.

I just want to say, that I appreciate your help very much. :D
This is quite fun.

I am going to go back to the std driver. I have to research that some. I didn't uninstall any old video driver, so its still there. Just not sure which it is. One step at a time.. Yes, I saw where Libreoffice was going to replace Openoffice. I am using the Libreoffice suite on my other install. Opens faster. :)

Re: LMDE – with SID (unstable) repos – looking for advice.

Posted: Thu Mar 03, 2011 5:25 pm
by blowtorch
GeneC wrote:My current sources list

Code: Select all

deb debian import main
deb unstable main contrib non-free
deb unstable/updates main contrib non-free
deb unstable main non-free
Its the LMDE standard " testing" with "testing" replaced by "unstable". I thought that was the correct way to go.

you've got it right except you need to remove the security repo because it doesn't exist for sid

Re: LMDE – with SID (unstable) repos – looking for advice.

Posted: Thu Mar 03, 2011 9:54 pm
by GeneC

I updated my "sources list" to what "blowtorch" suggested.

Code: Select all

deb debian import main
deb unstable main contrib non-free
deb unstable main non-free
I switched back to the "NV" video driver, as the Nvidia was to be removed with upgrade.


Code: Select all

sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade
After 310 upgrades!
(It took a long time).

I rebooted and got as far as getting a command line.
This kind of threw me, as I didn't expect it and didn't know what to input?

I rebooted in the rescue mode, = same thing.

Rebooted into the old kernel = same thing.

I am thinking that things are going ok, (no black screen of death), but just don't know what to input?

Re: LMDE – with SID (unstable) repos – looking for advice.

Posted: Thu Mar 03, 2011 11:04 pm
by sgosnell
Nvidia graphics cards are a problem. You probably need to reinstall your Nvidia driver. I have an Intel graphics card, and when I changed to Sid there were no issues at all. You may want to use sxmi to do the upgrade. This drops to a console, disables the x windows manager, and does the upgrade in a console, all text-based. You can then go back to the X system or just reboot from the console. It's safer, when you're going to have graphics upgrades.

Re: LMDE – with SID (unstable) repos – looking for advice.

Posted: Thu Mar 03, 2011 11:21 pm
by CiaW
Just FYI - the nv and nouveau are not the nvidia drivers but the 'open source' drivers. Basically it's one or the other -- when you install the Nvidia stuff you should also remove the nouveau-related drivers because they don't play well together. Or, re-install the nouveau and remove the nvidia and related stuff. See the 'how to' on the Nvidia topic for the related files.

Re: LMDE – with SID (unstable) repos – looking for advice.

Posted: Fri Mar 04, 2011 7:35 am
by GeneC
Thanks for the replies sgosnell and CiaW.

I would install the Nvidia, as I know it works. I am using it on this install (the first of two, this one is to be kept on "testing").
I went back to the "NV' driver, on my 2nd LMDE partition (the one updated to "SID") because update said it was going to remove it, so thought it best to go back to default.
I tired the "nouveau" driver, but it crashed. I tried the "nv" driver and it worked, so I left it there and did the full upgrade to "SID".

The problem is I cant get back to a GUI?
I just get back to the console

Code: Select all

gene@zordon ~ $ 
I am too much a novice to know what to enter. I am feeling that is probably just a simple command, but I dont know it. :oops:
Perhaps someone could give me a clue?

Re: LMDE – with SID (unstable) repos – looking for advice.

Posted: Fri Mar 04, 2011 8:08 am
by GeneC


I am back in GUI.

Found the command "startx". Got error messages

Code: Select all

 "..file/home/gene/.xauhority  does not exist.FAILED SERVER ERROR..".
Thought to change from nv to nouveau.
Edited xconfig

rebooted, got into gui, BUT very low resolution, can hardly read the screen. Cant change it to anything better than 720x400, its suppose to be 1680x1050.

Going to try to re-installed Nvidia.

Re: LMDE – with SID (unstable) repos – looking for advice.

Posted: Fri Mar 04, 2011 9:02 am
by GeneC
Frustration is setting in! :roll:

Installed Nvidia drivers using the very same procedure that I used before, that was previously sucessful. (Nvidia 195)

Code: Select all

From synaptic > downloaded

In this order

nvidia-vdpau-driver (195.36.31-6)
(this added these dependicies)
nvidia-kernel-2.6.32-5-amd64 (195.36.31+2+4+2.6.32-24)
nvidia-kernel-common (20100522+1)

(this added these dependicies)
libgl1-nvidia-alternatives (195.36.31-6)
libgl1-nvidia-glx (195.36.31-6)
libglx-nvidia-alternatives (195.36.31-6)
nvidia-glx (195.36.31-6)


Then ran 
sudo nvidia-xconfig (from terminal)

Logged out and back in (to restartred X)
Except logging out and back in did not restart x.

It crashed.
Rebooted, logged in.

ran "startx"

Got =

Code: Select all

Server is already active for display 0

If this server is no longer running, remove /tmp/.xo-lock and start again
1. "Nouveau" works, but only at very low resolutions. I cant read most of the screen, makes it near impossible to use GUI. Any way to improve resolutin with Nouveau? I tried setting with display settings, but 740x400? is the best I can do.

2. Why does the 195 Nvidia driver work before, but not now?

Re: LMDE – with SID (unstable) repos – looking for advice.

Posted: Fri Mar 04, 2011 1:16 pm
by GeneC
Just one last stab at this before I put it aside for a little while and try again later..

To recap

I have changed my repos on my LMDE-64bit install to point to SID (unstable).

Before upgrade I uninstalled the Nvidia 195 driver, because update said it was going to Uninstall them.
(all files uninstalled that I had previously installed for Nvidia).

I tired going back to "Nouveau", but that didnt work.

Tried "nv" that worked.

I did all the update/upgrades with

Code: Select all

sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade
took a LONG time (310 updates) but went ok.

Boot failed.
Changed back to "nouveau" from "nv"
That worked, but very low resolution (720x400, I think it was).
Could not make any better in the "monitors" gui setting.

I KNOW that I had 1680x1050 with the default install drivers. I assume it was the "nouveau" drivers.
There has to be a way to improve resolution.

My xorg.conf

Code: Select all

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildd@barber)  Sun Jun 13 12:08:56 UTC 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"

Section "Files"

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    [b]Driver         "nouveau"[/b]
    VendorName     "NVIDIA Corporation"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
Does anyone know how to change the resolution of the Nouveau driver? I dont see what (if anythng) to change in the xorg.conf. That file is the Nvidia xorg.conf with just the driver section changed from "Nvidia" to "nouveau". This file worked at 1680x1050

Perhaps if someone has a default "nouveau" xorg.conf, they could post it.

Its a shame as LMDE -SID is working fine, except for the video problem.



I found that the Nvidia 195 driver didnt work, because the download did not include the dependnecy = nvidia-glx (195.36.31-6).
If I tried to download that seperately it was going to removed a whole bunch of xorg files, that looked necessary. So I am going to wait on the Nvidia till I find a fix.

Re: LMDE – with SID (unstable) repos – looking for advice.

Posted: Tue Mar 08, 2011 10:55 am
by GeneC

Got everything up and working fine.

(Mar,7) Fresh install of LMDE-64bit with full update of testing repos.

(Mar,8) Changed repos over from testing to SID (unstable)
Ran full update from Synaptic
(331 files - 264mb)

Everything working perfectly.
Using default "nouveau" drivers.

Noticed changes from "testing"
1. New kernel (2.6.37-2). This kernel supports suspend/hibernate on this PC (see signature line), old kernel did not.

2. LibreOffice replaced OpenOffice. (Little apparent difference, except seems to load faster).

3. Chromium updated from 6.0xx to 9.0xx (Sound, HD full-screen videos from You-Tube play, as well as "apple movie trailers") with no extra ad-ins, plugins, or tweaking.

4. Using default "nouveau" video drivers, but get full 1680x1050 resolution, and have enabled "gnome composting". This setup seems to work as well as the Nvidia 195 drivers in my LMDE "testing" install, so will leave as if for now.

I expected breakage, but was very pleased to simply reboot and have everything working perfectly with not even to have to do one tweak.