LMDE BREAKAGES - (Tracking SID!) -{CLOSED}

Archived topics about LMDE 1 and LMDE 2
Locked
User avatar
xircon
Level 5
Level 5
Posts: 768
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: LMDE (Tracking SID, or..) BREAKAGES! - JAN 18

Post by xircon »

Possible fix for the "W95" look:

Code: Select all

nautilus -q && nautilus
Can someone test? Works for me.
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"

GeneC
Level 7
Level 7
Posts: 1598
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: LMDE (Tracking SID, or..) BREAKAGES! - JAN 18

Post by GeneC »

Steve

The 're-install gnome-core' worked for me yesterday, and everything is still ok.

http://forums.linuxmint.com/viewtopic.p ... 08#p528908

User avatar
xircon
Level 5
Level 5
Posts: 768
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: LMDE (Tracking SID, or..) BREAKAGES! - JAN 18

Post by xircon »

Tried that, it just re-installed gnome-core.

Code: Select all

sudo aptitude reinstall gnome-core
The following packages will be REINSTALLED:
  gnome-core 
0 packages upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 26 not upgraded.
Need to get 0 B/20.0 kB of archives. After unpacking 0 B will be used.
(Reading database ... 499614 files and directories currently installed.)
Preparing to replace gnome-core 1:3.0+6 (using .../gnome-core_1%3a3.0+6_amd64.deb) ...
Unpacking replacement gnome-core ...
Setting up gnome-core (1:3.0+6) ...
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"

GeneC
Level 7
Level 7
Posts: 1598
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: LMDE (Tracking SID, or..) BREAKAGES! - JAN 18

Post by GeneC »

Perhaps because of 'aptitude'?

I used apt-get (synaptic)

Code: Select all

Commit Log for Thu Jan 19 10:31:46 2012


Installed the following packages:
app-install-data (2010.11.17)
brasero (3.2.0-3)
brasero-common (3.2.0-3)
empathy (3.2.2-1+b1)
empathy-common (3.2.2-1)
epiphany-browser (3.2.1-2)
epiphany-browser-data (3.2.1-2)
fonts-cantarell (0.0.7-1)
freedesktop-sound-theme (0.7.dfsg-1)
geoclue (0.12.0-4)
geoclue-hostip (0.12.0-4)
geoclue-localnet (0.12.0-4)
geoclue-manual (0.12.0-4)
geoclue-yahoo (0.12.0-4)
gnome-backgrounds (3.2.0-1)
gnome-core (1:3.0+6)
gnome-font-viewer (3.2.1-2)
gnome-icon-theme-extras (3.0.0-3)
gnome-packagekit (3.2.1-2)
gnome-packagekit-data (3.2.1-2)
libbrasero-media3-1 (3.2.0-3)
libcanberra-pulse (0.28-3)
libchamplain-0.12-0 (0.12.1-1)
libchamplain-gtk-0.12-0 (0.12.1-1)
libgeocode-glib0 (0.99.0-1)
libtelepathy-farsight0 (0.0.19-1)
nautilus-sendto-empathy (3.2.2-1+b1)
packagekit (0.7.2-1)
packagekit-backend-aptcc (0.7.2-1)
python-packagekit (0.7.2-1)
telepathy-logger (0.2.12-1)
telepathy-salut (0.6.0-1)

User avatar
xircon
Level 5
Level 5
Posts: 768
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: LMDE (Tracking SID, or..) BREAKAGES! - JAN 18

Post by xircon »

No difference:

Code: Select all

sudo apt-get install --reinstall gnome-core
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 26 not upgraded.
Need to get 0 B/20.0 kB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 499614 files and directories currently installed.)
Preparing to replace gnome-core 1:3.0+6 (using .../gnome-core_1%3a3.0+6_amd64.deb) ...
Unpacking replacement gnome-core ...
Setting up gnome-core (1:3.0+6) ...
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"

GeneC
Level 7
Level 7
Posts: 1598
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: LMDE (Tracking SID, or..) BREAKAGES! - JAN 18

Post by GeneC »

:?:

See if the other packages from my output are installed

Code: Select all

Installed the following packages:
app-install-data (2010.11.17)
brasero (3.2.0-3)
brasero-common (3.2.0-3)
empathy (3.2.2-1+b1)
empathy-common (3.2.2-1)
epiphany-browser (3.2.1-2)
epiphany-browser-data (3.2.1-2)
fonts-cantarell (0.0.7-1)
freedesktop-sound-theme (0.7.dfsg-1)
geoclue (0.12.0-4)
geoclue-hostip (0.12.0-4)
geoclue-localnet (0.12.0-4)
geoclue-manual (0.12.0-4)
geoclue-yahoo (0.12.0-4)
gnome-backgrounds (3.2.0-1)
gnome-core (1:3.0+6)
gnome-font-viewer (3.2.1-2)
gnome-icon-theme-extras (3.0.0-3)
gnome-packagekit (3.2.1-2)
gnome-packagekit-data (3.2.1-2)
libbrasero-media3-1 (3.2.0-3)
libcanberra-pulse (0.28-3)
libchamplain-0.12-0 (0.12.1-1)
libchamplain-gtk-0.12-0 (0.12.1-1)
libgeocode-glib0 (0.99.0-1)
libtelepathy-farsight0 (0.0.19-1)
nautilus-sendto-empathy (3.2.2-1+b1)
packagekit (0.7.2-1)
packagekit-backend-aptcc (0.7.2-1)
python-packagekit (0.7.2-1)
telepathy-logger (0.2.12-1)
telepathy-salut (0.6.0-1)

User avatar
xircon
Level 5
Level 5
Posts: 768
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: LMDE (Tracking SID, or..) BREAKAGES! - JAN 18

Post by xircon »

Nautilus-send to empathy is the only one I didn't have installed.

Code: Select all

sudo apt-get install --reinstall brasero brasero-common empathy empathy-common epiphany-browser epiphany-browser-data fonts-cantarell freedesktop-sound-theme geoclue geoclue-hostip geoclue-localnet geoclue-manual geoclue-yahoo gnome-backgrounds gnome-core gnome-font-viewer gnome-icon-theme-extras gnome-packagekit gnome-packagekit-data libbrasero-media3-1 libcanberra-pulse libchamplain-0.12-0  libchamplain-gtk-0.12-0 libgeocode-glib0 libtelepathy-farsight0 nautilus-sendto-empathy packagekit packagekit-backend-aptcc python-packagekit telepathy-logger telepathy-salut 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  nautilus-sendto-empathy
0 upgraded, 1 newly installed, 30 reinstalled, 0 to remove and 26 not upgraded.
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"

User avatar
Andrew33
Level 4
Level 4
Posts: 462
Joined: Fri Mar 26, 2010 12:58 pm
Location: Maple Heights, Ohio Republic USA
Contact:

Re: LMDE (Tracking SID, or..) BREAKAGES! - JAN 18

Post by Andrew33 »

I have gnome-shell 3.2.1-8 on my laptop for about a week now and all is great....no worries...cheers


Andrew

User avatar
Andrew33
Level 4
Level 4
Posts: 462
Joined: Fri Mar 26, 2010 12:58 pm
Location: Maple Heights, Ohio Republic USA
Contact:

Re: LMDE (Tracking SID, or..) BREAKAGES! - JAN 18

Post by Andrew33 »

Aaahhh:....I do have issues with the new kernel.....lost the "Open as Administrator" option on the drop down when right clicking to tweak in system folders, and the network manager doesn't remember or keep password anymore....anyone have any ideas why this is going on or should I guess that kernel 3.2.1-8 isn't stable yet....cheers


Andrew

User avatar
mockturtl
Level 4
Level 4
Posts: 452
Joined: Sat Oct 09, 2010 8:51 pm

Re: LMDE (Tracking SID, or..) BREAKAGES! - JAN 18

Post by mockturtl »

andrew5859 wrote:Aaahhh:....I do have issues with the new kernel.....lost the "Open as Administrator" option on the drop down when right clicking to tweak in system folders, and the network manager doesn't remember or keep password anymore....anyone have any ideas why this is going on or should I guess that kernel 3.2.1-8 isn't stable yet....cheers
Andrew
Those sound like gnome bugs, not the kernel.

FWIW, network manager has been forgetting my wpa key lately in wheezy (3.1.0-1). I can't test it in sid at the moment.
Image

User avatar
mockturtl
Level 4
Level 4
Posts: 452
Joined: Sat Oct 09, 2010 8:51 pm

Re: LMDE (Tracking SID, or..) BREAKAGES! - JAN 18

Post by mockturtl »

planet.debian.org wrote: >= 2.6.39: security vulnerability
Image

User avatar
Andrew33
Level 4
Level 4
Posts: 462
Joined: Fri Mar 26, 2010 12:58 pm
Location: Maple Heights, Ohio Republic USA
Contact:

Re: LMDE (Tracking SID, or..) BREAKAGES! - JAN 18

Post by Andrew33 »

Thanks turtl....it's rather annoying though.....I had the drop down all configured with gksu through synaptic and it was working, until just a day or two ago after some updates....this is my repo list:


andrew@lmde:~$ inxi -r
Repos: Active apt sources in file: /etc/apt/sources.list
deb http://packages.linuxmint.com/ debian main upstream import backport romeo
deb http://www.debian-multimedia.org sid main non-free
deb http://ftp.us.debian.org/debian/ sid main contrib non-free
deb http://www.debian-multimedia.org wheezy main non-free
deb http://tridex.net/repo/debian/ wheezy main
andrew@lmde:~$

User avatar
mockturtl
Level 4
Level 4
Posts: 452
Joined: Sat Oct 09, 2010 8:51 pm

Re: LMDE (Tracking SID, or..) BREAKAGES! - JAN 18

Post by mockturtl »

andrew5859 wrote: deb http://www.debian-multimedia.org sid main non-free
deb http://www.debian-multimedia.org wheezy main non-free
My apt-fu is not very strong, but I think that will use wheezy packages, which could lead to trouble.
Image

gozer
Level 1
Level 1
Posts: 37
Joined: Mon Nov 26, 2007 1:57 pm

Re: LMDE (Tracking SID, or..) BREAKAGES! - JAN 18

Post by gozer »

Linux 3.2 blew away my (hard-earned) broadcom wireless driver and the old installation process failed to install it again. Back to 3.1 until I can find a fix.

Update: I installed the package 'firmware-b43-lpphy-installer', then ran 'modprobe b43' which got me back up and running. However, it won't autoload at boot.
Debian Testing
g+

User avatar
xircon
Level 5
Level 5
Posts: 768
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: LMDE (Tracking SID, or..) BREAKAGES! - JAN 18

Post by xircon »

Gozer

Have you tried sticking b43 in /etc/modules, always worked for me with "wl"

Steve
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"

gozer
Level 1
Level 1
Posts: 37
Joined: Mon Nov 26, 2007 1:57 pm

Re: LMDE (Tracking SID, or..) BREAKAGES! - JAN 18

Post by gozer »

That's what it needed. Thanks!

I haven't tried on a fresh install, but it seems that installing 'firmware-b43-lpphy-installer', then adding 'b43' to /etc/modules is all that is necessary to get the elusive broadcom wireless running.


Now for dropbox... Ever since 3.2, dropbox has not been loading correctly in the info bar and sidebar in nautilus.

Starting with "dropbox start" results in "To link this computer to a dropbox account, visit...."
Debian Testing
g+

GregE
Level 4
Level 4
Posts: 472
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: Broadcom

Post by GregE »

A bug has been raised and a solution found. It will take a while for the fix to filter through.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=656600

I am just continuing to use 3.1 until it is fixed.

User avatar
xircon
Level 5
Level 5
Posts: 768
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Pidgin

Post by xircon »

Don't use it a lot, but it appears to be broken:

Code: Select all

molly2@n5010 ~ $ pidgin
Gtk-Message: Failed to load module "pk-gtk-module"
Aborted
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"

GeneC
Level 7
Level 7
Posts: 1598
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: LMDE (Tracking SID, or..) BREAKAGES! - JAN 22

Post by GeneC »


User avatar
xircon
Level 5
Level 5
Posts: 768
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: LMDE (Tracking SID, or..) BREAKAGES! - JAN 22

Post by xircon »

I didn't have that key (I do now!), no dice. Uninstalled reinstalled still doesn't work.

:edit: Though I think the pk-gtk-module message is a red herring.

:edit2:

Code: Select all

gdb pidgin
GNU gdb (GDB) 7.3.50.20111117-cvs-debian
Copyright (C) 2011 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/pidgin...Reading symbols from /usr/lib/debug/usr/bin/pidgin...done.
done.
(gdb) run
Starting program: /usr/bin/pidgin 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Gtk-Message: Failed to load module "pk-gtk-module"

Program received signal SIGABRT, Aborted.
0x00007ffff4b10405 in raise () from /lib/x86_64-linux-gnu/libc.so.6
(gdb) 
Appears to be libc.so.6
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"

Locked

Return to “LMDE Archive”