[SOLVED] Problems with first upgrade to package 3

Archived topics about LMDE 1 and LMDE 2
Locked
Anthrogue
Level 2
Level 2
Posts: 76
Joined: Mon Jan 25, 2010 4:41 pm

[SOLVED] Problems with first upgrade to package 3

Post by Anthrogue »

Getting confused after reading and trying to follow instructions at http://blog.linuxmint.com/?p=1836 explicitly.

I have fresh install of LMDE xfce 201109. I saw that changing APT was important via that blog url above. It said "first thing you need to do":
gksu gedit /etc/apt/sources.list
.... Note: Coming out of Mint 8 KDE I was unsure of using terminal to do replacements, and not even realizing this invoked a text editor (since I did not know what gedit was)... So, I used Software Manager, and Software sources, editing the values therein. It reads like this:

Code: Select all

http://debian.linuxmint.com/latest testing main contrib non-free
http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
http://debian.linuxmint.com/latest/multimedia testing main non-free
But now if I refresh the Update Manager I get this:

Code: Select all

W: Failed to fetch http://www.debian.linuxmint.com/latest/multimedia/dists/testing/InRelease  

W: Failed to fetch http://www.debian.linuxmint.com/latest/multimedia/dists/testing/Release.gpg  Could not resolve 'www.debian.linuxmint.com'

W: Some index files failed to download. They have been ignored, or old ones used instead.
Scratching head I open terminal and run gksu gedit /etc/apt/sources.list which creates error:

Code: Select all

(gedit:27095): EggSMClient-WARNING **: Failed to connect to the session manager: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed]
Nevertheless (whatever that means), gedit opens the file - and it reads:

Code: Select all

deb http://packages.linuxmint.com/ debian main upstream import
deb http://debian.linuxmint.com/latest testing main contrib non-free
deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
deb http://www.debian.linuxmint.com/latest/multimedia testing main non-free

deb http://packages.linuxmint.com/ debian main
deb-src http://packages.linuxmint.com/ debian main
So, I don't know if this is correct or why the Update Manager says "failed to fectch.." ect.

Also, after making the APT source changes, but before I tried to refresh the Update Manage (related above), I tried to run the update and got some error that apparently stopped everything:

Code: Select all

]E: /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb: trying to overwrite '/usr/lib/gstreamer-0.10/libgstxvid.so', which is also in package gstreamer0.10-plugins-really-bad 0.10.22-0.1
Don't know how to proceed. And though I have run Mint 8 KDE for some time, the experience was flawless enough to where I did not have to learn so much about Linux "under the hood". Which is to say that I am willing and wanting to learn but stuff that assumes I know very much will fly over my head.
Last edited by Anthrogue on Wed Nov 09, 2011 6:44 pm, edited 1 time in total.
lebigouden
Level 1
Level 1
Posts: 11
Joined: Mon Oct 31, 2011 6:18 am

Re: Problems with first upgrade to package 3

Post by lebigouden »

Hi Anthrogue!


You will find the solution/explanation to your issue here : http://forums.linuxmint.com/viewtopic.php?f=185&t=82346
zerozero
Level 16
Level 16
Posts: 6477
Joined: Tue Jul 07, 2009 2:29 pm

Re: Problems with first upgrade to package 3

Post by zerozero »

hi,
let's go step by step :D
open a terminal, copy&paste

Code: Select all

inxi -r
and show us the output. we'll see the rest after 8)
Image

[ bliss of ignorance ]
Anthrogue
Level 2
Level 2
Posts: 76
Joined: Mon Jan 25, 2010 4:41 pm

Re: Problems with first upgrade to package 3

Post by Anthrogue »

Thanks... here is the inxi -r result

Code: Select all

~ $ inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.linuxmint.com/ debian main upstream import
           deb http://debian.linuxmint.com/latest testing main contrib non-free
           deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
           deb http://debian.linuxmint.com/latest/multimedia testing main non-free
I'm guessing that's correct, since Upgrade Manager now does not report errors seemingly related to APT sources. Most recent update attempt runs into some problem with

Code: Select all

Error
E: /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb: trying to overwrite '/usr/lib/gstreamer-0.10/libgstxvid.so', which is also in package gstreamer0.10-plugins-really-bad 0.10.22-0.1
I tried to then remove the gstreamer thing with a "solution" from another thread somewhere but got apparent error

Code: Select all

~ $ [b]sudo apt-get remove gstreamer0.10-plugins-really-bad[/b]
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  mint-meta-codecs
The following packages will be REMOVED:
  gstreamer0.10-plugins-really-bad
The following packages will be upgraded:
  mint-meta-codecs
1 upgraded, 0 newly installed, 1 to remove and 369 not upgraded.
E: Could not get lock /var/cache/apt/archives/lock - open (11: Resource temporarily unavailable)
E: Unable to lock directory /var/cache/apt/archives/
Trying to run update again, nevertheless hoping whatever was fixed, I then ran into same update error about gstreamer which apparently aborted update. If it is more apropos, I had shifted to another thread with this issue: http://forums.linuxmint.com/viewtopic.p ... 22#p492922
Anthrogue
Level 2
Level 2
Posts: 76
Joined: Mon Jan 25, 2010 4:41 pm

Re: Problems with first upgrade to package 3

Post by Anthrogue »

Thank you zerozero, hard to know logically some stuff in advance. APT sources correct and whatever with gstreamer was removed once I ran command without Update Manager open ;/ ...... Update competed successfully

Solved: also related to thread: http://forums.linuxmint.com/viewtopic.p ... 46#p492927
Gee7
Level 1
Level 1
Posts: 32
Joined: Tue Mar 31, 2009 7:07 am

Re: [SOLVED] Problems with first upgrade to package 3

Post by Gee7 »

I have exactly the same problem.

I have 368 recommendedupdates that won't install, and i get the message:

E: /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_amd64.deb: trying to overwrite '/usr/lib/gstreamer-0.10/libgstxvid.so', which is also in package gstreamer0.10-plugins-really-bad 0.10.22-0.1

Could you clarify how you solved the problem of the gstreamer issue stopping updates please, anthrogue.? I have It would be much appreciated, I could not gather what command you ran, thanks.
Gee7
Level 1
Level 1
Posts: 32
Joined: Tue Mar 31, 2009 7:07 am

Re: [SOLVED] Problems with first upgrade to package 3

Post by Gee7 »

hello anthrogue

i've been backtracking and found the neat solution you used. Thanks for originally posting it.

Solution: in root terminal, type the following command with Update Manager closed:

sudo apt-get remove gstreamer0.10-plugins-really-bad

then open and use Update Manager & everything should work fine.

It seems to be going well, Manager is now in full flow updating my new LMDE xfce.

Best wishes, enjoy your LMDE
Locked

Return to “LMDE Archive”