[SOLVED] building Cinnamon (sid)

Archived topics about LMDE 1 and LMDE 2
User avatar
mockturtl
Level 4
Level 4
Posts: 452
Joined: Sat Oct 09, 2010 8:51 pm

Re: building Cinnamon (sid)

Post by mockturtl »

My bash history will have all the nonsense I installed to get configure happy in sid and lisa -- I'll post that when I get a chance.
Image

o_unico
Level 1
Level 1
Posts: 19
Joined: Sun Dec 05, 2010 10:49 am

Re: building Cinnamon (sid)

Post by o_unico »

Hi.
I followed the steps and installed missing libraries then the cinnamon-session.
When I start the session with cinnamon it shows me some error about gnome-shell and falls back to my default manager (which is Gnome 3).

User avatar
mockturtl
Level 4
Level 4
Posts: 452
Joined: Sat Oct 09, 2010 8:51 pm

Re: building Cinnamon (sid)

Post by mockturtl »

mockturtl wrote:My bash history will have all the nonsense I installed to get configure happy in sid and lisa -- I'll post that when I get a chance.
This should be close:

Lisa:

Code: Select all

$ sudo apt-get install telepathy-devel telepathy-logger  clutter-1.0-tests  gstreamer0.10-plugins-base-dbg  gstreamer0.10-plugins-base gstreamer-0.10 libclutter-1.0-dev libmutter-dev libgtk-3-dev libfolks-dev libfolks-telepathy-dev libcanberra-dev libcanberra-gtk3-dev libgjs-dev libgnome-menu-3-0 gconf2  libstartup-notification0-dev gobject-introspection libpolkit-agent-1-dev libnm-glib-dev libnm-util-dev  libgjs-dev libgnome-menu-3-0 gconf2 libstartup-notification0-dev gobject-introspection libpolkit-agent-1-dev libnm-glib-dev libnm-util-dev  libgjs-dev libgnome-menu-3-0 gconf2 libstartup-notification0-dev gobject-introspection libpolkit-agent-1-dev libnm-glib-dev libnm-util-dev libsoup2.4-dev  libgnome-menu-3-dev libtelepathy-logger-dev libgnome-keyring-dev gconf2 libglib2.0-dev gconf2-common  libgconf2-dev libcroco3-dev libgtk2.0-dev  libgnome-desktop-dev  libgnome-desktop-3-dev  libpulse-dev libecal1.2-dev  libedataserver1.2-dev libedataserverui-3.0-dev
Sid:

Code: Select all

$ sudo apt-get install cdbs debhelper autotools-dev gnome-pkg-tools intltool libgjs-dev gvfs-backends gobject-introspection gir1.2-json-1.0 gnome-bluetooth gsettings-desktop-schemas-dev libcaribou-dev libcroco3-dev libdbus-glib-1-dev libgconf2-dev libgirepository1.0-dev libglib2.0-dev libglib2.0-bin libgnome-bluetooth-dev libgnome-desktop-3-dev libgnome-keyring-dev libgnome-menu-3-dev libgstreamer0.10-dev libgtk-3-dev libgudev-1.0-dev libnm-glib-dev  libstartup-notification0-dev  libmutter-dev  librsvg2-dev libwnck-dev libclutter-1.0-dev libxfixes-dev libxss-dev libpulse-dev libcanberra-dev libecal1.2-dev libedataserver1.2-dev libedataserverui-3.0-dev libfolks-dev libtelepathy-glib-dev libtelepathy-logger-dev libpolkit-agent-1-dev libjson-glib-dev dh-autoreconf libcanberra-gtk3-dev libxt-dev libcanberra-gtk3-module
edit: updated with muffin dependencies
Last edited by mockturtl on Mon Jan 23, 2012 11:38 pm, edited 2 times in total.
Image

zerozero
Level 16
Level 16
Posts: 6480
Joined: Tue Jul 07, 2009 2:29 pm

Re: building Cinnamon (sid)

Post by zerozero »

i was looking around and found this
mrjive - reply
January 19, 2012 at 1:50 pm

Can it be installed on debian or LMDE ?

thanks
mrjive

Edit by Clem: 1.1.4 was successfully installed on Debian Testing.
http://cinnamon.linuxmint.com/?p=99#comment-405
looks good :lol:
and cinnamon-session is already in the mint debian repos
http://packages.linuxmint.com/list.php?release=Debian
Image

[ bliss of ignorance ]

User avatar
mockturtl
Level 4
Level 4
Posts: 452
Joined: Sat Oct 09, 2010 8:51 pm

Re: building Cinnamon (sid)

Post by mockturtl »

Excellent. I haven't had any success with muffin, either. :cry:
Image

GeneC
Level 7
Level 7
Posts: 1599
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: building Cinnamon (sid)

Post by GeneC »

Cinnamon 1.2 just showed up in LMDE, but not yet installable.

From Blog
http://cinnamon.linuxmint.com/?p=119

User avatar
dcihon
Level 4
Level 4
Posts: 286
Joined: Sun Aug 07, 2011 2:15 pm
Location: Florissant, MO USA

Re: building Cinnamon (sid)

Post by dcihon »

Yea, I tried.
Getting this error:

Error: Dependency is not satisfiable: gir1.2-muffin-3.0
Kernel 3.2.0-3-amd64 x86_64 (64 bit) Distro Linux Mint Xfce Edition
ATI - Tracking - Testing

User avatar
xircon
Level 5
Level 5
Posts: 768
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: building Cinnamon (sid)

Post by xircon »

Same here, what next Crumpets? (or Pikelets if you are from the North of England like me). :D
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"

zerozero
Level 16
Level 16
Posts: 6480
Joined: Tue Jul 07, 2009 2:29 pm

Re: building Cinnamon (sid)

Post by zerozero »

i guess clem has to bake those muffins to satisfy cinnamon :lol:
Image

[ bliss of ignorance ]

AlbertP
Level 16
Level 16
Posts: 6714
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: building Cinnamon (sid)

Post by AlbertP »

On Mint 12 you can install dependencies much easier. Enable Source code in Software Sources, then run apt build-dep cinnamon. And then you can compile Cinnamon without having to worry about dependencies.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

User avatar
xircon
Level 5
Level 5
Posts: 768
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: building Cinnamon (sid)

Post by xircon »

Tempting, I have a recent backup, enabled Lisa repos:

Code: Select all

 sudo apt build-dep cinnamon
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  cdbs gir1.2-ebook-1.2 gir1.2-ecalendar-1.2 gir1.2-edataserver-1.2 gir1.2-gnomedesktop-3.0 gir1.2-gnomekeyring-1.0 gir1.2-muffin-3.0 gnome-pkg-tools
  gsettings-desktop-schemas-dev libcamel1.2-dev libcaribou-dev libclutter-1.0-dev libcogl-dev libcogl-pango-dev libcroco3-dev libebook1.2-dev libecal1.2-dev
  libedataserver1.2-dev libedataserverui-3.0-dev libfolks-dev libgee-dev libgnome-desktop-3-dev libgnome-keyring-dev libgnome-menu-3-dev libgstreamer0.10-dev
  libgudev-1.0-dev libical-dev libmuffin-dev libmuffin0 libnm-glib-dev libnm-util-dev libsqlite3-dev libtelepathy-glib-dev libtelepathy-logger-dev libxss-dev
  muffin-common network-manager-dev x11proto-scrnsaver-dev
0 upgraded, 38 newly installed, 0 to remove and 34 not upgraded.
Need to get 12.8 MB of archives.
After this operation, 51.2 MB of additional disk space will be used.
Do you want to continue [Y/n]? 
Edit: Still doesn't work:

Code: Select all

 sudo aptitude install cinnamon
The following NEW packages will be installed:
  cinnamon{b} 
0 packages upgraded, 1 newly installed, 0 to remove and 34 not upgraded.
Need to get 1,343 kB of archives. After unpacking 5,943 kB will be used.
The following packages have unmet dependencies:
  cinnamon: Depends: libgjs0c (>= 1.29.18) but it is not installable.
            Depends: libpulse-mainloop-glib0 (>= 1:0.99.1) but 1.1-2 is installed.
            Depends: libpulse0 (>= 1:0.99.1) but 1.1-2 is installed.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     cinnamon [Not Installed]                           



Accept this solution? [Y/n/q/?] 
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"

GeneC
Level 7
Level 7
Posts: 1599
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: building Cinnamon (sid)

Post by GeneC »

Steve

What's the repo for Lisa 'Source Code'? :mrgreen:
I have the Lisa enabled but not the Lisa source code.

Code: Select all

# deb http://packages.linuxmint.com/ lisa main upstream import #"Lisa"

Code: Select all

gene@zordon:~$ sudo apt build-dep cinnamon
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have unmet dependencies:
 libedataserverui-3.0-dev : Depends: libgtk-3-dev but it is not going to be installed
 libgnome-bluetooth-dev : Depends: libgtk-3-dev but it is not going to be installed
 libgnome-desktop-3-dev : Depends: libgtk-3-dev (>= 3.0.0) but it is not going to be installed
 libmuffin-dev : Depends: libclutter-1.0-dev (>= 1.0.0) but it is not going to be installed
                 Depends: libgtk-3-dev (>= 3.0.0) but it is not going to be installed
 librsvg2-dev : Depends: libcairo2-dev (>= 1.2.0) but it is not going to be installed
                Depends: libgtk2.0-dev (>= 2.21.5) but it is not going to be installed
 libwnck-dev : Depends: libpango1.0-dev but it is not going to be installed
               Depends: libgtk2.0-dev (>= 2.19.7) but it is not going to be installed
               Depends: libcairo2-dev but it is not going to be installed
E: Build-dependencies for cinnamon could not be satisfied.

AlbertP
Level 16
Level 16
Posts: 6714
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: building Cinnamon (sid)

Post by AlbertP »

You might screw up your Debian system adding so many Ubuntu-based stuff.

Just replace deb with deb-src and you've got the source code repo.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

GeneC
Level 7
Level 7
Posts: 1599
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: building Cinnamon (sid)

Post by GeneC »

AlbertP wrote:You might screw up your Debian system adding so many Ubuntu-based stuff.

Just replace deb with deb-src and you've got the source code repo.
Thanks Albert.
Made a clone before trying. :wink:

zerozero
Level 16
Level 16
Posts: 6480
Joined: Tue Jul 07, 2009 2:29 pm

Re: building Cinnamon (sid)

Post by zerozero »

you have a backup Gene?

Code: Select all

# deb-src http://packages.linuxmint.com/ lisa main upstream import #"Lisa"
# deb http://packages.linuxmint.com/ lisa main upstream import #"Lisa"
Image

[ bliss of ignorance ]

GeneC
Level 7
Level 7
Posts: 1599
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: building Cinnamon (sid)

Post by GeneC »

zerozero wrote:you have a backup Gene?
......
Conezilla and I are BEST friends... :lol:

Nope. Did not work.

Code: Select all

gene@zordon:~$ sudo apt build-dep cinnamon
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have unmet dependencies:
 libedataserverui-3.0-dev : Depends: libgtk-3-dev but it is not going to be installed
 libgnome-bluetooth-dev : Depends: libgtk-3-dev but it is not going to be installed
 libgnome-desktop-3-dev : Depends: libgtk-3-dev (>= 3.0.0) but it is not going to be installed
 libmuffin-dev : Depends: libclutter-1.0-dev (>= 1.0.0) but it is not going to be installed
                 Depends: libgtk-3-dev (>= 3.0.0) but it is not going to be installed
 librsvg2-dev : Depends: libcairo2-dev (>= 1.2.0) but it is not going to be installed
                Depends: libgtk2.0-dev (>= 2.21.5) but it is not going to be installed
 libwnck-dev : Depends: libpango1.0-dev but it is not going to be installed
               Depends: libgtk2.0-dev (>= 2.19.7) but it is not going to be installed
               Depends: libcairo2-dev but it is not going to be installed
E: Build-dependencies for cinnamon could not be satisfied.

zerozero
Level 16
Level 16
Posts: 6480
Joined: Tue Jul 07, 2009 2:29 pm

Re: building Cinnamon (sid)

Post by zerozero »

i installed manually from the lisa repo muffin-common, libmuffin0 and gir1.2-muffin-3.0-1 and the result is

Code: Select all

sudo apt-get install cinnamon
[sudo] password for amadeu: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 cinnamon : Depends: libecal1.2-10 (>= 3.2.2) but it is not installable
            Depends: libedataserver1.2-15 (>= 3.2.2) but it is not installable
            Depends: libgjs0c (>= 1.29.18) but it is not installable
            Depends: libmozjs185-1.0 (>= 1.8.5~hg20110306r6) but it is not installable
            Depends: libpulse-mainloop-glib0 (>= 1:0.99.1) but 1.0-4 is to be installed
            Depends: libpulse0 (>= 1:0.99.1) but 1.0-4 is to be installed
            Depends: caribou but it is not going to be installed
E: Broken packages
Image

[ bliss of ignorance ]

GeneC
Level 7
Level 7
Posts: 1599
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: building Cinnamon (sid)

Post by GeneC »

I tried installing muffin first also. It installed, but still not Cinnamon..

Will be keeping an eye on this. Cinnamon looks 'tasty' :lol:

Better disable 'Lisa' now, or I will have a real mess.
'SID' is proving to be a tough almost unbreakable old bird. :P

zerozero
Level 16
Level 16
Posts: 6480
Joined: Tue Jul 07, 2009 2:29 pm

Re: building Cinnamon (sid)

Post by zerozero »

ahh you are trying to install it in sid? :) my attempt was in testing, but i don't believe it would make any difference, the missing deps are basically the same and they have to be ported to debian (i think) or backport the lisa pkgs into lmde (and hope it won't break anything latter down the road :mrgreen: )
Image

[ bliss of ignorance ]

GeneC
Level 7
Level 7
Posts: 1599
Joined: Fri Sep 03, 2010 1:59 pm
Location: Maine, USA

Re: building Cinnamon (sid)

Post by GeneC »

I tried with SID and then with testing. No difference.
Yes, "Discretion is the better part of valor".
Going to wait it out, with my 'CREW" 8)
Image

Locked

Return to “LMDE Archive”