[SOLVED]Weird issue about system time

Archived topics about LMDE 1 and LMDE 2
Locked
anayonkars
Level 1
Level 1
Posts: 10
Joined: Thu Mar 29, 2012 12:01 pm

[SOLVED]Weird issue about system time

Post by anayonkars »

Hi All,

This is my first post, so please bear with me if I make any mistakes.

I've been using Linux Mint since Mint 10 days and after being fed up with reinstalling system every 6-8 months, recently, I switched to Linux Mint Debian Edition. And then the issue began.

The moment I configure system time using time-admin and it simply started modifying BIOS time. Let's take an example:

My timezone is GMT +5:30, and lets assume at my location, actual time is 9:00. So, I set time as 9:00 in BIOS settings, and when I boot in LMDE, I get system time as 14:30 (i.e. 9:00 + 5:30). Further, my timezone is still GMT +5:30.

So, I modified time in LMDE, to 9:00 and guess what? My BIOS time is now 3:30 (i.e. 9:00 - 5:30). Which means, my system time and BIOS time will always differ by 5:30. This is simply because I declared that my timezone is GMT +5:30.

I've used various distros (Debian, Ubuntu, and 3 versions of Mint) but I never faced this issue.

Since modification done in LMDE is modifying BIOS time, my other OS is also suffering from it. That is, I change time in LMDE, which changes BIOS time to incorrect value and other OS like Windows 7 picks that wrong time as it is.

All suggestions/help is appreciated.

Thanks.

Regards,
Anayonkar Shivalkar
Last edited by anayonkars on Fri Mar 30, 2012 9:36 am, edited 1 time in total.
Regards,
Anayonkar Shivalkar
grizzler
Level 5
Level 5
Posts: 652
Joined: Wed Jun 15, 2011 5:19 pm
Location: The Hague, NL

Re: Weird issue about system time

Post by grizzler »

This is probably because the OS assumes your system clock is on UTC. Take a look at the file /etc/default/rcS and make sure the UTC setting corresponds with what you use (UTC=no if you don't want your computer's internal clock to be on UTC, i.e. if your BIOS clock should not be five and a half hours behind your local time).
Darcy
Level 3
Level 3
Posts: 113
Joined: Tue Dec 13, 2011 7:19 pm

Re: Weird issue about system time

Post by Darcy »

Anayonkar: Thanks for asking this question.

Grizzler: Thanks for the solution, it worked for me!
I am old and senile (I think) please be nice.
anayonkars
Level 1
Level 1
Posts: 10
Joined: Thu Mar 29, 2012 12:01 pm

Re: Weird issue about system time

Post by anayonkars »

Thanks grizzler. It worked.

By the way, it is strange that LMDE does not have UTC configuration option in time-admin UI. Also, it didn't even asked me about UTC during installation. It seems that LMDE by default took UTC (which is not good).

I hope this issue won't be there in future releases.

Thanks for the help again.
Regards,
Anayonkar Shivalkar
grizzler
Level 5
Level 5
Posts: 652
Joined: Wed Jun 15, 2011 5:19 pm
Location: The Hague, NL

Re: Weird issue about system time

Post by grizzler »

Setting the internal clock to UTC actually is the right way. The real problem here is Microsoft. It didn't follow what the real operating systems did when it designed Windows. The Ubuntu designers thought it best to mimic that behaviour to make dual booting with Windows easier. Debian isn't likely to do that.
User avatar
twa
Level 4
Level 4
Posts: 231
Joined: Fri Sep 17, 2010 8:11 am
Location: Somewhere in the sky

Re: Weird issue about system time

Post by twa »

Hi,
I have solved installing from synaptic : ntp
cheers
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread.
anayonkars
Level 1
Level 1
Posts: 10
Joined: Thu Mar 29, 2012 12:01 pm

Re: Weird issue about system time

Post by anayonkars »

grizzler wrote:Setting the internal clock to UTC actually is the right way. The real problem here is Microsoft.
I don't think so. Initially, my clock setting was UTC and the moment I set correct time in LMDE, it used to set wrong time in BIOS - which is unacceptable.
I'm not sure about new Debian systems, but I used Debian Etch (i.e. version 4) for more than 2 years and never had this issue. Even I did not face this issue in Mint 10,11,12 etc.

In my opinion, no matter what I do in OS, BIOS time should be modified only via BIOS. If I make time changes at OS level, it should reflect only in OS and not in BIOS. I don't know how Microsoft handles this issue, but at least it sets same time everywhere (in OS and BIOS).

As already mentioned, I faced this issue for the first time in LMDE itself. I never faced this issue before (of course, I never set my clock to UTC before, but at least other distros provided an option whereas LMDE by default set the UTC option to true).

Anyways, now the issue is resolved, and since I'm using rolling distro, I don't have to reinstall it :D
Regards,
Anayonkar Shivalkar
AlbertP
Level 16
Level 16
Posts: 6701
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: [SOLVED]Weird issue about system time

Post by AlbertP »

Microsoft always sets local time in BIOS. Fedora however asks you what to do during installation (single-boot has UTC default, dual-boot local time as default).
LMDE apparently sets UTC by default as there are more people complaining about this. I think it would be good to have either UTC off to avoid problems with Windows/Ubuntu or offer people a choice like Fedora does.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
Locked

Return to “LMDE Archive”