Page 1 of 1

(Kind of?) Black Screen after updating

Posted: Tue Aug 08, 2017 6:22 am
by melltuga
Hi (:

I wanted to switch to LMDE2 from 18.1, as LMDE runs much faster on my other laptop, and I wanted to give new life to my old one as well ;)
So I downloaded & installed LMDE2, made all the updates, installed Media Codecs and everything when suddenly the screen turned black.
While moving my mouse (or pressing keys) I could see the the Mint-Logo "flickering" (it's probably the wallpaper) but could do nothing else.
So I rebooted, the Welcome Screen showed up, if I pressed the power button the power-menu showed up as well, but I could see or do nothing else.

I already tried nomodeset xforcevesa, using this -> viewtopic.php?t=122257 -> but it didn't change anything, which I found weird, as I was sure that the this is a graphic-card(-driver?) problem.
Booting up into Live-USB, everything works.
Reinstalling LMDE2, everything works.
As soon as I update - same problem again.

Notebook-Specs:

Code: Select all

Brand			Acer
Model / Series 		Extensa 5635ZG-item
weight 			8 Kg
Product dimensions 	42.6 x 32 x 9 cm
Screen size 		15.6 inches
Screen resolution 	1366 x 768 pixels
Processor brand 	Intel
Processor Type 		Pentium Dual-Core
Processor speed 	2.1 GHz
RAM size 			2 GB
Memory technology 	DDR3-SDRAM
Memory Type 		DDR3 SDRAM
Max Supported Size 	4 GB
Size Hard drive 		250 GB
Hard disk interface 	Serial ATA
Audio output 		1
Chipset manufacturer 	Intel
Description graphics card 	Intel
Connectivity Type 	802.11a / b / g / n. Yes
Number of USB 2.0 interfaces 	3
Number of Ethernet Ports 	1
Mine also has an old Nvidia-Geforce G105M inside (I still think that the problem might have something to do with the graphic unit).

Since I'm more or less a novice linux user, I really don't know where to go from here... any help would be appreciated!

Thanks,

*mT

Re: (Kind of?) Black Screen after updating

Posted: Thu Aug 10, 2017 7:08 am
by melltuga
Anyone :/ ?

Re: (Kind of?) Black Screen after updating

Posted: Thu Aug 10, 2017 8:59 am
by Pepi
You never said if you installed MATE or Cinnamon. I tried LMDE2 Cinnamon on an older laptop awhile back and it would NOT work. MATE worked fine. I wish I could help more but I'm a newbie also.

Re: (Kind of?) Black Screen after updating

Posted: Thu Aug 10, 2017 10:14 am
by melltuga
Thanks for your answer (: - but I forgot to mention that I'm using Mate :/

Re: (Kind of?) Black Screen after updating

Posted: Thu Aug 10, 2017 6:20 pm
by Pepi
Bummer :cry: Hopefully, some of these Gurus can answer.

Re: (Kind of?) Black Screen after updating

Posted: Sat Aug 12, 2017 8:58 am
by BG405
Not a Guru, but I would suggest you apply the updates one at a time (I know this might take ages) rebooting after each one. This should reveal the culprit(s). Might be a good idea to list the available updates for us, as ones unlikely to be responsible can be identified to save time.

The output of inxi -Fxxz may help too.

Re: (Kind of?) Black Screen after updating

Posted: Sat Aug 12, 2017 12:48 pm
by melltuga
Thanks for your answer!

You're right, that would probably take a looong time, time that I just don't have (or that I don't want to invest).
I'll just go back to using standard Linux Mint - thanks anyways, guys (:

Re: (Kind of?) Black Screen after updating

Posted: Sat Aug 19, 2017 6:10 pm
by morgas
Ok everyone I am running Mate. I updated my systems the week of Aug 13 2017. Desktops with Installed video cards, no problem at all.

Laptops, two Dell systems ended up with the Black Screen after update.

The problem is that within the update someone included the mint desktop files.
That part is not the problem, the problem is they are built for the new kernel so you
must also install the new kernel as well as all other level 3,4 files in the update to avoid
the black screen on desktops is my guess.....at least on my Dells. Hope this helps

Re: (Kind of?) Black Screen after updating

Posted: Sat Aug 19, 2017 8:51 pm
by Pepi
I've got an old Dell single core desktop that I put LMDE2 MATE on. It worked great until I did the full update and then TRASH. No video, just black screen on reboot :evil: I switched to Cinnamon and it runs fine on this old PC. I turned off all the fancy stuff and it runs like a top. The new MATE is not my friend :cry: It has failed me 3 times now.

Re: (Kind of?) Black Screen after updating

Posted: Thu Aug 24, 2017 3:52 am
by melltuga
Thanks!
I'll just try LMDE2 Cinnamon in a couple of days then (:

Re: (Kind of?) Black Screen after updating

Posted: Thu Aug 24, 2017 8:45 am
by Pepi
Many users say that Cinammon is a resource HOG but I don't find that being the case? I've tried both MATE and Cinnamon and they seen to run about the same on my computers. I do turn off all the 'eyecandy' stuff though