Nvidia driver breaks every time Xorg or Cinnamon updates

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
SlackerNet
Level 1
Level 1
Posts: 3
Joined: Fri May 01, 2015 9:34 pm

Nvidia driver breaks every time Xorg or Cinnamon updates

Postby SlackerNet » Sat Aug 12, 2017 10:42 am

running LMDE2 with nvidia driver 375.66

every time i get a cinnamon or x org update the system breaks and cinnamon runs in fallback mode

if its not bad enough to install the video driver

the dam updates break the system

WHY !!!!!!!!!!!!!!!!!!!!!!

i did xorg yesterday wich then brought in cinnamon updates so i do not know wich one is at fault....gooogle cinnamon crash log was 0 help also
I dont ask for help without trying to fix it myself first

but this is getting old and i am sick of backing everything up and reinstalling the system and the drivers so game play can be done...the default driver cannot handle games

anyone got a clue or an answer ?

x-org log i found using syslog


https://pastebin.com/FQGRbvHh

syslog is here

https://pastebin.com/4aqCmw70

if update history helps i found that also

http://imgur.com/a/bcZj7
Last edited by SlackerNet on Sat Aug 12, 2017 11:17 am, edited 1 time in total.

Frazatto
Level 1
Level 1
Posts: 7
Joined: Mon Mar 27, 2017 8:48 am

Re: Nvidia driver breaks every time Xorg or Cinnamon updates

Postby Frazatto » Sat Aug 12, 2017 11:14 am

I'm using Nvidia-driver and letting the package figure it out the best drivers and packages.
Everything works flawlessly.

SlackerNet
Level 1
Level 1
Posts: 3
Joined: Fri May 01, 2015 9:34 pm

Re: Nvidia driver breaks every time Xorg or Cinnamon updates

Postby SlackerNet » Sat Aug 12, 2017 11:20 am

Frazatto wrote:I'm using Nvidia-driver and letting the package figure it out the best drivers and packages.
Everything works flawlessly.


not sure what you mean letting the package figure it out ?

the update manager runs and installs automatically after i enter my password and choose the updates wich most times is all of the updates

the last time i had to do this was 7-1-17

for a long time updates never broke the system with the nvidia driver...this is ongoing for about a year now and i have had to reinstall about 5 times from updates breaking the system

the only game i run is modded minecraft and its graphics instense and ram intense

so i add java 8 from webudate team and the nvidia driver debacle to install

besides that the system is out of the box

kryssb
Level 1
Level 1
Posts: 10
Joined: Fri Apr 28, 2017 5:11 pm

Re: Nvidia driver breaks every time Xorg or Cinnamon updates

Postby kryssb » Mon Aug 14, 2017 6:12 pm

For my personal experience, I recommend using the NVidia binary driver. Yes, Cinnamon breaks every now and then with updates, but running the installer again solves (I never delete it). Specifically, the GL extensions are missing and that's why Cinnamon breaks (MATE doesn't).
Reinstalling just the driver takes no more than 10 minutes, all inconveniences included. Sometimes I find that there is an nvidia uninstaller holding the dpkg lock (although I'm using nvidia binaries!) and I cancel that. I suppose this uninstaller removes the GL extensions and that's what breaks the game.

Frazatto
Level 1
Level 1
Posts: 7
Joined: Mon Mar 27, 2017 8:48 am

Re: Nvidia driver breaks every time Xorg or Cinnamon updates

Postby Frazatto » Thu Aug 17, 2017 9:37 am

SlackerNet wrote:not sure what you mean letting the package figure it out ?


The only two packages I installed myself was nvidia-driver and nvidia-settings, the rest was installed as dependencies or during the nvidia-driver self configuration when you "sudo nvidia-xconfig" (i'm not sure this is the only command to run...it's been some time I had to do it)

That is it and it works as it should since.


Return to “Newbie Questions”