Clean install on HP Notebook, However 3d and Wifi aren't working.

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Pr1ymüL
Level 1
Level 1
Posts: 7
Joined: Mon Feb 05, 2018 1:50 pm

Clean install on HP Notebook, However 3d and Wifi aren't working.

Post by Pr1ymüL » Mon Feb 05, 2018 3:08 pm

I have a HP Notebook with a Intel Pentium driver purchased in 2016, Originally came with Windows 10. I became however good at partitioning and reformatting to clean install LMDE2 every time. However I don't have the drivers for it to work with the 3d graphics (so no Blender or gaming for me :( ) as well needing the Wi-Fi drivers however it works fine plugged to traditional internet, I wish to be able to get my laptop fully functional so it can game and internet freely!

I love LMDE2 and I want to use it to it's fullest capabilities freely and fun. I hope someone with some developer experience can deliver a solution.
I have bought the O.S. thinking it would require little thought to set up easily. Which of course installing and using it works but however 3d solutions and WiFi aren't there which are really killing me! Some one put an end to the frustrations so I don't end up breaking my installation disc!

User avatar
kc1di
Level 11
Level 11
Posts: 3657
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Clean install on HP Notebook, However 3d and Wifi aren't working.

Post by kc1di » Tue Feb 06, 2018 8:07 am

Hello Pr1ymüL and Welcome to Linux Mint Forums,
Good to have you here.

We need a little more info on the system to know how to help. I do not have LMDE installed at the moment.
but we need to know what wireless card and driver are installed on that machine.
I can't remember if inxi is installed in LMDE2 but if it is please post the output of this command:

Code: Select all

inxi -Fxz
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

Pr1ymüL
Level 1
Level 1
Posts: 7
Joined: Mon Feb 05, 2018 1:50 pm

Re: Clean install on HP Notebook, However 3d and Wifi aren't working.

Post by Pr1ymüL » Tue Feb 06, 2018 4:00 pm

Code: Select all

System:    Host: computer Kernel: 3.16.0-4-amd64 x86_64 (64 bit gcc: 4.8.4) 
           Desktop: MATE 1.16.1 (Gtk 3.14.5+4) Distro: LinuxMint 2 betsy 
Machine:   System: HP product: HP Notebook v: Type1ProductConfigId
           Mobo: HP model: 81F1 v: 64.53 Bios: Insyde v: F.30 date: 06/28/2017
CPU:       Quad core Intel Pentium N3710 (-MCP-) cache: 1024 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 12799 
           Clock Speeds: 1: 499 MHz 2: 499 MHz 3: 498 MHz 4: 498 MHz
Graphics:  Card: Intel Device 22b1 bus-ID: 00:02.0
           Display Server: X.Org 1.16.4 drivers: fbdev,intel (unloaded: vesa)
           Resolution: 1366x768@76.00hz
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.5, 128 bits)
           GLX Version: 3.0 Mesa 10.3.2 Direct Rendering: Yes
Audio:     Card Intel Device 2284 driver: snd_hda_intel bus-ID: 00:1b.0 
           Sound: Advanced Linux Sound Architecture v: k3.16.0-4-amd64
Network:   Card-1: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: 1000 bus-ID: 03:00.0
           IF: eth0 state: down mac: <filter>
           Card-2: Intel Device 3165 bus-ID: 02:00.0
           IF: N/A state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 1000.2GB (0.5% used)
           ID-1: /dev/sda model: WDC_WD10JPVX size: 1000.2GB
Partition: ID-1: / size: 32G used: 4.6G (16%) fs: ext4 dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 27.8C mobo: 27.0C 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 167 Uptime: 2 min Memory: 380.9/7848.3MB 
           Init: SysVinit runlevel: 2 Gcc sys: 4.9.2 
           Client: Shell (bash 4.3.301) inxi: 2.1.28

User avatar
kc1di
Level 11
Level 11
Posts: 3657
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Clean install on HP Notebook, However 3d and Wifi aren't working.

Post by kc1di » Wed Feb 07, 2018 6:44 am

First lets see if we can get the wireless going.
Please go to the terminal and type this command and post the output back here.

Code: Select all

rfkill list
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

Pr1ymüL
Level 1
Level 1
Posts: 7
Joined: Mon Feb 05, 2018 1:50 pm

Re: Clean install on HP Notebook, However 3d and Wifi aren't working.

Post by Pr1ymüL » Wed Feb 07, 2018 6:28 pm

Appreciate responding

my results ~ $ rfkill list
0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

Pr1ymüL
Level 1
Level 1
Posts: 7
Joined: Mon Feb 05, 2018 1:50 pm

Re: Clean install on HP Notebook, However 3d and Wifi aren't working.

Post by Pr1ymüL » Wed Feb 07, 2018 6:36 pm

Sorry for the double post but here's more information

Code: Select all

 ~ $ inxi -fi
CPU:       Quad core Intel Pentium N3710 (-MCP-) cache: 1024 KB 
           Clock Speeds: 1: 499 MHz 2: 499 MHz 3: 499 MHz 4: 499 MHz
           CPU Flags: 3dnowprefetch acpi aes aperfmperf apic arat arch_perfmon
           bts clflush cmov constant_tsc cx16 cx8 de ds_cpl dtes64 dtherm dts
           epb ept erms est flexpriority fpu fxsr ht ida lahf_lm lm mca mce
           mmx monitor movbe msr mtrr nonstop_tsc nopl nx pae pat pbe
           pclmulqdq pdcm pebs pge pni popcnt pse pse36 rdrand rdtscp rep_good
           sep smep ss sse sse2 sse4_1 sse4_2 ssse3 syscall tm tm2 tpr_shadow
           tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid xtopology xtpr
Network:   Card-1: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller
           driver: r8169
           IF: eth0 state: up speed: 100 Mbps duplex: full 
           mac: c8:d3:ff:96:c2:4e
           Card-2: Intel Device 3165
           IF: N/A state: N/A speed: N/A duplex: N/A mac: N/A
           WAN IP: 00.000.000.000 IF: eth0 ip: 00.000.0.000

JeremyB
Level 17
Level 17
Posts: 7894
Joined: Fri Feb 21, 2014 8:17 am

Re: Clean install on HP Notebook, However 3d and Wifi aren't working.

Post by JeremyB » Wed Feb 07, 2018 6:43 pm

The 3.16 kernel is far too old to support that wifi, it might work with the 4.4 kernel and firmware-intel

youstupiddarkness
Level 1
Level 1
Posts: 22
Joined: Sat Jun 17, 2017 8:29 pm

Re: Clean install on HP Notebook, However 3d and Wifi aren't working.

Post by youstupiddarkness » Fri Feb 09, 2018 1:01 am

You should go for the 4.9 kernel along with the updated Intel video driver in jessie-backports:

http://forums.debian.net/viewtopic.php?f=16&t=131611

That'll get your 3D working, too. Note that you will also need the newer firmware-misc-nonfree and firmware-iwlwifi from backports, too.

Pr1ymüL
Level 1
Level 1
Posts: 7
Joined: Mon Feb 05, 2018 1:50 pm

Re: Clean install on HP Notebook, However 3d and Wifi aren't working.

Post by Pr1ymüL » Wed Feb 14, 2018 11:23 pm

OK, so far appreciate the responses. 💯 I want to add a couple questions before I follow through so I can have a successful install. I need to know how to I add back ports, and update the kernel? Can I use sudo get iñ this process?
And unrelated I also installed Vista how do I get the OS to appear on GRUB thanks in advance.

Post Reply

Return to “Newbie Questions”