Page 1 of 1

Problem Installing snapd

Posted: Thu Mar 08, 2018 8:15 am
by tb75252
I am using Linux Mint Debian Edition 2, 64-bit. I would like to install the Snapcraft version of Skype. See https://snapcraft.io/skype

According to the instructions, I should first run

Code: Select all

sudo apt install snapd
But I get the error
Unable to locate package snapd
Any idea what I need to do to solve this issue?

Re: Problem Installing snapd

Posted: Thu Mar 08, 2018 9:33 am
by Sir Charles
You are right. Me to, I did

Code: Select all

sudo apt update
sudo apt install snapd
and I got the same error message. Could it be that snapd is not available in LMDE2?

Re: Problem Installing snapd

Posted: Sat Apr 07, 2018 7:06 pm
by kevinthefixer
Found your problem just a bit lower down on the linked page. Supported OSs listed: Debian testing, Debian unstable. Probably means Stretch and Buster. Add one of those repos to your sources if you care to sacrifice stability. Or just download the .deb from the repos.

Re: Problem Installing snapd

Posted: Sat Apr 07, 2018 7:56 pm
by Fred Barclay
Marziano wrote:
Thu Mar 08, 2018 9:33 am
Could it be that snapd is not available in LMDE2?
That's it. Snapd was introduced into Debian 9 (Stretch), so we'll first see it in LMDE 3.
https://packages.debian.org/stretch/snapd

Re: Problem Installing snapd

Posted: Sat Apr 07, 2018 8:09 pm
by Sir Charles
Fred Barclay wrote:
Sat Apr 07, 2018 7:56 pm
That's it. Snapd was introduced into Debian 9 (Stretch), so we'll first see it in LMDE 3.
https://packages.debian.org/stretch/snapd
Thanks Fred! Exciting times ahead, with the release of next generation LM.
:D