Page 1 of 1

Unable to Install Package "snapd"

Posted: Mon Mar 12, 2018 7:34 am
by tb75252
I am using LMDE 2, 64-bit.

I would like to install the Snapcraft version of Skype. See this link: https://snapcraft.io/skype
The instructions state that I should first install snapd

Code: Select all

sudo apt install snapd
but I get an error:
Unable to locate package snapd
It has been suggested to make sure that the option to accept software from given ppas is ticked. Where do I check that? I don't see it in Synaptic Package Manager...

Re: Unable to Install Package "snapd"

Posted: Mon Mar 12, 2018 7:39 am
by Pierre
well - - LMDE doesn't support PPAs . .
so, you can't install those.

and the program snapd should be in Package Manager AKA synaptic,
after which you may be able to install the Snapcraft version of Skype.

Re: Unable to Install Package "snapd"

Posted: Mon Mar 12, 2018 8:19 am
by Sir Charles
Pierre wrote:
Mon Mar 12, 2018 7:39 am
and the program snapd should be in Package Manager AKA synaptic,
It doesn't seem so. I run LMDE 2- MATE in a VM and in another thread (from the same OP: viewtopic.php?f=236&t=265318&p=1440821& ... e#p1440821) I tried to install snapd. I could do so neither from a terminal nor from Synaptic. So I wonder whether snapd is available for LMDE2 at all.

Re: Unable to Install Package "snapd"

Posted: Mon Mar 12, 2018 8:38 am
by Pierre
can you search in Package Manager AKA synaptic,
and see if snapd is listed there ?.

I've not got any LMDE working ATM, so I'm not able to check that.

Re: Unable to Install Package "snapd"

Posted: Mon Mar 12, 2018 9:14 am
by Sir Charles
Pierre wrote:
Mon Mar 12, 2018 8:38 am
can you search in Package Manager AKA synaptic,
and see if snapd is listed there ?.
"snapd" is nowhere to be found :?
SynapticSnapd.png

Re: Unable to Install Package "snapd"

Posted: Mon Mar 12, 2018 3:29 pm
by tb75252
I am told that snapd is surely in the Stretch (stable), Buster (testing) and Sid (unstable) debian archives, according to the debian package search.
What release is LMDE based on?

Re: Unable to Install Package "snapd"

Posted: Mon Mar 12, 2018 3:37 pm
by Sir Charles
LMDE 2 is based on Debian Jessie ("Stable").

Re: Unable to Install Package "snapd"

Posted: Wed Mar 14, 2018 11:49 pm
by youstupiddarkness
Marziano wrote:
Mon Mar 12, 2018 3:37 pm
LMDE 2 is based on Debian Jessie ("Stable").
Currently "oldstable", to be pedantic.

Re: Unable to Install Package "snapd"

Posted: Thu Mar 15, 2018 12:08 am
by sdibaja
youstupiddarkness wrote:
Wed Mar 14, 2018 11:49 pm
Marziano wrote:
Mon Mar 12, 2018 3:37 pm
LMDE 2 is based on Debian Jessie ("Stable").
Currently "oldstable", to be pedantic.
End of life date ~June 6th 2018 (full) / ~June 6th 2020 (LTS) ... only security updates
https://wiki.debian.org/DebianOldStable