Shutdown stops as gnome-keyring-daemon not responding [SOLVED]

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
ron_h
Level 4
Level 4
Posts: 278
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Shutdown stops as gnome-keyring-daemon not responding [SOLVED]

Post by ron_h » Mon Apr 30, 2018 5:51 pm

LMDE Cinnamon 64bit (installed about 1 year ago ; all updates applied)

A couple of days ago, shutdown stopped as gnome-keyring-daemon was not responding. I've been running for about a year and had not seen this before. Now happens on every shutdown. The 'shutdown anyway' option works, but that means I have to wait till the 'not responding' screen pops up. I've looked at the LM forums and it seems this feechur has been around for months, though mostly reported on LM main edition not on LMDE. I've tried some of the suggested 'fixes' but no success. In particular, gnome-keyring-daemon is NOT in my Startup Applications, so I can't remove it, and 'sudo purge-old-kernels' says there is no such command.

Solution for LMDE Cinnamon 64bit would be welcome.

Ron
Last edited by ron_h on Tue May 01, 2018 7:29 pm, edited 1 time in total.

User avatar
AZgl1500
Level 7
Level 7
Posts: 1998
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: Shutdown stops as gnome-keyring-daemon not responding

Post by AZgl1500 » Mon Apr 30, 2018 6:25 pm

Open Terminal

issue this command shutdown 0

All files will be pushed to the HDD and the keyring daemon will be ignored.

Works every-time for me, and what is better, the next reboot the keyring daemon is usually gone.
I rarely see it anymore.

18.3 Cinnamon here

ron_h
Level 4
Level 4
Posts: 278
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Re: Shutdown stops as gnome-keyring-daemon not responding

Post by ron_h » Mon Apr 30, 2018 7:13 pm

Thanks for the idea, sadly it didn't work ...

I had to sudo shutdown 0

I agree that on the next bootup, I was able to shutdown cleanly, no gnome-keyring-daemon issue.

BUT on the bootup after that, shutdown had its gnome-keyring-daemon issue again.

Ron

User avatar
AZgl1500
Level 7
Level 7
Posts: 1998
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: Shutdown stops as gnome-keyring-daemon not responding

Post by AZgl1500 » Mon Apr 30, 2018 8:23 pm

odd that you had to use Sudo,
I never have....

I am using 18.3 Cinnamon if that makes any difference?

but in any event, it does circumvent that ugly daemon.

ron_h
Level 4
Level 4
Posts: 278
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Re: Shutdown stops as gnome-keyring-daemon not responding

Post by ron_h » Tue May 01, 2018 6:31 pm

I've investigated a bit : it appears gnome-keyring was installed on my system as part of the latest SkypeforLinux update which I installed a couple of days ago. If I try to remove gnome-keyring, SkypeforLinux will be removed as well..

The good news is that since the latest update, I don't need to sign in to SkypeforLinux every time I boot the system. The bad news is (as I said in the first post for this thread), shutdown no longer works because of gnome-keyring-daemon not responding.

So, it seems I'm stuck with gnome-keyring. I am looking for a way to get it to -er- cooperate with shutdown on a LMDE Cinnamon 64bit system.

Ron

ron_h
Level 4
Level 4
Posts: 278
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Re: Shutdown stops as gnome-keyring-daemon not responding

Post by ron_h » Tue May 01, 2018 7:29 pm

After more research in the LM forums, I've found a solution that seems to be working for me (so far at least).

Install the Session Manager applet and use that instead of the Menu 'Quit' button to shut down.

Go to System Settings-Preferences-Applets then select 'Available applets (online)' then find and select 'Session Manager' and install it. Select 'Installed applets' and select 'Session Manager' then 'add to panel'. The icon will now be on the RH side of the panel. Use it to shut down from now onward.

Ron

Post Reply

Return to “Newbie Questions”