LMDE/GRUB missing after Mac OS X update

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
cm1
Level 1
Level 1
Posts: 14
Joined: Fri Mar 17, 2017 6:08 pm

LMDE/GRUB missing after Mac OS X update

Post by cm1 » Sun Feb 04, 2018 11:54 am

Hello,

I have a Mac which I configured to dual-boot MacOS and LMDE2. I had to update MacOS and after that, it doesn't boot into GRUB anymore, but only into MacOS. When I hold down the Option key during boot, the MacOS Startup Manager used to show both MacOS and the LMDE partition/startup disk, but now only MacOS shows up.

What can I do to fix this, so GRUB shows up first again? Or, just to boot into LMDE?

Thanks in advance.

fabien85
Level 6
Level 6
Posts: 1143
Joined: Tue Mar 11, 2014 4:30 pm

Re: LMDE/GRUB missing after Mac OS X update

Post by fabien85 » Mon Feb 05, 2018 4:40 am

That's indeed an unfortunate but common consequence of updating an OS (PC users dual-booting with windows gate the same thing).

There are several ways you can fix that :
1) From macOS, you could rebless grub
eg look at these instructions for refind : http://www.rodsbooks.com/refind/installing.html#osx
and adapt them to grub : mount the EFI partition then bless /Volumes/ESP/efi/grubx64.efi
That is going to work only if you have System Integrity Protection (SIP) disabled, otherwise the bless command will give you an error. See this page for explanations
2) From macOS, install refind. Simplest is with the provided install script : instructions
Again that's going to work only if SIP is disabled.
Frankly, I prefer refind as boot manager to grub. Especially for dual-boot with mac. It gives you a graphical interface at boot, autodetects all bootable media, provides many useful booting options fro macOS (eg verbose mode, single user mode, apple hardware test if you have it installed...), allows you to toggle SIP on/off...
3) Use a live medium to correct the boot order with efibootmgr
See the "EFI boot order" section in the Mint installation guide
4) Take a bulldozer and reinstall grub with a live medium
See these instructions by forum member Pjotr


When I hold down the Option key during boot, the MacOS Startup Manager used to show both MacOS and the LMDE partition/startup disk
How did you do that ?
This never happened for me with a standard install of Mint on a macbook.
I can see two ways to do that, but in both cases you have to do it on purpose :
- put your bootloader at EFI/BOOT/bootx64.efi on the EFI partition
then you would see a volume "EFI BOOT" in the startup manager
- make a dedicated hfs+ partition for the bootloader, following e.g. these instructions
I tired this in the past, and it worked for macOS 10.6 but not for 10.12. It must have broken somewhere between these versions, I didnt investigate it.

cm1
Level 1
Level 1
Posts: 14
Joined: Fri Mar 17, 2017 6:08 pm

Re: LMDE/GRUB missing after Mac OS X update

Post by cm1 » Tue Feb 13, 2018 12:16 am

fabien85 wrote:
Mon Feb 05, 2018 4:40 am
That's indeed an unfortunate but common consequence of updating an OS (PC users dual-booting with windows gate the same thing).

There are several ways you can fix that :
1) From macOS, you could rebless grub
eg look at these instructions for refind : http://www.rodsbooks.com/refind/installing.html#osx
and adapt them to grub : mount the EFI partition then bless /Volumes/ESP/efi/grubx64.efi
That is going to work only if you have System Integrity Protection (SIP) disabled, otherwise the bless command will give you an error. See this page for explanations
2) From macOS, install refind. Simplest is with the provided install script : instructions
Again that's going to work only if SIP is disabled.
Frankly, I prefer refind as boot manager to grub. Especially for dual-boot with mac. It gives you a graphical interface at boot, autodetects all bootable media, provides many useful booting options fro macOS (eg verbose mode, single user mode, apple hardware test if you have it installed...), allows you to toggle SIP on/off...
3) Use a live medium to correct the boot order with efibootmgr
See the "EFI boot order" section in the Mint installation guide
4) Take a bulldozer and reinstall grub with a live medium
See these instructions by forum member Pjotr
Thanks fabien85, I appreciate your help. Refind did work and allow me to boot back into LMDE.
When I hold down the Option key during boot, the MacOS Startup Manager used to show both MacOS and the LMDE partition/startup disk
How did you do that ?
This never happened for me with a standard install of Mint on a macbook.
I can see two ways to do that, but in both cases you have to do it on purpose :
- put your bootloader at EFI/BOOT/bootx64.efi on the EFI partition
then you would see a volume "EFI BOOT" in the startup manager
- make a dedicated hfs+ partition for the bootloader, following e.g. these instructions
I tired this in the past, and it worked for macOS 10.6 but not for 10.12. It must have broken somewhere between these versions, I didnt investigate it.
I'm not sure, I'd share if I remember, but the setup was done a long time ago!

Thanks again.

Post Reply

Return to “Installation & Boot”