[Solved] Sound at 100% on boot

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read how to get help

LMDE 2 support ends on 1-1-2019
Post Reply
CeeVee777
Level 1
Level 1
Posts: 20
Joined: Wed Aug 26, 2015 5:06 pm

[Solved] Sound at 100% on boot

Post by CeeVee777 » Sat Aug 06, 2016 12:32 pm

I've recently installed LMDE2 Betsy Cinnamon to try it out and it's working fine except for one small detail, the volume control reverts to 100% whenever I boot/reboot the system.
The sound output is through a pair of Bose speakers connected to the back panel rather than HDMI through the graphics card
I've installed pavucontrol and set the volume to 25% through there, tried the normal sound control through the tool box and tried setting it through the sound icon on the menu bar but it always reverts to a setting of 100% on boot/reboot
My system details are:
System: Host: terminator Kernel: 3.16.0-4-amd64 x86_64 (64 bit gcc: 4.8.4)
Desktop: Cinnamon 3.0.6 (Gtk 3.14.5+4) Distro: LinuxMint 2 betsy
Machine: Mobo: ASUSTeK model: SABERTOOTH 990FX R2.0 v: Rev 1.xx
Bios: American Megatrends v: 2501 date: 04/08/2014
CPU: Octa core AMD FX-8350 Eight-Core (-MCP-) cache: 16384 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 64221
Clock Speeds: 1: 1400 MHz 2: 1400 MHz 3: 1400 MHz 4: 1400 MHz
5: 4000 MHz 6: 1400 MHz 7: 1400 MHz 8: 1400 MHz
Graphics: Card: NVIDIA GF119 [GeForce GT 610] bus-ID: 01:00.0
Display Server: X.Org 1.16.4 drivers: nouveau (unloaded: fbdev,vesa)
Resolution: 1920x1200@59.95hz
GLX Renderer: Gallium 0.4 on NVD9
GLX Version: 3.0 Mesa 10.3.2 Direct Rendering: Yes
Audio: Card-1 NVIDIA GF119 HDMI Audio Controller
driver: snd_hda_intel bus-ID: 01:00.1
Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
driver: snd_hda_intel bus-ID: 00:14.2
Sound: Advanced Linux Sound Architecture v: k3.16.0-4-amd64
Network: Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: b000 bus-ID: 0a:00.0
IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives: HDD Total Size: 5147.1GB (5.1% used)
ID-1: /dev/sda model: Corsair_Force_LS size: 60.0GB
ID-2: /dev/sdb model: SanDisk_SDSSDP12 size: 126.0GB
ID-3: /dev/sdc model: WDC_WD20EZRX size: 2000.4GB
ID-4: /dev/sdd model: WDC_WD20EZRX size: 2000.4GB
ID-5: /dev/sde model: Crucial_CT960M50 size: 960.2GB
Optical: /dev/sr0 model: N/A
rev: N/A dev-links: cdrom,cdrw,dvd,dvdrw
Features: speed: 125x multisession: yes
audio: yes dvd: yes rw: cd-r,cd-rw,dvd-r state: N/A
Partition: ID-1: / size: 33G used: 7.7G (25%) fs: ext4 dev: /dev/sdb2
Sensors: System Temperatures: cpu: 37.0C mobo: 37.0C gpu: 49.0
Fan Speeds (in rpm): cpu: 727 fan-2: 0 fan-3: 0
Info: Processes: 250 Uptime: 3:36 Memory: 968.6/15981.7MB
Init: SysVinit runlevel: 2 Gcc sys: 4.9.2
Client: Shell (bash 4.3.301) inxi: 2.1.28

I'm a long-time Mint user and I've had a search through the forums but can't see anything relevant, anyone got any thoughts?


SOLUTION
I found a very good diagram of how the various layers interact on an old posting on the Ubuntu forums:
https://ubuntuforums.org/showthread.php?t=1794581

Run alsamixer in a terminal, I've found by testing that if the Alsamixer is set to 100% for the master slider then this will over-ride/reset the volume control on the higher levels, but setting the volume at application level or pulse level doesn't filter down to Alsa level.

So solution found, although I don' remember having to do this on any of my Mint installs.
Last edited by CeeVee777 on Sun Aug 07, 2016 8:33 am, edited 3 times in total.

User avatar
richyrich
Level 19
Level 19
Posts: 9027
Joined: Mon May 04, 2009 8:31 pm

Re: Sound at 100% on boot

Post by richyrich » Sat Aug 06, 2016 1:00 pm

I had this happen to me too on one of my machines. Turned out that it was the only machine that I installed the Pulse Audio Equalizer.

CeeVee777
Level 1
Level 1
Posts: 20
Joined: Wed Aug 26, 2015 5:06 pm

Re: Sound at 100% on boot

Post by CeeVee777 » Sat Aug 06, 2016 5:15 pm

Thanks for the swift reply.
Pulse audio equalizer requires a ppa to install and as LMDE2 is Debian based ppa's aren't allowed, so I don't think it's that.
However I looked at the alsamixer command from a console and found that everything was set to 100%, so I've turned the appropriate ones down to 75%.
I'll try a reboot and see if that has fixed the problem

DeMus
Level 6
Level 6
Posts: 1029
Joined: Sat Aug 15, 2009 5:11 pm

Re: Sound at 100% on boot

Post by DeMus » Sat Aug 06, 2016 5:33 pm

I use the following script, which is started aytomatically during boot, to start with all sounds set to 0. This to avoid my wife sitting straight up in bed when I, early in the morning, switch on the computer and forget that I used sound the evening before.

The script is not mine, I got it from somebody on the forum when I asked for help about this. Forgot who it was, though.

Code: Select all

#bin/bash
#
#Set Master volume to zero
amixer set 'Master',0  0% unmute
#
#Set Front to zero
amixer set 'Front',0  0%
#
#Set Surround to zero
amixer set 'Surround',0  0%
#
#Set Center to zero
amixer set 'Center',0  0%
The only "problem" I have now is that I start to play music and I don't hear anything cause the volume is still at zero.

User avatar
Flemur
Level 16
Level 16
Posts: 6279
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Sound at 100% on boot

Post by Flemur » Sat Aug 06, 2016 8:21 pm

The only "problem" I have now is that I start to play music and I don't hear anything cause the volume is still at zero.
I run a very similar script at login but the volume is set to 25%, which is medium-quiet.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

DeMus
Level 6
Level 6
Posts: 1029
Joined: Sat Aug 15, 2009 5:11 pm

Re: Sound at 100% on boot

Post by DeMus » Sun Aug 07, 2016 6:28 am

Flemur wrote:
The only "problem" I have now is that I start to play music and I don't hear anything cause the volume is still at zero.
I run a very similar script at login but the volume is set to 25%, which is medium-quiet.
It's a bit of track, but what are your settings in your script file, if I may ask.

CeeVee777
Level 1
Level 1
Posts: 20
Joined: Wed Aug 26, 2015 5:06 pm

Re: Sound at 100% on boot

Post by CeeVee777 » Sun Aug 07, 2016 7:39 am

Thanks for all the help guys.
I found a very good diagram of how the various layers interact on an old posting on the Ubuntu forums:
https://ubuntuforums.org/showthread.php?t=1794581

I've found by testing that if the Alsamixer is set toi 100% for the master slider then this will over-ride/reset the volume control on the higher levels, but setting the volume at application level or pulse level doesn't filter down to Alsa level.

So solution found, although I don' remember having to do this on any of my Mint installs.

User avatar
Flemur
Level 16
Level 16
Posts: 6279
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Sound at 100% on boot

Post by Flemur » Sun Aug 07, 2016 7:47 am

It's a bit of track, but what are your settings in your script file, if I may ask.
Uh, OK. For an old SoundBlaster; your control names might be different:

Code: Select all

# Note: with SoundBlaster, setting to 0db mostly doesn't work.
#
amixer set 'Master',0        25%  unmute
amixer set 'Headphone',0    100%  unmute
amixer set 'Headphone',1    100%  unmute
amixer set 'Wave'           100%  unmute
amixer set 'Wave Center'    100%
amixer set 'PCM'             23   unmute # 23=0db
amixer set 'Line'            23   unmute # 23=0db
amixer set 'Capture'          0dB unmute
#
amixer set 'Bass'           50%
amixer set 'Treble'         50%
#
amixer set 'Surround'        0 mute
amixer set 'Center'          0 mute
amixer set 'Front'           0 mute
#
# Turn off:
#
amixer set 'LFE',0         0 mute
#
Each control can be set with an integer, or % or db; I don't recall how/why I came up with the above mix.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

Caltrop
Level 2
Level 2
Posts: 79
Joined: Mon Aug 07, 2017 12:00 pm

Re: [Solved] Sound at 100% on boot

Post by Caltrop » Sat Sep 01, 2018 9:12 am

thanks for this

I added my script to the Startup Applications :)

you don't need the 'scontrol',0

Code: Select all

#!/bin/bash
# set-sound
# fix for 100% level issue
amixer set Master 25% unmute
amixer set Headphone 25% unmute
yeah, things started getting screwy in Mint when I got an external monitor
I've been trying to fix the no HDMI sound issue

installed: pavucontrol & pulseaudio-equalizer-gtk
that must have been when the 100% issue started

sound in Mint is messy but Mint uses pulseaudio
pavucontrol now lets me set the system sounds, beeps & chirps
mate-volume-control just does not work right

still after all this, no HDMI sound
must be a missing driver... :?

but as with ALL Operating Systems THEY come out with a new version with new problems instead of fixing things :evil:

so, we'll see if my script works on startup...

Caltrop
Level 2
Level 2
Posts: 79
Joined: Mon Aug 07, 2017 12:00 pm

Re: [Solved] Sound at 100% on boot

Post by Caltrop » Sat Sep 01, 2018 9:30 am

reboot...

things worked out... sort of
mate-volume-control gets knocked almost to zero
Mint & Alsa for some reason are not 1:1 in the terminal command amixer
when the GUI's of Alsa Mixer & mate-volume-control they are 1:1 after adjusting mate-volume-control first :?
but at least it is not 100%

merged things into one script that goes in Mint Startup Applications

Code: Select all

#!/bin/bash
# startup
# since /etc/rc.local & /etc/init.d/rc.local do not execute in Mint
# we made this script & put it in Mint Startup Applications

# fixes touch screen multiple monitor issue
xinput map-to-output 'ELAN Touchscreen' eDP1

# fix for 100% level issue
# pavucontrol & pulseaudio-equalizer-gtk
#     apparently one of these cause 100% level at startup
# even these commands don't fix things entirely
# mate-volume-control gets knocked almost to zero
#     so you have to tweak it after startup
# but no more 100% knock your ears off
# alsa mixer
amixer -q set Master 50% unmute
amixer -q set Headphone 50% unmute
amixer -q set Beep 25% unmute
# pulse audio
pactl set-sink-volume 0 50%
pactl set-sink-volume 1 50%
why does it say MONO on a STEREO system :?:

Code: Select all

Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 27 [31%] [-45.00dB] [on]
but... :?
for some reason the system beeps & chirps are now gone
wait... they're back... :?:

Linux Mint is NOT sound friendly!

Post Reply

Return to “Installation & Boot”