GRUB will not detect Windows 10 Installation (LMDE 2)

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read how to get help
freakytiki34
Level 1
Level 1
Posts: 1
Joined: Thu Nov 17, 2016 12:33 am

GRUB will not detect Windows 10 Installation (LMDE 2)

Postby freakytiki34 » Thu Nov 17, 2016 1:03 am

I'm going to shoot for over-explaining this one, TL:DR listed below.

I installed Windows 10 as normal on a 240GB SSD, leaving aside a few gigs for swap.

Then I installed LMDE 2 onto a separate 32 GB M.2 drive. I noted that that /boot/efi was pointed at the Windows system partition by default, and swap was pointed at the partition I had set aside, but otherwise this installation is on a separate physical disk.

I have an ASUS-Z170-A motherboard with Secure Boot disabled, but otherwise default settings.

No matter what I do, the only way to boot into the different operating systems is to select or unselect the Windows Boot Manager as my first boot device in the motherboard firmware. Even if I select the 240GB SSD, it gives me Grub, but no Windows. It has to be the Windows Boot Manager or I'll end up in LMDE.

Output of sudo update-grub

Code: Select all

Generating grub configuration file ...
Found linux image: /boot/vmlinuz-3.16.0-4-amd64
Found initrd image: /boot/initrd.img-3.16.0-4-amd64
Found memtest86+ image: /memtest86+.bin
Found memtest86+ multiboot image: /memtest86+_multiboot.bin
  No volume groups found
done


Output of cat /etc/default/grub

Code: Select all

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"


Output of sudo fdisk -l

Code: Select all

Disk /dev/sdb: 223.6 GiB, 240057409536 bytes, 468862128 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: AB0E9DAC-5C85-47C6-A9AA-F2B915A6B036

Device         Start       End   Sectors   Size Type
/dev/sdb1       2048    923647    921600   450M Windows recovery environment
/dev/sdb2     923648   1126399    202752    99M EFI System
/dev/sdb3    1126400   1159167     32768    16M Microsoft reserved
/dev/sdb4    1159168 435888127 434728960 207.3G Microsoft basic data
/dev/sdb5  468656128 468860927    204800   100M Linux filesystem
/dev/sdb6  435888128 468656127  32768000  15.6G Linux swap

Partition table entries are not in disk order.
Disk /dev/sdc: 1.4 TiB, 1500301910016 bytes, 2930277168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x6d19c0da

Device     Boot Start        End    Sectors  Size Id Type
/dev/sdc1        2048 2930274303 2930272256  1.4T  7 HPFS/NTFS/exFAT

Disk /dev/sda: 29.8 GiB, 32017047552 bytes, 62533296 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xb218bbe1

Device     Boot Start      End  Sectors  Size Id Type
/dev/sda1        2048 62531583 62529536 29.8G 83 Linux


TL;DR - Installed Windows 10, installed LMDE 2, using basically standard settings, Windows 10 is stubbornly resisting appearing in any Grub-related commands.

Moderator: Moved here from main support since it's LMDE
Last edited by WharfRat on Thu Nov 17, 2016 1:18 am, edited 1 time in total.
Reason: Moved here from main support since it's LMDE

zaileion
Level 3
Level 3
Posts: 147
Joined: Sun Jan 25, 2015 6:01 pm

Re: GRUB will not detect Windows 10 Installation (LMDE 2)

Postby zaileion » Tue Dec 06, 2016 9:23 am

In my experience GRUB does not detect windows when it was installed on the wrong HDD. it has to be on the same drive as the MBR (Master Boot Record) which is usually the Windows HDD. Done install it on a partition, just the Master Windows drive.


Return to “Installation & Boot”