Page 1 of 1

"Non-System disk .." message after fresh install

Posted: Thu Feb 16, 2017 1:48 pm
by ulli_m16
I made a complete new installation of LMDE 2 on a HP 5103 netbook from a flashdrive (USB stick). New partitions (for swap, root and home) were setup and formatted prior to the installation with GParted, all as Primary. The installation itself went absolutely smooth. The partitions already set up were just assigned and GRUB installed on sda (there is only one drive anyway). The installer finally gave the message "successfully done" (or something like that), the newly installed system was started and the packages from the live session were removed. Everything as it is supposed to be. I did that many times with different Linux distros.

When I now shutdown and restart the system I get the message "Non-System disk. Replace and strike any key when ready"

If I again start a live session using the same flashdrive as for the installation I can see both the / partition (with 7.6 out of 50 GB used) and the empty home partition. The internal HDD is physically o.k.. In / all data which are supposed to be there are there. When I start GParted it says:
"Libparted Warning. The driver descriptor says the physical block size is 2048 bytes, but Linux says it is 512 bytes."
When I click Ignore another message pops up:
"Partition(s) 1 on /dev/sdb have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use. As a result, the old partition(s) will remain in use. You should reboot now before making further changes."
/sdb is supposed to be the USB flashdrive. When I click Ignore again, GParted shows all the information of the internal HDD with the partitions which were set up prior to the installation. But something looks very odd to me: in GParted, in the window at the top on the right where the respective drive to be shown is selected, a drive /dev/sdb with a capacity of 15.09 GB is shown. As /sda is the internal HDD /sdb is supposed to be the external flashdrive. But this has a capacity of just 4 GB. The total volume of the LMDE 2 installation medium was around 1.5 GB. But for /sdb GParted gives the following data:

File System=unknown
Mount Point= /lib/live/mount/medium
Label= LMDE 2 Cinnamon 64-bit
Size= 4.00 KiB

File System=unallocated
Size= 5.79 MiB

File System=fat16
Size= 2.22 MiB (2.21 MiB used)

File System=unallocated
Size= 15.09 GiB (--- used)

Any idea what went wrong?? Again, there were not any messages about errors during installation.
Any help is highly appreciated.

Re: "Non-System disk .." message after fresh install

Posted: Thu Feb 16, 2017 2:18 pm
by Mute Ant
gparted and fdisk and gdisk are all rated 'incompetent' with the hybrid ISO images used for Live Session distributions. They have some good excuses...
o There's an MBR partition table and a GPT partition table and a CDROM signature all at the same time.
o There's a 2048 bytes-per-sector file system on 512 bytes-per-sector hardware. try not to look at /dev/sdb at all with a partition editor, to stop it being 'mended' inappropriately.

The "non-system-disk" message sounds like a message from a confused BIOS...trying to boot MBR from a EFI drive or vice-versa. You can use the Live Session boot to skip round that confusion and start the installed Mint.

Boot A Partition Using Live Session Menu
o Start the Live Session boot.
o Use down-arrow to stop the timer.
o Highlight the first entry.
o Press TAB to edit the boot arguments.
o Replace the text boot=live with root=/dev/sda1
o Press F10 to continue the boot.

How is the BIOS trying to boot? Or tell the BIOS what sort of boot you want and make Mint match that.

Re: "Non-System disk .." message after fresh install

Posted: Thu Feb 16, 2017 3:13 pm
by ulli_m16
@Mute Ant
thx for your quick reply.
I am very used setting up partitions with all their parameters and assign what they should be used for. But this time I am a bit confused.
I set up only 3 partitions: sda1 (Swap), sda2 (/) and sda3 (home). Looking at the GParted-table (out of the live session) I just recognize:
1. I do not have a boot flag
2. Mount Point for sda2 is not "/" as assigned during the installation, but "/media/mint/4d522868-a730........."
3. Mount Point for sda3 is not "home" as assigned during the installation, but "/media/mint/4eb84e........."

What the hack is that? And where does it come from? Should I unmount .. and edit the properties back to "/" and "home"?
Should there be another small partition just for the boot loader, a MBR, or whatever?

I will certainly check the BIOS settings. Already i) checked that the internal HDD is the first option to boot from ii) when I go into the BIOS during startup and activate Boot Options (or whatever those are called) then there are only 2: internal HDD and ethernet.

Re: "Non-System disk .." message after fresh install

Posted: Thu Feb 16, 2017 8:11 pm
by ulli_m16
@Mute Ant
Again, thx for your help.

Followed your advise and again started a Live Session, ..., and in the parameters replaced boot=live with root=/dev/sda1. When I pressed F10 nothing happened at all. There are some more parameters which all refer to "live". Shouldn`t they be changed as well, then? The only choice I had was to press ESC to get back to the BIOS startup choices. Checked the partitions again w/ GP. Checked all BIOS settings. Did not find anything which looked wrong in both. Finally deleted all partitions on /sda and made another (the 3rd) fresh install, this time creating the partitions from within the install routine. I cannot remember having ever made three installations to get something running. But again the same result: "Non-System disk ..." etc.

Finally found a solution. Will communicate that in another post to make it better accessible.

Greetings from Switzerland.

(Solved) "Non-System disk .." message after fresh install

Posted: Fri Feb 17, 2017 6:39 am
by ulli_m16
Folks, just wanted to communicate the solution I found separately in this post to make it better accessible. Following what worked for me:

It seems that there is no consistent view regarding a boot flag to be set or not. I made three installations of LMDE on my HP5103 netbook before I finally now have it up and running properly. For the first installations I used the partitions from an ealier installation of another distro. That first installation worked very well, but after just two days there was no content any longer in any popup or context menus (or windows, whatever the correct term is), not even in the shut down window. That regularly happened about 1-2 hours after the machine was powered on with nothing used but apps like FF, TB or Libre Office. After a cold start everything worked well for another 1-2 hours. Then the effect. Communicated that in another post. Tried everything, but could not fix it and decided to make a complete fresh install.

The point now is that as I used existing partitions for the first installation there also was a boot flag (I cross checked that at an installation on another PC). That initially worked well with the exception being the severe bug described above. For the second installation at which I experienced the "Non-System disk" issue afterward I deleted all partitions and created new ones using GParted. Tried several things but could not fix the "Non-System disk" issue. So I again deleted all partitions and made another installation from scratch this time creating the partitions during (from within) the install process. But again the same "Non-System disk" issue.

Then searched the forum again and realized there are quite a few threads in which the same problem is covered but not one of those gives a final solution. There are long discussions about wether a boot flag would be necessary or not and as far as I got it most members says it would not be necessary, it could even be deleted. Finally found one single post in the thread "LMDE wont boot after install (Solved)" from 2011. I never ever set such a boot flag and I did a lot of dual and triple boot installations. One single post in this thread convinced me and I set a boot flag for my root partition out of another live session; shut down and started the box again. And, guess what. Now it runs perfectly.

My godness. That post is from 2011. Do`nt wanne count how many years that is in the past. I highly appreciate the work being done by so many enthusiastic developers and I regret not being able to deliver a contribution although I have been working in IT for 20+ years. But this really was a bumpy road. Happy I finally got it up and running. That boot flag issue should be communicated somewhere.

Greetings from rainy Switzerland